[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-07-23 Thread Roundup Robot
Roundup Robot added the comment: New changeset 6ae34a948cb4 by Serhiy Storchaka in branch 'default': Issue #6167: Scrollbar.activate() now returns the name of active element if http://hg.python.org/cpython/rev/6ae34a948cb4 New changeset f5df571bfe1d by Serhiy Storchaka in branch '2.7': Issue

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-07-23 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: Committed without change activate() parameter name. I still think this parameter name is wrong. -- resolution: - fixed stage: patch review - resolved status: open - closed ___ Python tracker

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Serhiy Storchaka
Changes by Serhiy Storchaka storch...@gmail.com: -- versions: +Python 3.5 -Python 3.4 ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___ ___

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Jim Jewett
Jim Jewett added the comment: I'm still not seeing why these changes are sufficiently desirable to justify the code churn. Nor am I seeing test or doc changes that would explain the advantages of the new way, and prevent future regressions. I agree that the changes would make the signatures

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Terry J. Reedy
Terry J. Reedy added the comment: 1. In activate, change parameter 'index' to 'element'. I agree with Jim about rejecting this. A (specific). 'index' is routinely used to point to an item in a sequence; arrow1, slider, and arrow2 are visually sequenced. The doc string is clear on the

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: There is no the common interface for the set and activate methods. Listbox.activate(index) - mandatory argument is an index (an integer, active, anchor, end, or @x,y form). Menu.activate(index) - mandatory argument is an index.

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: Here is a patch with added tests. -- Added file: http://bugs.python.org/file35461/tkinter_Scrollbar_fixes_3.diff ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: Indices have special meaning in Tk. INDICES Many of the widget commands for listboxes take one or more indices as arguments. An index specifies a particular element of the listbox, in any of the following ways: number

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2014-06-02 Thread Terry J. Reedy
Terry J. Reedy added the comment: A Spinbox is not a Listbox. The common feature of the activate methods you listed is that the parameter is called 'index'. But I think this is a moot point. To the best of my knowledge, casually changing parameter names for no functional benefit is against

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-11-03 Thread Serhiy Storchaka
Changes by Serhiy Storchaka storch...@gmail.com: -- nosy: +terry.reedy ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___ ___ Python-bugs-list

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-11-03 Thread Serhiy Storchaka
Changes by Serhiy Storchaka storch...@gmail.com: Removed file: http://bugs.python.org/file32391/Scrollbar_fixes_2.diff ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-11-03 Thread Serhiy Storchaka
Changes by Serhiy Storchaka storch...@gmail.com: Added file: http://bugs.python.org/file32477/Scrollbar_fixes_2.diff ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-10-31 Thread Serhiy Storchaka
Changes by Serhiy Storchaka storch...@gmail.com: -- assignee: - serhiy.storchaka ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___ ___

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-10-27 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: I withdraw my comment about arbitrary number of arguments. Tk itself raises an exception if the number of arguments is wrong. -- ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-10-27 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: The patch updated to tip and added deprecation warning for the index keyword argument. -- Added file: http://bugs.python.org/file32391/Scrollbar_fixes_2.diff ___ Python tracker rep...@bugs.python.org

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2013-01-15 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: In versions of Tk before 4.0, the set command accepted 4 arguments. I think this is a new feature and can be applied only to 3.4. Agree with Jim that for backward compatibility we should keep name index and arbitrary number of arguments at least for one

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2012-04-06 Thread Jim Jewett
Jim Jewett jimjjew...@gmail.com added the comment: (1) Why did you change the name of the parameter from index to element? If the underlying engine also accepts indices (e.g., self.activate(4) ) then the name should stay. If it really is only meaningful to use the name of an element --

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2012-04-05 Thread Andrew Svetlov
Changes by Andrew Svetlov andrew.svet...@gmail.com: -- nosy: +asvetlov ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___ ___ Python-bugs-list

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2011-11-28 Thread Ezio Melotti
Changes by Ezio Melotti ezio.melo...@gmail.com: -- nosy: -BreamoreBoy versions: +Python 3.3 -Python 3.1 ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue6167 ___

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2010-08-04 Thread Mark Lawrence
Mark Lawrence breamore...@yahoo.co.uk added the comment: A tiny patch, can someone take a look with a view to committing, thanks. -- nosy: +BreamoreBoy stage: - patch review type: - behavior versions: +Python 3.2 ___ Python tracker

[issue6167] Tkinter.Scrollbar: the activate method needs to return a value, and set should take only two args

2009-06-01 Thread Guilherme Polo
New submission from Guilherme Polo ggp...@gmail.com: Hi, I've noticed some minor problems in Tkinter.Scrollbar that would be good to be addressed. The activate method never returns a value and it also doesn't accept to be called without an element -- which is accepted by tcl. When an element is