[issue10399] AST Optimization: inlining of function calls

2011-05-05 Thread Pas
Changes by Pas pasthe...@gmail.com: -- nosy: +pas ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue10399 ___ ___ Python-bugs-list mailing list

[issue1479611] speed up function calls

2011-05-05 Thread Pas
Changes by Pas pasthe...@gmail.com: -- nosy: +pas ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue1479611 ___ ___ Python-bugs-list mailing list

[issue15790] Python 3.3.0rc1 release notes claims PEP-405 support, yet pysetup is not in the package (needs more usage documentation, to get pip working)

2012-08-27 Thread Pas
New submission from Pas: Python 3.3.0rc1 release notes ( http://python.org/download/releases/3.3.0/ ) claims PEP-405 support, yet pysetup is not in the tarball. (After reading through mailing lists and bugs it's clear that the move to packaging module got pulled, so it's still just distutils

[issue15790] Python 3.3.0rc1 release notes claims PEP-405 support, yet pysetup is not in the package (needs more usage documentation, to get pip working)

2012-08-27 Thread Pas
Pas added the comment: It's not straightforward, at all. # (v3.3rc1) /home/pas/wololo/pip-1.1$ python setup.py install Traceback (most recent call last): File setup.py, line 3, in module from setuptools import setup ImportError: No module named 'setuptools' Then, of course one can try

[issue15790] Python 3.3.0rc1 release notes claims PEP-405 support, yet pysetup is not in the package (needs more usage documentation, to get pip working)

2012-08-27 Thread Pas
Pas added the comment: Thank you. The missing detail was to install distribute when a package needs setuptools. So, documentation. The setuptools page doesn't even mention distribute. The PEP mentions both, even though setuptools pretty much looks incompatible with Py3.3. Anyway. I'm

[issue22684] message.as_bytes() produces recursion depth exceeded

2014-10-21 Thread Pas
New submission from Pas: Please see the attached traceback (or this http://pastebin.com/WYinRGie for fancy colors). It depends on message size, we're trying to send Multipart MIME messages (a PDF attached, that has an image embedded). After editing flask_mail.py to use the fallback

[issue23061] Update pep8 to specify explicitly 'module level' imports at top of file

2016-02-19 Thread Pas
Changes by Pas <pasthe...@gmail.com>: -- nosy: +pas ___ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue23061> ___ ___ Python-bugs

[issue11566] hypot define in pyconfig.h clashes with g++'s cmath

2016-08-15 Thread Pas
Changes by Pas <pasthe...@gmail.com>: -- nosy: +pas ___ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue11566> ___ ___ Python-bugs