Joseph Armbruster schrieb:
> The -U option was added back in 2000, rev 15296 and mention of it was
> removed
> in rev 25288. Should the -U option still be handled from the command line?
Yes. The original goal of the -U command line (find out what happens
if all strings were unicode) still remains
Mateusz Rukowicz schrieb:
> Last holidays I was writting C decimal during summer of code 2006, I
> planned to take a breath for 1-2 months and then continue work, but
> well, things didn't go the way I planned. Now I am ready to continue
> work, I mainly plan to optimize it a little bit (top pri
Thomas Wouters schrieb:
> My only objection (which is a minor one) is with the 'NOARGS_NULL' name.
> Caps don't fit the normal style rules, and 'noargs_null' doesn't make
> much sense to me. 'unused' strikes me as a clearer name (or
> 'noargs_unused' or 'args_unused' or such.)
The point clearly i
Greg Ewing schrieb:
>> One idiom that people use a lot is foo[b], where
>> b is a boolean.
>
> Could that be addressed using the new __index__ mechanism?
That would be possible, yes.
Martin
___
Python-Dev mailing list
Python-Dev@python.org
http://mail.
Larry Hastings <[EMAIL PROTECTED]> wrote:
>
> Josiah Carlson wrote:
> > Larry Hastings <[EMAIL PROTECTED]> wrote:
> >
> >> Josiah Carlson wrote:
> >>
> >>> one thing to note with your method - you can't guarantee the order
> >>> of the attributes as they are being displayed.
> >>>
Josiah Carlson wrote:
> Larry Hastings <[EMAIL PROTECTED]> wrote:
>
>> Josiah Carlson wrote:
>>
>>> one thing to note with your method - you can't guarantee the order
>>> of the attributes as they are being displayed.
>>>
>> Actually, my record type *can*; see the hack using the __
Python Versions: 2.5 and trunk
Browsing through the code this evening and noticed a discrepancy between
the command line parameters listed with --help and those truly available in
the code. Namely with the -U Unicode flag..
The -U option was added back in 2000, rev 15296 and mention of it was
r
Hi,
Last holidays I was writting C decimal during summer of code 2006, I
planned to take a breath for 1-2 months and then continue work, but
well, things didn't go the way I planned. Now I am ready to continue
work, I mainly plan to optimize it a little bit (top priority would be
cut some copy
My only objection (which is a minor one) is with the 'NOARGS_NULL' name.
Caps don't fit the normal style rules, and 'noargs_null' doesn't make much
sense to me. 'unused' strikes me as a clearer name (or 'noargs_unused' or
'args_unused' or such.) It should be fine to fix this in 2.5 as well (as
lon
Martin v. Löwis wrote:
> One idiom that people use a lot is foo[b], where
> b is a boolean.
Could that be addressed using the new __index__ mechanism?
--
Greg
___
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/pyt
At 10:35 PM 2/23/2007 +0100, Martin v. Löwis wrote:
>Hans Meine schrieb:
>
> > (I first posted this to distutils-sig but was told that distutils is a bit
> > neglected there, so I decided to try to push these simple patches in via
> > python-dev.) Lately, a student came to me complaining about an
Hans Meine schrieb:
> (I first posted this to distutils-sig but was told that distutils is a bit
> neglected there, so I decided to try to push these simple patches in via
> python-dev.) Lately, a student came to me complaining about an old distutils
> bug which
> bit him:
> http://mail.pyt
Hans Meine schrieb:
> For a long time, I have been annoyed by distutils behavior concerning
> "scripts": I always put
> #!/usr/bin/env python
> into the first line in order to let the incredibly useful "env" program start
> the right python version.
>
> I know that it is quite evil to hardco
Greg Ewing schrieb:
> But bool isn't really a numeric type in the same way
> that the others are. It's only a subtype of int for
> historical reasons. If it had been a part of Python
> from the beginning, it probably would have been a
> separate type altogether.
>
> Hmmm... is that something that
Neal Becker schrieb:
> Doesn't this seem a bit inconsisent?
Please don't ask such questions. Instead, formulate them as
"I would have expected the result to be X instead. Why is
the result Y?" (if that is actually the question you meant
to ask)
IOW, what does it help you if somebody answers "yes"
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On Feb 23, 2007, at 9:55 AM, Jean-Paul Calderone wrote:
> On Fri, 23 Feb 2007 15:36:50 +0100, Hans Meine
> <[EMAIL PROTECTED]> wrote:
>> Hi!
>>
>> [snip - distutils should leave #!/usr/bin/env python alone]
>>
>> Comments? (I first posted this to d
The latest version of the PEP clarifies that both are allowed.
On 2/23/07, Jim Jewett <[EMAIL PROTECTED]> wrote:
> On 2/22/07, Guido van Rossum <[EMAIL PROTECTED]> wrote:
> > [-python-checkins, +python-dev]
> >
> > On 2/22/07, Jim Jewett <[EMAIL PROTECTED]> wrote:
> > > > __setitem__
> >
On Fri, 23 Feb 2007 15:36:50 +0100, Hans Meine <[EMAIL PROTECTED]> wrote:
>Hi!
>
> [snip - distutils should leave #!/usr/bin/env python alone]
>
>Comments? (I first posted this to distutils-sig but was told that distutils
>is a bit neglected there, so I decided to try to push these simple patches
On 2/22/07, Guido van Rossum <[EMAIL PROTECTED]> wrote:
> [-python-checkins, +python-dev]
>
> On 2/22/07, Jim Jewett <[EMAIL PROTECTED]> wrote:
> > > __setitem__
> > > __setslice__
> > > append
> > > count
> > > +decode
> > > +endswith
> > >
Hi!
(I first posted this to distutils-sig but was told that distutils is a bit
neglected there, so I decided to try to push these simple patches in via
python-dev.) Lately, a student came to me complaining about an old distutils
bug which
bit him:
http://mail.python.org/pipermail/patches/20
Hi!
For a long time, I have been annoyed by distutils behavior concerning
"scripts": I always put
#!/usr/bin/env python
into the first line in order to let the incredibly useful "env" program start
the right python version.
I know that it is quite evil to hardcode /usr/bin/python
or /usr/l
Neal Becker wrote:
> The fact that other numeric
> types act this way leaves a reasonable expectation that bool will.
But bool isn't really a numeric type in the same way
that the others are. It's only a subtype of int for
historical reasons. If it had been a part of Python
from the beginning, it
22 matches
Mail list logo