[Python-Dev] Re: Why doesn't venv also install python3*-config?

2020-01-13 Thread Janzert
;venv" and "virtualenv" are two related but different packages (venv being included in the standard library and virtualenv available on pypi). At least here on Ubuntu 18.04 with python 3.6 venv and virtualenv 16.7.9, venv does not include python-config and virtua

[Python-Dev] Re: Keyword arguments with non-string names

2019-07-09 Thread Janzert
October; which I believe is the most recent previous discussion: https://mail.python.org/pipermail/python-dev/2018-October/155435.html Janzert ___ Python-Dev mailing list -- python-dev@python.org To unsubscribe send an email to python-dev-le

Re: [Python-Dev] Updates to PEP 471, the os.scandir() proposal

2014-07-08 Thread Janzert
this in the future would be really nice. Janzert ___ Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Re: [Python-Dev] PEP 471 -- os.scandir() function -- a better and faster directory iterator

2014-07-01 Thread Janzert
came for free from the OS and then let the user decide if the extra expense is worth the extra information. Maybe that stat information was only going to be used for an informational log that can be skipped if it's going to incur extra expense? Janzert

Re: [Python-Dev] pep8 reasoning

2014-04-27 Thread Janzert
On 4/27/2014 12:40 PM, Barry Warsaw wrote: On Apr 26, 2014, at 12:33 AM, Janzert wrote: So the one example under discussion is: foo = long_function_name( var_one, var_two, var_three, var_four) and comes from http://legacy.python.org/dev/peps/pep-0008/#indentation Specifically the third

Re: [Python-Dev] pep8 reasoning

2014-04-25 Thread Janzert
spaces are allowed in this situation maybe verbiage to that effect could be added. Janzert ___ Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python

Re: [Python-Dev] Appeal for reviews

2014-04-13 Thread Janzert
its archives out of public view. Janzert ___ Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Re: [Python-Dev] 2.x vs 3.x survey results

2014-01-02 Thread Janzert
it was posted. Janzert ___ Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Re: [Python-Dev] Fwd: Python 2.x and 3.x usage survey

2013-12-31 Thread Janzert
it to hacker news[1] and it has been sitting around #5 on the front page for about 3 hours now. That should've helped broaden the responses a bit. Janzert 1. https://news.ycombinator.com/item?id=6990481 ___ Python-Dev mailing list Python-Dev

Re: [Python-Dev] cpython: Rename contextlib.ignored() to contextlib.ignore().

2013-10-12 Thread Janzert
I'd get it wrong if I was scanning through code with that construct in the midst of it. Janzert ___ Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options

Re: [Python-Dev] Add a transformdict to collections

2013-09-10 Thread Janzert
would except most often the initial insertion to be the canonical form. Whichever way is adopted, I think even if you say it's implementation specific, people will end up relying on it in their code. Janzert ___ Python-Dev mailing list Python-Dev

Re: [Python-Dev] RFC: PEP 454: Add a new tracemalloc module

2013-09-08 Thread Janzert
It seems like most of this could live on PyPi for a while so the API can get hashed out in use? If that's not the case is it because the PEP 445 API isn't rich enough? Janzert ___ Python-Dev mailing list Python-Dev@python.org https://mail.python.org

Re: [Python-Dev] Draft PEP for time zone support.

2012-12-12 Thread Janzert
On 12/12/2012 8:43 PM, Glenn Linderman wrote: On 12/12/2012 5:36 PM, Brian Curtin wrote: C:\ProgramData\Python ^ That. Is not the path that the link below is talking about, though. It actually does; it is rather confusing though. :/ It's referring to KNOWNFOLDERID constant

Re: [Python-Dev] Draft PEP for time zone support.

2012-12-12 Thread Janzert
On 12/13/2012 1:39 AM, Glenn Linderman wrote: On 12/12/2012 6:10 PM, Janzert wrote: On 12/12/2012 8:43 PM, Glenn Linderman wrote: On 12/12/2012 5:36 PM, Brian Curtin wrote: C:\ProgramData\Python ^ That. Is not the path that the link below is talking about, though

Re: [Python-Dev] PEP 418 is too divisive and confusing and should be postponed

2012-04-10 Thread Janzert
on windows. Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Re: [Python-Dev] PEP 418 is too divisive and confusing and should be postponed

2012-04-06 Thread Janzert
short term accuracy, but I don't know of anything providing that. Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive

Re: [Python-Dev] Rename time.steady(strict=True) to time.monotonic()?

2012-03-25 Thread Janzert
and failing that used the realtime clock but cached the previous returned value and ensured that all values returned obeyed the monotonic property still. But I don't see why that function shouldn't just be time.monotonic(). Janzert ___ Python-Dev mailing list

Re: [Python-Dev] Rename time.steady(strict=True) to time.monotonic()?

2012-03-23 Thread Janzert
one called time.monotonic(). To my mind a steady clock is by definition monotonic but a monotonic one may or may not be steady. Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe

Re: [Python-Dev] Counting collisions for the win

2012-01-23 Thread Janzert
worse case performance? Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

[Python-Dev] Digital video basics tutorial

2010-10-18 Thread Janzert
http://xiph.org/video/vid1.shtml ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Re: [Python-Dev] Digital video basics tutorial

2010-10-18 Thread Janzert
On 10/18/2010 3:33 PM, Janzert wrote: http://xiph.org/video/vid1.shtml Sorry, sent to the wrong place. Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http

Re: [Python-Dev] unsubscriptable vs object does not support indexing

2009-09-23 Thread Janzert
: 'A' object is unindexable a[a] Traceback (most recent call last): File stdin, line 1, in module TypeError: 'A' object is unsubscriptable Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev

Re: [Python-Dev] Functionality in subprocess.Popen.terminate()

2009-08-04 Thread Janzert
from your description that even if you check first a race condition will still exist. Specifically the subprocess could terminate after the check and before the TerminateProcess call. So it seems better just to call TerminateProcess and then correctly handle any possible error. Janzert

Re: [Python-Dev] Merging mailing lists

2008-12-04 Thread Janzert
appropriate list manually if needed. Otherwise +1 on getting the discussion and checkins back into combined lists. Janzert ___ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http

Re: [Python-Dev] PEP: Consolidating names and classes in the `unittest`module (updated 2008-07-15)

2008-07-14 Thread Janzert
with these new names. Underscores are not fun to type. They create a weird_mental_pause when reading them. +1 And Merriam-Webster agrees, http://www.merriam-webster.com/dictionary/setup http://www.merriam-webster.com/dictionary/teardown Janzert ___ Python

Re: [Python-Dev] PEP 365 (Adding the pkg_resources module)

2008-03-20 Thread Janzert
Guido van Rossum wrote: On Wed, Mar 19, 2008 at 12:54 PM, Phillip J. Eby [EMAIL PROTECTED] wrote: [a long message] I'm back at Google and *really* busy for another week or so, so I'll have to postpone the rest of this discussion for a while. If other people want to chime in please do so; if