Re: [PATCH v2 03/13] hw/ppc/spapr: Replace sprintf() by snprintf()

2024-04-15 Thread Harsh Prateek Bora
RIx, start); ^ 1 warning generated. Signed-off-by: Philippe Mathieu-Daudé With the typo fixed, Reviewed-by: Harsh Prateek Bora --- hw/ppc/spapr.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/hw/ppc/spapr.c b/hw/ppc/spapr.c index e9bc97fee0..9e97992c79 100644 --- a/hw/p

Re: [PATCH 2/6] qemu/main-loop: rename QEMU_IOTHREAD_LOCK_GUARD to QEMU_BQL_LOCK_GUARD

2023-11-30 Thread Harsh Prateek Bora
On 12/1/23 01:57, Stefan Hajnoczi wrote: On Thu, Nov 30, 2023 at 10:14:47AM +0100, Ilya Leoshkevich wrote: On Wed, 2023-11-29 at 16:26 -0500, Stefan Hajnoczi wrote: The name "iothread" is overloaded. Use the term Big QEMU Lock (BQL) instead, it is already widely used and unambiguous.

Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock()

2023-11-30 Thread Harsh Prateek Bora
*ioc, Error **errp) { -bool iolock = qemu_mutex_iothread_locked(); +bool iolock = qemu_bql_locked(); Should var name (one more below) be updated to reflect this update ? Otherwise, Reviewed-by: Harsh Prateek Bora bool iothread = qemu_in_iothread(); struct iovec send[2] = {

Re: [PATCH v2 01/16] migration: Don't use INT64_MAX for unlimited rate

2023-05-15 Thread Harsh Prateek Bora
e the rate .. there is a check in qemu_file_rate_limit() .. + * limit. + */ +#define RATE_LIMIT_MAX 0 + Reviewed-by: Harsh Prateek Bora /* * These are the ram migration statistic counters. It is loosely * based on MigrationStats. We change to Stat64 any counter

Re: [PATCH 10/21] migration: Move rate_limit_max and rate_limit_used to migration_stats

2023-05-15 Thread Harsh Prateek Bora
On 5/9/23 16:40, Juan Quintela wrote: Harsh Prateek Bora wrote: On 5/8/23 18:38, Juan Quintela wrote: This way we can make them atomic and use this functions from any s/this/these Fixed. Sure, providing ack from ppc/spapr perspective. Reviewed-by: Harsh Prateek Bora Thanks.

Re: [PATCH 07/21] migration: Correct transferred bytes value

2023-05-09 Thread Harsh Prateek Bora
On 5/8/23 18:38, Juan Quintela wrote: We forget several places to add to trasferred amount of data. With this fixes I get: qemu_file_transferred() + multifd_bytes == transferred The only place whrer this is not true is during devices sending. But s/whrer/where going all through

Re: [PATCH 10/21] migration: Move rate_limit_max and rate_limit_used to migration_stats

2023-05-09 Thread Harsh Prateek Bora
On 5/8/23 18:38, Juan Quintela wrote: This way we can make them atomic and use this functions from any s/this/these place. I also moved all functions that use rate_limit to migration-stats. Functions got renamed, they are not qemu_file anymore. qemu_file_rate_limit ->

Re: [PATCH 02/21] migration: Don't use INT64_MAX for unlimited rate

2023-05-09 Thread Harsh Prateek Bora
On 5/9/23 17:21, Juan Quintela wrote: Harsh Prateek Bora wrote: On 5/8/23 18:38, Juan Quintela wrote: Use 0 instead. Signed-off-by: Juan Quintela --- migration/migration.c | 4 ++-- migration/qemu-file.c | 3 +++ 2 files changed, 5 insertions(+), 2 deletions(-) diff --git

Re: [PATCH 02/21] migration: Don't use INT64_MAX for unlimited rate

2023-05-09 Thread Harsh Prateek Bora
On 5/8/23 18:38, Juan Quintela wrote: Use 0 instead. Signed-off-by: Juan Quintela --- migration/migration.c | 4 ++-- migration/qemu-file.c | 3 +++ 2 files changed, 5 insertions(+), 2 deletions(-) diff --git a/migration/migration.c b/migration/migration.c index 1192f1ebf1..3979a98949