[Qemu-devel] Re: hi, may I ask some help on the paravirtualization of KVM?

2010-03-24 Thread Charles Duffy
Liang YANG wrote: Maybe I solove the problem. I use the qemu-img make a new GustOS img. And install the debian5 on the image file with option -net nic, model=virtio. ./x86_64-softmmu/qemu-system-x86_64 -hda debian.img -cdrom debian.iso -net nic, model=virtio This email reads as: -net nic,

Re: [Qemu-devel] Re: Compile files only once: some planning

2010-03-24 Thread Anthony Liguori
On 03/24/2010 05:47 PM, Paul Brook wrote: Actually, Anthony suggested at some point to just use 64 bits for TARGET_PHYS_ADDR_BITS and remove the need for hw32/64. I think that people emulationg 32bits on 32bits would suffer, but have no clue how much. Anthony, what was the idea?

Re: [Qemu-devel] Re: Compile files only once: some planning

2010-03-24 Thread Paul Brook
On 03/24/2010 05:33 PM, Paul Brook wrote: But now there is a bigger problem, how to pass the property to the device. It's not fair to require the user to remember to set it. It should not be a property of the device. All devices have a native endianness (for PCI this is little-endian),

Re: [Qemu-devel] Re: Compile files only once: some planning

2010-03-24 Thread Anthony Liguori
On 03/24/2010 06:05 PM, Paul Brook wrote: On 03/24/2010 05:33 PM, Paul Brook wrote: But now there is a bigger problem, how to pass the property to the device. It's not fair to require the user to remember to set it. It should not be a property of the device. All devices have a

Re: [Qemu-devel] Re: [libvirt] Supporting hypervisor specific APIs in libvirt

2010-03-24 Thread Jamie Lokier
Avi Kivity wrote: On 03/24/2010 02:32 PM, Anthony Liguori wrote: You don't get a directory filled with a zillion socket files pointing at dead guests. Agree that's a poor return on investment. Deleting it on atexit combined with flushing the whole directory at startup is a pretty

[Qemu-devel] [PATCH 04/10] target-alpha: Implement cvtql inline.

2010-03-24 Thread Richard Henderson
It's a simple mask and shift sequence. Also, fix a typo in the actual masks used. Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/helper.h|4 target-alpha/op_helper.c | 20 target-alpha/translate.c | 45

[Qemu-devel] [PATCH 01/10] target-alpha: Add flags markups to helpers.h.

2010-03-24 Thread Richard Henderson
Almost all alpha helpers are at least TCG_CALL_CONST and a fair few are also TCG_CALL_PURE. Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/helper.h | 184 1 files changed, 92 insertions(+), 92 deletions(-) diff --git

[Qemu-devel] [PATCH 02/10] target-alpha: Implement cpys{, n, e} inline.

2010-03-24 Thread Richard Henderson
Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/helper.h|4 -- target-alpha/op_helper.c | 18 -- target-alpha/translate.c | 78 +++-- 3 files changed, 74 insertions(+), 26 deletions(-) diff --git

[Qemu-devel] [PATCH 05/10] target-alpha: Implement cvtlq inline.

2010-03-24 Thread Richard Henderson
It's a simple shift and mask sequence. Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/helper.h|1 - target-alpha/op_helper.c |7 --- target-alpha/translate.c | 21 - 3 files changed, 20 insertions(+), 9 deletions(-) diff --git

[Qemu-devel] [PATCH 06/10] target-alpha: Use setcond for int comparisons.

2010-03-24 Thread Richard Henderson
Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/translate.c | 43 ++- 1 files changed, 22 insertions(+), 21 deletions(-) diff --git a/target-alpha/translate.c b/target-alpha/translate.c index 90a14f5..80b5f52 100644 ---

[Qemu-devel] [PATCH 07/10] target-alpha: Use non-inverted arguments to gen_{f}cmov.

2010-03-24 Thread Richard Henderson
The inverted conditions as argument to the function looks wrong at a glance inside translate_one. Since we have an easy function to produce the inversion now, use it. Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/translate.c | 37 +++-- 1

[Qemu-devel] [PATCH 03/10] target-alpha: Implement rs/rc properly.

2010-03-24 Thread Richard Henderson
This is a per-cpu flag; there's no need for a spinlock of any kind. We were also failing to manipulate the flag with $31 as a target reg and failing to clear the flag on execution of a return-from-interrupt instruction. Signed-off-by: Richard Henderson r...@twiddle.net --- linux-user/main.c

[Qemu-devel] [PATCH 09/10] target-alpha: Implement load-locked/store-conditional properly.

2010-03-24 Thread Richard Henderson
Use __sync_bool_compare_and_swap to yield correctly atomic results. As yet, this assumes running on an strict-memory-ordering host (i.e. x86), since we're still implementing the memory-barrier instructions as nops. Rename the lock cpu field to lock_addr and add a lock_value field to be used as

[Qemu-devel] [PATCH 10/10] target-alpha: Enable NPTL.

2010-03-24 Thread Richard Henderson
Signed-off-by: Richard Henderson r...@twiddle.net --- configure|1 + linux-user/syscall.c |2 +- target-alpha/cpu.h | 28 +--- 3 files changed, 19 insertions(+), 12 deletions(-) diff --git a/configure b/configure index 6bc40a3..6b50b6a 100755 ---

[Qemu-devel] [PATCH 08/10] target-alpha: Emit goto_tb opcodes.

2010-03-24 Thread Richard Henderson
Use an ExitStatus enumeration instead of magic numbers as the return value from translate_one. Emit goto_tb opcodes when ending a TB via a direct branch. Signed-off-by: Richard Henderson r...@twiddle.net --- target-alpha/translate.c | 339 ++ 1 files

RE: [Qemu-devel] Re: KVM call agenda for Mar 23

2010-03-24 Thread Zhang, Xiantao
Jes Sorensen wrote: On 03/23/10 13:45, Anthony Liguori wrote: I don't think we can pull in: - extboot - ia64 - in-kernel pit[1] - associated command line options - device passthrough The question is, if we dropped those things, would people actually use qemu.git instead of

Re: [Qemu-devel] Re: [libvirt] Supporting hypervisor specific APIs in libvirt

2010-03-24 Thread Jamie Lokier
Anthony Liguori wrote: But the advantage is that if libvirt provided an API for a QMP transport encapsulated in their secure protocol, then provided the plumbed that API through their Python interface, you could use it for free in Python without having to reinvent the wheel. It's not free

Re: [Qemu-devel] Re: Compile files only once: some planning

2010-03-24 Thread Jamie Lokier
Juan Quintela wrote: Blue Swirl blauwir...@gmail.com wrote: Hi, Here's some planning for getting most files compiled as few times as possible. Comments and suggestions are welcome. I took some thought about this at some point. Problems here start from Recursive Makefile condered

[Qemu-devel] Re: [PATCH 10/15] virtio-serial: Add QMP events for failed port/device add

2010-03-24 Thread Amit Shah
On (Wed) Mar 24 2010 [17:34:15], Luiz Capitulino wrote: On Wed, 24 Mar 2010 20:19:28 +0530 Amit Shah amit.s...@redhat.com wrote: When adding a port or a device to the guest fails, management software might be interested in knowing and then cleaning up the host-side of the port. Introduce

Re: [Qemu-devel] virtio block device and sysfs

2010-03-24 Thread john cooper
john cooper wrote: Marc Haber wrote: Hi, On Mon, Mar 22, 2010 at 02:26:11AM -0400, john cooper wrote: I could have swore I sent out a guest-driver-app-interface-less version of the patch using virtio to pass the S/N but didn't find it in the archives. I did however locate it and can bring

[Qemu-devel] [PATCH 0/4] Add virtio disk identification support

2010-03-24 Thread john cooper
This series adds the minimal support to qemu and virtio_blk to support passing of a virtio_blk serial id string from qemu through the guest driver and to the guest userland. This is derived in part from a patch set posted by Rusty some time ago, but has been minimized to remove support for prior

[Qemu-devel] [PATCH 1/4] Add virtio disk identification support

2010-03-24 Thread john cooper
Add virtio-blk device id (s/n) support via virtio request. Remove artifacts of pci and ATA_IDENTIFY implementation relative to prior versions. Signed-off-by: john cooper john.coo...@redhat.com --- diff --git a/hw/virtio-blk.c b/hw/virtio-blk.c index 9915840..358b0af 100644 --- a/hw/virtio-blk.c

[Qemu-devel] [PATCH 2/4] Add virtio disk identification support

2010-03-24 Thread john cooper
Fix bug which truncated serial string to 8 bytes, nul terminate. Signed-off-by: john cooper john.coo...@redhat.com --- diff --git a/vl.c b/vl.c index d69250c..b74cbba 100644 --- a/vl.c +++ b/vl.c @@ -1162,7 +1162,7 @@ DriveInfo *drive_init(QemuOpts *opts, void *opaque, dinfo-on_write_error

<    1   2