[PULL 18/46] openrisc: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with OpenRISC. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini --- configs/devices/or1k-softmmu/default.mak |

[PULL 19/46] ppc: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with PowerPC/POWER. No changes to generated config-devices.mak files, other than adding CONFIG_PPC to the ppc64-softmmu target.

[PULL 07/46] alpha: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Start with Alpha. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini --- configs/devices/alpha-softmmu/default.mak | 5

[PULL 16/46] meson: make target endianneess available to Kconfig

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. MIPS boards may only be available for big-endian or only for little-endian emulators, add a symbol so that this can be described with a "depends on"

[PULL 28/46] target/i386: Introduce SapphireRapids-v3 to add missing features

2024-05-06 Thread Paolo Bonzini
From: Lei Wang Add the missing features(ss, tsc-adjust, cldemote, movdiri, movdir64b) in the SapphireRapids-v3 CPU model. Signed-off-by: Lei Wang Message-ID: <20240424072912.43188-1-lei4.w...@intel.com> Signed-off-by: Paolo Bonzini --- target/i386/cpu.c | 11 +++ 1 file changed, 11

[PULL 34/46] net: remove AnnounceTimer from typedefs.h

2024-05-06 Thread Paolo Bonzini
Exactly nobody needs it there. Place the typedef in the header that defines the struct. Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Paolo Bonzini --- include/net/announce.h | 4 ++-- include/qemu/typedefs.h | 1 - 2 files changed, 2 insertions(+), 3 deletions(-) diff --git

[PULL 03/46] tests/qtest: skip m48t59-test if the machine is absent

2024-05-06 Thread Paolo Bonzini
Together with the series at https://patchew.org/QEMU/20240423131612.28362-1-pbonz...@redhat.com/, this allows adding sparc-softmmu to the target list of the build-without-defaults CI job. Reviewed-by: Richard Henderson Signed-off-by: Paolo Bonzini --- tests/qtest/m48t59-test.c | 11

[PULL 38/46] migration: remove PostcopyDiscardState from typedefs.h

2024-05-06 Thread Paolo Bonzini
It is defined and referred to exclusively from a .c file. Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Paolo Bonzini --- include/qemu/typedefs.h | 1 - migration/postcopy-ram.c | 4 ++-- 2 files changed, 2 insertions(+), 3 deletions(-) diff --git a/include/qemu/typedefs.h

[PULL 29/46] bitmap: Use g_try_new0/g_new0/g_renew

2024-05-06 Thread Paolo Bonzini
Avoids an explicit use of sizeof(). The GLib allocation macros ensure that the multiplication by the size of the element uses the right type and does not overflow. While at it, change bitmap_new() to use g_new0 directly. Its current impl of calling bitmap_try_new() followed by a plain abort()

[PULL 25/46] tricore: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with TriCore. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini --- configs/devices/tricore-softmmu/default.mak

[PULL 27/46] docs: document new convention for Kconfig board symbols

2024-05-06 Thread Paolo Bonzini
Boards have been switched to use "default y" and are now listed in default-configs/*.mak only for convenience. Document this change and the new possibilities that it allows. Signed-off-by: Paolo Bonzini --- docs/devel/kconfig.rst | 14 -- 1 file changed, 12 insertions(+), 2

[PULL 36/46] intc: remove PICCommonState from typedefs.h

2024-05-06 Thread Paolo Bonzini
Move it to the existing "PIC related things" header, hw/intc/i8259.h. Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Paolo Bonzini --- include/hw/intc/i8259.h | 2 ++ include/qemu/typedefs.h | 1 - 2 files changed, 2 insertions(+), 1 deletion(-) diff --git a/include/hw/intc/i8259.h

[PULL 31/46] fw_cfg: remove useless declarations from typedefs.h

2024-05-06 Thread Paolo Bonzini
Only FWCfgState is used as part of APIs such as acpi_ghes_add_fw_cfg. Everything else need not be in typedefs.h. Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Paolo Bonzini --- include/hw/nvram/fw_cfg.h | 2 ++ include/qemu/typedefs.h | 3 --- 2 files changed, 2 insertions(+), 3

[PULL 32/46] qdev-core: remove DeviceListener from typedefs.h

2024-05-06 Thread Paolo Bonzini
It is needed in very few places, which already depend on other parts of qdev-core.h files. The benefit of having it in typedefs.h is small. Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Paolo Bonzini --- include/hw/qdev-core.h | 1 + include/qemu/typedefs.h | 1 - 2 files changed, 1

[PULL 37/46] lockable: remove QemuLockable from typedefs.h

2024-05-06 Thread Paolo Bonzini
Using QemuLockable almost always requires going through QEMU_MAKE_LOCKABLE(). Therefore, there is little point in having the typedef always present. Move it to lockable.h, with only a small adjustment to coroutine.h (which has a tricky co-dependency with lockable.h due to defining CoMutex *and*

[PULL 20/46] riscv: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with RISC-V. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini --- configs/devices/riscv32-softmmu/default.mak

[PULL 30/46] build: do not build virtio-vga-gl if virgl/opengl not available

2024-05-06 Thread Paolo Bonzini
If virgl and opengl are not available, the build process creates a useless libvirtio-vga-gl module that does not have any device in it. Follow the example of virtio-vga-rutabaga and do not build the module at all in that case. Signed-off-by: Paolo Bonzini --- hw/display/meson.build | 14

[PULL 33/46] numa: remove types from typedefs.h

2024-05-06 Thread Paolo Bonzini
Exactly nobody needs them there. Place the typedef in the header that defines the struct. Reviewed-by: Philippe Mathieu-Daudé Signed-off-by: Paolo Bonzini --- include/qemu/typedefs.h | 2 -- include/sysemu/numa.h | 8 2 files changed, 4 insertions(+), 6 deletions(-) diff --git

[PULL 14/46] m68k: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with m68k. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini --- configs/devices/m68k-softmmu/default.mak | 13

[PULL 22/46] s390x: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with s390. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini --- configs/devices/s390x-softmmu/default.mak | 5

[PULL 12/46] i386: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with i386. No changes to generated config-devices.mak files, other than adding CONFIG_I386 to the x86_64-softmmu target. Signed-off-by: Paolo

[PULL 39/46] monitor: remove MonitorDef from typedefs.h

2024-05-06 Thread Paolo Bonzini
MonitorDef is defined by hmp-target.h, and all users except one already include it; the reason why the stubs do not include it, is because hmp-target.h currently can only be used in files that are compiled per target. However, that is easily fixed. Because the benefit of having MonitorDef in

[PULL 24/46] sparc: switch boards to "default y"

2024-05-06 Thread Paolo Bonzini
Some targets use "default y" for boards to filter out those that require TCG. For consistency we are switching all other targets to do the same. Continue with SPARC and SPARC64. No changes to generated config-devices.mak file. Signed-off-by: Paolo Bonzini ---

[PULL 04/46] gitlab-ci: adjust msys2-64bit to be able to run qtest

2024-05-06 Thread Paolo Bonzini
sparc-softmmu is able to run a subset of qtests when compiled --without-default-devices, so use it instead of x86_64-softmmu for the msys2 run. Signed-off-by: Paolo Bonzini --- .gitlab-ci.d/windows.yml | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git

[PULL 06/46] configs: list "implied" device groups in the default configs

2024-05-06 Thread Paolo Bonzini
Match the optional device groups to what is actually included in the config-devices.mak files. Signed-off-by: Paolo Bonzini --- configs/devices/arm-softmmu/default.mak | 2 ++ configs/devices/loongarch64-softmmu/default.mak | 3 +++ configs/devices/or1k-softmmu/default.mak| 4

[PULL 01/46] target/i386: Give IRQs a chance when resetting HF_INHIBIT_IRQ_MASK

2024-05-06 Thread Paolo Bonzini
From: Ruihan Li When emulated with QEMU, interrupts will never come in the following loop. However, if the NOP instruction is uncommented, interrupts will fire as normal. loop: cli call do_sti jmp loop do_sti: sti

[PULL 05/46] kvm: ppc: disable sPAPR code if CONFIG_PSERIES is disabled

2024-05-06 Thread Paolo Bonzini
target/ppc/kvm.c calls out to code in hw/ppc/spapr*.c; that code is not present and fails to link if CONFIG_PSERIES is not enabled. Adjust kvm.c to depend on CONFIG_PSERIES instead of TARGET_PPC64, and compile out anything that requires cap_papr, because only the pseries machine will call

[PULL 02/46] Kconfig: kvm: allow building without any board

2024-05-06 Thread Paolo Bonzini
KVM code might have to call functions on the PCIDevice that is passed to kvm_arch_fixup_msi_route(). This fails in the case where --without-default-devices is used and no board is configured. While this is not really a useful configuration, and therefore setting up stubs for CONFIG_PCI is

[PULL 00/46] Mostly build system and other cleanups patches for 2024-05-06

2024-05-06 Thread Paolo Bonzini
The following changes since commit 4977ce198d2390bff8c71ad5cb1a5f6aa24b56fb: Merge tag 'pull-tcg-20240501' of https://gitlab.com/rth7680/qemu into staging (2024-05-01 15:15:33 -0700) are available in the Git repository at: https://gitlab.com/bonzini/qemu.git tags/for-upstream for you to

Re: [PATCH 7/7] net/can: Remove unused struct 'CanBusState'

2024-05-06 Thread Philippe Mathieu-Daudé
On 5/5/24 19:14, Dr. David Alan Gilbert wrote: As far as I can tell this struct has never been used in this file (it is used in can_core.c). Signed-off-by: Dr. David Alan Gilbert --- net/can/can_host.c | 6 -- 1 file changed, 6 deletions(-) Reviewed-by: Philippe Mathieu-Daudé

Re: [PATCH 5/7] hw/arm/bcm2836: Remove unusued struct 'BCM283XClass'

2024-05-06 Thread Philippe Mathieu-Daudé
On 5/5/24 19:14, Dr. David Alan Gilbert wrote: This struct has been unused since Commit f932093ae165 ("hw/arm/bcm2836: Split out common part of BCM283X classes") Rather than "splitting out", commit f932093ae165 duplicated BCM283XClass as BCM283XBaseClass and left it unmodified. Reviewed-by:

Re: [PATCH 4/7] hw/usb/dev-network: Remove unused struct 'rndis_config_parameter'

2024-05-06 Thread Philippe Mathieu-Daudé
On 5/5/24 19:14, Dr. David Alan Gilbert wrote: As far as I can tell it was never used. Signed-off-by: Dr. David Alan Gilbert --- hw/usb/dev-network.c | 8 1 file changed, 8 deletions(-) Reviewed-by: Philippe Mathieu-Daudé

Re: [PATCH] hw/arm/npcm7xx: remove setting of mp-affinity

2024-05-06 Thread Philippe Mathieu-Daudé
On 4/5/24 16:32, Richard Henderson wrote: On 5/4/24 07:17, Dorjoy Chowdhury wrote: The value of the mp-affinity property being set in npcm7xx_realize is always the same as the default value it would have when arm_cpu_realizefn is called if the property is not set here. So there is no need to

Re: [PATCH] include/exec/cpu-common.h: Rename PAGE_BITS macro to PAGE_RWX

2024-05-06 Thread Philippe Mathieu-Daudé
On 5/5/24 14:10, BALATON Zoltan wrote: This macro can be used to abbreviate PAGE_READ | PAGE_WRITE | PAGE_EXEC for which PAGE_RWX is a better name and renaming it also shows it is not related to TARGET_PAGE_BITS. Signed-off-by: BALATON Zoltan --- accel/tcg/user-exec.c | 2 +-

Re: [PATCH v11 19/21] i386: Add cache topology info in CPUCacheInfo

2024-05-06 Thread Zhao Liu
Hi Tejus, (Also +Paolo/Daniel) On Tue, Apr 30, 2024 at 06:14:52AM +, Tejus GK wrote: > Date: Tue, 30 Apr 2024 06:14:52 + > From: Tejus GK > Subject: Re: [PATCH v11 19/21] i386: Add cache topology info in CPUCacheInfo > > > > On 24 Apr 2024, at 9:19 PM, Zhao Liu wrote: > > @@

Re: [PATCH] hw/nvme: fix number of PIDs for FDP RUH update

2024-05-06 Thread Klaus Jensen
On May 3 13:50, Vincent Fu wrote: > The number of PIDs is in the upper 16 bits of cdw10. So we need to > right-shift by 16 bits instead of only a single bit. > > Signed-off-by: Vincent Fu > --- > hw/nvme/ctrl.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git

RE: [PATCH v3 06/19] range: Introduce range_get_last_bit()

2024-05-06 Thread Duan, Zhenzhong
>-Original Message- >From: Cédric Le Goater >Subject: Re: [PATCH v3 06/19] range: Introduce range_get_last_bit() > >On 4/30/24 11:58, Duan, Zhenzhong wrote: >> >> >>> -Original Message- >>> From: Cédric Le Goater >>> Subject: Re: [PATCH v3 06/19] range: Introduce

Re: [PATCH] docs/devel: Add introduction to LUKS volume with detached header

2024-05-06 Thread Markus Armbruster
Looks like this fell through the cracks. Is anyone familiar with LUKS willing to review it? Hyman Huang writes: > Signed-off-by: Hyman Huang > --- > MAINTAINERS | 1 + > docs/devel/luks-detached-header.rst | 182 > 2 files changed, 183

Re: [PATCH] Fixes: Indentation using TABs and improve formatting

2024-05-06 Thread Tanmay
Sure, I'll do it! Thanks, Tanmay On Mon, 6 May 2024 at 10:11, Thomas Huth wrote: > On 04/05/2024 22.34, Michael Tokarev wrote: > > 04.05.2024 21:58, Tanmay wrote: > >> Hi, > >> > >> I have attached a patch file that fixes indentation and formatting for > >> some files as listed in >

Re: [PATCH] MAINTAINERS: Update Aleksandar Rikalo email

2024-05-06 Thread Markus Armbruster
Looks like this fell through the cracks. As far as I can tell, the patch did come from @syrmia.com. Cc'ing qemu-trivial. Aleksandar Rikalo writes: > Syrmia LLC has been acquired recently and the syrmia.com domain will > disappear soon, so updating my email in the MAINTAINERS file. > >

Re: [PATCH v2 12/15] hw/riscv/riscv-iommu: Add another irq for mrif notifications

2024-05-06 Thread Frank Chang
Reviewed-by: Frank Chang Daniel Henrique Barboza 於 2024年3月8日 週五 上午12:06寫道: > > From: Andrew Jones > > And add mrif notification trace. > > Signed-off-by: Andrew Jones > Reviewed-by: Daniel Henrique Barboza > --- > hw/riscv/riscv-iommu-pci.c | 2 +- > hw/riscv/riscv-iommu.c | 1 + >

Re: [PATCH v3 1/5] hw/loongarch: Rename LOONGARCH_MACHINE with VIRT_MACHINE

2024-05-06 Thread maobibo
On 2024/5/6 下午12:24, Thomas Huth wrote: On 06/05/2024 05.02, Bibo Mao wrote: On LoongArch system, there is only virt machine type now, name LOONGARCH_MACHINE is confused, rename it with VIRT_MACHINE. Machine name about Other real hw boards can be added in future. Signed-off-by: Bibo Mao

<    1   2   3   4