Re: [PATCH 07/10] tcg: implement bulletproof JIT

2020-10-13 Thread BALATON Zoltan via
On Mon, 12 Oct 2020, Joelle van Dyne wrote: From: osy On iOS, we cannot allocate RWX pages without special entitlements. As a workaround, we can a RX region and then mirror map it to a separate RX Missing a verb here: "we can a RX region" region. Then we can write to one region and execute

Re: [PATCH 06/10] coroutine: add libucontext as external library

2020-10-13 Thread BALATON Zoltan via
On Tue, 13 Oct 2020, Stefan Hajnoczi wrote: On Mon, Oct 12, 2020 at 04:29:35PM -0700, Joelle van Dyne wrote: From: osy iOS does not support ucontext natively for aarch64 and the sigaltstack is also unsupported (even worse, it fails silently, see: https://openradar.appspot.com/13002712 ) As a

Re: [PATCH 04/10] meson: option to build as shared library

2020-10-13 Thread BALATON Zoltan via
On Tue, 13 Oct 2020, Daniel P. Berrangé wrote: On Mon, Oct 12, 2020 at 04:29:33PM -0700, Joelle van Dyne wrote: From: osy On iOS, we cannot fork() new processes, so the best way to load QEMU into an app is through a shared library. We add a new configure option `--enable-shared-lib` that will

Re: [PATCH v2 3/3] uninorth: use qdev gpios for PCI IRQs

2020-10-13 Thread BALATON Zoltan via
On Tue, 13 Oct 2020, Mark Cave-Ayland wrote: Currently an object link property is used to pass a reference to the OpenPIC into the PCI host bridge so that pci_unin_init_irqs() can connect the PCI IRQs to the PIC itself. This can be simplified by defining the PCI IRQs as qdev gpios and then

Re: [PATCH] Deprecate TileGX port

2020-10-12 Thread BALATON Zoltan via
On Mon, 12 Oct 2020, Peter Maydell wrote: Deprecate our TileGX target support: * we have no active maintainer for it * it has had essentially no contributions (other than tree-wide cleanups and similar) since it was first added * the Linux kernel dropped support in 2018, as has glibc Note the

Re: [PATCH 1/5] hw/pci-host/bonito: Make PCI_ADDR() macro more readable

2020-10-12 Thread BALATON Zoltan via
On Mon, 12 Oct 2020, Philippe Mathieu-Daudé wrote: From: Philippe Mathieu-Daudé The PCI_ADDR() macro use generic PCI fields shifted by 8-bit. Rewrite it extracting the shift operation one layer. Signed-off-by: Philippe Mathieu-Daudé --- hw/pci-host/bonito.c | 4 ++-- 1 file changed, 2

Re: [PATCH] hw/pci-host/grackle: Verify PIC link is properly set

2020-10-12 Thread BALATON Zoltan via
On Mon, 12 Oct 2020, David Gibson wrote: On Mon, Oct 12, 2020 at 08:21:41AM +0200, Philippe Mathieu-Daudé wrote: On 10/12/20 12:34 AM, David Gibson wrote: On Sun, Oct 11, 2020 at 09:03:32PM +0200, Philippe Mathieu-Daudé wrote: The Grackle PCI host model expects the interrupt controller being

Re: [PATCH qemu v9] spapr: Implement Open Firmware client interface

2020-10-12 Thread BALATON Zoltan via
On Mon, 12 Oct 2020, Alexey Kardashevskiy wrote: On 29/09/2020 20:35, Alexey Kardashevskiy wrote: On 16/07/2020 23:22, David Gibson wrote: On Thu, Jul 16, 2020 at 07:04:56PM +1000, Alexey Kardashevskiy wrote: Ping? I kinda realize it is not going to replace SLOF any time soon but still...

Re: Purpose of QOM properties registered at realize time?

2020-10-07 Thread BALATON Zoltan via
On Tue, 6 Oct 2020, Eduardo Habkost wrote: Hi, While trying to understand how QOM properties are used in QEMU, I stumbled upon multiple cases where alias properties are added at realize time. Now, I don't understand why those properties exist. As the properties are added at realize time, I

Re: [PATCH 1/2] softmmu: move more files to softmmu/

2020-10-06 Thread BALATON Zoltan via
On Tue, 6 Oct 2020, Paolo Bonzini wrote: Keep most softmmu_ss files into the system-emulation-specific directory. The name of this dir may be misleading. I think it originally stood for the actual MMU emulation but now it seems everything related to system emulation is dumped here. Is it

Re: Use of "?" for help has been deprecated for 8 years, can we drop it?

2020-10-01 Thread BALATON Zoltan via
On Thu, 1 Oct 2020, Eric Blake wrote: On 10/1/20 5:35 AM, Markus Armbruster wrote: We deprecated "?" more than eight years ago. We didn't have a deprecation process back then, but we did purge "?" from the documentation and from help texts. Can we finally drop it? I'm asking because there is

Re: [PATCH] load_elf: Remove unused address variables from callers

2020-09-23 Thread BALATON Zoltan via
On Wed, 23 Sep 2020, BALATON Zoltan wrote: On Tue, 7 Jul 2020, BALATON Zoltan wrote: On Tue, 7 Jul 2020, Alistair Francis wrote: On Sun, Jul 5, 2020 at 10:41 AM BALATON Zoltan wrote: Several callers of load_elf() pass pointers for lowaddr and highaddr parameters which are then not used for

Re: [PATCH] load_elf: Remove unused address variables from callers

2020-09-23 Thread BALATON Zoltan via
On Tue, 7 Jul 2020, BALATON Zoltan wrote: On Tue, 7 Jul 2020, Alistair Francis wrote: On Sun, Jul 5, 2020 at 10:41 AM BALATON Zoltan wrote: Several callers of load_elf() pass pointers for lowaddr and highaddr parameters which are then not used for anything. This may stem from a

Re: [PATCH 5/6] macio: don't reference serial_hd() directly within the device

2020-09-20 Thread BALATON Zoltan via
On Sun, 20 Sep 2020, Mark Cave-Ayland wrote: Instead use qdev_prop_set_chr() to configure the ESCC serial chardevs at the Mac Old World and New World machine level. Also remove the now obsolete comment referring to the use of serial_hd() and change user_createable to true accordingly.

Re: [PATCH] ati-vga: Fix checks in ati_2d_blt() to avoid crash

2020-08-22 Thread BALATON Zoltan via
On Sat, 22 Aug 2020, Philippe Mathieu-Daudé wrote: On 4/6/20 10:34 PM, BALATON Zoltan wrote: In some corner cases (that never happen during normal operation but a malicious guest could program wrong values) pixman functions were called with parameters that result in a crash. Fix this and add

<    1   2   3