Re: [Qemu-devel] [PATCH v2 21/40] job: Convert block_job_cancel_async() to Job

2018-05-25 Thread John Snow
On 05/25/2018 04:00 AM, Kevin Wolf wrote: > Am 24.05.2018 um 19:42 hat John Snow geschrieben: >> >> >> On 05/24/2018 04:24 AM, Kevin Wolf wrote: >>> Am 24.05.2018 um 01:18 hat John Snow geschrieben: > diff --git a/include/qemu/job.h b/include/qemu/job.h > index 3e817beee9..2648c74281

Re: [Qemu-devel] [PATCH v2 21/40] job: Convert block_job_cancel_async() to Job

2018-05-25 Thread Kevin Wolf
Am 24.05.2018 um 19:42 hat John Snow geschrieben: > > > On 05/24/2018 04:24 AM, Kevin Wolf wrote: > > Am 24.05.2018 um 01:18 hat John Snow geschrieben: > >>> diff --git a/include/qemu/job.h b/include/qemu/job.h > >>> index 3e817beee9..2648c74281 100644 > >>> --- a/include/qemu/job.h > >>> +++

Re: [Qemu-devel] [PATCH v2 21/40] job: Convert block_job_cancel_async() to Job

2018-05-24 Thread John Snow
On 05/24/2018 04:24 AM, Kevin Wolf wrote: > Am 24.05.2018 um 01:18 hat John Snow geschrieben: >>> diff --git a/include/qemu/job.h b/include/qemu/job.h >>> index 3e817beee9..2648c74281 100644 >>> --- a/include/qemu/job.h >>> +++ b/include/qemu/job.h >>> @@ -97,6 +97,12 @@ typedef struct Job { >>>

Re: [Qemu-devel] [PATCH v2 21/40] job: Convert block_job_cancel_async() to Job

2018-05-24 Thread Kevin Wolf
Am 24.05.2018 um 01:18 hat John Snow geschrieben: > > diff --git a/include/qemu/job.h b/include/qemu/job.h > > index 3e817beee9..2648c74281 100644 > > --- a/include/qemu/job.h > > +++ b/include/qemu/job.h > > @@ -97,6 +97,12 @@ typedef struct Job { > > */ > > bool cancelled; > > > > +

Re: [Qemu-devel] [PATCH v2 21/40] job: Convert block_job_cancel_async() to Job

2018-05-23 Thread John Snow
On 05/18/2018 09:20 AM, Kevin Wolf wrote: > block_job_cancel_async() did two things that were still block job > specific: > > * Setting job->force. This field makes sense on the Job level, so we can > just move it. While at it, rename it to job->force_cancel to make its > purpose more

[Qemu-devel] [PATCH v2 21/40] job: Convert block_job_cancel_async() to Job

2018-05-18 Thread Kevin Wolf
block_job_cancel_async() did two things that were still block job specific: * Setting job->force. This field makes sense on the Job level, so we can just move it. While at it, rename it to job->force_cancel to make its purpose more obvious. * Resetting the I/O status. This can't be moved