Re: [PATCH v1 04/10] linux-user: completely re-write init_guest_space

2020-05-21 Thread Richard Henderson
On 5/21/20 1:21 AM, Alex Bennée wrote: > > Thomas Huth writes: > >> On 13/05/2020 19.51, Alex Bennée wrote: >>> First we ensure all guest space initialisation logic comes through >>> probe_guest_base once we understand the nature of the binary we are >>> loading. The convoluted init_guest_space

Re: [PATCH v2 0/7] exec/memory: Enforce checking MemTxResult values

2020-05-21 Thread Paolo Bonzini
On 18/05/20 17:53, Philippe Mathieu-Daudé wrote: > Various places ignore the MemTxResult indicator of > transaction failed. Fix the easy places. > The rest are the DMA devices, which require deeper > analysis. > > Since v1: > - Dropped "exec/memory: Emit warning when MemTxResult is ignored" >

Re: [PATCH V2] Add a new PIIX option to control PCI hot unplugging of devices on non-root buses

2020-05-21 Thread Laine Stump
On 5/21/20 9:23 AM, Igor Mammedov wrote: On Thu, 21 May 2020 06:07:25 -0400 "Michael S. Tsirkin" wrote: On Thu, May 21, 2020 at 09:32:17AM +0200, Igor Mammedow wrote: On Wed, 20 May 2020 12:13:35 -0400 "Michael S. Tsirkin" wrote: On Wed, May 20, 2020 at 02:20:12PM +0200, Igor Mammedow

Re: [PATCH v2 1/4] Introduce yank feature

2020-05-21 Thread Lukas Straub
On Thu, 21 May 2020 16:03:35 +0100 Stefan Hajnoczi wrote: > On Wed, May 20, 2020 at 11:05:39PM +0200, Lukas Straub wrote: > > +void yank_generic_iochannel(void *opaque) > > +{ > > +QIOChannel *ioc = QIO_CHANNEL(opaque); > > + > > +qio_channel_shutdown(ioc, QIO_CHANNEL_SHUTDOWN_BOTH,

[PATCH v2] linux-user: limit check to HOST_LONG_BITS == 32

2020-05-21 Thread Alex Bennée
Newer clangs rightly spot that you can never exceed the full address space of 64 bit hosts with: linux-user/elfload.c:2076:41: error: result of comparison 'unsigned long' > 18446744073709551615 is always false [-Werror,-Wtautological-type-limit-compare] 4685 if ((guest_hiaddr -

Re: [PATCH v3 0/3] various: Remove unnecessary casts

2020-05-21 Thread Paolo Bonzini
On 19/05/20 06:34, Markus Armbruster wrote: > Cédric Le Goater writes: > >> On 5/18/20 3:17 PM, Markus Armbruster wrote: >>> Paolo Bonzini writes: >>> On 15/05/20 07:58, Markus Armbruster wrote: > Philippe Mathieu-Daudé writes: > >> Remove unnecessary casts using coccinelle

Re: [PATCH] target/i386: Fix OUTL debug output

2020-05-21 Thread Paolo Bonzini
On 19/05/20 14:23, Philippe Mathieu-Daudé wrote: > On 5/19/20 5:39 AM, Richard Henderson wrote: >> On 5/17/20 4:01 AM, Philippe Mathieu-Daudé wrote: >>> Fix OUTL instructions incorrectly displayed as OUTW. >>> >>> Signed-off-by: Philippe Mathieu-Daudé >>> --- >>>   target/i386/misc_helper.c | 2

Re: [PATCH 6/6] sm501: Remove obsolete changelog and todo comment

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/20/20 3:39 PM, BALATON Zoltan wrote: Also update copyright year for latest changes Signed-off-by: BALATON Zoltan --- hw/display/sm501.c | 19 +-- 1 file changed, 1 insertion(+), 18 deletions(-) diff --git a/hw/display/sm501.c b/hw/display/sm501.c index

Re: [PATCH v2 11/13] audio: deprecate -soundhw pcspk

2020-05-21 Thread Paolo Bonzini
On 18/05/20 15:27, Gerd Hoffmann wrote: > Ah, cool, that shows that I'm on the right path with my idea ;) > Sneak preview: > https://git.kraxel.org/cgit/qemu/log/?h=sirius/soundhw > > Suggestions for a good name? I've used "pc.pcspk" for now, > but maybe "pc.audiodev0" or "pc.sound0" is

Re: [PATCH v2] linux-user: limit check to HOST_LONG_BITS == 32

2020-05-21 Thread Peter Maydell
On Thu, 21 May 2020 at 14:58, Alex Bennée wrote: > > Newer clangs rightly spot that you can never exceed the full address > space of 64 bit hosts with: > > linux-user/elfload.c:2076:41: error: result of comparison 'unsigned > long' > 18446744073709551615 is always false >

Re: [PATCH v2 1/3] qom/object: Move Object typedef to 'qemu/typedefs.h'

2020-05-21 Thread Paolo Bonzini
On 15/05/20 09:00, Philippe Mathieu-Daudé wrote: > On Fri, May 15, 2020 at 8:07 AM Markus Armbruster wrote: >> >> Philippe Mathieu-Daudé writes: >> >>> We use the Object type all over the place. >>> Forward declare it in "qemu/typedefs.h". >>> >>> Signed-off-by: Philippe Mathieu-Daudé >>> ---

Re: [PATCH QEMU v23 08/18] vfio: Register SaveVMHandlers for VFIO device

2020-05-21 Thread Dr. David Alan Gilbert
* Kirti Wankhede (kwankh...@nvidia.com) wrote: > Define flags to be used as delimeter in migration file stream. > Added .save_setup and .save_cleanup functions. Mapped & unmapped migration > region from these functions at source during saving or pre-copy phase. > Set VFIO device state depending on

Re: [RFC PATCH] qom: Implement qom-get HMP command

2020-05-21 Thread Paolo Bonzini
On 20/05/20 11:59, Dr. David Alan Gilbert wrote: >> Count me in favour. I'd like to see the matching change to HMP qom-set, >> though. > It turns out I actually did do a JSON version, as the follow up to the > version Cédric reposted; but then that got lost in people not liking > JSON;

Re: [PATCH] Makefile: Let the 'help' target list the helper targets

2020-05-21 Thread Paolo Bonzini
On 23/04/20 12:43, Philippe Mathieu-Daudé wrote: > List the name of the helper targets when calling 'make help', > along with the tool targets: > > $ make help > [...] > > Helper targets: > fsdev/virtfs-proxy-helper - Build virtfs-proxy-helper > scsi/qemu-pr-helper

Re: [PATCH v6 1/3] memory: drop guest writes to read-only ram device regions

2020-05-21 Thread Paolo Bonzini
On 30/04/20 11:40, Peter Maydell wrote: >> This does not "drop" a write to a r/o region -- it causes it to generate >> whatever the guest architecture's equivalent of a bus error is (eg data >> abort on Arm). > More generally, this change seems a bit odd: currently we do not > check the

Re: [PATCH] cpus: Fix botched configure_icount() error API violation fix

2020-05-21 Thread Paolo Bonzini
On 08/05/20 12:49, Markus Armbruster wrote: > Fixes: abc9bf69a66a11499a801ff545b8fe7adbb3a04c > Fixes: Coverity CID 1428754 > Signed-off-by: Markus Armbruster > --- > cpus.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/cpus.c b/cpus.c > index 5670c96bcf..b9275c672d

Re: [PATCH] qom: remove index from object_resolve_abs_path()

2020-05-21 Thread Paolo Bonzini
On 10/05/20 03:32, Masahiro Yamada wrote: > You can advance 'parts' to track the current path fragment. > The 'index' parameter is unneeded. > > Signed-off-by: Masahiro Yamada > --- > > qom/object.c | 17 - > 1 file changed, 8 insertions(+), 9 deletions(-) > > diff --git

Re: [PATCH] qom/object: pass (Object *) to object_initialize_with_type()

2020-05-21 Thread Paolo Bonzini
On 12/05/20 19:31, Masahiro Yamada wrote: > object_new_with_type() already passes (Object *) pointer. > Avoid casting back and forth. > > Signed-off-by: Masahiro Yamada > --- > > qom/object.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/qom/object.c

Re: [PATCH] io_uring: use io_uring_cq_ready() to check for ready cqes

2020-05-21 Thread Stefan Hajnoczi
On Tue, May 19, 2020 at 03:49:42PM +0200, Stefano Garzarella wrote: > In qemu_luring_poll_cb() we are not using the cqe peeked from the > CQ ring. We are using io_uring_peek_cqe() only to see if there > are cqes ready, so we can replace it with io_uring_cq_ready(). > > Signed-off-by: Stefano

Re: [PATCH 1/2] hw/riscv: sifive_u: Remove the riscv_ prefix of the soc* functions

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/21/20 4:42 PM, Bin Meng wrote: From: Bin Meng To keep consistency with the machine* functions, remove the riscv_ prefix of the soc* functions. Signed-off-by: Bin Meng --- hw/riscv/sifive_u.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git

Re: [PATCH] io_uring: use io_uring_cq_ready() to check for ready cqes

2020-05-21 Thread Stefano Garzarella
On Thu, May 21, 2020 at 03:45:34PM +0100, Stefan Hajnoczi wrote: > On Tue, May 19, 2020 at 03:49:42PM +0200, Stefano Garzarella wrote: > > In qemu_luring_poll_cb() we are not using the cqe peeked from the > > CQ ring. We are using io_uring_peek_cqe() only to see if there > > are cqes ready, so we

[Bug 1879955] [NEW] target/i386/seg_helper.c: 16-bit TSS struct format wrong?

2020-05-21 Thread Peter Maydell
Public bug reported: In target/i386/seg_helper.c:switch_tss_ra() we have the following code to load registers from a 16-bit TSS struct: /* 16 bit */ new_cr3 = 0; new_eip = cpu_lduw_kernel_ra(env, tss_base + 0x0e, retaddr); new_eflags = cpu_lduw_kernel_ra(env,

Re: [PATCH v1 10/10] translate-all: include guest address in out_asm output

2020-05-21 Thread Philippe Mathieu-Daudé
Hi Alex, On 5/13/20 7:51 PM, Alex Bennée wrote: We already have information about where each guest instructions representation starts stored in the tcg_ctx->gen_insn_data so we can rectify the PC for faults. We can re-use this information to annotate the out_asm output with guest instruction

Re: [PATCH 1/6] sm501: Convert printf + abort to qemu_log_mask

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/20/20 3:39 PM, BALATON Zoltan wrote: Some places already use qemu_log_mask() to log unimplemented features or errors but some others have printf() then abort(). Convert these to qemu_log_mask() and avoid aborting to prevent guests to easily cause denial of service. Signed-off-by: BALATON

Re: [PATCH v1 01/10] tests/guest-debug: catch hanging guests

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/13/20 7:51 PM, Alex Bennée wrote: If gdb never actually connected with the guest we need to catch that and clean-up after ourselves. Signed-off-by: Alex Bennée Message-Id: <20200512104338.27365-1-alex.ben...@linaro.org> --- tests/guest-debug/run-test.py | 6 ++ 1 file changed, 6

Re: [PATCH 4/6] sm501: Clean up local variables in sm501_2d_operation

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/20/20 3:39 PM, BALATON Zoltan wrote: Make variables local to the block they are used in to make it clearer which operation they are needed for. Signed-off-by: BALATON Zoltan --- hw/display/sm501.c | 31 --- 1 file changed, 16 insertions(+), 15 deletions(-)

Re: [PATCH 3/6] sm501: Use BIT(x) macro to shorten constant

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/20/20 3:39 PM, BALATON Zoltan wrote: Signed-off-by: BALATON Zoltan --- hw/display/sm501.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/hw/display/sm501.c b/hw/display/sm501.c index f42d05e1e4..97660090bb 100644 --- a/hw/display/sm501.c +++

[Bug 1878915] Re: util/fdmon-io_uring.c:95: get_sqe: Assertion `ret > 1' failed.

2020-05-21 Thread Stefan Hajnoczi
Hi, This issue should no longer occur in qemu.git/master. Commit ba607ca8bff4d2c2062902f8355657c865ac7c29 ("aio-posix: disable fdmon-io_uring when GSource is used") disabled fdmon-io_uring in this scenario. -- You received this bug notification because you are a member of qemu- devel-ml, which

Re: [PATCH v8 74/74] cputlb: queue async flush jobs without the BQL

2020-05-21 Thread Robert Foley
We re-ran the numbers for a ppc64 VM, using the additional configuration details. This seems to show the scalability gains much clearer. Speedup vs a single thread for kernel build 7 +---+ | +

Re: [PATCH 0/4] memory: Add memory_region_msync() & make NVMe emulated device generic

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/21/20 2:46 PM, Paolo Bonzini wrote: On 21/05/20 14:32, Stefan Hajnoczi wrote: On Fri, May 08, 2020 at 08:24:52AM +0200, Philippe Mathieu-Daudé wrote: Let the NVMe emulated device be target-agnostic. It is not clear if dccvap_writefn() really needs memory_region_writeback() or could use

[Bug 1877136] Re: Qemu GDB Arm core registers XML description not valid for M-profile

2020-05-21 Thread Peter Maydell
Fix now in master, will be in QEMU 5.1. ** Changed in: qemu Status: In Progress => Fix Committed -- You received this bug notification because you are a member of qemu- devel-ml, which is subscribed to QEMU. https://bugs.launchpad.net/bugs/1877136 Title: Qemu GDB Arm core registers

Re: [PATCH 0/3] virtio: add vhost-user-vsock device

2020-05-21 Thread Stefan Hajnoczi
On Fri, May 15, 2020 at 05:21:07PM +0200, Stefano Garzarella wrote: > This series add vhost-user-vsock base device and its PCI version > (vhost-user-vsock-pci). > The vhost-user-vsock device can be used to implement the virtio-vsock > device emulation in user-space. > An use case might be Kata,

Re: [PATCH] io_uring: retry io_uring_submit() if it fails with errno=EINTR

2020-05-21 Thread Stefan Hajnoczi
On Tue, May 19, 2020 at 03:30:41PM +0200, Stefano Garzarella wrote: > As recently documented [1], io_uring_enter(2) syscall can return an > error (errno=EINTR) if the operation was interrupted by a delivery > of a signal before it could complete. > > This should happen when IORING_ENTER_GETEVENTS

Re: [PATCH v3] accel: Move Xen accelerator code under accel/xen/

2020-05-21 Thread Paolo Bonzini
On 08/05/20 12:02, Philippe Mathieu-Daudé wrote: > This code is not related to hardware emulation. > Move it under accel/ with the other hypervisors. > > Reviewed-by: Paul Durrant > Signed-off-by: Philippe Mathieu-Daudé > --- > We could also move the memory management functions from >

[PATCH 2/2] hw/riscv: virt: Remove the riscv_ prefix of the machine* functions

2020-05-21 Thread Bin Meng
From: Bin Meng Remove the riscv_ prefix of the machine* functions. Signed-off-by: Bin Meng --- hw/riscv/virt.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/hw/riscv/virt.c b/hw/riscv/virt.c index c695a44..f1d6b61 100644 --- a/hw/riscv/virt.c +++

[PATCH 1/2] hw/riscv: sifive_u: Remove the riscv_ prefix of the soc* functions

2020-05-21 Thread Bin Meng
From: Bin Meng To keep consistency with the machine* functions, remove the riscv_ prefix of the soc* functions. Signed-off-by: Bin Meng --- hw/riscv/sifive_u.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/hw/riscv/sifive_u.c

Re: [PATCH] qom/object: simplify type_initialize_interface()

2020-05-21 Thread Paolo Bonzini
On 12/05/20 20:25, Masahiro Yamada wrote: > iface_impl->class is the same as new_iface. Make it more readable. > > Signed-off-by: Masahiro Yamada > --- > > qom/object.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) > > diff --git a/qom/object.c b/qom/object.c > index

Re: [PATCH] qom/object: factor out the initialization of hash table of properties

2020-05-21 Thread Paolo Bonzini
On 12/05/20 19:26, Masahiro Yamada wrote: > Properties are not related to the initialization of interfaces. > > The initialization of the hash table can be moved after the if-block, > and unified. > > Signed-off-by: Masahiro Yamada > --- > > qom/object.c | 8 +++- > 1 file changed, 3

Re: [PATCH 2/2] hw/riscv: virt: Remove the riscv_ prefix of the machine* functions

2020-05-21 Thread Philippe Mathieu-Daudé
On 5/21/20 4:42 PM, Bin Meng wrote: From: Bin Meng Remove the riscv_ prefix of the machine* functions. Signed-off-by: Bin Meng --- hw/riscv/virt.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/hw/riscv/virt.c b/hw/riscv/virt.c index

Re: [PATCH] qom/container: remove .instance_size initializer from container_info

2020-05-21 Thread Paolo Bonzini
On 13/05/20 05:36, Masahiro Yamada wrote: > You can omit .instance_size if it is the same as that of the parent. > > .class_size = sizeof(ObjectClass) > > ... is omitted here, so removing .instance_size is more consistent. > > Signed-off-by: Masahiro Yamada > --- > > qom/container.c | 1

Re: [PATCH v2 1/4] Introduce yank feature

2020-05-21 Thread Stefan Hajnoczi
On Wed, May 20, 2020 at 11:05:39PM +0200, Lukas Straub wrote: > +void yank_generic_iochannel(void *opaque) > +{ > +QIOChannel *ioc = QIO_CHANNEL(opaque); > + > +qio_channel_shutdown(ioc, QIO_CHANNEL_SHUTDOWN_BOTH, NULL); > +} > + > +void qmp_yank(strList *instances, Error **errp) > +{ > +

Re: [PATCH 0/3] virtio: add vhost-user-vsock device

2020-05-21 Thread Stefano Garzarella
On Thu, May 21, 2020 at 03:35:59PM +0100, Stefan Hajnoczi wrote: > On Fri, May 15, 2020 at 05:21:07PM +0200, Stefano Garzarella wrote: > > This series add vhost-user-vsock base device and its PCI version > > (vhost-user-vsock-pci). > > The vhost-user-vsock device can be used to implement the

<    1   2   3   4   5   6