[PATCH v12 2/4] xlnx-zynqmp: Connect Xilinx ZynqMP CAN controllers

2020-11-18 Thread Vikram Garhwal
Connect CAN0 and CAN1 on the ZynqMP. Reviewed-by: Francisco Iglesias Reviewed-by: Edgar E. Iglesias Signed-off-by: Vikram Garhwal --- include/hw/arm/xlnx-zynqmp.h | 8 hw/arm/xlnx-zcu102.c | 20 hw/arm/xlnx-zynqmp.c | 34

[PATCH v12 0/4] Introduce Xilinx ZynqMP CAN controller

2020-11-18 Thread Vikram Garhwal
Changelog: v11 -> v12: Change/add new trace events with relevant debug info. Rename val64 to val wherever appropriate. Added new error logs. Corrected xlnx_zynqmp_can_receive function checks. v10 -> v11: Resending the series with correct cc. Replace DB_PRINTS with

[PATCH v2] Fix build with 64 bits time_t

2020-11-18 Thread Fabrice Fontaine
time element is deprecated on new input_event structure in kernel's input.h [1] This will avoid the following build failure: hw/input/virtio-input-host.c: In function 'virtio_input_host_handle_status': hw/input/virtio-input-host.c:198:28: error: 'struct input_event' has no member named 'time'

[PATCH v12 1/4] hw/net/can: Introduce Xilinx ZynqMP CAN controller

2020-11-18 Thread Vikram Garhwal
The Xilinx ZynqMP CAN controller is developed based on SocketCAN, QEMU CAN bus implementation. Bus connection and socketCAN connection for each CAN module can be set through command lines. Example for using single CAN: -object can-bus,id=canbus0 \ -machine xlnx-zcu102.canbus0=canbus0 \

[PATCH v12 3/4] tests/qtest: Introduce tests for Xilinx ZynqMP CAN controller

2020-11-18 Thread Vikram Garhwal
The QTests perform five tests on the Xilinx ZynqMP CAN controller: Tests the CAN controller in loopback, sleep and snoop mode. Tests filtering of incoming CAN messages. Reviewed-by: Philippe Mathieu-Daudé Reviewed-by: Francisco Iglesias Signed-off-by: Vikram Garhwal ---

Re: [PATCH 00/10] vhost/qemu: thread per IO SCSI vq

2020-11-18 Thread Mike Christie
On 11/18/20 1:54 AM, Jason Wang wrote: On 2020/11/18 下午2:57, Mike Christie wrote: On 11/17/20 11:17 PM, Jason Wang wrote: On 2020/11/18 上午12:40, Stefan Hajnoczi wrote: On Thu, Nov 12, 2020 at 05:18:59PM -0600, Mike Christie wrote: The following kernel patches were made over Michael's vhost

Re: [Virtio-fs] [PATCH] virtiofsd: Use --thread-pool-size=0 to mean no thread pool

2020-11-18 Thread Vivek Goyal
On Thu, Nov 12, 2020 at 10:57:11AM +0100, Miklos Szeredi wrote: [..] > > Another performance issue with virtiofs could be due to the strict > page writeback rules in fuse that are meant to prevent misuse of > kernel memory by unprivileged processes. Since virtiofs isn't > subject to that

Re: [PATCH RFC] vfio: Set the priority of VFIO VM state change handler explicitly

2020-11-18 Thread Kirti Wankhede
On 11/17/2020 7:10 AM, Shenming Lu wrote: In VFIO VM state change handler, VFIO devices are transitioned in _SAVING state, which should keep them from sending interrupts. Then we can save the pending states of all interrupts in GIC VM state change handler (on ARM). So we have to set the

[PATCH 1/1] Fix to show vfio migration stat in migration status

2020-11-18 Thread Kirti Wankhede
Header file where CONFIG_VFIO is defined is not included in migration.c file. Include config devices header file in migration.c. Fixes: 3710586caa5d ("qapi: Add VFIO devices migration stats in Migration stats") Signed-off-by: Kirti Wankhede --- meson.build | 1 +

Re: [PATCH RFC v3 23/23] i386: provide simple 'hyperv=on' option to x86 machine types

2020-11-18 Thread Eduardo Habkost
On Fri, Oct 09, 2020 at 02:18:42PM +0200, Vitaly Kuznetsov wrote: > Enabling Hyper-V emulation for a Windows VM is a tiring experience as it > requires listing all currently supported enlightenments ("hv_*" CPU > features) explicitly. We do have a 'hv_passthrough' mode enabling > everything but it

[PATCH v2] file-posix: Use OFD lock only if the filesystem supports the lock

2020-11-18 Thread Masayoshi Mizuma
From: Masayoshi Mizuma locking=auto doesn't work if the filesystem doesn't support OFD lock. In that situation, following error happens: qemu-system-x86_64: -blockdev driver=qcow2,node-name=disk,file.driver=file,file.filename=/mnt/guest.qcow2,file.locking=auto: Failed to lock byte 100

Re: [PATCH] gitlab-ci.yml: Add openSUSE Leap 15.2 for gitlab CI/CD

2020-11-18 Thread AL Yu-Chen Cho
On Tue, 2020-11-17 at 12:51 +0100, Thomas Huth wrote: > On 17/11/2020 07.57, Cho, Yu-Chen wrote: > > Add build-system-opensuse jobs and add opensuse-leap.docker > > dockerfile. > > Use openSUSE Leap 15.2 container image in the gitlab-CI. > > > > Signed-off-by: Cho, Yu-Chen > > --- > >

Re: [PATCH 1/7] Introduce 'track-writes-ram' migration capability.

2020-11-18 Thread Andrey Gruzdev
On 18.11.2020 17:31, Eric Blake wrote: On 11/18/20 5:22 AM, Andrey Gruzdev wrote: Signed-off-by: Andrey Gruzdev --- migration/migration.c | 96 +++ migration/migration.h | 1 + qapi/migration.json | 7 +++- 3 files changed, 103 insertions(+), 1

Re: [PATCH-for-5.2? 1/2] tests/qtest: variable defined by g_autofree need to be initialized

2020-11-18 Thread Thomas Huth
On 18/11/2020 13.13, Philippe Mathieu-Daudé wrote: > On 11/18/20 12:56 PM, Chen Qun wrote: >> According to the glib function requirements, we need initialise >> the variable. Otherwise there will be compilation warnings: >> >> glib-autocleanups.h:28:3: warning: ‘full_name’ may be >> used

Re: [PATCH v2 0/7] UFFD write-tracking migration/snapshots

2020-11-18 Thread Andrey Gruzdev
On 18.11.2020 17:54, Eric Blake wrote: On 11/18/20 7:20 AM, Andrey Gruzdev wrote: Currently the only way to make (external) live VM snapshot is using existing dirty page logging migration mechanism. The main problem is that it tends to produce a lot of page duplicates while running VM goes on

Re: [PATCH 1/2] file-posix: Use OFD lock only if the filesystem supports the lock

2020-11-18 Thread Masayoshi Mizuma
On Wed, Nov 18, 2020 at 02:10:36PM -0500, Masayoshi Mizuma wrote: > On Wed, Nov 18, 2020 at 04:42:47PM +0100, Kevin Wolf wrote: > > Am 06.11.2020 um 05:01 hat Masayoshi Mizuma geschrieben: > > > From: Masayoshi Mizuma > > > > > > locking=auto doesn't work if the filesystem doesn't support OFD

[PATCH v12 4/4] MAINTAINERS: Add maintainer entry for Xilinx ZynqMP CAN controller

2020-11-18 Thread Vikram Garhwal
Reviewed-by: Francisco Iglesias Reviewed-by: Edgar E. Iglesias Signed-off-by: Vikram Garhwal --- MAINTAINERS | 8 1 file changed, 8 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index 63223e1..447b7f2 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -1554,6 +1554,14 @@ F:

Re: Regressions in build process introduced since August

2020-11-18 Thread Stefan Weil
? Was this so that you can give distinct names to the Win32 vs Win64 installer exes ? If so, would it be better if QEMU used a distinct filename for the Win32 vs Win64 installers automatically, to avoid need to override at all ? I now use installer names like qemu-w64-setup-20201118.exe since

Re: [Virtio-fs] [PATCH] virtiofsd: Use --thread-pool-size=0 to mean no thread pool

2020-11-18 Thread Vivek Goyal
On Thu, Nov 12, 2020 at 10:06:37AM +0100, Miklos Szeredi wrote: > On Fri, Nov 6, 2020 at 11:35 PM Vivek Goyal wrote: > > > > On Fri, Nov 06, 2020 at 08:33:50PM +, Venegas Munoz, Jose Carlos wrote: > > > Hi Vivek, > > > > > > I have tested with Kata 1.12-apha0, the results seems that are

[PATCH v10 3/9] hw/arm/virt: Write extra pci roots into fw_cfg

2020-11-18 Thread Jiahui Cen
Add bus property to virt machine for primary PCI root bus and use it to add extra pci roots behind it. Signed-off-by: Jiahui Cen Signed-off-by: Yubo Miao --- hw/arm/virt.c | 7 +-- include/hw/arm/virt.h | 1 + 2 files changed, 6 insertions(+), 2 deletions(-) diff --git

[PATCH v10 5/9] acpi/gpex: Build tables for pxb

2020-11-18 Thread Jiahui Cen
From: Yubo Miao The resources of pxbs are obtained by crs_build and the resources used by pxbs would be moved from the resources defined for host-bridge. The resources for pxb are composed of following two parts: 1. The bar space of the pci-bridge/pcie-root-port behined it 2. The config space

[PATCH v10 4/9] acpi: Extract crs build form acpi_build.c

2020-11-18 Thread Jiahui Cen
From: Yubo Miao Extract crs build form acpi_build.c, the function could also be used to build the crs for pxbs for arm. The resources are composed by two parts: 1. The bar space of pci-bridge/pcie-root-ports 2. The resources needed by devices behind PXBs. The base and limit of memory/io are

Re: [RFC PATCH 0/5] ARM: reduce the memory consumed when mapping UEFI flash images

2020-11-18 Thread Philippe Mathieu-Daudé
On 11/16/20 2:48 PM, Markus Armbruster wrote: > Philippe Mathieu-Daudé writes: > >> Hi David, >> >> On 11/16/20 11:42 AM, David Edmondson wrote: >>> Currently ARM UEFI images are typically built as 2MB/768kB flash >>> images for code and variables respectively. These images are both then >>>

[PATCH] qga: Correct loop count in qmp_guest_get_vcpus()

2020-11-18 Thread Lin Ma
The guest-get-vcpus returns incorrect vcpu info in case we hotunplug vcpus(not the last one). e.g.: A VM has 4 VCPUs: cpu0 + 3 hotunpluggable online vcpus(cpu1, cpu2 and cpu3). Hotunplug cpu2, Now only cpu0, cpu1 and cpu3 are present & online. ./qmp-shell /tmp/qmp-monitor.sock (QEMU)

[PATCH v10 6/9] acpi: Align the size to 128k

2020-11-18 Thread Jiahui Cen
From: Yubo Miao If table size is changed between virt_acpi_build and virt_acpi_build_update, the table size would not be updated to UEFI, therefore, just align the size to 128kb, which is enough and same with x86. It would warn if 64k is not enough and the align size should be updated.

[PATCH v10 8/9] unit-test: Add testcase for pxb

2020-11-18 Thread Jiahui Cen
From: Yubo Miao Add testcase for pxb to make sure the ACPI table is correct for guest. Signed-off-by: Yubo Miao Signed-off-by: Jiahui Cen --- tests/qtest/bios-tables-test.c | 58 ++-- 1 file changed, 52 insertions(+), 6 deletions(-) diff --git

[PATCH v10 2/9] fw_cfg: Refactor extra pci roots addition

2020-11-18 Thread Jiahui Cen
Extract extra pci roots addition from pc machine, which could be used by other machines. In order to make uefi get the extra roots, it is necessary to write extra roots into fw_cfg. And only if the uefi knows there are extra roots, the config spaces of devices behind the root could be obtained.

[PATCH v10 9/9] unit-test: Add the binary file and clear diff.h

2020-11-18 Thread Jiahui Cen
From: Yubo Miao Add the binary file DSDT.pxb and clear bios-tables-test-allowed-diff.h Signed-off-by: Yubo Miao Signed-off-by: Jiahui Cen --- tests/data/acpi/virt/DSDT.pxb | Bin 0 -> 7802 bytes tests/qtest/bios-tables-test-allowed-diff.h | 1 - 2 files changed, 1 deletion(-)

[PATCH v10 1/9] acpi/gpex: Extract two APIs from acpi_dsdt_add_pci

2020-11-18 Thread Jiahui Cen
From: Yubo Miao Extract two APIs acpi_dsdt_add_pci_route_table and acpi_dsdt_add_pci_osc from acpi_dsdt_add_pci. The first API is used to specify the pci route table and the second API is used to declare the operation system capabilities. These two APIs would be used to specify the pxb-pcie in

[PATCH v10 7/9] unit-test: The files changed.

2020-11-18 Thread Jiahui Cen
From: Yubo Miao The unit-test is seperated into three patches: 1. The files changed and list in bios-tables-test-allowed-diff.h 2. The unit-test 3. The binary file and clear bios-tables-test-allowed-diff.h The ASL diff would also be listed. Sice there are 1000+lines diff, some changes would be

Re: [PATCH] hw/arm: Fix bad print format specifiers

2020-11-18 Thread Alex Chen
Kindly ping. On 2020/11/2 17:55, AlexChen wrote: > We should use printf format specifier "%u" instead of "%i" for > argument of type "unsigned int". > > Reported-by: Euler Robot > Signed-off-by: Alex Chen > --- > hw/arm/pxa2xx.c | 2 +- > hw/arm/spitz.c | 2 +- > hw/arm/tosa.c | 2 +- > 3

[PATCH] display/vmware_vga: Fix bad printf format specifiers

2020-11-18 Thread Alex Chen
We should use printf format specifier "%u" instead of "%d" for argument of type "unsigned int". Reported-by: Euler Robot Signed-off-by: Alex Chen --- hw/display/vmware_vga.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/hw/display/vmware_vga.c b/hw/display/vmware_vga.c

Re: [PATCH 00/10] vhost/qemu: thread per IO SCSI vq

2020-11-18 Thread Jason Wang
On 2020/11/19 上午4:06, Mike Christie wrote: On 11/18/20 1:54 AM, Jason Wang wrote: On 2020/11/18 下午2:57, Mike Christie wrote: On 11/17/20 11:17 PM, Jason Wang wrote: On 2020/11/18 上午12:40, Stefan Hajnoczi wrote: On Thu, Nov 12, 2020 at 05:18:59PM -0600, Mike Christie wrote: The following

[PATCH 1/1] vfio: Change default dirty pages tracking behavior during migration

2020-11-18 Thread Kirti Wankhede
By default dirty pages tracking is enabled during iterative phase (pre-copy phase). Added per device opt-out option 'pre-copy-dirty-page-tracking' to disable dirty pages tracking during iterative phase. If the option 'pre-copy-dirty-page-tracking=off' is set for any VFIO device, dirty pages

Re: [PATCH] qga: Correct loop count in qmp_guest_get_vcpus()

2020-11-18 Thread no-reply
Patchew URL: https://patchew.org/QEMU/20201119060833.25328-1-...@suse.com/ Hi, This series seems to have some coding style problems. See output below for more information: Type: series Message-id: 20201119060833.25328-1-...@suse.com Subject: [PATCH] qga: Correct loop count in

[PATCH v10 0/9] pci_expander_brdige:acpi: Support pxb-pcie for ARM

2020-11-18 Thread Jiahui Cen
Changes with v9 v9->v10: Refactor patch2 to drop useless macros and variables. Split patch2 into two patches. Changes with v8 v8->v9: Rebase to master Changes with v7 v7->v8: Fix the error:no member named 'fw_cfg' in 'struct PCMachineState' Changes with v6 v6->v7: Refactor

[PATCH] hw/display/qxl: Fix bad printf format specifiers

2020-11-18 Thread Alex Chen
We should use printf format specifier "%u" instead of "%d" for argument of type "unsigned int". Reported-by: Euler Robot Signed-off-by: Alex Chen --- hw/display/qxl-logger.c | 4 ++-- hw/display/qxl.c| 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH] hw/usb: Fix bad printf format specifiers

2020-11-18 Thread Alex Chen
We should use printf format specifier "%u" instead of "%d" for argument of type "unsigned int". Reported-by: Euler Robot Signed-off-by: Alex Chen --- hw/usb/ccid-card-passthru.c | 2 +- hw/usb/core.c | 4 ++-- hw/usb/dev-smartcard-reader.c | 8 hw/usb/hcd-ehci.c

Re: [PATCH v2] net/e1000e_core: adjust count if RDH exceeds RDT in e1000e_ring_advance()

2020-11-18 Thread Jason Wang
On 2020/11/18 下午4:53, Mauro Matteo Cascella wrote: On Wed, Nov 18, 2020 at 4:56 AM Jason Wang wrote: On 2020/11/13 下午6:31, Mauro Matteo Cascella wrote: The e1000e_write_packet_to_guest() function iterates over a set of receive descriptors by advancing rx descriptor head register (RDH) from

Re: [PATCH] display/vmware_vga: Fix bad printf format specifiers

2020-11-18 Thread Philippe Mathieu-Daudé
Hi Alex, On 11/19/20 4:01 AM, Alex Chen wrote: > We should use printf format specifier "%u" instead of "%d" for > argument of type "unsigned int". > > Reported-by: Euler Robot > Signed-off-by: Alex Chen > --- > hw/display/vmware_vga.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) >

<    1   2   3   4