Re: [Qemu-devel] [PATCH -V3 09/32] virtio-9p: Implement P9_TWRITE/ Thread model in QEMU

2010-03-28 Thread jvrao
Aneesh Kumar K.V wrote: > From: Anthony Liguori We have implemented all the vfs calls in state machine model so that we are prepared for the model where the VCPU thread(s) does the initial work until it needs to block then it submits that work (via a function pointer) to a thread pool. A threa

[Qemu-devel] [PATCH] ignore patch related files

2010-03-28 Thread Mike Frysinger
Signed-off-by: Mike Frysinger --- .gitignore |4 1 files changed, 4 insertions(+), 0 deletions(-) diff --git a/.gitignore b/.gitignore index dfc8e5b..def23c7 100644 --- a/.gitignore +++ b/.gitignore @@ -45,6 +45,10 @@ qemu-monitor.texi *.o .pc patches +*.diff +*.patch +*.rej +*.orig

Re: [Qemu-devel] [PATCH -V3 25/32] virtio-9p: Move V9fs File system specific options to a separate header file.

2010-03-28 Thread jvrao
Aneesh Kumar K.V wrote: Missed one more point in my previous response. > > -static int local_lstat(V9fsState *s, const char *path, struct stat *stbuf) > +static int local_lstat(FsContext *s, const char *path, struct stat *stbuf) We have been using 's' for V9fsState For FsContext it is better

Re: [Qemu-devel] [PATCH -V3 25/32] virtio-9p: Move V9fs File system specific options to a separate header file.

2010-03-28 Thread jvrao
Aneesh Kumar K.V wrote: > Move the V9fs File System specific operations structs into a different header > file. > > Also introduce a new struct named context which is the subset of the V9fsState > to be passed to the individual file-system operations. > > Signed-off-by: Aneesh Kumar K.V > Signed

[Qemu-devel] [PATCH 1/5] linux-user/ia64: workaround ia64 strangenesses

2010-03-28 Thread Aurelien Jarno
ia64 has some strangenesses that need to be workaround: - it has a __clone2() syscall instead of the using clone() one, with different arguments, and which is not declared in the usual headers. - ucontext.uc_sigmask is declared with type long int, while it is actually of type sigset_t. - uc_mco

[Qemu-devel] [PATCH 4/5] tcg: align static_code_gen_buffer to CODE_GEN_ALIGN

2010-03-28 Thread Aurelien Jarno
On ia64, the default memory alignement is not enough for a code alignement. To fix that, force static_code_gen_buffer alignment to CODE_GEN_ALIGN. Signed-off-by: Aurelien Jarno --- exec.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/exec.c b/exec.c index 1b0fe52..5c

[Qemu-devel] [PATCH 2/5] linux-user: fix page_unprotect when host page size > target page size

2010-03-28 Thread Aurelien Jarno
When the host page size is bigger that the target one, unprotecting a page should: - mark all the target pages corresponding to the host page as writable - invalidate all tb corresponding to the host page (and not the target page) Signed-off-by: Aurelien Jarno --- exec.c | 45 +++

[Qemu-devel] ia64 support

2010-03-28 Thread Aurelien Jarno
This patch series adds host Itanium support to QEMU. System mode works correctly except a few unaligned access in the slirp code (fixed by the kernel). It has been tested by booting debian installer on arm, i386, mips, mipsel, ppc, sparc, and x86_64. A full installation has been done on sparc.

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Cam Macdonell
On Sat, Mar 27, 2010 at 11:48 AM, Avi Kivity wrote: > On 03/26/2010 07:14 PM, Cam Macdonell wrote: >> >>> I'm not familiar with the uio internals, but for the interface, an >>> ioctl() >>> on the fd to assign an eventfd to an MSI vector.  Similar to ioeventfd, >>> but >>> instead of mapping a door

Re: [Qemu-devel] [PATCH 23/48] multi-mmc support in init call

2010-03-28 Thread Filip Navara
I see neither the change to sd_init implementation nor the implementation of sd_is_mmc. Best regards, Filip Navara On Fri, Mar 26, 2010 at 5:06 PM, Riku Voipio wrote: > From: Juha Riihimäki > > change sd_init convention to allow multiple entries > > Signed-Off-By: Riku Voipio > Signed-Off-By:

Re: [Qemu-devel] [PATCH 1/4] linux-user: add pselect syscall

2010-03-28 Thread Jamie Lokier
Paul Brook wrote: > >This patch adds support for the pselect syscall in linux-user emulation > >and also adds several support functions required to translate the > >timespec structs between the target and the host. > > IIUC the whole point of the pselect is that it should be atomic. By > emulating

[Qemu-devel] BlueTooth RFCOMM?

2010-03-28 Thread Samuel Thibault
Hello, I am trying to add support for Bluetooth braille devices, but I seem to be missing something. Basically, it should be using the RFCOMM PSM, but running rfcomm connect 0 BA:BE:BA:D0:00:01 in the Linux guest hangs for some time and then the connect() system call returns EINPROGRESS. Am I pe

Re: [Qemu-devel] Significant performance regression in qemu-system-mips.

2010-03-28 Thread Rob Landley
On Sunday 28 March 2010 09:57:09 Aurelien Jarno wrote: > > If you want the code actually cleaned up instead of minimally changed, > > here's a stab at that. (Unfortunately I haven't got a ppc64 setup to > > test it with yet, but ppc32 still works.) > > Not necessarily a code cleanup, but at least

[Qemu-devel] [PATCH] baum: add destroy hook

2010-03-28 Thread Samuel Thibault
Hello, This adds a destroy hook for the baum character device, to properly close the BrlAPI connection and free resources. Signed-off-by: Samuel Thibault commit 447c41758cfda0022ea6e09aaf81137b2b27b915 Author: Samuel Thibault Date: Sun Mar 28 20:38:38 2010 +0200 baum: add destroy hook

[Qemu-devel] [PATCH 3/3] qemu-nbd: Improve error reporting

2010-03-28 Thread Ryota Ozaki
- use err(3) instead of errx(3) if errno is available to report why failed - let fail prior to daemon(3) if opening a nbd file is likely to fail after daemonizing to avoid silent failure exit - add missing 'ret = 1' when unix_socket_outgoing failed Signed-off-by: Ryota Ozaki --- qemu-nbd.c

[Qemu-devel] [PATCH 2/3] qemu-nbd: Extend read-only option to nbd device file

2010-03-28 Thread Ryota Ozaki
This patch allows to operate on nbd device file without write permission for the file if read-only option is specified. Signed-off-by: Ryota Ozaki --- qemu-nbd.c | 10 +- 1 files changed, 5 insertions(+), 5 deletions(-) diff --git a/qemu-nbd.c b/qemu-nbd.c index 00b8896..7ef409f 10064

[Qemu-devel] [PATCH 1/3] qemu-nbd: Fix coding style

2010-03-28 Thread Ryota Ozaki
Follow "Every indented statement is braced; even if the block contains just one statement." described in CODING_STYLE. Signed-off-by: Ryota Ozaki --- qemu-nbd.c | 60 1 files changed, 40 insertions(+), 20 deletions(-) diff --git a/q

[Qemu-devel] Re: Significant performance regression in qemu-system-mips.

2010-03-28 Thread Paolo Bonzini
On 03/24/2010 09:34 PM, Rob Landley wrote: Unfortunately, I can't revert that patch in current origin/master because most of the hunks fail... Try this, or try disabling dynticks as a stopgap measure: http://permalink.gmane.org/gmane.comp.emulators.qemu/65821 Paolo

[Qemu-devel] [PATCH] Compile qemu-timer only once

2010-03-28 Thread Blue Swirl
Arrange various declarations so that also non-CPU code can access them, adjust users. Move CPU specific code to cpus.c. Signed-off-by: Blue Swirl --- The patch also available in my rebased tree: git://repo.or.cz/qemu/blueswirl.git http://repo.or.cz/r/qemu/blueswirl.git Makefile.objs |

Re: [Qemu-devel] Re: [PATCH 10/15] virtio-serial: Add QMP events for failed port/device add

2010-03-28 Thread Jamie Lokier
Amit Shah wrote: > > Without this specific thing, which is an indicator that guest has lost > > state outside its control, the guest<->host communication is > > unreliable (even for things like "cut and paste"), so every app that > > cares has to implement a packet framing protocol with no binary d

[Qemu-devel] Re: [PATCH v2] qemu-io: fix aio help texts

2010-03-28 Thread Aurelien Jarno
On Sun, Mar 28, 2010 at 12:19:31PM +0200, Christoph Hellwig wrote: > Fix a few typos in the help texts for the various aio commands. > > Signed-off-by: Christoph Hellwig Thanks, applied. > Index: qemu/qemu-io.c > === > --- qemu.ori

[Qemu-devel] Re: [PATCH] tcg/arm: Replace qemu_ld32u (left over from previous commit)

2010-03-28 Thread Aurelien Jarno
On Sun, Mar 28, 2010 at 11:44:29AM +0200, Stefan Weil wrote: > Commit 86feb1c860dc38e9c89e787c5210e8191800385e > did not change all occurrences of INDEX_op_qemu_ld32u > for tcg/arm. > > Please note that I could not test this patch > (I have currently no arm system available). > > Cc: Richard Hend

Re: [Qemu-devel] Significant performance regression in qemu-system-mips.

2010-03-28 Thread Aurelien Jarno
On Sat, Mar 27, 2010 at 06:01:39PM -0500, Rob Landley wrote: > On Saturday 27 March 2010 07:32:41 Aurelien Jarno wrote: > > On Fri, Mar 26, 2010 at 04:47:51PM -0500, Rob Landley wrote: > > > On Friday 26 March 2010 14:00:00 Aurelien Jarno wrote: > > > > I am pretty fine applying a correct patch if

Re: [Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread malc
On Sun, 28 Mar 2010, Jamie Lokier wrote: > Avi Kivity wrote: > > ioctls encode the buffer size into the ioctl number, so in theory strace > > doesn't need to be taught about an ioctl to show its buffer. > > Unfortunately ioctl numbers don't always follow that rule :-( It's not a rule to begin w

Re: [Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Jamie Lokier
Avi Kivity wrote: > ioctls encode the buffer size into the ioctl number, so in theory strace > doesn't need to be taught about an ioctl to show its buffer. Unfortunately ioctl numbers don't always follow that rule :-( But maybe that's just awful proprietary drivers that I've seen. Anyway, strace

Re: [Qemu-devel] [RFC][PATCH 7/7] qcow2: Trigger blkdebug events

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:35PM +0100, Kevin Wolf wrote: > This adds blkdebug events to qcow2 to allow injecting I/O errors in specific > places. Looks good, Reviewed-by: Christoph Hellwig

Re: [Qemu-devel] [RFC][PATCH 6/7] blkdebug: Add events and rules

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:34PM +0100, Kevin Wolf wrote: > +fprintf(stderr, "bdrv_debug_event: %d\n", event); Is this supposed to be in the final version or a leftover debugging aid? > +#define BLKDBG_EVENT(bs, evt) bdrv_debug_event(bs, evt) Why not call bdrv_debug_event directly? > +

Re: [Qemu-devel] [PATCH 3/3] qemu-nbd: Improve error reporting

2010-03-28 Thread Ryota Ozaki
On Sat, Mar 27, 2010 at 10:02 PM, Aurelien Jarno wrote: > On Sat, Mar 20, 2010 at 03:23:24PM +0900, Ryota Ozaki wrote: >> - use err(3) instead of errx(3) if errno is available >>   to report why failed >> - let fail prior to daemon(3) if opening a nbd file >>   is likely to fail after daemonizing

Re: [Qemu-devel] [RFC][PATCH 5/7] Make qemu-config available for tools

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:33PM +0100, Kevin Wolf wrote: > available in the tools. This involves moving two functions that can only be > built in the context of the emulator. > > Signed-off-by: Kevin Wolf Looks good, Reviewed-by: Christoph Hellwig

Re: [Qemu-devel] [RFC][PATCH 4/7] blkdebug: Inject errors

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:32PM +0100, Kevin Wolf wrote: > Add a mechanism to inject errors instead of passing requests on. With no > further patches applied, you can use it by setting inject_errno in gdb. > > Signed-off-by: Kevin Wolf The magic iocb is quite a hack, but it should work good e

Re: [Qemu-devel] [RFC][PATCH 3/7] blkdebug: Basic request passthrough

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:31PM +0100, Kevin Wolf wrote: > This isn't doing anything interesting. It creates the blkdebug block driver as > a protocol which just passes everything through to raw. > > Signed-off-by: Kevin Wolf > --- > Makefile.objs|2 +- > block/blkdebug.c | 104 > ++

Re: [Qemu-devel] [RFC][PATCH 2/7] qemu-config: Make qemu_config_parse more generic

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:30PM +0100, Kevin Wolf wrote: > qemu_config_parse gets the option groups as a parameter now instead of > hardcoding the VM configuration groups. This way it can be used for other > configurations, too. > > Signed-off-by: Kevin Wolf Looks good, Reviewed-by: Christo

Re: [Qemu-devel] [RFC][PATCH 1/7] qemu-config: qemu_read_config_file() reads the normal config file

2010-03-28 Thread Christoph Hellwig
On Mon, Mar 15, 2010 at 06:08:29PM +0100, Kevin Wolf wrote: > Introduce a new function qemu_read_config_file which reads the VM > configuration > from a config file. Unlike qemu_config_parse it doesn't take a open file but a > filename and reduces code duplication as a side effect. > > Signed-off

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Avi Kivity
On 03/28/2010 01:31 PM, Michael S. Tsirkin wrote: Aren't ioctls a lot simpler? Multiplexing multiple functions on write()s is just ioctls done uglier. I don't have an opinion here. Writes do have an advantage that strace can show the buffer content without being patched. ioctls e

Re: [Qemu-devel] [PATCH] qemu-img: add FUSE-based image access

2010-03-28 Thread Christoph Hellwig
On Thu, Mar 25, 2010 at 06:52:59PM +0100, Jan Kiszka wrote: > This adds the "map" subcommand to qemu-img. It is able to expose the raw > content of a disk image via a FUSE filesystem. Both the whole disk can > be accessed, e.g. to run partitioning tools against it, as well as > individual partition

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Michael S. Tsirkin
On Sun, Mar 28, 2010 at 12:45:02PM +0300, Avi Kivity wrote: > On 03/28/2010 12:40 PM, Michael S. Tsirkin wrote: uio accepts 32 bit writes to the char device file. We can encode the fd number there, and use the high bit to signal assign/deassign. >>> Ugh. Very unexpandab

[Qemu-devel] [PATCH v2] qemu-io: fix aio help texts

2010-03-28 Thread Christoph Hellwig
Fix a few typos in the help texts for the various aio commands. Signed-off-by: Christoph Hellwig Index: qemu/qemu-io.c === --- qemu.orig/qemu-io.c 2010-03-16 19:07:43.089009269 +0100 +++ qemu/qemu-io.c 2010-03-16 19:08:36.59700

[Qemu-devel] [PATCH] Documentation: Update chapter on installation

2010-03-28 Thread Stefan Weil
* Replace broken links by link to QEMU wiki. * Separate sections for Linux / Windows / Mac OS X are no longer needed: the wiki link will provide additional links, so we don't need them here. * Add hint for (Open) Solaris. Signed-off-by: Stefan Weil --- qemu-doc.texi | 38 +++---

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Avi Kivity
On 03/28/2010 12:40 PM, Michael S. Tsirkin wrote: uio accepts 32 bit writes to the char device file. We can encode the fd number there, and use the high bit to signal assign/deassign. Ugh. Very unexpandable. It currently fails on any non-4 byte write. So if we need more bits in

[Qemu-devel] [PATCH] tcg/arm: Replace qemu_ld32u (left over from previous commit)

2010-03-28 Thread Stefan Weil
Commit 86feb1c860dc38e9c89e787c5210e8191800385e did not change all occurrences of INDEX_op_qemu_ld32u for tcg/arm. Please note that I could not test this patch (I have currently no arm system available). Cc: Richard Henderson Cc: Aurelien Jarno Signed-off-by: Stefan Weil --- tcg/arm/tcg-targe

[Qemu-devel] [PATCH] Fix compilation with missing inotify_init1

2010-03-28 Thread Stefan Weil
Commit c05c7a7306a23a4b01d1606172b142c45caffc92 breaks cross compilation for mips (and other compilations without CONFIG_INOTIFY1): make[1]: Entering directory `/qemu/bin/mips' CCi386-linux-user/syscall.o cc1: warnings being treated as errors /qemu/linux-user/syscall.c: In function ‘do_sysca

[Qemu-devel] [PATCH] Fix cross compilation

2010-03-28 Thread Stefan Weil
This patch enhances the algorithm which finds the correct settings for SDL. For cross compilations (when cross_prefix is set), it looks for sdl-config with cross prefix. Here is the complete search order: ${cross_prefix}sdl_config (new, only used for cross compilation) $(cross_prefix}

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Michael S. Tsirkin
On Sun, Mar 28, 2010 at 11:02:11AM +0300, Avi Kivity wrote: > On 03/28/2010 10:47 AM, Michael S. Tsirkin wrote: >>> Maybe irqcontrol could be extended? >>> What's irqcontrol? >>> >> uio accepts 32 bit writes to the char device file. We can encode >> the fd number there,

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Avi Kivity
On 03/28/2010 10:47 AM, Michael S. Tsirkin wrote: Maybe irqcontrol could be extended? What's irqcontrol? uio accepts 32 bit writes to the char device file. We can encode the fd number there, and use the high bit to signal assign/deassign. Ugh. Very unexpandable. -- erro

[Qemu-devel] [PATCH] Fix conditional compilation case CONFIG_INOTIFY && !CONFIG_INOTIFY1.

2010-03-28 Thread takasi-y
There is undefined reference to sys_inotify_init1() at do_syscall() when CONFIG_INOTIFY=y and CONFIG_INOTIFY1=n. We should undef TARGET_NR_inotify_init1 if CONFIG_INOTIFY1 is undefined, as it seems to be the strategy of conditional compilation here. Signed-off-by: Takashi YOSHII --- linux-user/

[Qemu-devel] Re: [PATCH v3 1/1] Shared memory uio_pci driver

2010-03-28 Thread Michael S. Tsirkin
On Sat, Mar 27, 2010 at 08:48:34PM +0300, Avi Kivity wrote: > On 03/26/2010 07:14 PM, Cam Macdonell wrote: >> >>> I'm not familiar with the uio internals, but for the interface, an ioctl() >>> on the fd to assign an eventfd to an MSI vector. Similar to ioeventfd, but >>> instead of mapping a doorb