Re: [Qemu-devel] [PATCH v5 0/8] sheepdog: reconnect server after connection failure

2013-10-27 Thread Liu Yuan
On Thu, Oct 24, 2013 at 04:01:10PM +0900, MORITA Kazutaka wrote: > Currently, if a sheepdog server exits, all the connecting VMs need to > be restarted. This series implements a feature to reconnect the > server, and enables us to do online sheepdog upgrade and avoid > restarting VMs when sheepdog

Re: [Qemu-devel] About the migration_set_speed in the qemu monitor

2013-10-27 Thread Wanlong Gao
On 10/28/2013 01:30 PM, Yaodong Yang wrote: > Hi all, > > When we migrate a vm from one host to another, we set the " migrate_set_speed > 200" inside the qemu monitor. What does the 200 means? Is it the maximum > migration speed is 200MB/s or something else? > This means the bandwidth limit is

[Qemu-devel] About the migration_set_speed in the qemu monitor

2013-10-27 Thread Yaodong Yang
Hi all, When we migrate a vm from one host to another, we set the " migrate_set_speed 200" inside the qemu monitor. What does the 200 means? Is it the maximum migration speed is 200MB/s or something else? Thanks!

Re: [Qemu-devel] [PATCH_v2 0/9] target-openrisc: Corrections and speed improvements

2013-10-27 Thread Sebastian Macke
On 25/10/2013 5:21 PM, Jia Liu wrote: On Fri, Oct 25, 2013 at 7:23 AM, Sebastian Macke wrote: On 22/10/2013 8:47 PM, Jia Liu wrote: Hi Sebastian, On Tue, Oct 22, 2013 at 8:12 AM, Sebastian Macke wrote: This series is the first part to make the OpenRISC target more reliable and faster. It co

[Qemu-devel] [PATCH 2/2] slirp: make slirp event dispatch based on slirp instance

2013-10-27 Thread Liu Ping Fan
Each slirp instance has its own GFuncs, so we can driver slirp by glib main loop. Signed-off-by: Liu Ping Fan --- For easing the review, This patch does not obey coding guide. Will fix it later --- main-loop.c | 6 --- net/slirp.c | 3 ++ slirp/TFX7d70.tmp | 0 slirp/lib

[Qemu-devel] [PATCH 0/2] make slirp drivern by glib directly

2013-10-27 Thread Liu Ping Fan
This series make slirp drivern directly by glib, so we can clean up the hooks for slrip in mainloop and stub Liu Ping Fan (2): slirp: introduce gsource event abstraction slirp: make slirp event dispatch based on slirp instance main-loop.c | 6 --- net/slirp.c | 3 ++

[Qemu-devel] [PATCH 1/2] slirp: introduce gsource event abstraction

2013-10-27 Thread Liu Ping Fan
Introduce struct SlirpGSource. It will ease the usage of GSource associated with a group of files, which are dynamically allocated and release for slirp. Signed-off-by: Liu Ping Fan --- slirp/Makefile.objs | 2 +- slirp/slirp_gsource.c | 94 +++

[Qemu-devel] [PATCH for 1.7] exec: fix breakpoint_invalidate when pc may not be translated

2013-10-27 Thread Max Filippov
This fixes qemu abort with the following message: include/qemu/int128.h:22: int128_get64: Assertion `!a.hi' failed. which happens due to attempt to invalidate breakpoint by virtual address for which get_phys_page_debug couldn't find mapping. For more details see http://lists.nongnu.org/archi

[Qemu-devel] [PATCH v4 4/4] Protect coroutine_fn and blocking_fn with #ifndef

2013-10-27 Thread Charlie Shepherd
From: Gabriel Kerneis This patch allows defining coroutine and blocking annotations with ./configure --extra-cflags instead of modifying coroutine.h. Signed-off-by: Gabriel Kerneis --- include/block/coroutine.h | 4 1 file changed, 4 insertions(+) diff --git a/include/block/coroutine.h b

[Qemu-devel] [PATCH v4 0/4] Documentation for coroutine annotations

2013-10-27 Thread Charlie Shepherd
These patches were the first two from my GSoC series and were reasonably straight-forward and well accepted. Gabriel and I are hoping the patches from GSoC can be merged before I start my job in December, so I'm starting by sending the simple parts of the overall patchset, when they are merged then

[Qemu-devel] [PATCH v4 3/4] Introduce blocking_fn annotation

2013-10-27 Thread Charlie Shepherd
From: Gabriel Kerneis A blocking function is a function that must not be called in coroutine context, for example because it might block for a long amount of time. This annotation should be used to mark normal functions that have a coroutine_fn counterpart, to make sure that the former is not use

[Qemu-devel] [PATCH v4 1/4] Add an explanation of when a function should be marked coroutine_fn

2013-10-27 Thread Charlie Shepherd
Coroutine functions that can yield directly or indirectly should be annotated with a coroutine_fn annotation. Add an explanation to that effect in include/block/coroutine.h. Signed-off-by: Charlie Shepherd --- include/block/coroutine.h | 8 1 file changed, 8 insertions(+) diff --git a/

[Qemu-devel] [PATCH v4 2/4] Rename qemu_coroutine_self to qemu_coroutine_self_int and add an annotated wrapper

2013-10-27 Thread Charlie Shepherd
While it only really makes sense to call qemu_coroutine_self() in a coroutine context, some coroutine internals need to call it from functions not annotated as coroutine_fn, so add an annotated wrapper and rename the implementation versions to qemu_coroutine_self_int. Signed-off-by: Charlie Shephe

Re: [Qemu-devel] [PATCH v3 0/2] Documentation for coroutine annotations

2013-10-27 Thread Charlie Shepherd
On 27/10/2013 20:37, Gabriel Kerneis wrote: On Sun, Oct 27, 2013 at 04:23:54PM +0100, Charlie Shepherd wrote: These patches were the first two from my GSoC series and were reasonably straight-forward and well accepted. Gabriel and I are hoping the patches from GSoC can be merged before I start m

Re: [Qemu-devel] [PATCH v3 0/2] Documentation for coroutine annotations

2013-10-27 Thread Gabriel Kerneis
On Sun, Oct 27, 2013 at 04:23:54PM +0100, Charlie Shepherd wrote: > These patches were the first two from my GSoC series and were reasonably > straight-forward and well accepted. Gabriel and I are hoping the patches from > GSoC can be merged before I start my job in December, so I'm starting by >

Re: [Qemu-devel] [PATCH -V5] target-ppc: Fix page table lookup with kvm enabled

2013-10-27 Thread Alexander Graf
On 11.10.2013, at 09:58, Aneesh Kumar K.V wrote: > Alexander Graf writes: > >> On 11.10.2013, at 13:13, Aneesh Kumar K.V >> wrote: >> >>> From: "Aneesh Kumar K.V" >>> >>> With kvm enabled, we store the hash page table information in the >>> hypervisor. >>> Use ioctl to read the htab con

Re: [Qemu-devel] [PATCH -V6 3/3] target-ppc: Fix htab_mask calculation

2013-10-27 Thread Alexander Graf
On 15.10.2013, at 01:58, Aneesh Kumar K.V wrote: > From: "Aneesh Kumar K.V" > > Correctly update the htab_mask using the return value of > KVM_PPC_ALLOCATE_HTAB ioctl. Also we don't update sdr1 > on GET_SREGS for HV. So don't update htab_mask if sdr1 > is found to be zero. Fix the pte index c

Re: [Qemu-devel] [PATCH -V6 2/3] target-ppc: Fix page table lookup with kvm enabled

2013-10-27 Thread Alexander Graf
On 15.10.2013, at 01:58, Aneesh Kumar K.V wrote: > From: "Aneesh Kumar K.V" > > With kvm enabled, we store the hash page table information in the hypervisor. > Use ioctl to read the htab contents. Without this we get the below error when > trying to read the guest address > > (gdb) x/10 do_f

Re: [Qemu-devel] [RFC PATCH] spapr: add ibmveth to the supported network adapters list

2013-10-27 Thread Alexander Graf
On 10.10.2013, at 20:09, Alexey Kardashevskiy wrote: > The problem is that "-net nic,model=?" does not print "ibmveth" in > the list while it is actually supported. > > Most of the QEMU emulated network devices are PCI but "ibmveth" > (a.k.a. spapr-vlan) is not. However with "-net nic,model=?",

Re: [Qemu-devel] [PATCH] spapr: add vio-bus devices to categories

2013-10-27 Thread Alexander Graf
On 10.10.2013, at 20:08, Alexey Kardashevskiy wrote: > In order to get devices appear in output of > "./qemu-system-ppc64 -device ?", > they must be assigned to one of DEVICE_CATEGORY_. > > This puts VIO devices classes to corresponding categories. > > Signed-off-by: Alexey Kardashevskiy

Re: [Qemu-devel] [PATCH v7] powerpc: add PVR mask support

2013-10-27 Thread Alexander Graf
On 23.10.2013, at 07:57, Andreas Färber wrote: > Am 27.09.2013 09:05, schrieb Alexey Kardashevskiy: >> IBM POWERPC processors encode PVR as a CPU family in higher 16 bits and >> a CPU version in lower 16 bits. Since there is no significant change >> in behavior between versions, there is no poin

Re: [Qemu-devel] qemu 1.6.1

2013-10-27 Thread Stefan Weil
Am 27.10.2013 07:54, schrieb Paolo Bonzini: > > I think the problem is that 0x20(%esp) gets somehow corrupted at the > instruction I highlighted with **. > > The simplest fix then would be to add a barrier() before and after > SwitchToFiber. > > Paolo I added some debugging output (see code at htt

[Qemu-devel] [PATCH v3 2/2] Rename qemu_coroutine_self to qemu_coroutine_self_int and add an annotated wrapper

2013-10-27 Thread Charlie Shepherd
While it only really makes sense to call qemu_coroutine_self() in a coroutine context, some coroutine internals need to call it from functions not annotated as coroutine_fn, so add an annotated wrapper and rename the implementation versions to qemu_coroutine_self_int. --- coroutine-gthread.c

[Qemu-devel] [PATCH v3 1/2] Add an explanation of when a function should be marked coroutine_fn

2013-10-27 Thread Charlie Shepherd
Coroutine functions that can yield directly or indirectly should be annotated with a coroutine_fn annotation. Add an explanation to that effect in include/block/coroutine.h. --- include/block/coroutine.h | 8 1 file changed, 8 insertions(+) diff --git a/include/block/coroutine.h b/includ

[Qemu-devel] [PATCH v3 0/2] Documentation for coroutine annotations

2013-10-27 Thread Charlie Shepherd
These patches were the first two from my GSoC series and were reasonably straight-forward and well accepted. Gabriel and I are hoping the patches from GSoC can be merged before I start my job in December, so I'm starting by sending the simple parts of the overall patchset, when they are merged then

Re: [Qemu-devel] [patch 2/2] i386: pc: align gpa<->hpa on 1GB boundary

2013-10-27 Thread igor Mammedov
On Fri, 25 Oct 2013 11:34:22 -0200 Marcelo Tosatti wrote: > On Fri, Oct 25, 2013 at 11:57:18AM +0200, igor Mammedov wrote: > > On Fri, 25 Oct 2013 02:58:05 -0200 > > Marcelo Tosatti wrote: > > > > > On Fri, Oct 25, 2013 at 12:55:36AM +0100, Paolo Bonzini wrote: > > > > > +if (hpagesize

Re: [Qemu-devel] Fix SMB security configuration on newer samba versions

2013-10-27 Thread Michael Büsch
On Sun, 27 Oct 2013 18:50:18 +0800 Amos Kong wrote: > > Index: qemu-1.6.1/net/slirp.c > > === > > --- qemu-1.6.1.orig/net/slirp.c 2013-10-09 21:20:32.0 +0200 > > +++ qemu-1.6.1/net/slirp.c 2013-10-21 13:49:39.918960448 +

Re: [Qemu-devel] [PATCH v2] net: disallow to specify multicast MAC address

2013-10-27 Thread Amos Kong
On Mon, Oct 21, 2013 at 4:08 PM, Dmitry Krivenok wrote: > Changes to v1: > 1) Resolved names clash in include/net/eth.h > 2) Reused is_multicast_ether_addr() from that header for MAC check. > > Signed-off-by: Dmitry V. Krivenok Reviewed-by: Amos Kong > --- > include/net/eth.h | 6 +++--- > ne

Re: [Qemu-devel] Fix SMB security configuration on newer samba versions

2013-10-27 Thread Amos Kong
On Mon, Oct 21, 2013 at 7:50 PM, Michael Büsch wrote: > The following changes fix the samba security configuration on > newer samba versions. > > samba version 4.0.10-Debian throws this warning: > >> WARNING: Ignoring invalid value 'share' for parameter 'security' > > Which makes it fall back to

Re: [Qemu-devel] qemu 1.6.1

2013-10-27 Thread Stefan Weil
Am 27.10.2013 07:54, schrieb Paolo Bonzini: > Here is the code with annotations > > broken works > - > push %ebx > sub$0x18,%espsub$0x1c,%esp

Re: [Qemu-devel] [PATCH] block: Don't copy backing file name on error

2013-10-27 Thread Amos Kong
On Sat, Oct 26, 2013 at 9:44 PM, Max Reitz wrote: > > bdrv_open_backing_file() tries to copy the backing file name using > pstrcpy directly after calling bdrv_open() to open the backing file > without checking whether that was actually successful. If it was not, > ps->backing_hd->file will probabl