Re: [PATCH] hw/gpio/aspeed_gpio: Fix QOM pin property

2022-05-18 Thread Rashmica Gupta
On Mon, 2022-05-02 at 01:08 -0700, Peter Delevoryas wrote: > I was setting gpioV4-7 to "1110" using the QOM pin property handler > and > noticed that lowering gpioV7 was inadvertently lowering gpioV4-6 too. > >     (qemu) qom-set /machine/soc/gpio gpioV4 true >     (qemu) qom-set /machine/soc/gpio

Re: [PATCH v2 3/3] target/ppc: Rename sfprf to sfifprf where it's also used as set fi flag

2022-05-11 Thread Rashmica Gupta
  \ > @@ -2767,9 +2767,9 @@ VSX_CVT_FP_TO_FP_VECTOR(xscvdpqp, 1, float64, > float128, VsrD(0), f128, 1) >   *   ttp   - target type >   *   sfld  - source vsr_t field >   *   tfld  - target vsr_t field > - *   sfprf - set FPRF > + *   sfifprf - set FPRF set FI and FPRF? otherwise, Reviewed-by: Rashmica Gupta signature.asc Description: This is a digitally signed message part

Re: [PATCH v2 2/3] target/ppc: Fix FPSCR.FI changing in float_overflow_excp()

2022-05-11 Thread Rashmica Gupta
7.4.3 Floating-Point Overflow Exception' as instructions that don't modify FR, FI and FPRF. It would be ideal if the ISA mentioned that there were exceptions in the part that you quoted! This patch makes sense to me. Reviewed-by: Rashmica Gupta > > The root cause for this seems t

Re: [PATCH v2 1/3] target/ppc: Fix FPSCR.FI bit being cleared when it shouldn't

2022-05-11 Thread Rashmica Gupta
Hello, cc'ing Paul and Nick for clarification on the behaviour of xsrsp (see below) On Tue, 2022-05-10 at 17:46 -0300, Víctor Colombo wrote: > The FI bit in FPSCR is said to be a non-sticky bit on Power ISA. > One could think this means that, if an instruction is said to modify > the FPSCR regis

Re: [PATCH 1/1] hw: aspeed_gpio: Fix pin I/O type declarations

2021-09-30 Thread Rashmica Gupta
> - GPIOU0..GPIOU7 should have been GPIU0..GPIU7. > > > - GPIW0..GPIW7 should have been GPIOW0..GPIOW7. > > > - GPIOY0..GPIOY7 and GPIOZ0...GPIOZ7 were disabled. > > > Fixes: 4b7f956862dc2db4c5c ("hw/gpio: Add basic Aspeed GPIO model > > > for AST2400 and AST2500"

Re: [PATCH v2 3/3] hw: aspeed_gpio: Clarify GPIO controller name

2021-07-13 Thread Rashmica Gupta
On Tue, 2021-07-13 at 16:28 +0930, Joel Stanley wrote: > There are two GPIO controllers in the ast2600; one is 3.3V and the > other > is 1.8V. > > Signed-off-by: Joel Stanley Thanks for picking this up. Reviewed-by: Rashmica Gupta > --- >  hw/gp

Re: [PATCH v2 2/3] hw: aspeed_gpio: Simplify 1.8V defines

2021-07-13 Thread Rashmica Gupta
remove the offset to save future confusion. > > Signed-off-by: Joel Stanley Makes sense, and it is cleaner. Reviewed-by: Rashmica Gupta > --- >  hw/gpio/aspeed_gpio.c | 73 + > -- >  1 file changed, 36 insertions(+), 37 deletions(-) >

Re: [PATCH v2 1/3] hw: aspeed_gpio: Fix memory size

2021-07-13 Thread Rashmica Gupta
perianal, which happens to be the RTC. > > The mmio region used by each device is a maximum of 2KB, so avoid the > calculations and hard code this as the maximum. > > Fixes: 36d737ee82b2 ("hw/gpio: Add in AST2600 specific > implementation") > Signed-off-by: Joel Stan

[Qemu-devel] [PATCH v6 2/3] aspeed: add a GPIO controller to the SoC

2019-08-26 Thread Rashmica Gupta
Signed-off-by: Rashmica Gupta Reviewed-by: Cédric Le Goater --- include/hw/arm/aspeed_soc.h | 3 +++ hw/arm/aspeed_soc.c | 17 + 2 files changed, 20 insertions(+) diff --git a/include/hw/arm/aspeed_soc.h b/include/hw/arm/aspeed_soc.h index cef605ad6b..fa04abddd8 100644

[Qemu-devel] [PATCH v6 1/3] hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500

2019-08-26 Thread Rashmica Gupta
source driving the GPIO pins in the model is the ARM model (as there currently aren't models for the LPC or Coprocessor). (2) None of the registers in the model are reset tolerant (needs integration with the watchdog). Signed-off-by: Rashmica Gupta Tested-by: Andrew Jeffery Reviewed-by: Cédri

[Qemu-devel] [PATCH v6 3/3] hw/gpio: Add in AST2600 specific implementation

2019-08-26 Thread Rashmica Gupta
The AST2600 has the same sets of 3.6v gpios as the AST2400 plus an addtional two sets of 1.8V gpios. Signed-off-by: Rashmica Gupta Reviewed-by: Cédric Le Goater --- hw/gpio/aspeed_gpio.c | 142 -- 1 file changed, 137 insertions(+), 5 deletions(-) diff

[Qemu-devel] [PATCH v6 0/3] Add Aspeed GPIO controller model

2019-08-26 Thread Rashmica Gupta
added debounce regs, renamed get/set to read/write to minimise confusion with a 'set' of registers. Rashmica Gupta (3): hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500 aspeed: add a GPIO controller to the SoC hw/gpio: Add in AST2600 specific implementation in

Re: [Qemu-devel] [PATCH v4 0/3] Add Aspeed GPIO controller model

2019-08-26 Thread Rashmica Gupta
On Fri, 2019-08-16 at 18:21 +0200, Cédric Le Goater wrote: > On 16/08/2019 09:32, Rashmica Gupta wrote: > > v5: > > - integrated AspeedGPIOController fields into AspeedGPIOClass > > - separated ast2600_3_6v and ast2600_1_8v into two classes > > Rashmica, > > This

Re: [Qemu-devel] [PATCH v5 2/3] aspeed: add a GPIO controller to the SoC

2019-08-16 Thread Rashmica Gupta
Cédric, this is how I thought changes to the SOC for your aspeed-4.1 branch would look >From 13a07834476fa266c352d9a075b341c483b2edf9 Mon Sep 17 00:00:00 2001 From: Rashmica Gupta Date: Fri, 16 Aug 2019 15:18:22 +1000 Subject: [PATCH] Aspeed SOC changes --- include/hw/arm/aspeed_soc.h |

[Qemu-devel] [PATCH v5 3/3] hw/gpio: Add in AST2600 specific implementation

2019-08-16 Thread Rashmica Gupta
The AST2600 has the same sets of 3.6v gpios as the AST2400 plus an addtional two sets of 1.8V gpios. Signed-off-by: Rashmica Gupta --- hw/gpio/aspeed_gpio.c | 142 -- 1 file changed, 137 insertions(+), 5 deletions(-) diff --git a/hw/gpio/aspeed_gpio.c b

[Qemu-devel] [PATCH v5 1/3] hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500

2019-08-16 Thread Rashmica Gupta
source driving the GPIO pins in the model is the ARM model (as there currently aren't models for the LPC or Coprocessor). (2) None of the registers in the model are reset tolerant (needs integration with the watchdog). Signed-off-by: Rashmica Gupta Tested-by: Andrew Jeffery --- incl

[Qemu-devel] [PATCH v4 0/3] Add Aspeed GPIO controller model

2019-08-16 Thread Rashmica Gupta
with a 'set' of registers. Rashmica Gupta (3): hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500 aspeed: add a GPIO controller to the SoC hw/gpio: Add in AST2600 specific implementation include/hw/arm/aspeed_soc.h |3 + include/hw/gpio/aspeed_gpio.h | 100

[Qemu-devel] [PATCH v5 2/3] aspeed: add a GPIO controller to the SoC

2019-08-16 Thread Rashmica Gupta
Signed-off-by: Rashmica Gupta --- include/hw/arm/aspeed_soc.h | 3 +++ hw/arm/aspeed_soc.c | 17 + 2 files changed, 20 insertions(+) diff --git a/include/hw/arm/aspeed_soc.h b/include/hw/arm/aspeed_soc.h index cef605ad6b..fa04abddd8 100644 --- a/include/hw/arm

Re: [Qemu-devel] [PATCH v4 3/3] hw/gpio: Add in AST2600 specific implementation

2019-08-15 Thread Rashmica Gupta
On Wed, 2019-08-14 at 14:37 +0200, Cédric Le Goater wrote: > On 14/08/2019 09:14, Rashmica Gupta wrote: ... > > +static void aspeed_2600_gpio_realize(DeviceState *dev, Error > > **errp) > > +{ > > +AspeedGPIOState *s = ASPEED_GPIO(dev); > > +

Re: [Qemu-devel] [PATCH v3 3/3] hw/gpio: Add in AST2600 specific implementation

2019-08-14 Thread Rashmica Gupta
Thanks for the feedback! I fixed up all the things you mentioned in v4. On Tue, 2019-08-13 at 17:31 +1000, Alexey Kardashevskiy wrote: > > On 30/07/2019 15:45, Rashmica Gupta wrote: > > The AST2600 has the same sets of 3.6v gpios as the AST2400 plus an > > addtional two

Re: [Qemu-devel] [PATCH v3 1/3] hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500

2019-08-14 Thread Rashmica Gupta
On Tue, 2019-08-06 at 14:57 +0100, Peter Maydell wrote: > On Tue, 30 Jul 2019 at 06:45, Rashmica Gupta > wrote: > > GPIO pins are arranged in groups of 8 pins labeled > > A,B,..,Y,Z,AA,AB,AC. > > (Note that the ast2400 controller only goes up to group AB). > > A set

[Qemu-devel] [PATCH v4 2/3] aspeed: add a GPIO controller to the SoC

2019-08-14 Thread Rashmica Gupta
Signed-off-by: Rashmica Gupta --- hw/arm/aspeed_soc.c | 17 + include/hw/arm/aspeed_soc.h | 3 +++ 2 files changed, 20 insertions(+) diff --git a/hw/arm/aspeed_soc.c b/hw/arm/aspeed_soc.c index c6fb3700f2..ff422c8ad1 100644 --- a/hw/arm/aspeed_soc.c +++ b/hw/arm

[Qemu-devel] [PATCH v4 1/3] hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500

2019-08-14 Thread Rashmica Gupta
source driving the GPIO pins in the model is the ARM model (as there currently aren't models for the LPC or Coprocessor). (2) None of the registers in the model are reset tolerant (needs integration with the watchdog). Signed-off-by: Rashmica Gupta Tested-by: Andrew Jeffery --- hw/gpio/Ma

[Qemu-devel] [PATCH v4 0/3] Add Aspeed GPIO controller model

2019-08-14 Thread Rashmica Gupta
ementation (patch 3) - renamed a couple of variables for clarity v2: Addressed Andrew's feedback, added debounce regs, renamed get/set to read/write to minimise confusion with a 'set' of registers. Rashmica Gupta (3): hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500 aspe

[Qemu-devel] [PATCH v4 3/3] hw/gpio: Add in AST2600 specific implementation

2019-08-14 Thread Rashmica Gupta
The AST2600 has the same sets of 3.6v gpios as the AST2400 plus an addtional two sets of 1.8V gpios. Signed-off-by: Rashmica Gupta --- hw/gpio/aspeed_gpio.c | 188 -- slirp | 2 +- 2 files changed, 184 insertions(+), 6 deletions(-) diff

[Qemu-devel] [PATCH v3 1/3] hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500

2019-07-29 Thread Rashmica Gupta
source driving the GPIO pins in the model is the ARM model (as there currently aren't models for the LPC or Coprocessor). (2) None of the registers in the model are reset tolerant (needs integration with the watchdog). Signed-off-by: Rashmica Gupta --- hw/gpio/Makefile.objs | 1

[Qemu-devel] [PATCH v3 3/3] hw/gpio: Add in AST2600 specific implementation

2019-07-29 Thread Rashmica Gupta
The AST2600 has the same sets of 3.6v gpios as the AST2400 plus an addtional two sets of 1.8V gpios. Signed-off-by: Rashmica Gupta --- hw/gpio/aspeed_gpio.c | 186 +- include/hw/gpio/aspeed_gpio.h | 2 +- 2 files changed, 184 insertions(+), 4 deletions

[Qemu-devel] [PATCH v3 0/3] Add Aspeed GPIO controller model

2019-07-29 Thread Rashmica Gupta
(only exists on ast2500) - added ast2600 implementation (patch 3) - renamed a couple of variables for clarity v2: Addressed Andrew's feedback, added debounce regs, renamed get/set to read/write to minimise confusion with a 'set' of registers. Rashmica Gupta (3): hw/gpio: Add basic

[Qemu-devel] [PATCH v3 2/3] aspeed: add a GPIO controller to the SoC

2019-07-29 Thread Rashmica Gupta
Signed-off-by: Rashmica Gupta --- hw/arm/aspeed_soc.c | 17 + include/hw/arm/aspeed_soc.h | 3 +++ 2 files changed, 20 insertions(+) diff --git a/hw/arm/aspeed_soc.c b/hw/arm/aspeed_soc.c index c6fb3700f2..ff422c8ad1 100644 --- a/hw/arm/aspeed_soc.c +++ b/hw/arm

Re: [Qemu-devel] [PATCH 0/2] Add Aspeed GPIO controller model

2019-07-14 Thread Rashmica Gupta
Doh! Forgot the v2 tag! On Mon, 2019-07-15 at 16:19 +1000, Rashmica Gupta wrote: > Rebased on Peter's target-arm.next branch. > > v2: Addressed Andrew's feedback, added debounce regs, renamed get/set > to > read/write to minimise confusion with a 'set' o

[Qemu-devel] [PATCH 1/2] hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500

2019-07-14 Thread Rashmica Gupta
source driving the GPIO pins in the model is the ARM model (as there currently aren't models for the LPC or Coprocessor). (2) None of the registers in the model are reset tolerant (needs integration with the watchdog). Signed-off-by: Rashmica Gupta --- hw/gpio/Makefile.objs | 1

[Qemu-devel] [PATCH 0/2] Add Aspeed GPIO controller model

2019-07-14 Thread Rashmica Gupta
Rebased on Peter's target-arm.next branch. v2: Addressed Andrew's feedback, added debounce regs, renamed get/set to read/write to minimise confusion with a 'set' of registers. Rashmica Gupta (2): hw/gpio: Add basic Aspeed GPIO model for AST2400 and AST2500 aspeed: add

[Qemu-devel] [PATCH 2/2] aspeed: add a GPIO controller to the SoC

2019-07-14 Thread Rashmica Gupta
Signed-off-by: Rashmica Gupta --- hw/arm/aspeed_soc.c | 17 + include/hw/arm/aspeed_soc.h | 3 +++ 2 files changed, 20 insertions(+) diff --git a/hw/arm/aspeed_soc.c b/hw/arm/aspeed_soc.c index c6fb3700f2..ff422c8ad1 100644 --- a/hw/arm/aspeed_soc.c +++ b/hw/arm

Re: [Qemu-devel] [PATCH 1/2] hw/gpio: Add basic Aspeed GPIO model

2019-07-14 Thread Rashmica Gupta
Sorry for the late reply! I agree with most of your feedback and will send out a v2 shortly with those changes. I have a few replies below [snip] > > +static const struct AspeedGPIO gpios[0x1f0] = { > > +/* Set ABCD */ > > +[GPIO_ABCD_DATA_VALUE] = {0, read_data_value, > > _write_data_val

Re: [Qemu-devel] [PATCH 2/2] aspeed: add a GPIO controller to the SoC

2019-06-18 Thread Rashmica Gupta
On Tue, 2019-06-18 at 11:21 +0200, Cédric Le Goater wrote: > On 18/06/2019 10:51, Rashmica Gupta wrote: > > Signed-off-by: Rashmica Gupta > > --- > > hw/arm/aspeed_soc.c | 17 + > > include/hw/arm/aspeed_soc.h | 3 +++ > > 2 files change

[Qemu-devel] [PATCH 1/2] hw/gpio: Add basic Aspeed GPIO model

2019-06-18 Thread Rashmica Gupta
Add in details for GPIO controller for AST 2400 and 2500 Signed-off-by: Rashmica Gupta --- hw/gpio/Makefile.objs | 1 + hw/gpio/aspeed_gpio.c | 869 ++ include/hw/gpio/aspeed_gpio.h | 76 +++ 3 files changed, 946 insertions(+) create mode

[Qemu-devel] [PATCH 0/2] Add Aspeed GPIO controller model

2019-06-18 Thread Rashmica Gupta
would be great! Rashmica Gupta (2): hw/gpio: Add basic Aspeed GPIO model aspeed: add a GPIO controller to the SoC hw/arm/aspeed_soc.c | 17 + hw/gpio/Makefile.objs | 1 + hw/gpio/aspeed_gpio.c | 869 ++ include/hw/arm/aspeed_soc.h

[Qemu-devel] [PATCH 2/2] aspeed: add a GPIO controller to the SoC

2019-06-18 Thread Rashmica Gupta
Signed-off-by: Rashmica Gupta --- hw/arm/aspeed_soc.c | 17 + include/hw/arm/aspeed_soc.h | 3 +++ 2 files changed, 20 insertions(+) diff --git a/hw/arm/aspeed_soc.c b/hw/arm/aspeed_soc.c index 1cc98b9f40..8583869acf 100644 --- a/hw/arm/aspeed_soc.c +++ b/hw/arm