Re: [Qemu-devel] [PATCH v4] linux-user: fix preadv/pwritev offsets

2018-04-09 Thread Max Filippov
On Mon, Apr 9, 2018 at 5:23 PM, Richard Henderson
 wrote:
> On 04/06/2018 11:36 AM, Max Filippov wrote:
>> +static void target_to_host_low_high(abi_ulong tlow,
>> +abi_ulong thigh,
>> +unsigned long *hlow,
>> +unsigned long *hhigh)
>> +{
>> +unsigned long long off = tlow |
>> +((unsigned long long)thigh << TARGET_LONG_BITS / 2) <<
>> +TARGET_LONG_BITS / 2;
>
> Use uint64_t instead of unsigned long long.

Ok.

>> +
>> +*hlow = (unsigned long)off;
>> +*hhigh = (unsigned long)((off >> HOST_LONG_BITS / 2) >>
>> + HOST_LONG_BITS / 2);
>
> The casts here are unnecessary and are implied by the assignment.

Did that to avoid value truncation warning. Will drop.

> Otherwise,
> Reviewed-by: Richard Henderson 

-- 
Thanks.
-- Max



Re: [Qemu-devel] [PATCH v4] linux-user: fix preadv/pwritev offsets

2018-04-09 Thread Richard Henderson
On 04/06/2018 11:36 AM, Max Filippov wrote:
> +static void target_to_host_low_high(abi_ulong tlow,
> +abi_ulong thigh,
> +unsigned long *hlow,
> +unsigned long *hhigh)
> +{
> +unsigned long long off = tlow |
> +((unsigned long long)thigh << TARGET_LONG_BITS / 2) <<
> +TARGET_LONG_BITS / 2;

Use uint64_t instead of unsigned long long.

> +
> +*hlow = (unsigned long)off;
> +*hhigh = (unsigned long)((off >> HOST_LONG_BITS / 2) >>
> + HOST_LONG_BITS / 2);

The casts here are unnecessary and are implied by the assignment.

Otherwise,
Reviewed-by: Richard Henderson 


r~



Re: [Qemu-devel] [PATCH v4] linux-user: fix preadv/pwritev offsets

2018-04-09 Thread Laurent Vivier
Le 06/04/2018 à 03:36, Max Filippov a écrit :
> preadv/pwritev accept low and high parts of file offset in two separate
> parameters. When host bitness doesn't match guest bitness these parts
> must be appropriately recombined.
> Introduce target_to_host_low_high that does this recombination and use
> it in preadv/pwritev syscalls.
> 
> This fixes glibc testsuite test misc/tst-preadvwritev64.
> 
> Signed-off-by: Max Filippov 
> ---
> Changes v3->v4:
> - recombine offset into unsigned long long and split it into two longs.
> 
> Changes v2->v3:
> - rename helper to target_to_host_low_high;
> - handle cases TARGET_LONG_BITS * 2 > HOST_LONG_BITS and
>   TARGET_LONG_BITS < 2 * HOST_LONG_BITS correctly.
> 
> Changes v1->v2:
> - fix host high computation in TARGET_LONG_BITS > HOST_LONG_BITS case
> 
>  linux-user/syscall.c | 24 ++--
>  1 file changed, 22 insertions(+), 2 deletions(-)
> 

Reviewed-by: Laurent Vivier