Re: [QGIS-Developer] QGIS3 plugin migration issue

2018-04-05 Thread Nyall Dawson
On 5 April 2018 at 15:11, André William wrote: >> My thinking here is whether this needs to be supported officially - >> e.g. by making the panel wider by default. Alternatively we could add >> a method to QgsProcessingAlgorithmDialogBase to handle resizing of >> this panel.

Re: [QGIS-Developer] QgsLocator & common python libs

2018-04-05 Thread Nyall Dawson
On 5 April 2018 at 05:06, Richard Duivenvoorde wrote: > So my main point: > - how to give everybody the possibilty to implement a locator class, BUT > also share a common base class or use the same QgsNetworkAccessManager > moduel? > > Some options: > - we create a separate

Re: [QGIS-Developer] QGIS3 dependencies

2018-04-05 Thread Borys Jurgiel
I'd say it absolutely requires Qt5 and you can build it without Python support. But if you need Python, Py3 and PyQt5 are the only compatible. Regards, Borys Dnia środa, 4 kwietnia 2018 20:41:11 CEST Richard Duivenvoorde pisze: > On 04-04-18 19:24, doublebyte wrote: > > Does it absolutely

[QGIS-Developer] Get canvas scale wrong (qgis 2.18)

2018-04-05 Thread Công Nam Phạm
if try get *scale map, coordinate mouse *(lon, lat) but wrong value. my code: *def init.* ** self.canvas.useImageToRender(False) self.canvas.setWheelAction(0,1.5) self.canvas.MinScale = 5000 self.canvas.MaxScale = 50

[QGIS-Developer] Plugin [1437] KSP-Plugin approval notification.

2018-04-05 Thread noreply
Plugin KSP-Plugin approval by zimbogisgeek. The plugin version "[1437] KSP-Plugin 0.9.1 Experimental" is now approved Link: http://plugins.qgis.org/plugins/komonplugin/ ___ QGIS-Developer mailing list QGIS-Developer@lists.osgeo.org List info:

[QGIS-Developer] Plugin [1437] KSP-Plugin approval notification.

2018-04-05 Thread noreply
Plugin KSP-Plugin approval by zimbogisgeek. The plugin version "[1437] KSP-Plugin 0.9.2 Experimental" is now approved Link: http://plugins.qgis.org/plugins/komonplugin/ ___ QGIS-Developer mailing list QGIS-Developer@lists.osgeo.org List info:

[QGIS-Developer] Plugin [606] Azimuth and Distance Calculator approval notification.

2018-04-05 Thread noreply
Plugin Azimuth and Distance Calculator approval by zimbogisgeek. The plugin version "[606] Azimuth and Distance Calculator 2.0" is now approved Link: http://plugins.qgis.org/plugins/AzimuthDistanceCalculator/ ___ QGIS-Developer mailing list

[QGIS-Developer] Plugin [285] Multipart Split approval notification.

2018-04-05 Thread noreply
Plugin Multipart Split approval by zimbogisgeek. The plugin version "[285] Multipart Split 0.10.0 Experimental" is now approved Link: http://plugins.qgis.org/plugins/splitmultipart/ ___ QGIS-Developer mailing list QGIS-Developer@lists.osgeo.org List

[QGIS-Developer] Plugin [1437] KSP-Plugin approval notification.

2018-04-05 Thread noreply
Plugin KSP-Plugin approval by zimbogisgeek. The plugin version "[1437] KSP-Plugin 0.9 Experimental" is now approved Link: http://plugins.qgis.org/plugins/komonplugin/ ___ QGIS-Developer mailing list QGIS-Developer@lists.osgeo.org List info:

Re: [QGIS-Developer] QgsLocator & common python libs

2018-04-05 Thread Borys Jurgiel
A new built-in module, like qgis.commons or, say, qgis.elements (just a dummy name) sounds the best for me. Dnia środa, 4 kwietnia 2018 23:31:54 CEST Luigi Pirelli pisze: > common-qgis-python like that we created in Boundless when we where there > [1] had this intention: > 1) create a set of

Re: [QGIS-Developer] Custom widgets and Qt Designer 4 and 5

2018-04-05 Thread matteo
Hi Etienne, > I'm finally trying to use custom widgets from QT Creator instead of using > promoted widgets. > I'm facing the same issue with the generated path. It's not using > "qgis.gui" so it's failing during the import in QGIS. > > Did you fix this issue? > I can manually fix these imports,

[QGIS-Developer] Plugin [1345] FastVersion approval notification.

2018-04-05 Thread noreply
Plugin FastVersion approval by zimbogisgeek. The plugin version "[1345] FastVersion 1.3.0" is now approved Link: http://plugins.qgis.org/plugins/FastVersion/ ___ QGIS-Developer mailing list QGIS-Developer@lists.osgeo.org List info: