Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Thierry Godefroy via Ql-Users
On Tue, 12 May 2020 07:34:08 +0200, Fabrizio Diversi via Ql-Users wrote: > I am in the middle of multiple tests with CF/IDE and SD/IDE readers with > different type/size of CF and SD > > Few words about the 2 machine I am using : > > - Q40 with 1 IDE controller card with primary channel

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Peter Graf via Ql-Users
> If it is the drives, well, that's the problem Thierry has mentioned. By the way I doubt the ISA bus reset is required, which is adding to the delay. Neither QDOS Classic nor my own Utility ROMs use it. Never seen any issue. ___ QL-Users Mailing List

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Wolfgang Lenerz via Ql-Users
Hi, > I could be wrong, and for sure I am, but I noted that smsq/e 3.36b in > eprom boots in an instant and I  suspect that smsq/e 3.36 start so fast > that sometime for unknown reasons hangs before the boot, this explain > the few hangs I have. > Apart from spinning up mechanical drives, I

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Tobias Fröschle via Ql-Users
Well, you can bring up the OS from ROM without working mass storage. That's definitely an advantage, especially for the early days, when we didn't have fast storage (i.e. floppy only). Compared to the Atari, that's ROM-TOS vs. Disk-TOS (but not running from ROM) Tobias > Am 12.05.2020 um

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Fabrizio Diversi via Ql-Users
Yep, I am using last version of 3.36b. I revert back to initial original eprom, waiting the brand new Eprom (10 items exactly the same) i ordered from China Unfortunately I bought 4 eprom second hand from eBay, they are branded ST M27C1024 12F even if they look different from external: 2

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Ralf Reköndt via Ql-Users
A simple bootstrap loader would do the trick, right? Why a complete SMSQ/E in EPROM? As far as I remind, TT has written such one, having it it one of my TT disks (for Atari). Am 12.05.2020 um 18:28 schrieb Peter Graf via Ql-Users: Ralf Reköndt via Ql-Users wrote: Hmm, so why use it in an

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Peter Graf via Ql-Users
Ralf Reköndt via Ql-Users wrote: > Hmm, so why use it in an EPROM? You need some kind of ROM to boot the machine and load the OS. This can be a separate loader, like inside the Q68, but then it needs to access mass storage to load the OS. In case of the Q40 and Q60, the OS can boot completely

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Peter Graf via Ql-Users
Marcel Kilgus via Ql-Users wrote: > Fabrizio Diversi via Ql-Users wrote: >> This issue seems to address newer SMSQ/E in Eprom, I used second >> hand ST M27C1024 eprom 120ns. I ordered completely new eprom from >> China the same Brand but with 100ns.not sure where is the >> problem. > >

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Ralf Reköndt via Ql-Users
Hmm, so why use it in an EPROM? Am 12.05.2020 um 15:48 schrieb Marcel Kilgus via Ql-Users: Fabrizio Diversi via Ql-Users wrote: This issue seems to address newer SMSQ/E in Eprom, I used second hand ST M27C1024 eprom 120ns. I ordered completely new eprom from China the same Brand but with

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Marcel Kilgus via Ql-Users
Fabrizio Diversi via Ql-Users wrote: > This issue seems to address newer SMSQ/E in Eprom, I used second > hand ST M27C1024 eprom 120ns. I ordered completely new eprom from > China the same Brand but with 100ns.not sure where is the > problem. SMSQ/E never executes from EPROM, it is always

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Wolfgang Lenerz via Ql-Users
Hi, Yes, thanks, that will be in the next version of SMSQE. I sent Fabrizio a preview version with that fix already included, I presume that is what Fabrizio is using I'm not sure whether that is his problem, though. Woflgang > >> Just a question - what happens if you re-load (per LRESPR

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Thierry Godefroy via Ql-Users
On Tue, 12 May 2020 10:27:07 +0200, Wolfgang Lenerz via Ql-Users wrote: > Just a question - what happens if you re-load (per LRESPR ,not > automatically at boot time) Yes, I was about to ask the same question, but you bet me to it. It is probably the same issue as the one I encountered with my

Re: [Ql-Users] Memory cards and the Q60 (was Re: SMSQE 3.36)

2020-05-12 Thread Wolfgang Lenerz via Ql-Users
Hi, (...) > - Same Q60 as before but with SMSQ/e 3.36 on rom..here the situation > is more complex. (...) Just a question - what happens if you re-load (per LRESPR ,not automatically at boot time) 1 - the same version of SMSQ/E as the one in your Eproms? 2 - the same as the one you would