Re: [Ql-Users] Strange channel bugs?

2017-11-13 Thread Bob Spelten via Ql-Users
Op Sun, 12 Nov 2017 18:11:57 +0100 schreef Per Witte via Ql-Users : Is this the sort of issue you mean? 100 CLS 110 FOR i = 0 TO 4 120 FOR j = 0 TO 4 130 AT i * 2, j * 6: PRINT i; ','; j; 140 END FOR 150 END FOR 160 : 170 PRINT 180 PAUSE RUNs fine under SMSQ/E,

Re: [Ql-Users] Strange channel bugs?

2017-11-12 Thread Per Witte via Ql-Users
Is this the sort of issue you mean? 100 CLS 110 FOR i = 0 TO 4 120 FOR j = 0 TO 4 130 AT i * 2, j * 6: PRINT i; ','; j; 140 END FOR 150 END FOR 160 : 170 PRINT 180 PAUSE RUNs fine under SMSQ/E, displays only the first line if compiled as a Qlib job (but no errors or warnings are given -

Re: [Ql-Users] Strange channel bugs?

2017-11-12 Thread Bob Spelten via Ql-Users
Op Tue, 12 Sep 2017 18:47:35 +0200 schreef Bob Spelten : What's happening? I have successfully compiled a new version of my program. That's to say, there were no errors reported by BasicLinker or Qlibeator. But when the _obj is executed nothing seems to happen, no menu to act

Re: [Ql-Users] Strange channel bugs?

2017-09-13 Thread Bob Spelten via Ql-Users
Op Wed, 13 Sep 2017 09:29:26 +0200 schreef Wolfgang Lenerz via Ql-Users : Hi Bob, Looks like something is overwriting part of the OS. Since QPC & SMSQmulator are located at different addresses, this explains the difference. As Marcel wrote, are you Peeking/poking

Re: [Ql-Users] Strange channel bugs?

2017-09-13 Thread Wolfgang Lenerz via Ql-Users
Hi Bob, Looks like something is overwriting part of the OS. Since QPC & SMSQmulator are located at different addresses, this explains the difference. As Marcel wrote, are you Peeking/poking stuff? Without knowing what your prog does, I can't really help you beyond that If you send it to me,

Re: [Ql-Users] Strange channel bugs?

2017-09-12 Thread Marcel Kilgus via Ql-Users
Bob Spelten via Ql-Users wrote: > These errors were not given every time but after what looked like a proper > reset, an newly started QD still did not do C-F6/F8. > The QPC2 job has to be restarted before QD behaves normal again. The OS is not write protected on QPC and only read once on

[Ql-Users] Strange channel bugs?

2017-09-12 Thread Bob Spelten via Ql-Users
What's happening? I have successfully compiled a new version of my program. That's to say, there were no errors reported by BasicLinker or Qlibeator. But when the _obj is executed nothing seems to happen, no menu to act on. It's there in the JOBS list but no channels were opened for it. When I