Re: [Ql-Users] QA.RESRI info incorrect

2018-06-10 Thread Wolf via Ql-Users
Hi Per, yes I misquoted myself. On SMSQ/E it is not necessary for A1 to contain the ARI stack pointer before calling this vector. Regards Wolfgang ___ QL-Users Mailing List

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-09 Thread pjwitte via Ql-Users
Great, Wolfgang! But surely, if you have something on the stack youd like to keep, you still need to save the stack pointer, otherwise how will the system know? Per On 09/06/2018 06:50, Wolf via Ql-Users wrote: Hi, I'll amend the documentation. I will also mention that this vector, under

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread Wolf via Ql-Users
Hi, I'll amend the documentation. I will also mention that this vector, under SMSQ/E, simply does nothing when called from a compiled program. I already added a note that under SMSQ/E it is not necessary to save the stack pointer in BV_RIP(A6) before calling this vector. There are also

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread pjwitte via Ql-Users
Having gone through it all again, Ive come to the conclusion that the bugs are in the documentation! This is what it should look like: ||Vector $11A Reserve Room on Arithmetic Stack QA.RESRI Call parameters Return parameters D1.L Number of bytes required D1 ???

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread pjwitte via Ql-Users
On 08/06/2018 17:16, Jan Bredenbeek via Ql-Users wrote: On 8 June 2018 at 15:52, pjwitte via Ql-Users wrote: When loading this into RESPR and then doing CALL base+4 I get an 'insufficient memory' error. But PEEK_L(base) returns 0 so the code never got to the point where it stores the result.

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread Jan Bredenbeek via Ql-Users
On 8 June 2018 at 15:52, pjwitte via Ql-Users wrote: > When loading this into RESPR and then doing CALL base+4 I get an >> 'insufficient memory' error. But PEEK_L(base) returns 0 so the code never >> got to the point where it stores the result. >> > Sure, but this is not the whole story. For

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread pjwitte via Ql-Users
On 08/06/2018 14:29, Jan Bredenbeek via Ql-Users wrote: On 8 June 2018 at 13:26, pjwitte via Ql-Users wrote: It appears that, on an error, QDOS doesnt return here at all! Correct. Under SMSQ/E it may return an error (IMEM), but the error code is not always set! That implies that you could

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread Jan Bredenbeek via Ql-Users
On 8 June 2018 at 13:26, pjwitte via Ql-Users wrote: It appears that, on an error, QDOS doesnt return here at all! > Correct. > Under SMSQ/E it may return an error (IMEM), but the error code is not > always set! That implies that you could get a wrong result, depending on > what was in D0

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread pjwitte via Ql-Users
On 08/06/2018 12:20, gdgqler--- via Ql-Users wrote: On 14 Feb 2018, at 13:49, pjwitte via Ql-Users wrote: |In later versions of the QDOS and SMSQ/E Reference Manual the documentation on QA.RESRI (aka bv.chrix), to test or stretch the arithmetic stack states: Vector $11A Reserve Room on

Re: [Ql-Users] QA.RESRI info incorrect

2018-06-08 Thread gdgqler--- via Ql-Users
> On 14 Feb 2018, at 13:49, pjwitte via Ql-Users > wrote: > > |In later versions of the QDOS and SMSQ/E Reference Manual the documentation > on QA.RESRI (aka bv.chrix), to test or stretch the arithmetic stack states: > > Vector $11A Reserve Room on Arithmetic Stack QA.RESRI > Call

Re: [Ql-Users] QA.RESRI info incorrect

2018-02-14 Thread Marcel Kilgus via Ql-Users
pjwitte via Ql-Users wrote: > On 14/02/2018 15:04, Marcel Kilgus via Ql-Users wrote: >> pjwitte via Ql-Users wrote: >>> Error returns: >>> IMEM out of memory [SMSQ] >> This is correct. > If this is correct, isnt that bad news for any old toolkits that dont > expect the call to return on IMEM (as

Re: [Ql-Users] QA.RESRI info incorrect

2018-02-14 Thread pjwitte via Ql-Users
On 14/02/2018 15:04, Marcel Kilgus via Ql-Users wrote: pjwitte via Ql-Users wrote: Error returns: IMEM out of memory [SMSQ] This is correct. If this is correct, isnt that bad news for any old toolkits that dont expect the call to return on IMEM (as per the original Technical Guide)? They

Re: [Ql-Users] QA.RESRI info incorrect

2018-02-14 Thread Marcel Kilgus via Ql-Users
pjwitte via Ql-Users wrote: > Error returns: > IMEM out of memory [SMSQ] This is correct. > A1                                     A1 ??? This is probably correct. > Error returns: none This is not ;-) Marcel ___ QL-Users Mailing List