Re: [qubes-users] Minimal VM requirements for Salt configuration are not documented

2017-01-22 Thread Marek Marczykowski-Górecki
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On Sun, Jan 22, 2017 at 01:44:48AM +0100, john.david.r.smith wrote:
> On 20/01/17 14:13, john.david.r.smith wrote:
> > On 20/01/17 13:18, qu...@posteo.de wrote:
> > > Hi John,
> > > 
> > > On 20.01.2017 10:26, john.david.r.smith wrote:
> > > >  looks like my problem i posted here:
> > > > https://groups.google.com/d/msg/qubes-users/C1tJV4Ykgr8/5H09IT06CQAJ
> > > > 
> > > > i did not try it again since i had this problem.
> > > > missing in min are sudo and file (but after this i still get problems)
> > > 
> > > many thx for the reply. You are right, some issues overlap.
> > > 
> > > I have tried installing sudo but not file. Installing also the later
> > > fixes the issue of the default template, so you can use the extended
> > > Minimal as default template with these changes and do not get the error
> > > 127 for standard templates.
> > > 
> > > But applying salt on minimals vms with all the mentioned packages plus
> > > sudo and file still results in the exit code 20.
> > > 
> > > How can I debug this further. What commands are run on the disposble vms
> > > so I can see more output?
> > > 
> > > Thx in advance
> > > 
> > 
> > well that is the part i am currently at (as i wrote, i did not try again 
> > after Marek answered.
> > 
> > Marek wrote a few tricks on debugging this problem. (ctrl+z when the target 
> > vm is started etc. (you can look it up in the linked thread))
> > 
> > i will probably try again this weekend and will post any results i get.
> > in case you manage to fix this, tell me! ;)
> > 
> > concerning a tutorial:
> > i probably will write a more verbose tutorial if i got all my stuff fixed.
> > 
> > -john
> > 
> 
> problem solved (details posted in other thread).
> 
> you need to install in fed24 minimal the sudo package and delete the left 
> over files in the ~/QubesIncomming folder (they screw you over)

Created a ticket for this:
https://github.com/QubesOS/qubes-issues/issues/2600

- -- 
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
-BEGIN PGP SIGNATURE-
Version: GnuPG v2

iQEcBAEBCAAGBQJYhXo0AAoJENuP0xzK19csX1IIAIDNIGgv8Bx3GTpbrbDGGc4H
20SjI8TdnGtRZdsIZvvIUA5MfCPBn1cPSFuUMGzbwgTNQrnnAtJ1Vd0jxkbtSKhc
jGqTUPqTt7DGGfqAIzvGKX+gSUuGnwqcjMYW7dhqdm1P/rhpXL/UC2vxZ6O4y6c+
YMOeY7KkzSsb9JAjpFCJLs1gQNVWm3AX6po0nQ03T62/8BLG+HBlswzvaTPtL2zn
2dY7K2GKdXHqREA7Rmgh9DA7tL5/v2n6WyOVxG9nhlu/MDnAbpVBTukKkSZqRlCT
WwDXooEgOMYVZ2fvvkheA0cn3+KtDAg3E9dbRlt7EUTd5r64x3drkQbc/H1rBFM=
=aQCf
-END PGP SIGNATURE-

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170123033619.GA7447%40mail-itl.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Suggestions for RBAC for grsecurity-enabled kernel?

2017-01-22 Thread Kopimi Security
Hardened kernel with Grsecurity is coming along nicely - and there is yet more 
to come, as this medium-post shows 
https://medium.com/@securitystreak/living-with-qubes-os-r3-2-rc3-for-a-week-1a37e04c799e

Here's the background, I just sent this mail to coldhak.ca:
---
Referring to https://coldhak.ca/coldkernel/

1.
Please add that error-messages from "sudo update-grub2" can safely be ignored.
As also stated in https://www.qubes-os.org/doc/managing-vm-kernel/ , 
"Installing PV GRUB2".

2.
Also please add that one needs to change the kernel in appvms to pvgrub2

3.
And related, that one should also install paxtest and run it to confirm that 
grsecurity is running
As mentioned at https://micahflee.com/2016/01/debian-grsecurity/

4.
And that there is the option to add further to securing the appvm, by using 
gradm2 in learning mode as explained at 
https://en.wikibooks.org/wiki/Grsecurity/The_Administration_Utility#Full_System_Learning
---

And so I'd like to hear if you have any suggestions for RBAC given the 
opportunities for compartmentalization that Qubes OS provides.

Cheers,
C-c & C-v


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0dfeb459-3b7f-438f-b028-e8d8a32848c8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Lenovo x230 Laptop vs. Lenovo x230t Tablet on Qubes R3.2

2017-01-22 Thread knaoxfaox
I'm looking into getting a budget laptop around $100-$250 for Qubes R3.2.  I've 
heard good things about the x220 and x230.  Although I have a question that I 
havent been able to find answered.


My question is has anyone installed on the tablet version of those and is there 
any difficulties with that verse the laptop variant?

I've seen that the specs are similiar, but wasn't sure about the periphereals 
like the keyboard and trackpad.

If you have any suggestions for laptops in that price range, that would help.


Thank you.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/aeb77351-965c-4bdd-8c39-4259b14fe964%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Minimal VM requirements for Salt configuration are not documented

2017-01-22 Thread Manuel Amador (Rudd-O)
On 01/20/2017 08:58 AM, qu...@posteo.de wrote:
> Hi,
>
> I am trying to setup all VMs with Salt since the switch to Fedora 24.
>
> I usually took the minimal template and create the others on base of
> this with more packages.
>
> The problem is that the Qubes salt documentation does not document
> what the minimal requirements on packages are for deploying salt and
> receiving.
>
> For example if I install in the minimal fedora 24 template
> qubes-mgmt-salt-vm-connector I still can not install any packages with
> Salt from the outside. If I use this minimal template as the default I
> can not deploy Salt anymore to templates which can be updated with
> Salt because they have all the necessary packages. 

You're going to need at the very minimum python-dnf.

-- 
Rudd-O
http://rudd-o.com/

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a6913e0b-4211-2f4f-d2a2-42fce10e2c35%40rudd-o.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Re: Which templates update automatically?

2017-01-22 Thread Unman
On Sun, Jan 22, 2017 at 02:59:48AM -0800, FWM wrote:
> >From my experience, This auto check for updates doesnt seem to work properly.
> 
> The default templates definitely get checked for updates, but the cloned 
> templates never seem to. If i manually click the "Update VM system" on a 
> cloned template, it will often find updates.
> 
> I ran "qubes-set-update status" in dom0, and both were enabled.
> 
> Running Qubes OS 3.1
> 

Yes, this has been reported in a more recent thread.
The notification should come if you have a network connected qube based
on that template. If you have firewall rules implemented, that will
affect this process, obviously.

Can you check that you have the "qubes-update-check" service running in
the qube based on the cloned template, and that it has unfettered access
to the internet?

Which templates do you think are affected?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170122212433.GC8262%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Installing Wickr on Whonix-ws Qubes OS 3.1

2017-01-22 Thread Unman
On Sun, Jan 22, 2017 at 02:39:21AM -0800, FWM wrote:
> Wickr is a secure messaging app https://wickr.com/security#encryption
> 
> First to get Wickr to work on the whonix-ws i had to install the following 
> packages;
> 
> libavutil52_9.18-0ubuntu0.14.04.1_amd64.deb
> libicu52_52.1-8ubuntu0.2_amd64.deb
> libsqlcipher0_3.2.0-1.1~bpo80+1_amd64.deb
> libx264-142_0.142.2389+git956c8d8-2_amd64.deb
> libgstreamer-plugins-base0.10-0
> gtk2-engines-pixbuf
> 
> wickr-me_2.6.0_amd64.deb (of course)
> 
> 
> The app seems to be working ok (havent tested all functionality)
> 
> I had a couple of questions tho:
> 
> 1. Could any of these packages interfere with the anonymity of the whonix-ws?
> 
> 2. Should i even run Wickr from a Whonix-ws? Or just use a deb template & 
> route it through a Whonix-gw?
> 
> 3.1 wicker has the option to put in proxy details. IP & port. Im not clear if 
> its socks5 of not. should i put some information in here so Wickr creates its 
> own unique TOR route? which IP should i use 127.0.0.1 or?
> 
> 3.2 Ive heard if an app isn't using a socks5 proxy setting it will still use 
> Whonix-gw, but not create its own unique route. I believe this opens up the 
> risk of cross analysis of network activity on?
> 
> 
> Thanks
> 
I don't see anytjhiong Qubes specific here - you'd probably get a better
response on the Whonix forums:
https://forums.whonix.org



-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170122210105.GB8262%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Firewall Broken

2017-01-22 Thread Unman
On Sun, Jan 22, 2017 at 07:18:13PM +0100, qube...@tutanota.com wrote:
> Qubes 3.2
> Have created new AppVM and within "firewall rules" restricted access using 
> "deny access" to all websites [by leaving it blank] or  just a single 
> website. Bizarrely however,the firewall lets all traffic thro'
> Any ideas
> 

Do you have the qube connected to a firewall, or directly to sys-net?

If the latter, then sys-net (by default) does not implement the Qubes
firewall.

If the former, open a console in the firewall and look at the relevant
rules :
iptables -L -nv
Are there rules allowing the traffic from the relevant IP in the FORWARD
chain?

Try changing the netvm for the relevant qube - make sure the iptables
rules change on the firewall. Then try reconnecting.
You can do this on command line using:
qvm-prefs  netvm -s none
and 
qvm-prefs  netvm -s 


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170122205558.GA8262%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Another reason for Linux and QubesOS

2017-01-22 Thread stevenwinderlich
Windows Update Prioritizing itself over Chrome

https://www.youtube.com/watch?v=GD3Lxyin8VY



I do not know if this applies to other applications than Chrome but this is 
ridiculous.

If i want to get something done then i dont want Updates to kill my connection.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b34ff3fc-9d4d-4fda-be83-9998a7f37639%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Firewall Broken

2017-01-22 Thread qubesos
Qubes 3.2
Have created new AppVM and within "firewall rules" restricted access using 
"deny access" to all websites [by leaving it blank] or  just a single website. 
Bizarrely however,the firewall lets all traffic thro'
Any ideas

--
Securely sent with Tutanota. Claim your encrypted mailbox today!
https://tutanota.com

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/Kb6O_zb--3-0%40tutanota.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Chipping/Crackling noise on HDMI

2017-01-22 Thread taii...@gmx.com

What drivers are you using for the video device?

Is this a qubes-specific issue? (have your tried other linux distros)

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/876e517b-9b9a-b7ca-fa4c-1188c12ef603%40gmx.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Minimal VM requirements for Salt configuration are not documented

2017-01-22 Thread qubes

On 22.01.2017 01:44, john.david.r.smith wrote:


problem solved (details posted in other thread).

you need to install in fed24 minimal the sudo package and delete the
left over files in the ~/QubesIncomming folder (they screw you over)


The original issue is fixed.

But if I try to setup a NetVM template with the packages described under 
https://www.qubes-os.org/doc/templates/fedora-minimal/ I can not install 
tinyproxy and the notification-daemon because of the 
qubes-templates-minimal-stub package. If I remove this it tries to 
remove 147 packages including the Qubes ones which breaks the vm.
I did not find another template package. I could install all these 
packages manually but this does not seem like a good approach.


Somehow I was able to install the manually in the past but it does not 
work now. Did anybody find a solution to install these packages in the 
minimal template without the template package interfering?


Thx in advance

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/f4e5e7e768e32cc27130fa6aa51ed657%40posteo.de.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: How to view Youtube in Fullscreen ? (for dummies)

2017-01-22 Thread '01v3g4n10' via qubes-users
On Sunday, January 22, 2017 at 11:13:06 AM UTC, FWM wrote:
> BUMP,
> 
> I also have this problem.
> Cant fullscreen youtube in firefox.
> + once fullscreen is clicked, the browser become unresponsive.
> Forced to close browser and re-open.

You can right click on the top of the window border and set fullscreen or use 
alt+space and select fullscreen.  Or you can use this guide as long as long as 
you understand the potential security risk.
https://www.qubes-os.org/doc/full-screen-mode/

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/6e4dd26e-ce45-4d07-a1b1-4cd69ebd8e9d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Chipping/Crackling noise on HDMI

2017-01-22 Thread FWM
Software is VLC

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/1a6d2570-26ca-4eaa-86a7-d9eda16904ee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Chipping/Crackling noise on HDMI

2017-01-22 Thread FWM
Sorry
Running Qubes 3.2
Debian-8 template
GPU is a HD6950

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/1d9ce4e7-6c44-4281-98cf-18113f16d43c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Installing Wickr on Whonix-ws Qubes OS 3.1

2017-01-22 Thread FWM
CORRECTION: Im actually running Qubes 3.2

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/326d5e8f-2644-49d4-96dc-162fcb0e6589%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: using Arduino development environment with Qubes OS

2017-01-22 Thread jav . montoya
On Saturday, January 21, 2017 at 1:17:29 PM UTC-5, Gray Olson wrote:
> Try a permissive pass through of the usb pci device 
> https://www.qubes-os.org/doc/assigning-devices/

Thanks a lot Gray, there is a lot of new information in the documentation 
indeed:
 
I went around the problem in a different way, which I describe here for future 
reference:

First open a terminal in your TemplateVM (fedora-23 in my case) and type:

> groups

if dialout does not appear listed you can either type

> sudo gpasswd --add user dialout

or

> sudo usermod -aG dialout user

Either way. it will give you access to the dialout group in order to make use 
of the /dev/tty* communication devices inside VMs that depend on that Template. 
But you must restart the Template VM in order to see a change in the output of 
the command: "> groups", since the groups information is only loaded at login.

Finally, it is reported 
(https://www.qubes-os.org/doc/usb/#attaching-a-single-usb-device-to-a-qube-usb-passthrough)
 that with Qubes 3.2 it is now possible to give access to any USB device to a 
VM from dom0.

It goes as follows:

Assuming that you have not created yet a USB qube (it's a VM usually named: 
sys-usb) you can create one in two easy steps, by typing in dom0:

> qubesctl top.enable qvm.sys-usb

> qubesctl state.highstate

>From now on your dom0 environment is protected from direct contact with any 
>USB device and they are directly attached to the sys-usb VM. Now, what you can 
>do after starting sys-usb, is to transfer the device from that VM to another 
>one, lets say "work" VM:

First identify it from a terminal in dom0,

> qvm-usb
sys-usb:3-2   2341:0043 Arduino__www.arduino.cc__0043...

and then attach it to your ALREADY STARTED "work" VM,

>qvm-usb -a work sys-usb:3-2

The final check is to open a terminal in your "work" VM and type in there:

> lsusb

and

> ls -l /dev/ttyACM0

both outputs should tell you that there is a device connected to your VM.


Cheers,

Javier

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b0dc60ed-2be9-4c2e-83a1-3bf72bc720f3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Random screen blackouts Qubes 3.1

2017-01-22 Thread FWM
CORRECTION, Im actually running Qubes 3.2

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/29429023-2500-4e1e-ad51-129e200a223c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: How to view Youtube in Fullscreen ? (for dummies)

2017-01-22 Thread FWM
BUMP,

I also have this problem.
Cant fullscreen youtube in firefox.
+ once fullscreen is clicked, the browser become unresponsive.
Forced to close browser and re-open.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/81ea52c8-f6b3-4c9e-b766-34a77b703bcb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Random screen blackouts Qubes 3.1

2017-01-22 Thread FWM
So a problem im having is randomly it looks like the screen saver will try come 
on, even though im typing or using the mouse.

And even if i move the mouse the screen will stay black, and i have to move 
mouse to the tool bar and click open windows, which will remove the blackness 
only over that window.

Seems very much like some kind of graphic bug.

But its also the typo of glitchy thing that ive seen when computers/GPUs get 
hot.

Is this a know issue?
Is there a tool i can use to monitor my system temps? where should i install 
such tool? in dom0?

Thanks

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/3a811346-0850-40ca-91ac-b240a5db08e9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Installing Wickr on Whonix-ws Qubes OS 3.1

2017-01-22 Thread FWM
Wickr is a secure messaging app https://wickr.com/security#encryption

First to get Wickr to work on the whonix-ws i had to install the following 
packages;

libavutil52_9.18-0ubuntu0.14.04.1_amd64.deb
libicu52_52.1-8ubuntu0.2_amd64.deb
libsqlcipher0_3.2.0-1.1~bpo80+1_amd64.deb
libx264-142_0.142.2389+git956c8d8-2_amd64.deb
libgstreamer-plugins-base0.10-0
gtk2-engines-pixbuf

wickr-me_2.6.0_amd64.deb (of course)


The app seems to be working ok (havent tested all functionality)

I had a couple of questions tho:

1. Could any of these packages interfere with the anonymity of the whonix-ws?

2. Should i even run Wickr from a Whonix-ws? Or just use a deb template & route 
it through a Whonix-gw?

3.1 wicker has the option to put in proxy details. IP & port. Im not clear if 
its socks5 of not. should i put some information in here so Wickr creates its 
own unique TOR route? which IP should i use 127.0.0.1 or?

3.2 Ive heard if an app isn't using a socks5 proxy setting it will still use 
Whonix-gw, but not create its own unique route. I believe this opens up the 
risk of cross analysis of network activity on?


Thanks

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/687cc188-8d93-4721-b1bc-b654f8bdabce%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: new air-gapped security distro

2017-01-22 Thread qmastery16
воскресенье, 22 января 2017 г., 4:28:32 UTC+3 пользователь Syd Brisby написал:
> There's a new air-gapped security distro that is just CD-sized and loads into 
> RAM. It also recognises the threat of wirelessly leaked data. Unfortunately, 
> it's only bitcoin-focused, but it is Debian-based and has a web browser, so 
> it could be useful.
> 
> https://bitkey.io

I know a TempleOS operating system. This whole OS, kernel, all userspace & 
apps, compiler, assembler, unassembler, etc., even a special programming 
language for it, - over 10 years everything has created by a single genius man 
who hates CIA niggers with a passion ! TempleOS does not support networking, so 
its truly air-gapped ;) Lots of interesting stuff in this OS, even some games 
like 3D shooter and 3D flight simulator.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0f338048-7995-4d95-ac9a-47194e21bbe9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Just realized one of the major disadvantages of Qubes OS...

2017-01-22 Thread qmastery16
суббота, 21 января 2017 г., 22:12:10 UTC+3 пользователь 
e5f3c2ea89...@tutanota.com написал:
> ... It makes you feel significantly less safe when using anything other than 
> Qubes :]

Haha you are a master of clickbait titles :]

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/386ce3bd-71aa-4ae5-a326-2e4b1835d5b8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Minimal VM requirements for Salt configuration are not documented

2017-01-22 Thread qubes

On 22.01.2017 01:44, john.david.r.smith wrote:

problem solved (details posted in other thread).

you need to install in fed24 minimal the sudo package and delete the
left over files in the ~/QubesIncomming folder (they screw you over)


Many thx for the hint. It seems to fix my issue too. This should be 
documented in the Wiki until there is a solution for this.


I also ran into another issue configuring the repos with salt, because 
yum.conf under Qubes seems to be different, but I guess this should be 
easier to fix from our side.


Regards

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0c5d7d48b43d96a3578f0abfad857c6c%40posteo.de.
For more options, visit https://groups.google.com/d/optout.