[qubes-users] Re: Nested virtualization

2017-02-10 Thread pixel fairy
On Friday, February 10, 2017 at 9:03:47 PM UTC-8, adoni...@gmail.com wrote: > Hi guys, thanks for the responses, I will have a look at it. > > What I need in this case in particular requires VBox, it is Genymotion, an > Android emulator. this might help.

Re: [qubes-users] Re: Nested virtualization

2017-02-10 Thread Andrew David Wong
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 On 2017-02-10 19:16, pixel fairy wrote: > On Friday, February 10, 2017 at 5:40:36 PM UTC-8, > adoni...@gmail.com wrote: >> Hi guys, >> >> Is it possible to install let's say Virtual Box inside a Qube? >> I've done some reading and all people seem

Re: [qubes-users] Re: Shouldn't this be specially noted in Qubes HCL? (was: what about usb to jtag interface?)

2017-02-10 Thread Andrew David Wong
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 On 2017-02-10 19:07, pixel fairy wrote: > On Friday, February 10, 2017 at 2:56:15 PM UTC-8, Oleg Artemiev > wrote: >> On Thu, Feb 9, 2017 at 6:38 PM, pixel fairy >> wrote: >>> On Thursday, February 9, 2017 at 3:54:03 AM UTC-8,

Re: [qubes-users] Mount point /proc/xen in appVM prevents flatpak packages from starting (Issue #2540 impact wider than reported)

2017-02-10 Thread Andrew David Wong
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 On 2017-02-10 03:23, Alex wrote: > Hi all, > I've been trying to use MonoDevelop 6, now distributed as a flatpak > package instead of the usual RPM (fedora 25). > > I've had some problems in trying to run it, mainly because of an obscure > error

[qubes-users] Re: [qubes-devel] Re: Devilspie2 integration

2017-02-10 Thread Andrew David Wong
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 On 2017-02-10 15:32, Oleg Artemiev wrote: > On Tue, Feb 7, 2017 at 1:41 PM, Andrew David Wong > wrote: >> -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 >> >> [Please keep the list CCed.] > why do we use operating systems

[qubes-users] Re: Nested virtualization

2017-02-10 Thread adonis28850
Hi guys, thanks for the responses, I will have a look at it. What I need in this case in particular requires VBox, it is Genymotion, an Android emulator. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop

[qubes-users] Re: Nested virtualization

2017-02-10 Thread pixel fairy
On Friday, February 10, 2017 at 5:40:36 PM UTC-8, adoni...@gmail.com wrote: > Hi guys, > > Is it possible to install let's say Virtual Box inside a Qube? I've done some > reading and all people seem to say is that it should be possible, but nothing > conclusive. this should be a faq somewhere,

[qubes-users] Re: Shouldn't this be specially noted in Qubes HCL? (was: what about usb to jtag interface?)

2017-02-10 Thread pixel fairy
On Friday, February 10, 2017 at 2:56:15 PM UTC-8, Oleg Artemiev wrote: > On Thu, Feb 9, 2017 at 6:38 PM, pixel fairy wrote: > > On Thursday, February 9, 2017 at 3:54:03 AM UTC-8, Oleg Artemiev wrote: > >> Does this mean that USB qube is now useless as a security border on >

[qubes-users] Re: Nested virtualization

2017-02-10 Thread justin . h . holguin
On Friday, February 10, 2017 at 5:40:36 PM UTC-8, adoni...@gmail.com wrote: > Hi guys, > > Is it possible to install let's say Virtual Box inside a Qube? I've done some > reading and all people seem to say is that it should be possible, but nothing > conclusive. VirtualBox definitely did not

[qubes-users] Re: Nested virtualization

2017-02-10 Thread nicholas roveda
Yeah, currently I'm using LXC Containers inside AppVMs. What do you need exactly? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] Qubes doesn't support LXC unprivileged containers?

2017-02-10 Thread nicholas roveda
Why it's not possible to set 'kernel.unprivileged_userns_clone' (/proc/sys/kernel/unprivileged_userns_clone) to use LXC unprivileged containers? Qubes Kernel doesn't support it yet or is it possible to recompile the Kenel to add support to this? -- You received this message because you are

[qubes-users] Nested virtualization

2017-02-10 Thread adonis28850
Hi guys, Is it possible to install let's say Virtual Box inside a Qube? I've done some reading and all people seem to say is that it should be possible, but nothing conclusive. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe

[qubes-users] efi_memmap problem powering off.. coldhak paxtest fail

2017-02-10 Thread cesecurenj
Hello, i have qubes 3.2 installed with 4.4.38-11 kernel. Install went fine. In the beginning powering off went good but now i get stuck at a screen that says efi: EFI_MEMMAP is not enabled esrt: ESRT header is not in the memory map .. i also installed coldhaks grsec script for debian template.

Re: [qubes-users] qvm-run fails silently with chromium

2017-02-10 Thread Unman
On Fri, Feb 10, 2017 at 03:28:53AM -0800, m...@lamarciana.com wrote: > > The issue you raise there arises because the xterm is not a login shell > > so will not use .profile. > > It is interactive so (using bash) will use .bashrc > > > > On the immediate question here you can always set the path

Re: [qubes-users] I have a bank vm, how do you restrict

2017-02-10 Thread Oleg Artemiev
On Sat, Feb 11, 2017 at 2:35 AM, Oleg Artemiev wrote: > On Wed, Feb 8, 2017 at 2:36 AM, Chris Laprise wrote: >> On 02/07/2017 04:47 AM, Oleg Artemiev wrote: > I have a bank vm, how do you restrict the browser from being able to go > else >

Re: [qubes-users] I have a bank vm, how do you restrict

2017-02-10 Thread Oleg Artemiev
On Wed, Feb 8, 2017 at 2:36 AM, Chris Laprise wrote: > On 02/07/2017 04:47 AM, Oleg Artemiev wrote: >> >> On Tue, Feb 7, 2017 at 11:57 AM, '0xDEADBEEF00' via qubes-users >> wrote: I have a bank vm, how do you restrict the browser

[qubes-users] Re: [qubes-devel] Re: Devilspie2 integration

2017-02-10 Thread Oleg Artemiev
On Tue, Feb 7, 2017 at 1:41 PM, Andrew David Wong wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > [Please keep the list CCed.] why do we use operating systems at all? Because them provide some set of default pretty functionality/environment from the

Re: [qubes-users] Ad-blocking ProxyVM?

2017-02-10 Thread Unman
On Fri, Feb 10, 2017 at 04:10:06AM -0800, Joe Ruether wrote: > On Thursday, February 9, 2017 at 10:21:26 AM UTC-5, Unman wrote: > > On Thu, Feb 09, 2017 at 04:32:12AM -0800, Joe Ruether wrote: > > > Hello! > > > > > > I am trying to set up a proxy vm that will redirect DNS requests to a > > >

Re: [qubes-users] ubuntu template

2017-02-10 Thread Unman
On Fri, Feb 10, 2017 at 10:04:54AM -0800, damien.wa...@gmail.com wrote: > Le jeudi 9 février 2017 12:41:42 UTC+1, Unman a écrit : > > On Thu, Feb 09, 2017 at 02:37:36AM -0800, wrote: > > > Hi, > > > > > > I am new into qubes (few months) and find it great. But I need a distro > > > with newer

Re: [qubes-users] ubuntu template

2017-02-10 Thread Unman
On Fri, Feb 10, 2017 at 01:46:02AM -0800, trul...@gmail.com wrote: > четверг, 9 февраля 2017 г., 14:41:42 UTC+3 пользователь Unman написал: > > On Thu, Feb 09, 2017 at 02:37:36AM -0800, damien.wa...@gmail.com wrote: > > > Hi, > > > > > > I am new into qubes (few months) and find it great. But

[qubes-users] Shouldn't this be specially noted in Qubes HCL? (was: what about usb to jtag interface?)

2017-02-10 Thread Oleg Artemiev
On Thu, Feb 9, 2017 at 6:38 PM, pixel fairy wrote: > On Thursday, February 9, 2017 at 3:54:03 AM UTC-8, Oleg Artemiev wrote: >> I've heared that new intel mother boards will have (or already have) >> ability to access jtag interface via USB. > yes, skylake and kabylake

Re: [qubes-users] ubuntu template

2017-02-10 Thread Nick Darren
On 02/10/2017 09:46 AM, trul...@gmail.com wrote: > четверг, 9 февраля 2017 г., 14:41:42 UTC+3 пользователь Unman написал: >> On Thu, Feb 09, 2017 at 02:37:36AM -0800, damien.wa...@gmail.com wrote: >>> Hi, >>> >>> I am new into qubes (few months) and find it great. But I need a distro >>>

Re: [qubes-users] Updating packages with salt does not refresh the repositories

2017-02-10 Thread qubes
On 10.02.2017 17:04, Jean-Philippe Ouellet wrote: On Thu, Feb 9, 2017 at 6:46 PM, wrote: I have an update.sls with the following content: updates: pkg.uptodate: - refres: True If that's literally a copy & paste... because you're missing the h in refresh? Thx for

Re: [qubes-users] ubuntu template

2017-02-10 Thread damien . waber
Le jeudi 9 février 2017 12:41:42 UTC+1, Unman a écrit : > On Thu, Feb 09, 2017 at 02:37:36AM -0800, wrote: > > Hi, > > > > I am new into qubes (few months) and find it great. But I need a distro > > with newer packages (debian jessie was fine until I ran in issues with > > encfs compatibility).

[qubes-users] qubes 3.2: Realtek ethernet not detected by sys-net, please help.

2017-02-10 Thread surf . nx
Tried all the following over the last 4 days. Please help if possible. rpm -q linux-firmware : linux-firmware-20161205-69.git91ddce49.fc24.noarch Failed with DMA setting at: qvm-prefs -s netvm kernelopts "iommu=soft swiotlb=16384" dom0 dmesg: 02:00.0 Ethernet controller: Realtek Semiconductor

Re: [qubes-users] Re: What? Can I access a windows USB drive?

2017-02-10 Thread raahelps
Yes go to sys-usb in the start menu and select files. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscr...@googlegroups.com. To post to this

Re: [qubes-users] Updating packages with salt does not refresh the repositories

2017-02-10 Thread Jean-Philippe Ouellet
On Thu, Feb 9, 2017 at 6:46 PM, wrote: > I have an update.sls with the following content: > > updates: > pkg.uptodate: > - refres: True If that's literally a copy & paste... because you're missing the h in refresh? -- You received this message because you are subscribed

[qubes-users] using a custom salt module in top files

2017-02-10 Thread john.david.r.smith
hi. i wrote some custom salt module and use it for rendering in my top-file. everything works great as long as i am only in dom0. as soon as my stuff is run in domU (or rather its management-vm) i get errors: when rendering:

[qubes-users] Re: Ad-blocking ProxyVM?

2017-02-10 Thread mb
Is there any particular reason you are setting up another app VM for this? Why not run it on the net o firewall VM? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email

Re: [qubes-users] Re: traveling - best practice

2017-02-10 Thread Jake
On 02/10/2017 05:02 AM, john.david.r.smith wrote: On 10/02/17 11:53, '0xDEADBEEF00' via qubes-users wrote: Interesting topic... I would like to here more about how people handle this. On my side, I'would never work on sensitive information in such a situation. To make just some surfing in

Re: [qubes-users] Re: traveling - best practice

2017-02-10 Thread pixel fairy
On Friday, February 10, 2017 at 3:02:23 AM UTC-8, john.david.r.smith wrote: > On 10/02/17 11:53, '0xDEADBEEF00' via qubes-users wrote: ... > > This also serves as a decoy, if I'm forced to boot my laptop when passing > > borders or so. > > > > Best, > > > > 0xdeadbeef > > dual booting opens a

Re: [qubes-users] Ad-blocking ProxyVM?

2017-02-10 Thread Joe Ruether
On Thursday, February 9, 2017 at 10:21:26 AM UTC-5, Unman wrote: > On Thu, Feb 09, 2017 at 04:32:12AM -0800, Joe Ruether wrote: > > Hello! > > > > I am trying to set up a proxy vm that will redirect DNS requests to a local > > DNS server, for the purposes of adblocking. > > > > Here is the

[qubes-users] Re: Cant Update with Fedora 24 minimal template as net-vm

2017-02-10 Thread CF
On 02/10/2017 04:24 AM, FWM wrote: > I've setup a new firewall-VM & net-vm to use the fedora-24-minimal-template, > > Firewall uses base template with no aditional packages. > > the net-vm is a cloned fedora-24-minimal-template with the following packages > installed (NetworkManager

Re: [qubes-users] qvm-run fails silently with chromium

2017-02-10 Thread marc
> The issue you raise there arises because the xterm is not a login shell > so will not use .profile. > It is interactive so (using bash) will use .bashrc > > On the immediate question here you can always set the path explicitly: > qvm-run -p qube "export PATH=$PATH: && foo" Hey Unman. The issue

[qubes-users] Mount point /proc/xen in appVM prevents flatpak packages from starting (Issue #2540 impact wider than reported)

2017-02-10 Thread Alex
Hi all, I've been trying to use MonoDevelop 6, now distributed as a flatpak package instead of the usual RPM (fedora 25). I've had some problems in trying to run it, mainly because of an obscure error message "Can't mount proc on /newroot/proc: Operation not permitted". Further debugging had me

Re: [qubes-users] Re: traveling - best practice

2017-02-10 Thread john.david.r.smith
On 10/02/17 11:53, '0xDEADBEEF00' via qubes-users wrote: Interesting topic... I would like to here more about how people handle this. On my side, I'would never work on sensitive information in such a situation. To make just some surfing in public place, my laptop is installed with a standard

Re: [qubes-users] Re: traveling - best practice

2017-02-10 Thread '0xDEADBEEF00' via qubes-users
Interesting topic... I would like to here more about how people handle this. On my side, I'would never work on sensitive information in such a situation. To make just some surfing in public place, my laptop is installed with a standard w10 that I use only to check a generic mailbox with on

[qubes-users] Re: Qubes R3.2 on Thinkpad X250: cannot install Windows 7 (hangs on "Starting Windows" at install)

2017-02-10 Thread truleeeeeed
четверг, 9 февраля 2017 г., 21:10:00 UTC+3 пользователь bal...@gmail.com написал: > I have the same Problem :( > > When I change the model type to Cirrus,then appear a libvirtError that > doesn't make any sense to me: > > Orignal Message: libvirt.libvirtError: Operation schlug fehl: Domain

Re: [qubes-users] ubuntu template

2017-02-10 Thread john.david.r.smith
Unman can you make a template rpm Ubuntu and put it on https://ftp.qubes-os.org/repo/yum/r3.2/templates-community/rpm/ ?:) i also would prefer this option, but it seems it is not possible due to legal issues. see: https://www.qubes-os.org/doc/templates/ubuntu/ maybe we could convince

Re: [qubes-users] ubuntu template

2017-02-10 Thread truleeeeeed
четверг, 9 февраля 2017 г., 14:41:42 UTC+3 пользователь Unman написал: > On Thu, Feb 09, 2017 at 02:37:36AM -0800, damien.wa...@gmail.com wrote: > > Hi, > > > > I am new into qubes (few months) and find it great. But I need a distro > > with newer packages (debian jessie was fine until I ran in