[qubes-users] postfix

2017-03-07 Thread Ted Brenner
Hi all,

I'm trying to setup postfix following this guide
. But I'm not able to get a few
things to work.

First, the commands I added to /rw/config/rc.local don't seem to run.
Namely, it doesn't appear to be mounting the /usr/local/etc/postfix
directory in /etc/postfix. Also postfix doesn't appear to be running on
startup. How do we tell if that gets run correctly?

Thanks!
Ted

-- 
Sent from my Desktop

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CANKZutyCdxDUjvmdad%3DpUoLDEv7hqU%3D%2BB1gA7DqoEj8%3D4H7vJw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Win 7, Qubes 3.2, qubes-windows-tools 3.2.2-3 struggles

2017-03-07 Thread Ed Welch

On 03/07/2017 08:52 PM, Ted Brenner wrote:
On Mon, Mar 6, 2017 at 8:25 PM, Ed Welch > wrote:


On 03/06/2017 09:16 PM, Ted Brenner wrote:

Thanks for the details Ed. Did you have to start over from
scratch or were you able to remove QWT and then install the older
version?

On Fri, Mar 3, 2017 at 8:46 PM, Ed Welch > wrote:

I figured out how to install an older version of
qubes-windows-tools

sudo dnf remove qubes-windows-tools

sudo qubes-dom0-update
--enablerepo=qubes-dom0-current-testing
qubes-windows-tools-3.2.1-3.x86_64

From the testing repo:
http://yum.qubes-os.org/r3.2/current-testing/dom0/fc23/rpm/


I was able to see the different versions so I chose the most
recent prior to 3.2.2-3, which was 3.2.1-3.

And I have to say, this was a whole different ballgame,
everything with this version went really smoothly, I'm up and
running now with an updated win 7 instance, gui comes up
fine, never even needed debug mode.

I'm not sure if Ted and I are just among the first to do a
clean install with 3.2.1-3 or if there is something about our
systems giving us these issues.

Anyone please let me know how I can help (filing issues in
github, logs, etc) but for now I'm happy with how the older
version is working.

Ed


On 03/03/2017 11:45 AM, Ted Brenner wrote:

For what it's worth, I'm having the exact same issues.

On Fri, Mar 3, 2017 at 9:13 AM, Ed Welch > wrote:

Hey everyone, new to qubes, love it!

Getting going with linux I found pretty straight
forward, no issues.

Trying to get a Windows 7 HVM template created, not
going so well.

Thought I would post some of the issues I've had for
posterity and also see if I can get some help.


If you are like me and don't generally read long winded
posts, please at least scroll to my QUESTION at the
bottom :)


Most of the instructions tell you to create a VM,
however, none of them tell you to increase the default
VM specs.  For win 7 64 it seems you want to increase
the RAM to 4096MB and primary partition to 40960MB (40G)
I know for a fact 20G is not enough to update windows 7
sp1 to latest.

You'll want to do this before anything else because it's
more difficult to do after you get started


Then I ran into the xen/cirrus video driver issue which
causes windows to freeze on the startup screen, found
this issue with workaround:
https://github.com/QubesOS/qubes-issues/issues/2488


This workaround does the trick, but I think it's
important to note a few additional steps, after the last
setup reboot and BEFORE YOU SHUTDOWN windows and try to
install the windows guest additions.

MAKE SURE to enable login without password through the
netplwiz tool, it seemed like this was the crucial step
in avoiding this issue:

https://groups.google.com/forum/#!msg/qubes-users/Vbga8Z-DjHE/GVHIWIob5uIJ



Also, users mentioned in that thread the importance of
adding more RAM, however, for me it seemed that enabling
login without password was the step that avoided putting
your VM in a totally unrecoverable BSOD loop.

Following the wiki instructions, I then installed the
windows tools from the qubes-dom0-current-testing repo
(and also updated the qrexec_timeout to 300 seconds)
then switching back to the modified instructions for
working around the cirrus/xen bug I was able to boot
into windows and install the windows tools.


This is where I hit my next big stumbling point, during
the installation the PV drivers prompt you to reboot. DO
NOT REBOOT until the installation finishes, I did
eventually see on this page 'Xen PV driver components
may display a message box asking for reboot during
installation – it’s safe to ignore them and defer the
reboot.'

Really this needs to be promoted to
https://www.qubes-os.org/doc/windows-appvms/
 IMO and
in big bold letters DO 

Re: [qubes-users] Qubes 4 Release Date

2017-03-07 Thread lokedhs
On Wednesday, 8 March 2017 02:59:18 UTC+8, cooloutac  wrote:
> I think most new users want more passthrough like gpu. IMO if I want to be 
> secure 
> on my pc i try to avoid those things.  I have a separate machine for gaming 
> for 
> example.  But I guess the idea of qubes is to be able to do risky things more 
> securely in isolated manner and is originally aimed at home users.

Didn't the Linux kernel gain VGPU support recently? The whole point of that 
feature is to allow VM's to take advantage of the GPU. Couldn't that be 
supported in Qubes?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/7e473c0a-6764-4458-b065-329ac7c50862%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Win 7, Qubes 3.2, qubes-windows-tools 3.2.2-3 struggles

2017-03-07 Thread Ted Brenner
On Mon, Mar 6, 2017 at 8:25 PM, Ed Welch  wrote:

> On 03/06/2017 09:16 PM, Ted Brenner wrote:
>
> Thanks for the details Ed. Did you have to start over from scratch or were
> you able to remove QWT and then install the older version?
>
> On Fri, Mar 3, 2017 at 8:46 PM, Ed Welch  wrote:
>
>> I figured out how to install an older version of qubes-windows-tools
>> sudo dnf remove qubes-windows-tools
>>
>> sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing
>> qubes-windows-tools-3.2.1-3.x86_64
>>
>> From the testing repo: http://yum.qubes-os.org/r3.2/c
>> urrent-testing/dom0/fc23/rpm/
>>
>> I was able to see the different versions so I chose the most recent prior
>> to 3.2.2-3, which was 3.2.1-3.
>>
>> And I have to say, this was a whole different ballgame, everything with
>> this version went really smoothly, I'm up and running now with an updated
>> win 7 instance, gui comes up fine, never even needed debug mode.
>>
>> I'm not sure if Ted and I are just among the first to do a clean install
>> with 3.2.1-3 or if there is something about our systems giving us these
>> issues.
>>
>> Anyone please let me know how I can help (filing issues in github, logs,
>> etc) but for now I'm happy with how the older version is working.
>>
>> Ed
>>
>>
>> On 03/03/2017 11:45 AM, Ted Brenner wrote:
>>
>> For what it's worth, I'm having the exact same issues.
>>
>> On Fri, Mar 3, 2017 at 9:13 AM, Ed Welch  wrote:
>>
>>> Hey everyone, new to qubes, love it!
>>>
>>> Getting going with linux I found pretty straight forward, no issues.
>>>
>>> Trying to get a Windows 7 HVM template created, not going so well.
>>>
>>> Thought I would post some of the issues I've had for posterity and also
>>> see if I can get some help.
>>>
>>>
>>> If you are like me and don't generally read long winded posts, please at
>>> least scroll to my QUESTION at the bottom :)
>>>
>>>
>>> Most of the instructions tell you to create a VM, however, none of them
>>> tell you to increase the default VM specs.  For win 7 64 it seems you want
>>> to increase the RAM to 4096MB and primary partition to 40960MB (40G) I know
>>> for a fact 20G is not enough to update windows 7 sp1 to latest.
>>>
>>> You'll want to do this before anything else because it's more difficult
>>> to do after you get started
>>>
>>>
>>> Then I ran into the xen/cirrus video driver issue which causes windows
>>> to freeze on the startup screen, found this issue with workaround:
>>> https://github.com/QubesOS/qubes-issues/issues/2488
>>>
>>> This workaround does the trick, but I think it's important to note a few
>>> additional steps, after the last setup reboot and BEFORE YOU SHUTDOWN
>>> windows and try to install the windows guest additions.
>>>
>>> MAKE SURE to enable login without password through the netplwiz tool, it
>>> seemed like this was the crucial step in avoiding this issue:
>>> https://groups.google.com/forum/#!msg/qubes-users/Vbga8Z-DjH
>>> E/GVHIWIob5uIJ
>>>
>>> Also, users mentioned in that thread the importance of adding more RAM,
>>> however, for me it seemed that enabling login without password was the step
>>> that avoided putting your VM in a totally unrecoverable BSOD loop.
>>>
>>> Following the wiki instructions, I then installed the windows tools from
>>> the qubes-dom0-current-testing repo (and also updated the qrexec_timeout to
>>> 300 seconds) then switching back to the modified instructions for working
>>> around the cirrus/xen bug I was able to boot into windows and install the
>>> windows tools.
>>>
>>>
>>> This is where I hit my next big stumbling point, during the installation
>>> the PV drivers prompt you to reboot.  DO NOT REBOOT until the installation
>>> finishes, I did eventually see on this page 'Xen PV driver components may
>>> display a message box asking for reboot during installation – it’s safe to
>>> ignore them and defer the reboot.'
>>>
>>> Really this needs to be promoted to https://www.qubes-os.org/doc/w
>>> indows-appvms/ IMO and in big bold letters DO NOT REBOOT until the
>>> installation is completed kind of thing.  If you reboot before it finishes
>>> this is really unrecoverable and it's easier to just blow away the vm and
>>> start again...
>>>
>>>
>>> Ok, so now we get to where I'm stuck, my vm is installed,
>>> qubes-windows-tools 3.2.2-3 is installed, however as soon as I start the
>>> thing, it boots and the display immediately goes away, found this issue:
>>> https://github.com/QubesOS/qubes-issues/issues/1896  which matches the
>>> behavior I'm seeing, however, this was fixed some time ago, but not totally
>>> sure when it was released??
>>>
>>>
>>> My second, issue, which may actually be causing the first, seems to best
>>> be described in this thread: https://groups.google.com/d/to
>>> pic/qubes-users/4OgwojFK-sI/discussion
>>>
>>> Specifically I'm having the issue in the last comment, the only way I
>>> can get any UI is if I boot with --debug, and when I do, I 

[qubes-users] Re: Qubes i3 Tips & Tricks

2017-03-07 Thread anoa
On 03/07/2017 05:42 AM, Daniel Moerner wrote:
> On Mon, Mar 6, 2017 at 11:02 PM, sm8ax1
>  > wrote:
>> Thanks for this. I've used i3 on other OSes and I like it a lot. I
>> probably won't use it on Qubes however because of an issue that I'll
>> note here since it may or may not affect other users.
>>
>> In i3 it is rather difficult to control the size of a window with fine
>> granularity, and in particular it is very difficult to restore the exact
>> size a window would have been created with. This is a problem for users
>> of Tor Browser, because websites and exit nodes can query the browser
>> window's size even when you have JavaScript disabled. This makes you an
>> easy fingerprinting target.
>>
>> If anyone knows of any workarounds for this, perhaps forcing certain
>> kinds of windows to be created in floating mode and keep their original
>> size, please share them.
> 
> You'd have to experiment with whether it keeps the windows their
> original size, but you can force windows to start in floating mode in
> .i3/config:
> https://faq.i3wm.org/question/61/forcing-windows-as-always-floating.1.html
> 
> A line similar to:
> 
> for_window [class="anon-whonix:[.]*"] floating enable
> 
> Should make all windows from the anon-whonix VM float by default,
> although I haven't tested this.
> 
> Daniel
> 
> -- 
> You received this message because you are subscribed to the Google
> Groups "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to
> qubes-users+unsubscr...@googlegroups.com
> .
> To post to this group, send email to
> qubes-users@googlegroups.com
> .
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/qubes-users/CAPSgt5nbAWaR0EXRQvNG_Z_4tDx4ULfifZHYyNzRzgMUeQn3VA%40mail.gmail.com
> .
> For more options, visit https://groups.google.com/d/optout.

I can confirm that the following works for keeping the Tor Browser in
it's initial default state. Might be more convenient for users using
other tools in Whonix that just the browser.

for_window [class="Tor Browser"] floating enable


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/o9nmfl%24p5u%241%40blaine.gmane.org.
For more options, visit https://groups.google.com/d/optout.


signature.asc
Description: OpenPGP digital signature


Re: [qubes-users] do I really need these packages in dom0 :?

2017-03-07 Thread Eva Star



ModemManager-glib
NetworkManager-wifi
anaconda-gui
anaconda-widgets
enchant
fros
geoclue2
glade-libs
harfbuzz-icu
hunspell
hunspell-en-US
initial-setup-gui
libgnomekbd
libicu
libnm-gtk
libreport-gtk
libtimezonemap
mobile-broadband-provider-info
nm-connection-editor
python3-meh-gui
webkitgtk3
wpa_supplicant
yelp
yelp-libs
yelp-xsl


+ keybinder3 in my list.
Can we remove all of this?


--
Regards

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b47349b3-26d0-3a41-da01-93cfa83c0a1c%40openmailbox.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes i3 Tips & Tricks

2017-03-07 Thread Eva Star

Can somebody share screenshots of i3 ? Thanks


--
Regards

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/add2297f-5044-278e-e8bd-1f8187c1fa22%40openmailbox.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Tip: Restoring functionality of Windows AppVMs after a crash or forced termination

2017-03-07 Thread Grzesiek Chodzicki
After a Windows AppVM running in Seamless Gui mode crashes it often fails to 
connect to qrexec agent at subsequent boot causing the user to be forced to 
kill the AppVM which causes the machine to fail to connect co qrexec agent 
which causes a spiral of misery. Here's how to fix that:

1. Disable Seamless GUI and enable debug mode of Windows VM
2. Start Windows VM
3. In the VM window You'll see the Safe Mode prompt. This prompt is the real 
cause of the issue as the 30 second timer prolongs the boot process which in 
turns causes qrexec to timeout. Select "Start Windows normally.
4. In Windows AppVM launch Command Prompt as Administrator
5. Use following commands in the Commands Prompt: "bcdedit /set {bootmgr} 
displaybootmenu no" (no quotes) and "bcdedit /set {default} bootstatuspolicy 
ignoreallfailures" (no quotes)
6. Shutdown Windows machine
7. (optionally) change how long the qrexec waits for connection from the 
default 60 seconds to 120 seconds
8. Enable Seamless GUI back and disable debug mode

Your Windows VM should start normally after a crash now.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ba542940-7b14-4df4-ad88-189fc833bbaa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: app-vm distorted sound

2017-03-07 Thread Grzesiek Chodzicki
W dniu wtorek, 7 marca 2017 09:21:48 UTC+1 użytkownik legaw...@gmail.com 
napisał:
> Hi all! I was watching movie by VLC player in my Debian-8 App-VM, and 
> discovered that I can set up volume in it up to 200% with mouse wheel 
> (instead of maximum 125% in the classical way), then I closed VLC at this 
> volume... After that system volume (in app-vm i guess) became distorted (stay 
> at 200%?). Any manipulations with audio mixer did nothing, reboot did nothing 
> as well. How can I drop audio mixer or app-vm's volume to defaults?

Run alsamixer in that appvm's terminal and set it back to default

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0e178f91-c6a3-4d67-9019-363e88ad58fe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Can NOT get Broadcom BCM43602 Wifi Card working , DELL XPS 15 9950- Qubes sys-net freezes/ crashes

2017-03-07 Thread elimisteve
> I've ordered a AR9462. Estimated delivery 27 Jan 2017 - 16 Mar 2017!

Please let us know how it goes! I'm looking to buy a Dell XPS 15 9550, but only 
once I'm confident that it'll work well with Qubes, and it sounds like it will 
as long as the wifi card is replaced. Thanks!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/6273d809-7cc5-4f27-8a4c-ece8952185f9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Cannot boot from Qubes installation media in UEFI mode (grub command line)

2017-03-07 Thread smengler3
Hi everyone, I'm trying to install Qubes OS from a USB drive (the installation 
media) to another USB drive. My computer is in UEFI mode. When I boot from the 
installation media, the GRUB CLI "grub >" starts and I'm not sure what to do 
from here. If I run `ls`, I see my main SSD with Windows installed "(hd0) 
(hd0,gpt5) (hd0,gpt4) (hd0,...)", but I do not see any other drives in this 
list.

I want to be careful not to change anything on my internal SSD, which currently 
has my Windows installation. If I change my computer to legacy mode rather than 
UEFI, it boots from the installation media properly and I can install Qubes, 
but I'd prefer to use UEFI so I figured I'd ask here. I have read the UEFI 
Troubleshooting docs, but they don't seem relevant in this situation 

Since I'm not very familiar with GRUB, can anyone tell me why the installation 
media starts at the GRUB command line and maybe point me in the right direction?

Best,
Steve

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/470a4edf-e05a-42d8-9d97-ddb7b2cdbfdb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] New User...Install won't setup and Run from SSD

2017-03-07 Thread William Fisher
Hi,

My name is William Fisher, and I built a desktop specifically for Qubes Os.
I have one Samsung M.2 NVMe SSD and one 1TB disk drive. After I install
Qubes to the SSD and reboot, it does not recognize the SSD as a bootable
device. Using the same install procedures on the HDD, everything works
fine. When using Qubes from the HDD to access the SSD, the BOOT file is
empty, so there are no files to rename as you've directed in the UEFI
troubleshooting. Also, I cannot access the /BOOT/EFI/ file on my HDD, it
says I don't have the required permissions. On install, I set up a password
for the root user, but cannot act as the root user, even through terminal.
There is no prompt for a password.

Also, I've tried to use a 4K monitor with Qubes, but the max resolution
option is 1080p. I understand that there is a way to create custom
resolution options through terminal using xrandr, but have tried and it
failed when using addmode eDPI 2560x1600 (I was trying this resolution
first as someone in an email string did this successfully).

Any help would be greatly appreciated, especially the the boot issues. I
would prefer not booting Qubes off my HDD when I got an M.2 SSD
specifically for Qubes.

Thank you,
William fisher

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAJyh_i9pYKOHHE%2BUC%3Dzp_GmQvNmhy%3DkvDjgsp_MYbtRRkN-EOg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Upgrading from Qubes 3 to 4.

2017-03-07 Thread Marek Marczykowski-Górecki
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On Tue, Mar 07, 2017 at 11:34:48AM -0800, Vít Šesták wrote:
> AFAIR you will have to perform full reinstall when upgrading to Q4 because of 
> switch to LVM.

Yes. And not only because of LVM switch, but also many other changes,
like new qubes.xml format.

- -- 
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
-BEGIN PGP SIGNATURE-
Version: GnuPG v2

iQEcBAEBCAAGBQJYvyLSAAoJENuP0xzK19csi50IAJLk598lUZDTEpE2Okeq2nUp
JDb+MCJP+510iveDdRQZznSn7Jgs9t3f1oz7mBBPHYve11dlFDQmQ/FJFxmLrZTR
pESQjqrw4eeepSAs0fxdj0xw5BxWXHuVxWBAJNUZCcCuB0AqH333+hGs/6AeIUB0
fB8+xNnCBcqimEMNZAPIsWThjnhvgP54TLTO2iXTus219oi1Fl0bCyJBoAyiu185
FhKb1MLkPrgTsgp8dzCwJtVMiyDKwXfpPloynh7gXvkZsw6BKg55Y+6+NiOeHeWz
cCYVcYT8l9akFIW+apdd7N1fYEw5fP9/jZKmRFqCWDZ2e4jnBet/sC85HP47i9g=
=q6ku
-END PGP SIGNATURE-

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170307211459.GA5360%40mail-itl.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] DNS

2017-03-07 Thread Unman
On Tue, Mar 07, 2017 at 09:56:23PM +0100, 'Antoine' via qubes-users wrote:
> On Mon, Mar 06, 2017 at 04:31:31PM -0800, Andrew David Wong wrote:
> > >> Filed a bug report:
> > >> 
> > >> https://github.com/QubesOS/qubes-issues/issues/2674
> > >> 
> > >> Antoine, you didn't mention which version of Qubes or Debian 
> > >> you're using, so I assumed Qubes 3.2 and the Debian 8 
> > >> TemplateVM.
> > > 
> > > In fact, I am using a Debian 9 TemplateVM.
> > > 
> > > Antoine
> > > 
> > 
> > Thanks. I've updated the bug report.
> > 
> > However, please note that Debian 8 has gone more extensive testing
> > than Debian 9 as a TemplateVM. You may wish to try Debian 8 to see
> > whether this resolves your problem.
> 
> I have the same problem with Fedora 23, Debian 8 and Debian 9:
> 
> = Fedora 23 =
> [user@work ~]$ grep PRETTY /etc/os-release 
> PRETTY_NAME="Fedora 23 (Workstation Edition)"
> [user@work ~]$ cat /etc/resolv.conf 
> nameserver 10.137.2.1
> nameserver 10.137.2.254
> [user@work ~]$ dig +short gov.uk @10.137.2.1
> 23.235.33.144
> 23.235.37.144
> [user@work ~]$ dig +short gov.uk @10.137.2.254
> ;; connection timed out; no servers could be reached
> 
> = Debian 8 =
> user@cloud:~$ grep PRETTY /etc/os-release 
> PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
> user@cloud:~$ cat /etc/resolv.conf 
> nameserver 10.137.2.1
> nameserver 10.137.2.254
> user@cloud:~$ dig +short gov.uk @10.137.2.1
> 23.235.33.144
> 23.235.37.144
> user@cloud:~$ dig +short gov.uk @10.137.2.254
> ;; connection timed out; no servers could be reached
> 
> = Debian 9 =
> user@Email:~$ grep PRETTY /etc/os-release 
> PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
> user@Email:~$ cat /etc/resolv.conf 
> nameserver 10.137.2.1
> nameserver 10.137.2.254
> user@Email:~$ dig +short gov.uk @10.137.2.1
> 23.235.33.144
> 23.235.37.144
> user@Email:~$ dig +short gov.uk @10.137.2.254
> ;; connection timed out; no servers could be reached
> 
> Do you have an advise how to remove 10.137.2.254 from the list of
> default name servers?

Probaly more relevant would be for you to discover why the first
nameserver isnt reachable or isnt responding.
With multiple entries they are queried in the order given, so if the
first is working correctly the second entry wont be hit.

Thats the real problem.
.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170307210807.GA30418%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] DNS

2017-03-07 Thread 'Antoine' via qubes-users
On Mon, Mar 06, 2017 at 04:31:31PM -0800, Andrew David Wong wrote:
> >> Filed a bug report:
> >> 
> >> https://github.com/QubesOS/qubes-issues/issues/2674
> >> 
> >> Antoine, you didn't mention which version of Qubes or Debian 
> >> you're using, so I assumed Qubes 3.2 and the Debian 8 
> >> TemplateVM.
> > 
> > In fact, I am using a Debian 9 TemplateVM.
> > 
> > Antoine
> > 
> 
> Thanks. I've updated the bug report.
> 
> However, please note that Debian 8 has gone more extensive testing
> than Debian 9 as a TemplateVM. You may wish to try Debian 8 to see
> whether this resolves your problem.

I have the same problem with Fedora 23, Debian 8 and Debian 9:

= Fedora 23 =
[user@work ~]$ grep PRETTY /etc/os-release 
PRETTY_NAME="Fedora 23 (Workstation Edition)"
[user@work ~]$ cat /etc/resolv.conf 
nameserver 10.137.2.1
nameserver 10.137.2.254
[user@work ~]$ dig +short gov.uk @10.137.2.1
23.235.33.144
23.235.37.144
[user@work ~]$ dig +short gov.uk @10.137.2.254
;; connection timed out; no servers could be reached

= Debian 8 =
user@cloud:~$ grep PRETTY /etc/os-release 
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
user@cloud:~$ cat /etc/resolv.conf 
nameserver 10.137.2.1
nameserver 10.137.2.254
user@cloud:~$ dig +short gov.uk @10.137.2.1
23.235.33.144
23.235.37.144
user@cloud:~$ dig +short gov.uk @10.137.2.254
;; connection timed out; no servers could be reached

= Debian 9 =
user@Email:~$ grep PRETTY /etc/os-release 
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
user@Email:~$ cat /etc/resolv.conf 
nameserver 10.137.2.1
nameserver 10.137.2.254
user@Email:~$ dig +short gov.uk @10.137.2.1
23.235.33.144
23.235.37.144
user@Email:~$ dig +short gov.uk @10.137.2.254
;; connection timed out; no servers could be reached

Do you have an advise how to remove 10.137.2.254 from the list of
default name servers?

Many thanks,

Antoine

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170307205623.bz6ibs44qcme6s2x%40fedora-23-dvm.
For more options, visit https://groups.google.com/d/optout.


signature.asc
Description: PGP signature


Re: [qubes-users] Re: Qubes OS 3.1 reaches EOL on 2017-03-29

2017-03-07 Thread Unman
On Tue, Mar 07, 2017 at 11:05:59AM -0800, raahe...@gmail.com wrote:
> On Tuesday, March 7, 2017 at 7:18:05 AM UTC-5, Sybil wrote:
> > On 03/01/2017 10:01 AM, Andrew David Wong wrote:
> > > Qubes OS releases are normally supported for six months after each 
> > > subsequent
> > > major or minor release (see [Supported Versions] and [Version Scheme]). In
> > > accordance with this policy, Qubes 3.1, which was released on 2016-03-09, 
> > > is
> > > scheduled to reach end-of-life (EOL) on 2017-03-29 --- six months after 
> > > Qubes
> > > 3.2 was released on 2016-09-29. We strongly urge all current Qubes 3.1 
> > > users to
> > > upgrade to Qubes 3.2 or newer before 2017-03-29. As always, newer 
> > > releases are
> > > available on the [downloads] page.
> > 
> > With Fedora 23 being EOL (2016-12-20) too, shouldn't there be an update 
> > by now anyway? (Or some document on how to upgrade the core parts to 
> > Fedora 24 or 25?)
> > 
> > https://fedoramagazine.org/fedora-23-end-of-life/
> > "After December 20th, all packages in the Fedora 23 repositories will no 
> > longer receive security, bugfix, or enhancement updates, and no new 
> > packages will be added to the Fedora 23 collection."
> > 
> > Sybil
> 
> yes there is one already. 
> https://www.qubes-os.org/news/2016/11/15/fedora-24-template-available/   I 
> guess you need to upgrade to qubes 3.2 first.
> 

I think the concern was more with "the core parts" in dom0 - 
EOL here isn't critical at all, as is explicitly covered in the docs:
www.qubes-os.org/doc/supported-versions.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170307202349.GB29987%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Re: app-vm distorted sound

2017-03-07 Thread Unman
On Tue, Mar 07, 2017 at 11:22:47AM -0800, raahe...@gmail.com wrote:
> On Tuesday, March 7, 2017 at 3:21:48 AM UTC-5, legaw...@gmail.com wrote:
> > Hi all! I was watching movie by VLC player in my Debian-8 App-VM, and 
> > discovered that I can set up volume in it up to 200% with mouse wheel 
> > (instead of maximum 125% in the classical way), then I closed VLC at this 
> > volume... After that system volume (in app-vm i guess) became distorted 
> > (stay at 200%?). Any manipulations with audio mixer did nothing, reboot did 
> > nothing as well. How can I drop audio mixer or app-vm's volume to defaults?
> 
> weird,  alsamixer from terminal maybe.  try in dom0 as well unmute 
> everything. if using pulse maybe pavucontrol?
> 
Have you tried the obvious step of starting the qube and manipulating
the volume control with the mouse?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170307201717.GA29987%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: New User, First Time Install - Have I lost everything?

2017-03-07 Thread Vít Šesták
Now, I am not sure if I understand you. Were you able to access the files or 
not? Do you try it from console, or from some GUI. If you use a GUI, what app 
are you using?

Regards,
Vít Šesták 'v6ak'

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a1e9f5b5-cfcb-4149-9967-cff765eeb456%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Nvidia Optimus mode not possible?

2017-03-07 Thread Vít Šesták
Good point on Bumblebee being dead, I've missed that. It works with my GPU, but 
my laptop model is from 2011…

Bbswitch seems to be rather simple piece of software that can disable the 
Nvidia GPU. It might be worth of trying it even with new GPUs. Unless you have 
an output wired directly to Nvidia card, disabling Nvidia is probably the only 
thing you need to do with it.

If bbswitch does not support new Nvidia GPUs, it is an unfortunate fact that I 
should consider when buying a new laptop  Unfortunately, discarding all 
Nvidia-equipped laptops from my selection seems to discard many laptops. 

Regards,
Vít Šesták 'v6ak'

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/543de50a-ee7b-45ca-a53d-1731ccd5d8d5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Upgrading from Qubes 3 to 4.

2017-03-07 Thread raahelps
On Tuesday, March 7, 2017 at 2:34:48 PM UTC-5, Vít Šesták wrote:
> AFAIR you will have to perform full reinstall when upgrading to Q4 because of 
> switch to LVM.
> 
> I am in similar situation. I plan buying a new laptop, because my current 
> laptop EOLs soon (end of 5Y warranty). I cannot migrate to Qubes 4 before 
> that (compatibility issues) and I don't want to install 3.2 on the new laptop 
> and perform full reinstall in few weeks/months.
> 
> Regards,
> Vít Šesták 'v6ak'

its pretty quick and easy though if restoring backup vms.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/62bb230b-c6ff-4c7a-a120-d9391f6bc3c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Upgrading from Qubes 3 to 4.

2017-03-07 Thread Vít Šesták
AFAIR you will have to perform full reinstall when upgrading to Q4 because of 
switch to LVM.

I am in similar situation. I plan buying a new laptop, because my current 
laptop EOLs soon (end of 5Y warranty). I cannot migrate to Qubes 4 before that 
(compatibility issues) and I don't want to install 3.2 on the new laptop and 
perform full reinstall in few weeks/months.

Regards,
Vít Šesták 'v6ak'

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/3d021065-4d00-4fc4-a230-8d83ec29046d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: app-vm distorted sound

2017-03-07 Thread raahelps
On Tuesday, March 7, 2017 at 3:21:48 AM UTC-5, legaw...@gmail.com wrote:
> Hi all! I was watching movie by VLC player in my Debian-8 App-VM, and 
> discovered that I can set up volume in it up to 200% with mouse wheel 
> (instead of maximum 125% in the classical way), then I closed VLC at this 
> volume... After that system volume (in app-vm i guess) became distorted (stay 
> at 200%?). Any manipulations with audio mixer did nothing, reboot did nothing 
> as well. How can I drop audio mixer or app-vm's volume to defaults?

weird,  alsamixer from terminal maybe.  try in dom0 as well unmute everything. 
if using pulse maybe pavucontrol?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a5177125-e859-419d-87dc-81fea3cb812b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Screen stuck at network configuration.

2017-03-07 Thread raahelps
On Tuesday, March 7, 2017 at 5:34:01 AM UTC-5, shubham dubey wrote:
> I am trying to install qubes os. The installation happen successfully but on 
> configuration screen the os get stuck on network configuration dialog. I have 
> tried the to disable the ethernet card on bios as given in this post 
> https://groups.google.com/forum/#!topic/qubes-users/X5Iomlu_oo4 (as
> it seems same problem) but that option is not available in my bios.So can 
> anyone have any other solution.
> 
> The option I am selecting on configuration screen is only create system level 
> vm.My system is lenovo z50-70 with 4 GB ram.
> 
> Thanks,
> Shubham

maybe u can try and create network vm after install instead of a automatically. 
 Also 4gb is alittle low for Qubes, fyi prolly only be able to run 1 or 2 
appvms at a time, but it should work fine.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/d9795357-b21c-4b4b-ad89-e4018951d477%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Upgrading from Qubes 3 to 4.

2017-03-07 Thread raahelps
On Tuesday, March 7, 2017 at 4:34:32 AM UTC-5, lok...@gmail.com wrote:
> On Tuesday, 7 March 2017 03:56:20 UTC+8, Jean-Philippe Ouellet  wrote:
> 
> > https://www.qubes-os.org/news/2016/09/02/4-0-minimum-requirements-3-2-extended-support/
> > 
> > Note that those are bare minimum requirements, and that you will
> > probably want more. If you need to run windows HVMs, I'd say at least
> > double those recommendations.
> > 
> > I'm probably something of a power user, but used to run out of memory
> > regularly with 8gb and am about to run out of disk with 500gb.
> > 
> > I think perhaps we should consider adding a "recommended requirements"
> > section instead of just "minimum requirements".
> 
> Thank you. I have read that, and I have already settled on getting a 32 GB 
> laptop. My question, however, was whether it's expected that the upgrade 
> procedure will be difficult to the point where doing a full reinstall is 
> easier.
> 
> In particular, I'd like to know if existing QVM's will be compatible with 
> Qubes 4 (i.e. can I just back them up and load them into Qubes 4?).
> 
> Of course, if Qubes 4 isn't going to be out until much later, then the entire 
> question is moot anyway since I'll have no choice but to go for Qubes 3.2 
> anyway. That is the reason I was asking whether there is a release date for 
> Qubes 4 yet.

I've run into problems twice trying to upgrade so a full reinstall with backup 
vms was much easier and quick too.  one note is if you have custom templates 
use clones instead of defaults to make restoring easier.

most likely you will have to use Qubes 3.2 for a while. Probably a good idea to 
go to 3.2 first before v 4 if you're restoring older backups. which I know will 
restore fine on 3.2.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/eb5f32c0-0fc9-4ee3-a734-fb5c4b798c39%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes 4 Release Date

2017-03-07 Thread raahelps
I think most new users want more passthrough like gpu. IMO if I want to be 
secure on my pc i try to avoid those things.  I have a separate machine for 
gaming for example.  But I guess the idea of qubes is to be able to do risky 
things more securely in isolated manner and is originally aimed at home users.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a12730a3-111f-4dd8-bf17-5748a49f1fcd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes 4 Release Date

2017-03-07 Thread 7v5w7go9ub0o


On 03/07/2017 08:04 AM, qube...@tutanota.com wrote:
> Back in July 16 Joanna announced 
> (http://qubesos4z6n4.onion/news/2016/07/21/new-hw-certification-for-q4) 
> that Qubes 4 was due to be released later that year in Sept 16.
> Has Qubes 4 been scrapped? Anyone any idea if/when it will be released?


Their priority is to get it right; their response to 
questions/complaints like this have historically been that it'll be 
released when it's ready.

Given the number of users now using or wanting to use Qubes, the range 
of their technical abilities, and that the new users want to use Qv4 as 
plug-and-play full production, ITL would be smart to take their time on 
releases from now on and get them *very* right.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/58bee562.90d1370a.70dea.253b%40mx.google.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Nvidia Optimus mode not possible?

2017-03-07 Thread evo


On 03/07/2017 11:00 AM, Zrubi wrote:
> On 03/06/2017 07:48 PM, evo wrote:
>> i read some posts about this and as i understood, it is not
>> possible to use optimus mode with nvidia and intel card on Qubes
>> OS, is it right?
> 
> Sadly you are right.
> But this is a general limitation on linux, not a Qubes issue.
> Moreover nVidia binary drivers still not support Optimus on linux.
> 
> 
>> The thing with Bumblebee and bbswitch, which i don't fully
>> understand, seems not to work, or do somebody have some new
>> tricks?
> 
> These are dead projects, mentioning outdated drivers. I would not
> bother trying to follow those instructions.
> 
> 
> nVidia also blocking GPU passthrough via VGA BIOS (expect Quadro
> cards) so we can't even hope about passing the nVidia VGA to a VM, and
> use it there natively.
> 
> Currently the only use case where the binary drivers may be useful if
> you have a single nVidia VGA and want to use it under Qubes -
> accepting the risks for a better battery life. Or if that single card
> is a new (1000 series) one, because that is not even supported by the
> open source drivers.
> 
> 
> 

oh, ok.. so i thought.. pitty.

i have Quadro K1000M in my notebook, so not very old and not new.

The thing is, if i start in descrete-card mode, i have some strange
grafic boot, but the system runs well. Runs there the Nvidia card, but
with nouveau-driver??

as it seems, yes.

is Nvidia in nouveau-mode then better than the intel card? not really,
isn't it?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/955e8eb8-a0c0-3282-cc7b-eee4781c5397%40aliaks.de.
For more options, visit https://groups.google.com/d/optout.


0x35CA0532.asc
Description: application/pgp-keys


signature.asc
Description: OpenPGP digital signature


Re: [qubes-users] Qubes i3 Tips & Tricks

2017-03-07 Thread Daniel Moerner
On Mon, Mar 6, 2017 at 11:02 PM, sm8ax1  wrote:
> Thanks for this. I've used i3 on other OSes and I like it a lot. I
> probably won't use it on Qubes however because of an issue that I'll
> note here since it may or may not affect other users.
>
> In i3 it is rather difficult to control the size of a window with fine
> granularity, and in particular it is very difficult to restore the exact
> size a window would have been created with. This is a problem for users
> of Tor Browser, because websites and exit nodes can query the browser
> window's size even when you have JavaScript disabled. This makes you an
> easy fingerprinting target.
>
> If anyone knows of any workarounds for this, perhaps forcing certain
> kinds of windows to be created in floating mode and keep their original
> size, please share them.

You'd have to experiment with whether it keeps the windows their original
size, but you can force windows to start in floating mode in .i3/config:
https://faq.i3wm.org/question/61/forcing-windows-as-always-floating.1.html

A line similar to:

for_window [class="anon-whonix:[.]*"] floating enable

Should make all windows from the anon-whonix VM float by default, although
I haven't tested this.

Daniel

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAPSgt5nbAWaR0EXRQvNG_Z_4tDx4ULfifZHYyNzRzgMUeQn3VA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Qubes OS 3.1 reaches EOL on 2017-03-29

2017-03-07 Thread Sybil

On 03/01/2017 10:01 AM, Andrew David Wong wrote:

Qubes OS releases are normally supported for six months after each subsequent
major or minor release (see [Supported Versions] and [Version Scheme]). In
accordance with this policy, Qubes 3.1, which was released on 2016-03-09, is
scheduled to reach end-of-life (EOL) on 2017-03-29 --- six months after Qubes
3.2 was released on 2016-09-29. We strongly urge all current Qubes 3.1 users to
upgrade to Qubes 3.2 or newer before 2017-03-29. As always, newer releases are
available on the [downloads] page.


With Fedora 23 being EOL (2016-12-20) too, shouldn't there be an update 
by now anyway? (Or some document on how to upgrade the core parts to 
Fedora 24 or 25?)


https://fedoramagazine.org/fedora-23-end-of-life/
"After December 20th, all packages in the Fedora 23 repositories will no 
longer receive security, bugfix, or enhancement updates, and no new 
packages will be added to the Fedora 23 collection."


Sybil


--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/acab6726-a199-570c-1538-12789d31fbd5%40intodark.space.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: HCL - MacBookPro10,1

2017-03-07 Thread m . syasko
Boris, 

how do you managed to go through the boot menu. I'm getting issue on my 
MacBookAir7,2: "Unsupported device path component". Could you maybe suggest 
something?

Thank you, 
Michael.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/9129-9df2-49aa-bcba-20e30d6f4643%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


RE: [qubes-users] installing qubes 3.2 from a usb disk behind a hub

2017-03-07 Thread Wim Vervoorn
Hello All,

I have an update to this posting. The problem is  a bit different. I tried the 
install with another USB disk, an older USB 2.0 8GB SanDisk Cruzer. In this 
case it works fine. The problem I have is with a SanDisk Ultra USB 3.0 64GB 
stick. 

So the problem is either related to this specific usb stick or the USB 3 
support.


Best regards,

Wim Vervoorn



-Original Message-
From: qubes-users@googlegroups.com [mailto:qubes-users@googlegroups.com] On 
Behalf Of wvervo...@eltan.com
Sent: Monday, March 6, 2017 4:24 PM
To: qubes-users 
Subject: [qubes-users] installing qubes 3.2 from a usb disk behind a hub

Hello,

I have a UEFI system that I try to install Qubes 3.2 on.

This system only has a single USB port available. So I connected a hub to the 
system and the USB disk is connected behind this Hub.

The installation starts but the usb disk is not recognized so the installation 
fails because of that. If I unplug the disk and plug it in again it is 
recognized properly so I guess Qubes has problems mounting the disk behind the 
hub while it is starting the kernel.

Do you have any suggestions?

Best regards,

Wim Vervoorn

-- 
You received this message because you are subscribed to a topic in the Google 
Groups "qubes-users" group.
To unsubscribe from this topic, visit 
https://groups.google.com/d/topic/qubes-users/udDbNxjwC88/unsubscribe.
To unsubscribe from this group and all its topics, send an email to 
qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/e7a7381f-263d-458e-b282-62b77aca6124%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/d5781b26188e44a49190a80c4dcd7eee%40Eltsrv03.Eltan.local.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Screen stuck at network configuration.

2017-03-07 Thread shubham dubey
I am trying to install qubes os. The installation happen successfully but on 
configuration screen the os get stuck on network configuration dialog. I have 
tried the to disable the ethernet card on bios as given in this post 
https://groups.google.com/forum/#!topic/qubes-users/X5Iomlu_oo4 (as
it seems same problem) but that option is not available in my bios.So can 
anyone have any other solution.

The option I am selecting on configuration screen is only create system level 
vm.My system is lenovo z50-70 with 4 GB ram.

Thanks,
Shubham

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/4a5e5466-d2bf-46d0-a590-b2cc22c441b5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: HCL - ASUS UX305FA

2017-03-07 Thread CF
On 03/04/2017 11:31 PM, Jane Jok wrote:
> Hi!
> Could you please tell more about your experience with Qubes on UX305FA? I am 
> considering ordering a notebook with  M-5Y10c CPU for use with Qubes but I'd 
> like to know more
> 
> On Tuesday, February 14, 2017 at 9:49:59 AM UTC+3, CF wrote:
>> Works well. I was able to use a bluetooth external speaker in a
>> fedora-24 based VM:
>> sudo dnf install pavucontrol pulseaudio-module-bluetooth bluez blueman
>> sudo service bluetooth restart
>> pactl load-module module-bluetooth-driver
>> blueman-manager &
>> pavucontrol &
> 
Hi,

What do you want to do with that notebook?

4GB of RAM is the minimum system requirement but if you can have more,
it is better. I have no issue with UX305FA...

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/o9gppc%24mi6%241%40blaine.gmane.org.
For more options, visit https://groups.google.com/d/optout.


signature.asc
Description: OpenPGP digital signature


Re: [qubes-users] Nvidia Optimus mode not possible?

2017-03-07 Thread Zrubi
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On 03/06/2017 07:48 PM, evo wrote:
> i read some posts about this and as i understood, it is not
> possible to use optimus mode with nvidia and intel card on Qubes
> OS, is it right?

Sadly you are right.
But this is a general limitation on linux, not a Qubes issue.
Moreover nVidia binary drivers still not support Optimus on linux.


> The thing with Bumblebee and bbswitch, which i don't fully
> understand, seems not to work, or do somebody have some new
> tricks?

These are dead projects, mentioning outdated drivers. I would not
bother trying to follow those instructions.


nVidia also blocking GPU passthrough via VGA BIOS (expect Quadro
cards) so we can't even hope about passing the nVidia VGA to a VM, and
use it there natively.

Currently the only use case where the binary drivers may be useful if
you have a single nVidia VGA and want to use it under Qubes -
accepting the risks for a better battery life. Or if that single card
is a new (1000 series) one, because that is not even supported by the
open source drivers.


- -- 
Zrubi
-BEGIN PGP SIGNATURE-
Version: GnuPG v2

iQIcBAEBCAAGBQJYvoSpAAoJEH7adOMCkunm3UUP/0Ujg3jTDOffOJfUjpk2BTy+
pGwvI1zpd+GACf3Hm3E8KTfuF1j1OQGyiWJMwu3XIyK5XoZcKraH41au6AcKL0br
YXlBQPXYMIs4dNgZH8oTP0uTcUzkeTBgCpK0c2liKTIyaGYMrwtKdH5FgNEQ2KUy
cfGGQSCJ9be7vFSAOUSnBSHklMY6jgXS54MD4bUj9uk+2rZ6ggsE4ULZMg1r3IMg
9WfV3F95+vlFMUBEFWMIZBfbOraGMg+JDtQ45GYsQCA3cHd3dlIhvB29MkSQ48kB
egE26CYinSscLgQs5cXjpuBYxbHGyEr7ISbrykIZRjxFh7lCu+aChrxMVqpCOr1f
3OY3UV/HgXalKHUtjfhdgKt7jjmNo39tTiWuWy28+F+k5993wQRSTzIQ2VEvOCZv
P3NWjr7ARFVSmKeN4xX73AZUbyxVpYxUsxb+YdcETs4zNvKO1TSknH8jqoPfn18g
uOU9dgBj7l4zyFdMyX0g+6Nc+UTnxsF1WPykpH6QibBT5czXpsKtu6qUNZe2QdHS
iDLlbf/QXpm8oCGTd5UFR9y164PRQTflo31x4x2sLV3MqGGqN+ItPLGXxVT/5Vbq
Bmp7dTVVOXJN2XsENOZzLkxbdmXMZKafACorpmL93fdS6QWXJr/MTFrxbt5lxasj
lP0+C0h1PDbYdj/USdOC
=1Een
-END PGP SIGNATURE-

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/998e7ec0-950b-4db8-d3cb-b4a81c0239ca%40zrubi.hu.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Upgrading from Qubes 3 to 4.

2017-03-07 Thread lokedhs
On Tuesday, 7 March 2017 03:56:20 UTC+8, Jean-Philippe Ouellet  wrote:

> https://www.qubes-os.org/news/2016/09/02/4-0-minimum-requirements-3-2-extended-support/
> 
> Note that those are bare minimum requirements, and that you will
> probably want more. If you need to run windows HVMs, I'd say at least
> double those recommendations.
> 
> I'm probably something of a power user, but used to run out of memory
> regularly with 8gb and am about to run out of disk with 500gb.
> 
> I think perhaps we should consider adding a "recommended requirements"
> section instead of just "minimum requirements".

Thank you. I have read that, and I have already settled on getting a 32 GB 
laptop. My question, however, was whether it's expected that the upgrade 
procedure will be difficult to the point where doing a full reinstall is easier.

In particular, I'd like to know if existing QVM's will be compatible with Qubes 
4 (i.e. can I just back them up and load them into Qubes 4?).

Of course, if Qubes 4 isn't going to be out until much later, then the entire 
question is moot anyway since I'll have no choice but to go for Qubes 3.2 
anyway. That is the reason I was asking whether there is a release date for 
Qubes 4 yet.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b4610ab6-f7ce-4a5b-b91e-d9ee6e495f36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] app-vm distorted sound

2017-03-07 Thread legawrique
Hi all! I was watching movie by VLC player in my Debian-8 App-VM, and 
discovered that I can set up volume in it up to 200% with mouse wheel (instead 
of maximum 125% in the classical way), then I closed VLC at this volume... 
After that system volume (in app-vm i guess) became distorted (stay at 200%?). 
Any manipulations with audio mixer did nothing, reboot did nothing as well. How 
can I drop audio mixer or app-vm's volume to defaults?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/e0484f9a-804e-44e6-86ea-4db9116ec7f9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Qubes 4 Release Date

2017-03-07 Thread qubesos
Back in July 16 Joanna announced 
(http://qubesos4z6n4.onion/news/2016/07/21/new-hw-certification-for-q4) 
that Qubes 4 was due to be released later that year in Sept 16.
Has Qubes 4 been scrapped? Anyone any idea if/when it will be released?

--
Securely sent with Tutanota. Claim your encrypted mailbox today!
https://tutanota.com

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/Kebn0px--3-0%40tutanota.com.
For more options, visit https://groups.google.com/d/optout.