Re: [qubes-users] Partially off-topic: best OpenVPN-Set-up with Qubes 3.2, AirVPN and Turris Omnia router?

2017-05-27 Thread Chris Laprise

On 05/27/2017 06:09 PM, rob_66 wrote:

-BEGIN PGP SIGNED MESSAGE-
Hash: SHA512

Hello all.

What do you think would produce the best balance between security and
speed?

1. Running AirVPN's client 'Eddie' in sys-netVM.

2. Putting AirVPN's OpenVPN config into Turris Omnia 2 GB router.

3. Setting up a VPN gateway in Qubes as described in Qubes' docs.

Hardware: Asus »Zenbook«, Intel i5-5200U, 2.20 GHz, 12 GB RAM.

Any hint is very much appreciated.

Best regards,
rob


Best overall approach is to download your service's openvpn config files 
and continue with the doc instructions or the slightly fancier setup here:


https://github.com/tasket/Qubes-vpn-support

The one at the link (my own project) configures the link as a systemd 
service... gives you more control. The anti-leak measures are the same.


I haven't looked at 'Eddie' but usually these proprietary tools assume 
you are configuring a traditional PC. OTOH, Qubes proxyVMs are akin to 
_routers_ so protection features in Eddie et al might not work. (Anyway 
it would go in a proxyVM, not sys-net.) There was some discussion here I 
think about Mullvad and that service's special tool, and ultimately it 
was better to download the config files and use the Qubes-specific 
instructions.


As for Turris Omnia router setup, it depends on how much you trust the 
security of that router -- generally, openvpn is safer in Qubes than in 
router hardware (even the 'impressive' ones).


--

Chris Laprise, tas...@openmailbox.org
https://twitter.com/ttaskett
PGP: BEE2 20C5 356E 764A 73EB  4AB3 1DC4 D106 F07F 1886

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/86a16253-319b-d2ac-ac68-a025054e9c01%40openmailbox.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Installed software and trying to use it

2017-05-27 Thread James Chi
I installed software using sudo apt-get.  More specifically, this is what I use:

$ sudo apt-get install python-qt4 python-pip
$ sudo pip install 
https://github.com/stratisproject/electrum-stratis/releases/download/2.7.17/Electrum-Stratis-2.7.17-unix.tar.gz

After entering those commands, the terminal stated: the directory 
'/home/user/.cache/pip/http' or its parent directory is not owned by the 
current user and the cache has been disabled.  Please check the permissions and 
owner of that directory.  If executing pip with sudo, you may want sudo's -H 
flag.  

Then same message regarding 'home/user/.cache/pip' directory

The terminal went on to collect and download.  Then installed.

I then received message to upgrade pip version which I tried to do with pip 
install --upgrade pip

Then I tried to add the newly installed software to the list of shortcuts and 
could not find it.

Did I install correctly?
If so, how do I find it and start it?

Thanks!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b5d613df-f1ae-44c4-993a-8e2c5cc6b584%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Failed to initialize disk

2017-05-27 Thread 'Milleniumboard' via qubes-users
My Windows HVM haven't lagging problem after installed QWT, the only little 
issue is the message showed during the first boot 'Failed to initialize the 
private disk', and rebooting this doesn't appear more but there isn't the 'E:' 
disk dedicated to qubes but only 'C:'. Is it a relevant? Is there a solution?

Best Regards

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/MIP9K6V00wlLNKE4UQB8kvS38DlXgad8jc8jk_FvyTTVJQoGzQ-90gv5WDY-7YQ-yzO4awJOQLJPPRvTD4lDU_QoDjH7CVkok3-tnAWsJfg%3D%40protonmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Installing ubuntu template

2017-05-27 Thread James Chi
You are awesome.  Thanks!



James Chi

On Sat, May 27, 2017 at 6:42 PM, Unman  wrote:

> On Sat, May 27, 2017 at 02:29:49PM -0700, James Chi wrote:
> > I used this idiot's guide to installing an ubuntu template (
> https://www.reddit.com/r/Qubes/comments/5vzg04/idiots_
> guide_to_installing_qbuntu_ubuntu_1604/) and apparently I am an idiot.  I
> am towards the end where I am installing the template using:
> >
> > qvm-run --pass-io ubuntu-builder 'cat/home/user/qubes-builder/
> qubes-src/linux-template-builder/rpm/install-templates.
> sh'>install-templates.sh
> >
> > And I am getting the following error:
> >
> > sh: cat/home/user/qubes-builder/qubes-src/linux-template-
> builder/rpm/install-templates.sh: No such file or director
> >
> > Does anyone know what could be the problem?
> >
> > I would appreciate your help.  Thanks!
> >
>
> You're missing a space:
> cat /home/user/qubes-builder/qubes-src/linux-template-
> builder/rpm/install-templates.sh
>

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAKz%2BW18L0ZQXE26mC-N-23pgXOx6%2Br%3D3RafVRxtQnaqx5EjOxQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Installing ubuntu template

2017-05-27 Thread Unman
On Sat, May 27, 2017 at 02:29:49PM -0700, James Chi wrote:
> I used this idiot's guide to installing an ubuntu template 
> (https://www.reddit.com/r/Qubes/comments/5vzg04/idiots_guide_to_installing_qbuntu_ubuntu_1604/)
>  and apparently I am an idiot.  I am towards the end where I am installing 
> the template using:
> 
> qvm-run --pass-io ubuntu-builder 
> 'cat/home/user/qubes-builder/qubes-src/linux-template-builder/rpm/install-templates.sh'>install-templates.sh
> 
> And I am getting the following error:
> 
> sh: 
> cat/home/user/qubes-builder/qubes-src/linux-template-builder/rpm/install-templates.sh:
>  No such file or director
> 
> Does anyone know what could be the problem?  
> 
> I would appreciate your help.  Thanks!
> 

You're missing a space:
cat 
/home/user/qubes-builder/qubes-src/linux-template-builder/rpm/install-templates.sh

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170527224252.GA3483%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Partially off-topic: best OpenVPN-Set-up with Qubes 3.2, AirVPN and Turris Omnia router?

2017-05-27 Thread rob_66
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA512

Hello all.

What do you think would produce the best balance between security and
speed?

1. Running AirVPN's client 'Eddie' in sys-netVM.

2. Putting AirVPN's OpenVPN config into Turris Omnia 2 GB router.

3. Setting up a VPN gateway in Qubes as described in Qubes' docs.

Hardware: Asus »Zenbook«, Intel i5-5200U, 2.20 GHz, 12 GB RAM.

Any hint is very much appreciated.

Best regards,
rob
-BEGIN PGP SIGNATURE-

iQIwBAEBCgAaBQJZKfkXExxyb2JvdGljb0Bwb3N0ZW8uZXMACgkQxPzEC1AWVIWA
ARAAjsidL/LbmAmfwL0u+9F3rmcm6sLA/dLlI2NEJbNAA64YwP2UUbCOGh1+ELz2
pzrmeKdAmkBU2pu2XP7AuH85rNSf0t+PoN9mqYBJjkWL78QNYSHB1i+E4exwr4EF
l+F+0+rJHx6+OGQJBqXxahPCiAckA1AnGg/O5ttRFu/YzyHyLWooGUnjObfAlu8D
gwPF+7vtCSygWYPumq2E9A50NeO0NmLHmhQ7IjzXcs/EVQ+sh+fkQWLXNwa0reEY
XMAbYXyRqL5lKcMiUtRVuRDuNDNEqg1dgqRQQ1lUpg0oBGjVaYctmMScDpU9BZ0w
KUYtX815mx8gPep+iOKzLpBWVt2l5+Rt4bfPeg4vSmb20sAy+wwvmB/eiCFMs0zM
JwNnG20q8rf+O7qklkLSe5MhK4tz0+BV/Mp4cyWKrcLrObtvIGB9BS3QuogbLDG2
Yx0bAwLRTBl50swx82jQ666b82NT4ZxIzmfQRlmbGQ0hOIFS1UpDsw1uTgtWOkYy
Rl0pqftFpyqzmvuiFL3G9jJPFgtyv+CSFUDpspDggMiZWCGva+Ip/azlBg93l7iC
6IODaS/iwPouSv4EAh50H/HpMZc1DvzRsgcLknbpm/2JpaJMbh10oSYnZbIFHiy0
cfETKcy1Ksr6beW+DTfbgGGnycT7CDfAAr4W0711SXsXlig=
=yvA1
-END PGP SIGNATURE-

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/d4f6795a-96b1-a951-17b3-dfbe6b591b0c%40posteo.es.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Installing ubuntu template

2017-05-27 Thread James Chi
I used this idiot's guide to installing an ubuntu template 
(https://www.reddit.com/r/Qubes/comments/5vzg04/idiots_guide_to_installing_qbuntu_ubuntu_1604/)
 and apparently I am an idiot.  I am towards the end where I am installing the 
template using:

qvm-run --pass-io ubuntu-builder 
'cat/home/user/qubes-builder/qubes-src/linux-template-builder/rpm/install-templates.sh'>install-templates.sh

And I am getting the following error:

sh: 
cat/home/user/qubes-builder/qubes-src/linux-template-builder/rpm/install-templates.sh:
 No such file or director

Does anyone know what could be the problem?  

I would appreciate your help.  Thanks!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ba93aa50-5e29-4b99-ad0b-f5656e421ce8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Have only one resolution option in qubes 3.2 XFCE

2017-05-27 Thread dgdfjhfjhgjhjhghfg
I see most info on the topic is for KDE, but I guess it has been switched to 
xfce desktop recently?

However, I just finished my install and in the display options I have only one 
resolution in the drop down menu, 1024x768 (if i remember correctly) well my 
monitor is 3800x2400 (or something like that) and I see absolutely no way to 
change it to that.

Neither any info online on this issue?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a0ef4359-7c67-4474-ad09-678ace975f6b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Installed fine but doesn't boot.

2017-05-27 Thread dgdfjhfjhgjhjhghfg
On Saturday, May 27, 2017 at 7:06:02 PM UTC+3, mikih...@gmail.com wrote:
> On Saturday, May 27, 2017 at 12:36:28 PM UTC+2, dgdfjhfjh...@gmail.com wrote:
> > Installed from USB on brand new computer on an empty ssd m2. All went fine 
> > but after reboot nothing happens and it enters the bios.
> > From there I select to boot from the ssd but it does the same loop.
> > 
> > I read through:
> > https://www.qubes-os.org/doc/uefi-troubleshooting/#f1
> > 
> > But I can't even get to the grub menu
> > 
> > 
> > and if it's the problem further down "Boot device not recognized after 
> > installing" I don't know how to get to those files and copy them when I 
> > can't even get to a terminal.
> 
> You can enter a Qubes Rescue Mode via your installer USB Boot Menu. Maybe 
> this problem ? :
> https://github.com/QubesOS/qubes-issues/issues/2381
> 
> regards

yes I eventually figured it out. Booted from the USB install and mounted the 
quebes install and did the changes in the troubleshooting tutorial and all 
worked fine.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/47ceae79-52b8-4f35-b79e-ca54b02c289c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Can't go pasts the grub menu

2017-05-27 Thread dgdfjhfjhgjhjhghfg
On Saturday, May 27, 2017 at 10:40:32 PM UTC+3, ghjgjgk wrote:
> I have the exact same problem I tried so many times never succeeded to pass 
> the 4 options.
> The usb boots, 4 options;
> I press enter; 
> 2 lines flash quickly and then back to square one
> 
> I m trying with the 3.2 version on an old acer.
> 
> I also tried your technique but didn't work. Did you use F12?

Well I entered my bios with delete and then selected the partition 1 of the USB 
drive and was all fine after that.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/abda0e41-ad55-41e6-b2f4-a9186ffea307%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Can't go pasts the grub menu

2017-05-27 Thread dqzdqzd
I have the exact same problem I tried so many times never succeeded to pass the 
4 options.
The usb boots, 4 options;
I press enter; 
2 lines flash quickly and then back to square one

I m trying with the 3.2 version on an old acer.

I also tried your technique but didn't work. Did you use F12?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/1dc5608c-dac1-4c5a-ad7e-42b7a1100a15%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Maccchanger, debian9 template, Screensave

2017-05-27 Thread Chris Laprise

On 05/27/2017 10:24 AM, Finsh wrote:

Hello,
ive installed Qubes now on my Lenovo X1C, and so far, im really happy with it.
But of course, i do have some minor issues.

1: Maccchanger.

I wanted  to install the Macchanger,  and followed closely the  Instructions.
It all worked fine, the service is up, but its not changing the actual 
Macadress.
My Guess is, its not possible with the wifimodule of Lenovo?
So i tried to use the debian9 template ive installed instead, but i cant get an 
internetconnection with it, maybe debian is missing the hardware-driver?
if so, how do i get and install it in the terminal?(im sry, im pretty new to 
linux)
I know it works with the method using the Networkmanager, since if done it that 
way with this very same model under Ubuntu with a friends Computer.


This is the type of feature that requires integrated management; a 
collection of scripts and one-shot commands won't work properly. The 
best option is to use Network Manager 1.4.2 or later and turn on address 
randomization.



--

Chris Laprise, tas...@openmailbox.org
https://twitter.com/ttaskett
PGP: BEE2 20C5 356E 764A 73EB  4AB3 1DC4 D106 F07F 1886

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/4d1c73e2-fda0-cb99-59de-59c39bd94fa0%40openmailbox.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Maccchanger, debian9 template, Screensave

2017-05-27 Thread rob_66
Finsh:
> 1: Maccchanger.
> maybe debian is missing the hardware-driver?
> if so, how do i get and install it in the terminal?

Hi, Finsh.
I'm not an expert either, but the following worked for me on my –
different – machine:

In your macchanger-debian9-VM, let's call it 'spoofVM', you open a
terminal and perform this to get (above the output of my computer):

user@spoofVM:~$ lspci -knn
00:00.0 Network controller [0280]: Intel Corporation Wireless 7265
[8086:095a] (rev 59)
Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [8086:5100]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

If you're lucky, the iwlwifi package
(https://packages.debian.org/stretch/firmware-iwlwifi) contains your
network controller as well, and you follow the installation instructions
here: https://wiki.debian.org/iwlwifi (replace Debian 8 "Jessie" with
Debian 9 "Stretch")

If not, at least the prodedure should be clear.

> 3. Eyecandy
> Is there a possibility to customize the Xscreensaver wallpaper?

Did you already play around with 'System Tools > Screensaver' under the
white on blue 'Q'-menu (probably in the top left corner)?

Good luck and best regards,
rob

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/5b80cbb0-3cb0-ebc0-d8d6-ddc73ebcf633%40posteo.es.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Installed fine but doesn't boot.

2017-05-27 Thread mikihonzero
On Saturday, May 27, 2017 at 12:36:28 PM UTC+2, dgdfjhfjh...@gmail.com wrote:
> Installed from USB on brand new computer on an empty ssd m2. All went fine 
> but after reboot nothing happens and it enters the bios.
> From there I select to boot from the ssd but it does the same loop.
> 
> I read through:
> https://www.qubes-os.org/doc/uefi-troubleshooting/#f1
> 
> But I can't even get to the grub menu
> 
> 
> and if it's the problem further down "Boot device not recognized after 
> installing" I don't know how to get to those files and copy them when I can't 
> even get to a terminal.

You can enter a Qubes Rescue Mode via your installer USB Boot Menu. Maybe this 
problem ? :
https://github.com/QubesOS/qubes-issues/issues/2381

regards

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/27bf8607-03a7-427a-be67-74b0aded5b1f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Maccchanger, debian9 template, Screensave

2017-05-27 Thread Finsh
 
> 2. Thunderbird/G-chrome.
> 
> When im clicking on a link in thunderbird, it is opening it in Google chrome?
> I dont know how this is possible, i didnt add Google chrome to the selected 
> Applications in this particular VM (i only use non-OSS software in the 
> "untrusted" vm)

Please, forget about the Second Question.It was remarkable stupid, i didnt 
fully unterstand the use of the Templates untill now.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/62add285-db38-4396-809c-d7eed3c24e6c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Maccchanger, debian9 template, Screensave

2017-05-27 Thread Finsh
Hello,
ive installed Qubes now on my Lenovo X1C, and so far, im really happy with it.
But of course, i do have some minor issues.

1: Maccchanger.

I wanted  to install the Macchanger,  and followed closely the  Instructions.
It all worked fine, the service is up, but its not changing the actual 
Macadress.
My Guess is, its not possible with the wifimodule of Lenovo?
So i tried to use the debian9 template ive installed instead, but i cant get an 
internetconnection with it, maybe debian is missing the hardware-driver?
if so, how do i get and install it in the terminal?(im sry, im pretty new to 
linux)
I know it works with the method using the Networkmanager, since if done it that 
way with this very same model under Ubuntu with a friends Computer.

2. Thunderbird/G-chrome.

When im clicking on a link in thunderbird, it is opening it in Google chrome?
I dont know how this is possible, i didnt add Google chrome to the selected 
Applications in this particular VM (i only use non-OSS software in the 
"untrusted" vm)

3. Eyecandy

Is there a possibility to customize the Xscreensaver wallpaper? it looks really 
ugly.

hellp is much appreciated,

greetings from Germany 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/4333b34a-9632-46ef-952a-dc61a9289b46%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] HCL - Dell XPS 15 9560

2017-05-27 Thread Mike Keehan
On Fri, 26 May 2017 12:40:03 -0700 (PDT)
Alchemist  wrote:

> I just grabbed a new xps15 and the installer is falling back to text
> mode. I'm not sure why we're getting different results on the same
> computers. Anyone have any ideas? 
> 

Use EFI boot with the usb install stick, not legacy bios.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170527134054.1130cdb2.mike%40keehan.net.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Can't go pasts the grub menu

2017-05-27 Thread dgdfjhfjhgjhjhghfg
Figured this one out and posting the solution for anyone else.

After full shutdown and power on, all the partitions of the USB drive showed up 
in the bios. Then I just selected the specific partition instead of the drive 
in general and it went just fine after that.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/de01f465-c0e2-421b-9d91-6fbc62903729%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Installed fine but doesn't boot.

2017-05-27 Thread dgdfjhfjhgjhjhghfg
Installed from USB on brand new computer on an empty ssd m2. All went fine but 
after reboot nothing happens and it enters the bios.
>From there I select to boot from the ssd but it does the same loop.

I read through:
https://www.qubes-os.org/doc/uefi-troubleshooting/#f1

But I can't even get to the grub menu


and if it's the problem further down "Boot device not recognized after 
installing" I don't know how to get to those files and copy them when I can't 
even get to a terminal.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/70fe3b06-b40f-4217-a41b-40a572131d4e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Can't go pasts the grub menu

2017-05-27 Thread dgdfjhfjhgjhjhghfg
When I press on any of the 4 option (install quebes, test media and install 
quebes) something flashes for milisecond (cant read it) and the same screen 
with the 4 options appears. 


I tried the work around at:
https://www.qubes-os.org/doc/uefi-troubleshooting/#f1

not sure if did it right but doesn't work.
here is pic of it:
http://imgur.com/a/Jr37B



So I can't even start the install.

I'm trying on a brand new PC, with latest i7, modern MB and everything brand 
new and latest models.

Booting from USB 3.0

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/30d49388-c47f-40a1-ac31-a7a305183267%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] X.org failure preventing boot, Intel graphics

2017-05-27 Thread Vít Šesták
Are you able to connect the laptop via ethernet? If so, you might try something 
like?

1. Boot in rescue mode.
2. chroot
3. systemctl mask lightdm # this will prevent X from starting
4. Boot in Qubes (without X11)
5. Update kernel using qubes-dom0-update, ideally to the one from 
current-testing (e.g., qubes-dom0-update 
--enablerepo=qubes-dom0-current-testing kernel.

I am not 100% sure with the commands etc., I am writing them by heart.

Alternatively, you could try booting Qubes with kernel from Fedora 25. I don't 
recommend using it this way (Qubes adds some hardening for kernel), but it 
might be useful for booting in Qubes in order to install newer kernel from 
repositories.

Regards,
Vít Šesták 'v6ak'

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/49239c41-141d-4d87-bd40-c534cdcb2d74%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Booting USB Quebes across multiple machines?

2017-05-27 Thread Vít Šesták
I've asked some slightly similar question like a month ago. I was told I should 
run dracut without hostonly mode in order to have all the modules I need.

Your case is a bit harder. You would need to either run dracut after any kernel 
update (without this, it might make Qubes unbootable on other machines than the 
one you have updated it from) or reconfigure dracut (like edit something in 
/etc) if possible.

Regards,
Vít Šesták 'v6ak'

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ef0508a0-78b5-4369-857d-820650a4c618%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.