[qubes-users] Has anyone made Qubes 4.0-rc5 work with BCM43602 on MBP 13,2?

2018-03-21 Thread q120248681
Hi all, recently I'm trying to install Qubes on may MacBook, I can boot 
into the system, and avoid system freeze with the help of Greg's tips, see this 
thread: https://groups.google.com/forum/#!topic/qubes-users/r1JWkcqLNGs .
However, I now can't make the network controller work using the method 
mentioned in the thread above. I tried to run ""sudo xl pci-attach sys-net 
'02:00.0,permissive=1'", it seems to be successful but sys-net still don't have 
device attached, and therefore the network manager don't have device managed, 
using "qvm-pci attach" still causes a system freeze, has anyone ever solved 
this problem?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/4bf59d7c-f27a-4828-bff5-98a408f4325e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
On Wednesday, March 21, 2018 at 2:37:45 PM UTC-4, Unman wrote:
> On Wed, Mar 21, 2018 at 09:34:51AM -0700, cooloutac wrote:
> > I'm trying to figure out when UMAN became very active here.  If it was 2 
> > years ago I'm fkn ghost.   Qubes is done...
> > 
> 
> If you look back you'll see I infiltrated the project 3 years ago.
> 
> Started using Qubes 7 years ago - sleeper for 4 years and activated by
> my handler after 4 years. Oops, probably shouldn't have said that.

3 years ago, not two.  hmm  Maybe it took you a year...  Whoever your handler 
is made a big mistake.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/e439db68-c1b0-4f27-bd61-92306f4dfc90%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
On Wednesday, March 21, 2018 at 2:29:29 PM UTC-4, Unman wrote:
> On Wed, Mar 21, 2018 at 09:27:15AM -0700, cooloutac wrote:
> > maybe simply sudo mount -o remount,size=5000M /tmp  will work.  I'll try it 
> > when I get a chance to use the qubes machine.  But I think the problem is I 
> > need to increase the whole system storage.  And Uman is refusing to tell me 
> > how.  The qubes instructions dont' give detailed instructions.  they just 
> > give the qvm-grow-root command.
> 
> If you're using a Template based appVM then you need to resize the
> root.img of the Template - that's what the error message tells you if
> you use qvm-grow-root on such a qube.
> You'll need to resize the template and shut it down and then restart the
> qube to see the new size.
> 
> That command you've cited will work for resizing /tmp and /dev/shm.
> 
> 
> > 
> > I find it strange uman asks me what I mean by system storage and  Asks me 
> > if I'm using root user lol  wtf...
> > 
> 
> I didn't ask if you were using root to run the download. Obviously I should 
> have
> done.

As I've said I already did this.  and restarted the template.  and saw no 
change.

And why would I use root user? You did ask me this and what does that even mean 
there is no root in qubes appvm??

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/2938f7a8-fd12-49ad-a8a2-e54503009d31%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
On Wednesday, March 21, 2018 at 2:06:01 PM UTC-4, Unman wrote:
> On Wed, Mar 21, 2018 at 08:34:31AM -0700, cooloutac wrote:
> > On Wednesday, March 21, 2018 at 9:23:38 AM UTC-4, Unman wrote:
> > > On Tue, Mar 20, 2018 at 08:14:33PM -0700, cooloutac wrote:
> > > > On Tuesday, March 20, 2018 at 11:10:52 AM UTC-4, Unman wrote:
> > > > > On Mon, Mar 19, 2018 at 05:00:05PM -0700, cooloutac wrote:
> > > > > > Can't download qubes 4.0 not enough space.  tried to raise system 
> > > > > > storage size on template through qubes manager.  messag said I 
> > > > > > might have use resize2f.   tried that didn't do antyhing.   Tried 
> > > > > > to use qvm-grow-root  it staid to start template to complete 
> > > > > > process but it also didn't change.
> > > > > > 
> > > > > >in vm settings it shows the size I specified,  but when running 
> > > > > > nautlius and looking at the space or doing df -h it is still only 
> > > > > > 4.3gb out of 10.5 available.
> > > > > >   I've never downloaded a file this large in qubes so never ran 
> > > > > > into this problem. Only thing I ever had to increase was private 
> > > > > > storage.  I have this issue with all templates.
> > > > > >  
> > > > > > Qubes 3.2 iso must be under the limit so I was able to download 
> > > > > > that iso but can't donload 4.0 it is too large and fails to 
> > > > > > download.
> > > > > > 
> > > > > > 
> > > > > > Is there any detailed step by step instructions because I'm 
> > > > > > obviously doing something wrong?
> > > > > > 
> > > > > > Ty for the help.
> > > > > > 
> > > > > > Rich.
> > > > > > 
> > > > > 
> > > > > Rich,  can you confirm you're using 3.2?
> > > > > 
> > > > > How are you downloading the iso?
> > > > > Are you doing this as root or user?
> > > > > Where are you trying to download it to?
> > > > > 
> > > > > As you have enough space in /home my guess is that you are using /tmp
> > > > > or /dev/shm 
> > > > > If you run df in the qube you're using WHILE the download is running,
> > > > > you should see the free space moving down as the download progresses.
> > > > > Can you check this and report back?
> > > > 
> > > > Yes i'm definitely using 3.2.  
> > > > 
> > > >   it starts off as 4.3 or 4.7 available I believe available out of 
> > > > 10.5gb.  no matter what I set private storage to. its the system 
> > > > storage.I remember marek showing how to increase the temp file 
> > > > storage size when having a diff issue a few qubes versions ago,  when I 
> > > > use to have the issue of playing long video streams cutting off using 
> > > > fedora.  I forget how maybe similar issue here? But it doesn't matter 
> > > > which appvm or template I use. 
> > > > 
> > > > and yes i can see the available space slowly doing down as downloading. 
> > > > using df-h or just watching in file manager.
> > > > 
> > > > I'm trying to download the iso from any vm,  using any template.  
> > > > loading firefox or google chrome and clicking on the iso.  they all 
> > > > have the same problem.   I'd really have ot hate to use some other 
> > > > operating system just to download 4.0,  almost seems like a joke on 
> > > > qubes users, that the extra  100mb's puts me over the top and it fails 
> > > > to download lol.
> > > > 
> > > > I mean I do have media qubes with 100s of gbs of data in there.  But 
> > > > they were copied to vms from usb devices and I did have to increase 
> > > > private storage size.  this seems to be a diff issue.
> > > > 
> > > 
> > > I'm a little confused by what you are saying - what does "its the system
> > > storage" mean?
> > > Can you post the output from 'df -h ', and also what value you have set 
> > > the
> > > private storage to .
> > > 
> > > I recommend that you use a single qube for this, rather thsan trying
> > > many templates and many qubes. It will really help with troubleshooting
> > > your problem.
> > > So please say also what template you are using and whether you are using
> > > testing repos.
> > 
> > when you download a file from the internet using a browser it uses temp 
> > storage.  Can you tell me how to increase it please!?!?!   I can't fine 
> > Mareks old post telling me how to do it from the commandline in the past.   
> > The bug I used to have when playing long streams was fixed.   But Now 
> > apparently a similar problem is back when Trying to download this 4.0 iso.
> 
> Using a Debian-9 template, firefox downloads to ~/Downloads. It doesnt
> touch temporary storage. But you can change this under Preferences.
> 
> To increase the size of /tmp or /dev/shm:
> sudo mount -o remount,size=4096M /dev/shm
> 
> Alternatively, create a directory under /:
> sudo mkdir /down
> sudo chown user:user /down
> 
> And set that as target for Downloads in user preferences.
> 
> 
> > 
> > I could never stand your posts on this "forum",  and if you are the main 
> > dev on this project now it might be time to abandon Qubes-os.
> > 
> 
> I'm not

ya thats what I thought, haven't got a 

[qubes-users] Re: Bitmask installation problem

2018-03-21 Thread abilgili950
On Monday, March 19, 2018 at 4:32:09 AM UTC-4, niepo...@gmail.com wrote:
> Hello,
> 
> I'm trying make set up vpn with bitmask application.
> 
> I tried install bitmask to debian template.
> 
>  have done steps listed on bitmask site as below in termainal:
> 
> sudo apt install leap-archive-keyring
> sudo sh -c 'echo "deb http://deb.leap.se/client release stretch" > 
> /etc/apt/sources.list.d/bitmask.list'
> sudo apt update && sudo apt install bitmask
> 
> But there is info as below
> 
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  bitmask : Depends: bitmask-core but it is not going to be installed
>Depends: bitmask-qt but it is not going to be installed
>Depends: bitmask-vpn but it is not going to be installed
>Depends: bitmask-mail but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> 
> How can I resolve this problem? Any advices?

You should look into these two guides for VPN on Qubes : 

Basic one : 
https://www.youtube.com/watch?v=wYEmDZebow4

Pro one : 
https://www.youtube.com/watch?v=K1_zqT7_N7k

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/3bb679b1-ab7f-4b69-8c2c-3f33546378dc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] HCL report for Lenovo ThinkPad T520 4240-4HG

2018-03-21 Thread yrebstv
Jan Hustak  

Feb 6

Hello, 

See attached. Regarding BIOS settings mentioned in "remark": the 
combination of both VT-d and Discrete Graphics being ON causes the 
installer to freeze. If configured post-install, it causes the OS to 
freeze while booting. 

Turning VT-d OFF allows for installation (with warning) but breaks 
networking and who knows what else. As the remark states, the proper 
configuration is VT-d ON and Discrete Graphics OFF. 

jh 


-


Hello, per 
https://groups.google.com/forum/#!msg/qubes-users/TB0r0Qv0yhc/l4e1tsCBAQAJ

I am attempting to install Q4.0 rc5 from a USB drive on a Thinkpad T520
4240-4AU  UEFI BIOS Version 8AET62WW (1.42) 

I note from the HCL Mr.Jan , says to disable "discrete graphics"  (I did
enable VT-d) , If I go to  Config -> Display , there is no reference to
"discrete graphics" it offers 1 option on Boot Display Device  "thinkpad
LCD", Analog VGA , etc 

Further, I have chosen  "UEFI only"  in the Startup-> UEFI/Legacy Boot  
choice  AND
I see no "secure boot" anywhere to disable. 

NOW when I boot off the USB Drive I see the line of penguins and then 
probably all the  loading information  BUT, it is all in warped and
unreadable .  So , I tried Legacy Mode, and it just stops @ a "
failed to load ldlinux.c32"   etc 


I , also , am aware of :
https://www.qubes-os.org/doc/thinkpad-troubleshooting/

but, again there is no "secure boot" option to disable ;  this  USB
stick  *Was  created  with dd if of  ; but the URL doesn't specifically 
reference the T520 .. and the solution looks quite involved 
.. is this my only choice at this stage ?

or is there some "discrete graphics"  to disable that I can't find  ?? 

the HCL Bios version  Mr. Jan  references for 4.0  is  8AET51WW (1.31 ) 
, if anything mine seems to be slightly newer and  should it  have
"discrete graphics" to disable ?


with the graphics messed up,  don't think I can't get to the Intel
HD3000 reference, that seems to be something to be done after
installation in any event?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/2670eccedd8ccadd1d4314e6549d7ae3%40riseup.net.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] HCL - Dell Inspiron 5420

2018-03-21 Thread Manuel Nuñez

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/1521678342.1344.0%40smtp.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Qubes-HCL-Dell_Inc__-Inspiron_5420-20180321-211752.yml
Description: application/yaml


Re: [qubes-users] Re: [Q4-rc5] Custom VPN/ProxyVM problem. Please, help

2018-03-21 Thread Chris Laprise

On 03/21/2018 03:13 PM, Zrubi wrote:

-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On 03/21/2018 04:56 PM, evastar via qubes-users wrote:

I do another research. After clean reboot I tried to change
"networking"-vm to another one for my AppVM-client from Qube
Manager. Without success. After I do this I loss my network at
App-client and I do not know how to fix it, because if I manually
change "networking"-vm again to the first one I still not have
network. Only reboot of AppVM-client helps.


Seems you are hit by this bug:
https://github.com/QubesOS/qubes-issues/issues/3657

please check your kernels, and report back.
Thanks.


I'm using R4.0rc5 and kernel 4.14.18. What I experience is that my VPN 
or other proxyVMs will stay running all day, but I can't live switch the 
netvm setting for any VMs or else networking for them will be blocked.


On the outside chance evastar's problem is triggered by a VPN 
disconnection issue, you could try adding a ping timeout directive like 
"keepalive 10 41" (for openvpn) to see if that helps.



--

Chris Laprise, tas...@posteo.net
https://github.com/tasket
https://twitter.com/ttaskett
PGP: BEE2 20C5 356E 764A 73EB  4AB3 1DC4 D106 F07F 1886

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/61849c14-320d-837d-597c-7a80afa9e7e1%40posteo.net.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Can't get qvm-run to work

2018-03-21 Thread Patrick Bouldin
Thank you all, working now. :)

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/50a61b6a-55da-465c-b1da-5fb264bc5d35%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Re: [Q4-rc5] Custom VPN/ProxyVM problem. Please, help

2018-03-21 Thread Zrubi
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On 03/21/2018 04:56 PM, evastar via qubes-users wrote:
> I do another research. After clean reboot I tried to change 
> "networking"-vm to another one for my AppVM-client from Qube
> Manager. Without success. After I do this I loss my network at
> App-client and I do not know how to fix it, because if I manually
> change "networking"-vm again to the first one I still not have
> network. Only reboot of AppVM-client helps.

Seems you are hit by this bug:
https://github.com/QubesOS/qubes-issues/issues/3657

please check your kernels, and report back.
Thanks.

- -- 
Zrubi
-BEGIN PGP SIGNATURE-

iQIzBAEBCAAdFiEEw39Thm3rBIO+xeXXGjNaC1SPN2QFAlqyrtoACgkQGjNaC1SP
N2SwQA/+ML/cbUQM8LxwbPaNvUgo2wotTBmK90aKe7oBnCH3HXpYk5odi8Sr9VZ4
h/96rHwg1SAfki0tuau2kwl3Qsmy1CZtLcaeAqwXOI55ASGPZSi3nTBK8yx7a76q
SUBasuUf65t/VthTzOyWTjlQsmtOog4/27n9L0z5reN6LULqDt635pM+IDzCWe2W
Mcc6p+4tfx3tCjDfso4KWJ/g6HMKb/QgxkSElX1/wgrs1myAJOiBibbKfnUzI6/7
4L1LjXyFNJYNZ+cumhxjSG9/EWHS0Zkta/oS0H1zktiuQpIRIwbPsONjbHNSlDc7
pGP2fFuzaFOyjmYjck0F+prfgDQzWKVAh+sUVGWqJcWSh8sZK5vmemm5T4Sm6fk+
a+IysIItEfTGyaGxdZVXN6bEj69kvQi50PU4vtYS7jwcFmOZxoWVmF9n9BrPF78y
SYN5+ZfqNsc6EKIOakZLq36fqGW3tk7bD6PuVeLgiV58C9YGFoZc6QdwBZm+XvnH
VAN6+s1JY1nQRWEEzc7Q7F0NDB96HpbzNMd4FAtJlBuzyZQLE0UFvgpvB57DY5kr
3piSBo75I+2nemF8By3KkSdfUp/QFOUb7ZhfD3aXPg0vL9PYm6itXz4l+UZGA7sM
JIeu5n/dcw8uf4jjSSVtH+i2JMU2TujpvoiLp9IsT5haqeFlaiQ=
=GI08
-END PGP SIGNATURE-

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ba956ed6-4429-b3dc-f36a-0f7fce76800c%40zrubi.hu.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Can't get qvm-run to work

2018-03-21 Thread 'awokd' via qubes-users
On Wed, March 21, 2018 6:44 pm, Unman wrote:
> On Wed, Mar 21, 2018 at 11:37:59AM -0700, Patrick Bouldin wrote:
>
>> Hello,
>>
>>
>> I'm simply trying to copy a file to dom0 form work  ~/Downloads/
>>
>>
>> Can someone please tell me the precise letters to use if the filename
>> was qvm-screenshot-to-clipboard.sh and I want to put it in dom0
>> ~/Downloads/
>>
>>
>> Here is the instruction in the manual:
>> qvm-run --pass-io  'cat /path/to/file_in_src_domain' >
>> /path/to/file_name_in_dom0
>>
>>
>> I get permission denied and tried sudo, etc.
>>
>>
>> Thought it would be:
>>
>>
>> qvm-run --pass-io work ~/Downloads/qvm-screenshot-to-clipboard.sh >
>> /home/mandoguy/qvm-screenshot-to-clipboard.sh
>>
>>
>>
>> Wish the documentation had real examples.
>>
>>
>> Thanks,
>> Patrick
>>
>>
>
>
> Check the permissions on ~/Downloads and
> /home/mandoguy/qvm-screenshot-to-clipboard.sh in the work qube.
>
>
> Try:
> qvm-run --pass-io work 'cat
> /home/mandoguy/qvm-screenshot-to-clipboard.sh'>
> /home/user/Downloads/qvm-screenshot-to-clipboard.sh
>
>
> If necessary you can use qvm-run -u root

I forgot the "cat", probably because of UMAN's satellite mind control
system. I think the arguments might be backwards above, though. Try:

qvm-run --pass-io work
'cat /home/user/Downloads/qvm-screenshot-to-clipboard.sh' >
/home/mandoguy/qvm-screenshot-to-clipboard.sh


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c957708a7ebae3e7709a1016ce9457af.squirrel%40tt3j2x4k5ycaa5zt.onion.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes 4.0-rc5 Some issues

2018-03-21 Thread 'awokd' via qubes-users
On Wed, March 21, 2018 1:41 pm, evastar via qubes-users wrote:
> Sorry, I tried other usd drive with NTFS and ExFAT and no results! It
> does not mound automatically and I do not know how to mount all this
> drives. The problem not only with usb drive, but also with HDD. Maybe my
> template lack some driver that support NTFS? Hot to check his? I guess
> it's possible, because current fedora-26 image from rc5 come without
> 'nano'...
> How to check this and fix this issue :
> Thanks!

Thought fedora-26 had native NTFS support but you could try debian-9
instead. In either case, are you following the steps here?
https://www.qubes-os.org/doc/usb/#r40

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/35dcde85f03395efb479d5f737cb4055.squirrel%40tt3j2x4k5ycaa5zt.onion.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Can't get qvm-run to work

2018-03-21 Thread Unman
On Wed, Mar 21, 2018 at 11:37:59AM -0700, Patrick Bouldin wrote:
> Hello,
> 
> I'm simply trying to copy a file to dom0 form work  ~/Downloads/
> 
> Can someone please tell me the precise letters to use if the filename was 
> qvm-screenshot-to-clipboard.sh and I want to put it in dom0 ~/Downloads/
> 
> Here is the instruction in the manual:
> qvm-run --pass-io  'cat /path/to/file_in_src_domain' > 
> /path/to/file_name_in_dom0
> 
> I get permission denied and tried sudo, etc.
> 
> Thought it would be:
> 
> qvm-run --pass-io work ~/Downloads/qvm-screenshot-to-clipboard.sh > 
> /home/mandoguy/qvm-screenshot-to-clipboard.sh
> 
> 
> Wish the documentation had real examples.
> 
> Thanks,
> Patrick
> 


Check the permissions on ~/Downloads and
/home/mandoguy/qvm-screenshot-to-clipboard.sh in the work qube.

Try:
qvm-run --pass-io work 'cat /home/mandoguy/qvm-screenshot-to-clipboard.sh'> 
/home/user/Downloads/qvm-screenshot-to-clipboard.sh

If necessary you can use qvm-run -u root 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20180321184426.n7bufmyphxdn3ujd%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Can't get qvm-run to work

2018-03-21 Thread 'awokd' via qubes-users
On Wed, March 21, 2018 6:37 pm, Patrick Bouldin wrote:

> I get permission denied and tried sudo, etc.

> qvm-run --pass-io work ~/Downloads/qvm-screenshot-to-clipboard.sh >
> /home/mandoguy/qvm-screenshot-to-clipboard.sh

Try:

qvm-run --pass-io work
'/home/user/Downloads/qvm-screenshot-to-clipboard.sh' >
/home/mandoguy/qvm-screenshot-to-clipboard.sh

Note- the single quotes are important, and manually expand ~ like I've done.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/bb723875c2326587ef862ea24064df99.squirrel%40tt3j2x4k5ycaa5zt.onion.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread Unman
On Wed, Mar 21, 2018 at 09:34:51AM -0700, cooloutac wrote:
> I'm trying to figure out when UMAN became very active here.  If it was 2 
> years ago I'm fkn ghost.   Qubes is done...
> 

If you look back you'll see I infiltrated the project 3 years ago.

Started using Qubes 7 years ago - sleeper for 4 years and activated by
my handler after 4 years. Oops, probably shouldn't have said that.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20180321183743.s7bsvsogdsdbbssd%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Can't get qvm-run to work

2018-03-21 Thread Patrick Bouldin
Hello,

I'm simply trying to copy a file to dom0 form work  ~/Downloads/

Can someone please tell me the precise letters to use if the filename was 
qvm-screenshot-to-clipboard.sh and I want to put it in dom0 ~/Downloads/

Here is the instruction in the manual:
qvm-run --pass-io  'cat /path/to/file_in_src_domain' > 
/path/to/file_name_in_dom0

I get permission denied and tried sudo, etc.

Thought it would be:

qvm-run --pass-io work ~/Downloads/qvm-screenshot-to-clipboard.sh > 
/home/mandoguy/qvm-screenshot-to-clipboard.sh


Wish the documentation had real examples.

Thanks,
Patrick

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/39057950-b062-4fff-9e92-3717a2df5673%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Issues with Yubikey 4 input

2018-03-21 Thread Jon R.
Just a brief update on this -- I snagged a few Yubikey FIDO specific
devices and they seem to work fine and as you'd expect. The issue seems to
be isolated to the Yubikey 4 / the ones that support smart card features /
things of that nature.

Color me confused.

On Mon, Mar 19, 2018 at 12:17 AM, Jon R.  wrote:

> > Looks like the X server in target VM cannot access the device. See
> > ~/.local/share/xorg/X.0.log there for lines like this:
> >
> >[247082.612] (EE) xf86OpenSerial: Cannot open device /dev/input/event1
> >Permission denied.
> >[247082.612] (II) event1: opening input device '/dev/input/event1'
> failed (Permission denied).
> >[247082.612] (II) event1  - failed to create input device
> '/dev/input/event1'.
>
> > In Fedora there is "ykpers" package, which ships appropriate udev rules
> > to fix permissions.
>
> This doesn't appear to be the issued. The only relevant messages I'm
> seeing in both the sys-usb VM & the one I'm attaching it to (personal in
> this case) is the following:
>
> > [   684.323] (II) config/udev: Adding input device Yubico Yubikey 4
> OTP+CCID (/dev/input/event8)
> > [   684.323] (II) No input driver specified, ignoring this device.
> > [   684.323] (II) This device may have been added with another device
> file.
>
> This appears in the sys-usb ~/.local/xorg/Xorg.0.log upon plugging in the
> Yubikey however the Yubikey functions as usual. When attaching the device
> to another VM the local ~/.local/xorg/Xorg.0.log shows the same message as
> above however it does not work.
>
> Just to remove the udev rules being the potential culprit I added both
> ykpers / ykpers-devel to the fedora template and rebooted. The same
> behavior persists.
>
> On Sun, Mar 18, 2018 at 11:43 AM, Marek Marczykowski-Górecki <
> marma...@invisiblethingslab.com> wrote:
>
>> -BEGIN PGP SIGNED MESSAGE-
>> Hash: SHA256
>>
>> On Fri, Mar 09, 2018 at 12:34:02PM -0500, Jon R. wrote:
>> > Hello,
>> >
>> > I've scoured around the mailing lists / SO / Reddit and haven't come
>> across
>> > a solution to this yet. I'm running 4.0 (R4.0) and when I attempt to
>> use my
>> > Yubikey it's seemingly not picking up any input on the button press.
>> >
>> > It's detecting the USB properly and I can attach it fine:
>> >
>> > [cloe@dom0 Desktop]$ qvm-usb
>> > BACKEND:DEVID  DESCRIPTION USED BY
>> > sys-usb:2-1Yubico_Yubikey_4_OTP+CCID
>> >
>> > [cloe@dom0 Desktop]$ qvm-usb attach work sys-usb:2-1
>> >
>> > [cloe@dom0 Desktop]$ qvm-usb
>> > BACKEND:DEVID  DESCRIPTION USED BY
>> > sys-usb:2-1Yubico_Yubikey_4_OTP+CCID   work
>> >
>> > However upon button presses on the Yubikey in the "work" domain there
>> is no
>> > action. I've tested this in gedit, the terminal and elsewhere to no
>> avail.
>> >
>> > Can someone point me in the right direction as to what may be happening?
>> > I've successfully attached storage devices and other smart card related
>> > devices without any issue so it seems to be isolated to the Yubikey
>> itself.
>> > I've tried 2 separate Yubikey 4's and an older version to no avail.
>>
>> Looks like the X server in target VM cannot access the device. See
>> ~/.local/share/xorg/X.0.log there for lines like this:
>>
>> [247082.612] (EE) xf86OpenSerial: Cannot open device /dev/input/event1
>> Permission denied.
>> [247082.612] (II) event1: opening input device '/dev/input/event1'
>> failed (Permission denied).
>> [247082.612] (II) event1  - failed to create input device
>> '/dev/input/event1'.
>>
>> In Fedora there is "ykpers" package, which ships appropriate udev rules
>> to fix permissions.
>>
>> - --
>> Best Regards,
>> Marek Marczykowski-Górecki
>> Invisible Things Lab
>> A: Because it messes up the order in which people normally read text.
>> Q: Why is top-posting such a bad thing?
>> -BEGIN PGP SIGNATURE-
>>
>> iQEzBAEBCAAdFiEEhrpukzGPukRmQqkK24/THMrX1ywFAlqoECkACgkQ24/THMrX
>> 1ywKfgf/VZgu5vIHC0sNztwJU6+8nZ23LaBtoEAceGdN3v9GZCkVY0kFDQ6jDhKO
>> Jzp3wVPNM2XopNXmo+5mCgheL6nFGEQZfv6yB4MSwAUqqzcKxXy3eBkxAvAHfr3F
>> g0H/lEYLLQImuoaEgz0RfQZUwxz3VKItakj2S6tqUfDzUvprFTo1Gvhv/xT1wp+6
>> OcfK953ID4pl1DTBdf18DOQcTFIxWplGpHBEScJVjFVrtVtxlW72c/kJvliEl7uh
>> EQjGtCM3MHNL4GC2x8+n5aWrfva9tiEqVXlubvo/ReFbCtpqISxJI8TQkCi1IC8g
>> pAbBb8scoDJ9ik97GjvhMfoDuXwZvw==
>> =Ut6d
>> -END PGP SIGNATURE-
>>
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAJd29SRBY5M0Ut%3Dvz6HMuCn1%3Dj92%2B67P35q8G15%3DPnNZUXj1gA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread Unman
On Wed, Mar 21, 2018 at 09:27:15AM -0700, cooloutac wrote:
> maybe simply sudo mount -o remount,size=5000M /tmp  will work.  I'll try it 
> when I get a chance to use the qubes machine.  But I think the problem is I 
> need to increase the whole system storage.  And Uman is refusing to tell me 
> how.  The qubes instructions dont' give detailed instructions.  they just 
> give the qvm-grow-root command.

If you're using a Template based appVM then you need to resize the
root.img of the Template - that's what the error message tells you if
you use qvm-grow-root on such a qube.
You'll need to resize the template and shut it down and then restart the
qube to see the new size.

That command you've cited will work for resizing /tmp and /dev/shm.


> 
> I find it strange uman asks me what I mean by system storage and  Asks me if 
> I'm using root user lol  wtf...
> 

I didn't ask if you were using root to run the download. Obviously I should have
done.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20180321182926.2ztyuprrucpfcwex%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread Unman
On Wed, Mar 21, 2018 at 08:34:31AM -0700, cooloutac wrote:
> On Wednesday, March 21, 2018 at 9:23:38 AM UTC-4, Unman wrote:
> > On Tue, Mar 20, 2018 at 08:14:33PM -0700, cooloutac wrote:
> > > On Tuesday, March 20, 2018 at 11:10:52 AM UTC-4, Unman wrote:
> > > > On Mon, Mar 19, 2018 at 05:00:05PM -0700, cooloutac wrote:
> > > > > Can't download qubes 4.0 not enough space.  tried to raise system 
> > > > > storage size on template through qubes manager.  messag said I might 
> > > > > have use resize2f.   tried that didn't do antyhing.   Tried to use 
> > > > > qvm-grow-root  it staid to start template to complete process but it 
> > > > > also didn't change.
> > > > > 
> > > > >in vm settings it shows the size I specified,  but when running 
> > > > > nautlius and looking at the space or doing df -h it is still only 
> > > > > 4.3gb out of 10.5 available.
> > > > >   I've never downloaded a file this large in qubes so never ran into 
> > > > > this problem. Only thing I ever had to increase was private storage.  
> > > > > I have this issue with all templates.
> > > > >  
> > > > > Qubes 3.2 iso must be under the limit so I was able to download that 
> > > > > iso but can't donload 4.0 it is too large and fails to download.
> > > > > 
> > > > > 
> > > > > Is there any detailed step by step instructions because I'm obviously 
> > > > > doing something wrong?
> > > > > 
> > > > > Ty for the help.
> > > > > 
> > > > > Rich.
> > > > > 
> > > > 
> > > > Rich,  can you confirm you're using 3.2?
> > > > 
> > > > How are you downloading the iso?
> > > > Are you doing this as root or user?
> > > > Where are you trying to download it to?
> > > > 
> > > > As you have enough space in /home my guess is that you are using /tmp
> > > > or /dev/shm 
> > > > If you run df in the qube you're using WHILE the download is running,
> > > > you should see the free space moving down as the download progresses.
> > > > Can you check this and report back?
> > > 
> > > Yes i'm definitely using 3.2.  
> > > 
> > >   it starts off as 4.3 or 4.7 available I believe available out of 
> > > 10.5gb.  no matter what I set private storage to. its the system storage. 
> > >I remember marek showing how to increase the temp file storage size 
> > > when having a diff issue a few qubes versions ago,  when I use to have 
> > > the issue of playing long video streams cutting off using fedora.  I 
> > > forget how maybe similar issue here? But it doesn't matter which appvm or 
> > > template I use. 
> > > 
> > > and yes i can see the available space slowly doing down as downloading. 
> > > using df-h or just watching in file manager.
> > > 
> > > I'm trying to download the iso from any vm,  using any template.  loading 
> > > firefox or google chrome and clicking on the iso.  they all have the same 
> > > problem.   I'd really have ot hate to use some other operating system 
> > > just to download 4.0,  almost seems like a joke on qubes users, that the 
> > > extra  100mb's puts me over the top and it fails to download lol.
> > > 
> > > I mean I do have media qubes with 100s of gbs of data in there.  But they 
> > > were copied to vms from usb devices and I did have to increase private 
> > > storage size.  this seems to be a diff issue.
> > > 
> > 
> > I'm a little confused by what you are saying - what does "its the system
> > storage" mean?
> > Can you post the output from 'df -h ', and also what value you have set the
> > private storage to .
> > 
> > I recommend that you use a single qube for this, rather thsan trying
> > many templates and many qubes. It will really help with troubleshooting
> > your problem.
> > So please say also what template you are using and whether you are using
> > testing repos.
> 
> when you download a file from the internet using a browser it uses temp 
> storage.  Can you tell me how to increase it please!?!?!   I can't fine 
> Mareks old post telling me how to do it from the commandline in the past.   
> The bug I used to have when playing long streams was fixed.   But Now 
> apparently a similar problem is back when Trying to download this 4.0 iso.

Using a Debian-9 template, firefox downloads to ~/Downloads. It doesnt
touch temporary storage. But you can change this under Preferences.

To increase the size of /tmp or /dev/shm:
sudo mount -o remount,size=4096M /dev/shm

Alternatively, create a directory under /:
sudo mkdir /down
sudo chown user:user /down

And set that as target for Downloads in user preferences.


> 
> I could never stand your posts on this "forum",  and if you are the main dev 
> on this project now it might be time to abandon Qubes-os.
> 

I'm not

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 

[qubes-users] Re: HP Folio 1040 i7

2018-03-21 Thread Linus Stridbeck
Den tisdag 20 mars 2018 kl. 15:29:39 UTC+1 skrev Yuraeitha:
> On Tuesday, March 20, 2018 at 10:00:27 AM UTC+1, Linus Stridbeck wrote:
> > hi, I just wanted to take the opportunity to see if some one used qubes on 
> > HP Folio 1040 i7? its a elitebook essentielly but its noton the 
> > compatibility list.
> 
> Many report their laptop to the HCL list, so it might not be likely to find 
> anyone having it here if it's not on the HCL list, especially not on a short 
> notice. 
> 
> Perhaps the better question to ask if others think it's a good idea to go for 
> this laptop, for Qubes use-cases. As such you can post your use-case needs, 
> your security needs (do you have reasons to put in extra hard security 
> efforts?), as well as mentioning which generation of HP Folio 1040 i7 you're 
> talking about, as far as I can see there are gen1, gen2, and gen3. Which 
> specs variant are you looking at as well? One has more RAM than the other, 
> etc. 
> 
> Even the cheapest model of the HP Folio 1040 i7 series, found on amazon.uk.co 
> seems to go at roughly 700 pounds. That's super expensive for the poor 
> performance this machine gives. Nevermind security concerns in hardware, it's 
> a redicouless price to pay for this sloppy performance. So it's a good thing 
> you asked before buying it.
> 
> gen 1 CPU benchmark
> https://www.cpubenchmark.net/cpu.php?cpu=Intel+Core+i7-4650U+%40+1.70GHz=1955
> 
> gen 2 CPU benchmark
> https://www.cpubenchmark.net/cpu.php?cpu=Intel+Core+i7-5600U+%40+2.60GHz=2456
> 
> In comparison, but not nessicarily a buying recommendation (This is purely to 
> show you the difference).
> https://www.amazon.co.uk/HP-15-bq150na-15-6-inch-Touchscreen-Resolution/dp/B07BBLZ5WR/ref=sr_1_fkmr0_1?ie=UTF8=152193=8-1-fkmr0=360+x+envy+ryzen
> 
> and it's CPU benchmarks 
> https://www.cpubenchmark.net/cpu.php?cpu=AMD+Ryzen+5+2500U=3123
> 
> This is a ryzen apu though, it's still mostly untested with kernel and Qubes, 
> but you can find intel equivalents in performance/price ratio as they are 
> competing. Some Ryzen works with kernel/Qubes, but i.e. the desktop 
> motherboard AB350 Pro4 with Ryzen 3 1200 can run Qubes, but it's not perfect. 
> I do not have any Ryzen experience beyond that model, so I won't recommend it 
> either, especially not when Ryzen mobile is so new as it is now. In general 
> though, this is not a buying recommendation, but to shake you up a bit when 
> comparing performance/price ratios.
> 
> What Intel bets a lot on is to cheat the customers who don't know where to 
> look, essentially making people buy more for less, by heavily segmenting the 
> market, confusing people as to what is better value and what is crap value. 
> Thereby overall more people buy less value for more money, and Intel isn't 
> doing anything illegal, and if customers don't realize, then they can live 
> happy ever after, that much richer profiting on people's lack of knowledge on 
> computer hardware.
> 
> Also considering you're up there in the price range already, you might want 
> to look for a laptop which either has 16GB+ RAM pre-installed, or allows for 
> 16GB+ RAM in the future (i.e. check if its upgrade-able). Running Qubes on 
> 8GB can work just fine, but 16GB really does make a difference in comfort, so 
> you don't need to shut down other VM's as much to make space for other VM's 
> to run.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/98b9bf33-2599-4c44-91cb-d9cee6712d6f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: HP Folio 1040 i7

2018-03-21 Thread Linus Stridbeck
Dose grafikcard (ryzen for instance) matter for seperating difrent WM? Im some 
what suprised by this. 
To be hones im not sure what security features I nead as long as the the WM as 
well as whonix works, the VM are properly seperated, encryption works, and 
fireware is as at leas as hard to get in as Qubes alows. Im not sure if the 
computer matters for the last Point or dose it? Or will this protection aginst 
hacking the firewar that Qubes provides work on an any computer on the list at 
least?


I had no ider that the HP Folio had sutch low preformance! Apparently i5 can be 
better than i7! Im might acturly have bought one for Windows.

I have bin considering geting a more expensive computer (since I need a new one 
any way)such as HP Folio and using two separate hard drives one with windows 
and one with Qubes and that way geting more value. But now as I have learned 
more I have reconsidered so at this Point I plan on getting a less expensive 
compute for qubes only.

A this Point Im leaning towards HP Elitebook 2170p with i7 and its one the list 
as well so guse it will work. It only has 4 gigabyte of ram however but it 
seams to be very easy to upgrade all Elite Books any way.


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/5842fc16-5a22-46fe-9742-ac88cfc39c73%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: HP Folio 1040 i7

2018-03-21 Thread Linus Stridbeck
Dose grafikcard (ryzen for instance) matter for seperating difrent WM? Im some 
what suprised by this. 

To be hones im not sure what security features I nead as long as the the WM as 
well as whonix works, the VM are properly seperated, encryption works, and 
fireware is as at leas as hard to get in as Qubes alows. Im not sure if the 
computer matters for the last Point or dose it? Or will this protection aginst 
hacking the firewar that quotes provides work on an any computer on the list at 
least?


I had no ider that the HP Folio had sutch low preformance! Apparently i5 can be 
better than i7! Im might acturly have bought one for Windows.

I have bin considering geting a more expensive computer (since I need a new one 
any way)such as HP Folio and using two separate hard drives one with windows 
and one with Qubes and that way geting more value. But now as I have learned 
more I have reconsidered so at this Point I plan on getting a less expensive 
compute for qubes only.

A this Point Im leaning towards HP Elitebook 2170p with i7 and its one the list 
as well so guse it will work. It only has 4 gigabyte of ram however but it 
seams to be very easy to upgrade all Elite Books any way.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ed1bcf6f-28c9-43fe-a80e-48d1b652bab8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Macbook Pro - Broadcom WLAN adapter BCM43602 causing freezing under Qubes OS 4.0 rc5

2018-03-21 Thread q120248681
Hi, thanks for your tips I finally got Qubes running on my MBP. However, I 
can't get the wifi card working using methods you discussed above, after 
running "sudo xl pci-attach sys-net '02:00.0,permissive=1'" (02:00.0 is the 
network controller pci address), sys-net still don't have the network 
controller attached and using "qvm-pci attach" still cause the system to 
freeze, how do you finish the attach phase?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c8f55007-fad8-45dc-ac70-5338ddc6c7a3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
I'm trying to figure out when UMAN became very active here.  If it was 2 years 
ago I'm fkn ghost.   Qubes is done...

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c42d9e85-21ef-43a3-8649-d9b6eef048eb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
maybe simply sudo mount -o remount,size=5000M /tmp  will work.  I'll try it 
when I get a chance to use the qubes machine.  But I think the problem is I 
need to increase the whole system storage.  And Uman is refusing to tell me 
how.  The qubes instructions dont' give detailed instructions.  they just give 
the qvm-grow-root command.

I find it strange uman asks me what I mean by system storage and  Asks me if 
I'm using root user lol  wtf...

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/f09bd75f-4488-479a-a83e-792c3269c609%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
Or don't even respond to me anymore.   It already seems like most of ITL team 
abandoned Qubes.  I still think most of us got our hardware compromised over a 
year ago due to that bad dom0 update, which got my bank account hacked,  right 
before intel patched their hardware and right before Joanna came out with the 
suggestion of paranoid mode.  Call me paranoid if you want but I think its 
maybe time I stopped bothering with Qubes.

Only reason I'm still using it is for convenience.  But it seems to be getting 
less and less convenient.

Seems like Qubes is aimed at enterprises now instead of regular home users.  
And ITL's philosophy keeps changing.  Richard Stall man even supports secure 
boot saying its good for security usage since its failed its intended 
purpose..lol.   But Joanna is sounding more and more like this nut Tai that 
keeps posting on here.   

And Now not being able to download the 4.0 iso from Qubes itself is like a fkn 
joke on its users. 

I guess its like that guy who left qubes-whonix said.   It just became a "cool 
tech experiment"  and that seems to be the only people left using it.   Its no 
longer anything serious or practical for a home family.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/11da9b8e-3161-4164-b429-81c9f47002fa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: [Q4-rc5] Custom VPN/ProxyVM problem. Please, help

2018-03-21 Thread evastar via qubes-users
I do another research. After clean reboot I tried to change "networking"-vm to 
another one for my AppVM-client from Qube Manager. Without success. After I do 
this I loss my network at App-client and I do not know how to fix it, because 
if I manually change "networking"-vm again to the first one I still not have 
network. Only reboot of AppVM-client helps.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/zu5zRMlYOjqelcx6t32cQMlKaGyWEUiNX5kpsz9lka71Pey5e0g5eAhM6HvSdviA-wdMyf6HpLf7zdXu52oCTvaV5iFktpZRnjoKN9zdMiA%3D%40protonmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
Also,  it happens with any template with any browser. Why do I have to say that 
again.  Just pick any one and use that for your "troubleshooting".  Everytime I 
see your name now I want to break my fucking computer screen.

Pick a default template.   Pick any fkn browser and tell me how to download 
qubes 4.0 without it failing due to not enough temporary space.

only testing repo I use is the security one.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/97c49e4a-994e-48ac-8f02-0eaa16fdeb1a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] [Q4-rc5] Custom VPN/ProxyVM problem. Please, help

2018-03-21 Thread evastar via qubes-users
I have trouble with my ProxyVM setup. It's the same VPN Qube (ProxyVM, now 
AppVM) from Qubes 3.2. At the previous Q3.2 version it works like a charm for 
all day long. With Q4 I noticed that my workground loss connection at all 
AppVMs connected to this ProxyVM.

Connection lost after 30/60 minutes of use. I do not actually check the time, 
but something around this. It always lost connection after some amount of time.

I do some investigation and found that ProxyVM still have access to network. It 
can connect and disconnect to my server, but AppVM-client that connected to 
this ProxyVM do not have any network access. I tried to change "network"-vm at 
settings for this AppVM and this do not help. The same befaviour to sys-whonix.

I found that
> ip route list
at ProxyVM show me "linkdown"
IP dev vif8.0 scope link metric 32744 (when network works fine)
IP dev vif8.0 scope link metric 32744 linkdown (this)

If I reboot App-Client then it can connect to network.

Any ideas how to fix this? Please.

I have branch of ProxyVMs and it's not possible to reboot only one VM to 
restore access. Now, it's not possible to use Q4 all day long, because it loss 
access time to time.

Thanks.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/cxBk8kCYpCT8RiROeNGo-ts88y2fAWMAcKN6Tz15d7NRFoOzmGsQVROnqtgAOAJayIujn7_wu0HeXmDV9HSCETy2t4bnPqJ5kPYEgYrtZU8%3D%40protonmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
On Wednesday, March 21, 2018 at 10:16:01 AM UTC-4, Yuraeitha wrote:
> On Wednesday, March 21, 2018 at 3:14:33 AM UTC, cooloutac wrote:
> > On Tuesday, March 20, 2018 at 11:10:52 AM UTC-4, Unman wrote:
> > > On Mon, Mar 19, 2018 at 05:00:05PM -0700, cooloutac wrote:
> > > > Can't download qubes 4.0 not enough space.  tried to raise system 
> > > > storage size on template through qubes manager.  messag said I might 
> > > > have use resize2f.   tried that didn't do antyhing.   Tried to use 
> > > > qvm-grow-root  it staid to start template to complete process but it 
> > > > also didn't change.
> > > > 
> > > >in vm settings it shows the size I specified,  but when running 
> > > > nautlius and looking at the space or doing df -h it is still only 4.3gb 
> > > > out of 10.5 available.
> > > >   I've never downloaded a file this large in qubes so never ran into 
> > > > this problem. Only thing I ever had to increase was private storage.  I 
> > > > have this issue with all templates.
> > > >  
> > > > Qubes 3.2 iso must be under the limit so I was able to download that 
> > > > iso but can't donload 4.0 it is too large and fails to download.
> > > > 
> > > > 
> > > > Is there any detailed step by step instructions because I'm obviously 
> > > > doing something wrong?
> > > > 
> > > > Ty for the help.
> > > > 
> > > > Rich.
> > > > 
> > > 
> > > Rich,  can you confirm you're using 3.2?
> > > 
> > > How are you downloading the iso?
> > > Are you doing this as root or user?
> > > Where are you trying to download it to?
> > > 
> > > As you have enough space in /home my guess is that you are using /tmp
> > > or /dev/shm 
> > > If you run df in the qube you're using WHILE the download is running,
> > > you should see the free space moving down as the download progresses.
> > > Can you check this and report back?
> > 
> > Yes i'm definitely using 3.2.  
> > 
> >   it starts off as 4.3 or 4.7 available I believe available out of 10.5gb.  
> > no matter what I set private storage to. its the system storage.I 
> > remember marek showing how to increase the temp file storage size when 
> > having a diff issue a few qubes versions ago,  when I use to have the issue 
> > of playing long video streams cutting off using fedora.  I forget how maybe 
> > similar issue here? But it doesn't matter which appvm or template I use.
> >  
> > 
> > and yes i can see the available space slowly doing down as downloading. 
> > using df-h or just watching in file manager.
> > 
> > I'm trying to download the iso from any vm,  using any template.  loading 
> > firefox or google chrome and clicking on the iso.  they all have the same 
> > problem.   I'd really have ot hate to use some other operating system just 
> > to download 4.0,  almost seems like a joke on qubes users, that the extra  
> > 100mb's puts me over the top and it fails to download lol.
> > 
> > I mean I do have media qubes with 100s of gbs of data in there.  But they 
> > were copied to vms from usb devices and I did have to increase private 
> > storage size.  this seems to be a diff issue.
> 
> You must be concise in describing what you're trying to do. Are you refuting 
> the normal method to increase the AppVM's size, in favor for some old method 
> from several Qubes versions back? 
> 
> I apologize for the rude question, but at this point it needs to be asked. Is 
> this an attempt to try preserve old habits instead of trying to build new 
> habits? Are you getting stuck in old ways of doing things, which may no 
> longer be supported/working?

It has nothing to do with private storage. What os did you use to download your 
qubes 4.0 image?  

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/9e5d4451-daca-4906-ac83-0a36c6056e9b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] VLC won't play DVDs even after installing libdvdcss

2018-03-21 Thread Kyle Breneman
>
> I'm running Qubes 3.2 and Fedora 26.  I've installed VLC Media Player as
> well as libdvdcss, but I still *cannot* get commercial DVDs to play on my
> laptop.
>

>It seems you're trying to play DVDs from your sys-firewall VM, why?

>I have created a multimedia AppVM based on Debian and I was able to play
DVDs.
>Maybe you take a look at the how-to, which I put together trying to get
multimedia working.

>https://www.qubes-os.org/doc/multimedia/


>If you run into any problems, do not hesitate to contact me, so that we
can improve the documentation.

I didn't realize that I was using the sys-firewall terminal.  That happens
to be color-coded the same as my personal VM in the VM Manager, so I guess
I picked the wrong one.  Happens the same way in the other VM though.
Thanks for pointing me to that documentation!  I'll try it out this weekend
and let you know how it goes.


On Tue, Mar 20, 2018 at 3:31 PM, 799  wrote:

> Hello,
>
> Kyle Breneman  schrieb am Di., 20. März 2018,
> 19:58:
>
>> I'm running Qubes 3.2 and Fedora 26.  I've installed VLC Media Player as
>> well as libdvdcss, but I still *cannot* get commercial DVDs to play on
>> my laptop.
>>
>
> It seems you're trying to play DVDs from your sys-firewall VM, why?
>
> I have created a multimedia AppVM based on Debian and I was able to play
> DVDs.
> Maybe you take a look at the how-to, which I put together trying to get
> multimedia working.
>
> https://www.qubes-os.org/doc/multimedia/
>
> If you run into any problems, do not hesitate to contact me, so that we
> can improve the documentation.
>
> [799]
>
>>

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAOtZr%3DEPr1a%3DSL-ZAwi3bQ_n8RgYf0SqTW58aiS2WtsRgjDOFw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread cooloutac
On Wednesday, March 21, 2018 at 9:23:38 AM UTC-4, Unman wrote:
> On Tue, Mar 20, 2018 at 08:14:33PM -0700, cooloutac wrote:
> > On Tuesday, March 20, 2018 at 11:10:52 AM UTC-4, Unman wrote:
> > > On Mon, Mar 19, 2018 at 05:00:05PM -0700, cooloutac wrote:
> > > > Can't download qubes 4.0 not enough space.  tried to raise system 
> > > > storage size on template through qubes manager.  messag said I might 
> > > > have use resize2f.   tried that didn't do antyhing.   Tried to use 
> > > > qvm-grow-root  it staid to start template to complete process but it 
> > > > also didn't change.
> > > > 
> > > >in vm settings it shows the size I specified,  but when running 
> > > > nautlius and looking at the space or doing df -h it is still only 4.3gb 
> > > > out of 10.5 available.
> > > >   I've never downloaded a file this large in qubes so never ran into 
> > > > this problem. Only thing I ever had to increase was private storage.  I 
> > > > have this issue with all templates.
> > > >  
> > > > Qubes 3.2 iso must be under the limit so I was able to download that 
> > > > iso but can't donload 4.0 it is too large and fails to download.
> > > > 
> > > > 
> > > > Is there any detailed step by step instructions because I'm obviously 
> > > > doing something wrong?
> > > > 
> > > > Ty for the help.
> > > > 
> > > > Rich.
> > > > 
> > > 
> > > Rich,  can you confirm you're using 3.2?
> > > 
> > > How are you downloading the iso?
> > > Are you doing this as root or user?
> > > Where are you trying to download it to?
> > > 
> > > As you have enough space in /home my guess is that you are using /tmp
> > > or /dev/shm 
> > > If you run df in the qube you're using WHILE the download is running,
> > > you should see the free space moving down as the download progresses.
> > > Can you check this and report back?
> > 
> > Yes i'm definitely using 3.2.  
> > 
> >   it starts off as 4.3 or 4.7 available I believe available out of 10.5gb.  
> > no matter what I set private storage to. its the system storage.I 
> > remember marek showing how to increase the temp file storage size when 
> > having a diff issue a few qubes versions ago,  when I use to have the issue 
> > of playing long video streams cutting off using fedora.  I forget how maybe 
> > similar issue here? But it doesn't matter which appvm or template I use.
> >  
> > 
> > and yes i can see the available space slowly doing down as downloading. 
> > using df-h or just watching in file manager.
> > 
> > I'm trying to download the iso from any vm,  using any template.  loading 
> > firefox or google chrome and clicking on the iso.  they all have the same 
> > problem.   I'd really have ot hate to use some other operating system just 
> > to download 4.0,  almost seems like a joke on qubes users, that the extra  
> > 100mb's puts me over the top and it fails to download lol.
> > 
> > I mean I do have media qubes with 100s of gbs of data in there.  But they 
> > were copied to vms from usb devices and I did have to increase private 
> > storage size.  this seems to be a diff issue.
> > 
> 
> I'm a little confused by what you are saying - what does "its the system
> storage" mean?
> Can you post the output from 'df -h ', and also what value you have set the
> private storage to .
> 
> I recommend that you use a single qube for this, rather thsan trying
> many templates and many qubes. It will really help with troubleshooting
> your problem.
> So please say also what template you are using and whether you are using
> testing repos.

when you download a file from the internet using a browser it uses temp 
storage.  Can you tell me how to increase it please!?!?!   I can't fine Mareks 
old post telling me how to do it from the commandline in the past.   The bug I 
used to have when playing long streams was fixed.   But Now apparently a 
similar problem is back when Trying to download this 4.0 iso.

I could never stand your posts on this "forum",  and if you are the main dev on 
this project now it might be time to abandon Qubes-os.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ccfc6a2a-9b70-425b-be30-3bb54831ac07%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] VLC won't play DVDs even after installing libdvdcss

2018-03-21 Thread Kyle Breneman
>Hmm, why is vlc looking for a bluray index?
>Is this a standard DVD?

Yes, this is a standard DVD, definitely not a BluRay disc.  I've tried it
with several DVDs and gotten the same result.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAOtZr%3DFCsk7a%3D4wcA_2j9370is_9W30bL6Sy%2BK3AhFZy074Fcg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Monero Wallet on Qubes

2018-03-21 Thread Ted Brenner
Yeah, I'd agree with Giulio. I too use the daemon so I don't have to
dedicate a ton of disk space to the blockchain.

On Wed, Mar 21, 2018 at 10:11 AM, Giulio  wrote:

> Hello,
> I use the monero gui in a clean fedora-25 template succesfully. However i
> use a remote daemon for the gui because of the cpu power and storage space
> (50gb+) needed. Are you trying to sync locally?
>
>
>
>
> On March 21, 2018 3:59:37 PM GMT+01:00, Unman 
> wrote:
>>
>> On Wed, Mar 21, 2018 at 07:25:50AM -0700, abilgili...@gmail.com wrote:
>>
>>>  Hi there beautiful community,
>>>
>>>  5 months user here.
>>>  I think i have figured Qubes out enough to use it as my main OS but still 
>>> i'm so noob.
>>>  I have been trying to move my monero wallet to Qubes from windows as well 
>>> and there is no good documentation about it just like any other thing 
>>> about Qubes.
>>>
>>>  So i have found this guide :
>>>
>>>  
>>> https://github.com/0xB44EFD8751077F97/monero-site/blob/3e6f4fa28b7b834a7049ee45edc294ff1c026565/resources/user-guides/cli_wallet_daemon_isolation_qubes_whonix.md
>>>
>>>  I have followed every step and managed to setup everything EXCEPT running 
>>> and synchronizing MONEROD ( monero blockchain )
>>>
>>>  This is the error that i'm getting :
>>>
>>>  user@host:~/monero-v0.11.1.0$ ./monerod
>>>  2018-03-21 14:17:46.267 719f8bf9e740INFOglobal  
>>> src/daemon/main.cpp:279 Monero 'Helium Hydra' (v0.11.1.0-release)
>>>  2018-03-21 14:17:46.267 719f8bf9e740INFOglobal  
>>> src/daemon/protocol.h:55Initializing cryptonote protocol...
>>>  2018-03-21 14:17:46.268 719f8bf9e740INFOglobal  
>>> src/daemon/protocol.h:60Cryptonote protocol initialized OK
>>>  2018-03-21 14:17:46.268 719f8bf9e740INFOglobal  
>>> src/daemon/p2p.h:63 Initializing p2p server...
>>>  2018-03-21 14:17:52.126 719f8bf9e740INFOglobal  
>>> src/daemon/p2p.h:68 P2p server initialized OK
>>>  2018-03-21 14:17:52.126 719f8bf9e740INFOglobal  
>>> src/daemon/rpc.h:58 Initializing core rpc server...
>>>  2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
>>> contrib/epee/include/net/http_server_impl_base.h:70   Binding on 
>>> 127.0.0.1:18081
>>>  2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
>>> src/daemon/rpc.h:63 Core rpc server initialized OK on port: 18081
>>>  2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
>>> src/daemon/core.h:73Initializing core...
>>>  2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
>>> src/cryptonote_core/cryptonote_core.cpp:323   Loading blockchain from 
>>> folder /home/user/.bitmonero/lmdb ...
>>>  2018-03-21 14:17:52.128 719f8bf9e740WARNblockchain.db.lmdb 
>>>  src/blockchain_db/lmdb/db_lmdb.cpp:1155   LMDB memory map needs to be 
>>> resized, doing that now.
>>>  2018-03-21 14:17:52.164 719f8bf9e740INFOglobal  
>>> src/blockchain_db/lmdb/db_lmdb.cpp:494LMDB Mapsize increased.  Old: 
>>> 1024MiB, New: 2048MiB
>>>  Bus error
>>>
>>>  If any of the users of this community have this software or using this 
>>> wallet for XMR can help me, that'd be highly appreciated.
>>>
>>>  If not, no worries.
>>>
>>>  Have a good day.
>>>  King Regards.
>>>
>>>
>> Greetings
>>
>> Can you confirm which Qubes version you're using?
>> Is there anything in the logs?
>> Can you check memory allocated and also free space with df ?
>>
>> It looks as if LMDB wants 2G space, and if this is in ~ you'll need to
>> allocate more space for /rw
>>
>>
> --
> Sent from my Android device with K-9 Mail. Please excuse my brevity.
>
> --
> You received this message because you are subscribed to the Google Groups
> "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to qubes-users+unsubscr...@googlegroups.com.
> To post to this group, send email to qubes-users@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/
> msgid/qubes-users/E325A89B-96A0-4AB7-AF06-5CF1A86FB37C%40anche.no
> 
> .
>
> For more options, visit https://groups.google.com/d/optout.
>



-- 
Sent from my Desktop

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CANKZutyELCQeO9PFafAo7RTqUdehDPAPeLx6n%2B%3D_hZsn866M7g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Monero Wallet on Qubes

2018-03-21 Thread Giulio
Hello,
I use the monero gui in a clean fedora-25 template succesfully. However i use a 
remote daemon for the gui because of the cpu power and storage space (50gb+) 
needed. Are you trying to sync locally?



On March 21, 2018 3:59:37 PM GMT+01:00, Unman  
wrote:
>On Wed, Mar 21, 2018 at 07:25:50AM -0700, abilgili...@gmail.com wrote:
>> Hi there beautiful community,
>> 
>> 5 months user here.
>> I think i have figured Qubes out enough to use it as my main OS but
>still i'm so noob.
>> I have been trying to move my monero wallet to Qubes from windows as
>well and there is no good documentation about it just like any
>other thing about Qubes.
>> 
>> So i have found this guide : 
>> 
>>
>https://github.com/0xB44EFD8751077F97/monero-site/blob/3e6f4fa28b7b834a7049ee45edc294ff1c026565/resources/user-guides/cli_wallet_daemon_isolation_qubes_whonix.md
>> 
>> I have followed every step and managed to setup everything EXCEPT
>running and synchronizing MONEROD ( monero blockchain ) 
>> 
>> This is the error that i'm getting :
>> 
>> user@host:~/monero-v0.11.1.0$ ./monerod
>> 2018-03-21 14:17:46.267 719f8bf9e740INFOglobal 
>src/daemon/main.cpp:279 Monero 'Helium Hydra' (v0.11.1.0-release)
>> 2018-03-21 14:17:46.267 719f8bf9e740INFOglobal 
>src/daemon/protocol.h:55Initializing cryptonote protocol...
>> 2018-03-21 14:17:46.268 719f8bf9e740INFOglobal 
>src/daemon/protocol.h:60Cryptonote protocol initialized OK
>> 2018-03-21 14:17:46.268 719f8bf9e740INFOglobal 
>src/daemon/p2p.h:63 Initializing p2p server...
>> 2018-03-21 14:17:52.126 719f8bf9e740INFOglobal 
>src/daemon/p2p.h:68 P2p server initialized OK
>> 2018-03-21 14:17:52.126 719f8bf9e740INFOglobal 
>src/daemon/rpc.h:58 Initializing core rpc server...
>> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal 
>contrib/epee/include/net/http_server_impl_base.h:70   Binding on
>127.0.0.1:18081
>> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal 
>src/daemon/rpc.h:63 Core rpc server initialized OK on port: 18081
>> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal 
>src/daemon/core.h:73Initializing core...
>> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal 
>src/cryptonote_core/cryptonote_core.cpp:323   Loading blockchain
>from folder /home/user/.bitmonero/lmdb ...
>> 2018-03-21 14:17:52.128 719f8bf9e740WARN   
>blockchain.db.lmdb  src/blockchain_db/lmdb/db_lmdb.cpp:1155   LMDB
>memory map needs to be resized, doing that now.  
>> 2018-03-21 14:17:52.164 719f8bf9e740INFOglobal 
>src/blockchain_db/lmdb/db_lmdb.cpp:494LMDB Mapsize increased.  Old:
>1024MiB, New: 2048MiB
>> Bus error
>> 
>> If any of the users of this community have this software or using
>this wallet for XMR can help me, that'd be highly appreciated.
>> 
>> If not, no worries.
>> 
>> Have a good day.
>> King Regards.
>> 
>
>Greetings
>
>Can you confirm which Qubes version you're using?
>Is there anything in the logs?
>Can you check memory allocated and also free space with df ?
>
>It looks as if LMDB wants 2G space, and if this is in ~ you'll need to
>allocate more space for /rw
>
>-- 
>You received this message because you are subscribed to the Google
>Groups "qubes-users" group.
>To unsubscribe from this group and stop receiving emails from it, send
>an email to qubes-users+unsubscr...@googlegroups.com.
>To post to this group, send email to qubes-users@googlegroups.com.
>To view this discussion on the web visit
>https://groups.google.com/d/msgid/qubes-users/20180321145937.awnmrsucwiflihdf%40thirdeyesecurity.org.
>For more options, visit https://groups.google.com/d/optout.

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/E325A89B-96A0-4AB7-AF06-5CF1A86FB37C%40anche.no.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Monero Wallet on Qubes

2018-03-21 Thread Unman
On Wed, Mar 21, 2018 at 07:25:50AM -0700, abilgili...@gmail.com wrote:
> Hi there beautiful community,
> 
> 5 months user here.
> I think i have figured Qubes out enough to use it as my main OS but still i'm 
> so noob.
> I have been trying to move my monero wallet to Qubes from windows as well and 
> there is no good documentation about it just like any other thing about 
> Qubes.
> 
> So i have found this guide : 
> 
> https://github.com/0xB44EFD8751077F97/monero-site/blob/3e6f4fa28b7b834a7049ee45edc294ff1c026565/resources/user-guides/cli_wallet_daemon_isolation_qubes_whonix.md
> 
> I have followed every step and managed to setup everything EXCEPT running and 
> synchronizing MONEROD ( monero blockchain ) 
> 
> This is the error that i'm getting :
> 
> user@host:~/monero-v0.11.1.0$ ./monerod
> 2018-03-21 14:17:46.267 719f8bf9e740INFOglobal  
> src/daemon/main.cpp:279 Monero 'Helium Hydra' (v0.11.1.0-release)
> 2018-03-21 14:17:46.267 719f8bf9e740INFOglobal  
> src/daemon/protocol.h:55Initializing cryptonote protocol...
> 2018-03-21 14:17:46.268 719f8bf9e740INFOglobal  
> src/daemon/protocol.h:60Cryptonote protocol initialized OK
> 2018-03-21 14:17:46.268 719f8bf9e740INFOglobal  
> src/daemon/p2p.h:63 Initializing p2p server...
> 2018-03-21 14:17:52.126 719f8bf9e740INFOglobal  
> src/daemon/p2p.h:68 P2p server initialized OK
> 2018-03-21 14:17:52.126 719f8bf9e740INFOglobal  
> src/daemon/rpc.h:58 Initializing core rpc server...
> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
> contrib/epee/include/net/http_server_impl_base.h:70   Binding on 
> 127.0.0.1:18081
> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
> src/daemon/rpc.h:63 Core rpc server initialized OK on port: 18081
> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
> src/daemon/core.h:73Initializing core...
> 2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
> src/cryptonote_core/cryptonote_core.cpp:323   Loading blockchain from 
> folder /home/user/.bitmonero/lmdb ...
> 2018-03-21 14:17:52.128 719f8bf9e740WARNblockchain.db.lmdb
>   src/blockchain_db/lmdb/db_lmdb.cpp:1155   LMDB memory map needs to be 
> resized, doing that now.  
> 2018-03-21 14:17:52.164 719f8bf9e740INFOglobal  
> src/blockchain_db/lmdb/db_lmdb.cpp:494LMDB Mapsize increased.  Old: 
> 1024MiB, New: 2048MiB
> Bus error
> 
> If any of the users of this community have this software or using this wallet 
> for XMR can help me, that'd be highly appreciated.
> 
> If not, no worries.
> 
> Have a good day.
> King Regards.
> 

Greetings

Can you confirm which Qubes version you're using?
Is there anything in the logs?
Can you check memory allocated and also free space with df ?

It looks as if LMDB wants 2G space, and if this is in ~ you'll need to
allocate more space for /rw

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20180321145937.awnmrsucwiflihdf%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Booting from two separate hard drives?

2018-03-21 Thread Linus Stridbeck
Very god information! Thanks..

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c445a8d5-60ba-4e89-b8e7-3099b90e8ce7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Monero Wallet on Qubes

2018-03-21 Thread abilgili950
Hi there beautiful community,

5 months user here.
I think i have figured Qubes out enough to use it as my main OS but still i'm 
so noob.
I have been trying to move my monero wallet to Qubes from windows as well and 
there is no good documentation about it just like any other thing about 
Qubes.

So i have found this guide : 

https://github.com/0xB44EFD8751077F97/monero-site/blob/3e6f4fa28b7b834a7049ee45edc294ff1c026565/resources/user-guides/cli_wallet_daemon_isolation_qubes_whonix.md

I have followed every step and managed to setup everything EXCEPT running and 
synchronizing MONEROD ( monero blockchain ) 

This is the error that i'm getting :

user@host:~/monero-v0.11.1.0$ ./monerod
2018-03-21 14:17:46.267 719f8bf9e740INFOglobal  
src/daemon/main.cpp:279 Monero 'Helium Hydra' (v0.11.1.0-release)
2018-03-21 14:17:46.267 719f8bf9e740INFOglobal  
src/daemon/protocol.h:55Initializing cryptonote protocol...
2018-03-21 14:17:46.268 719f8bf9e740INFOglobal  
src/daemon/protocol.h:60Cryptonote protocol initialized OK
2018-03-21 14:17:46.268 719f8bf9e740INFOglobal  
src/daemon/p2p.h:63 Initializing p2p server...
2018-03-21 14:17:52.126 719f8bf9e740INFOglobal  
src/daemon/p2p.h:68 P2p server initialized OK
2018-03-21 14:17:52.126 719f8bf9e740INFOglobal  
src/daemon/rpc.h:58 Initializing core rpc server...
2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
contrib/epee/include/net/http_server_impl_base.h:70   Binding on 
127.0.0.1:18081
2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
src/daemon/rpc.h:63 Core rpc server initialized OK on port: 18081
2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
src/daemon/core.h:73Initializing core...
2018-03-21 14:17:52.127 719f8bf9e740INFOglobal  
src/cryptonote_core/cryptonote_core.cpp:323   Loading blockchain from 
folder /home/user/.bitmonero/lmdb ...
2018-03-21 14:17:52.128 719f8bf9e740WARNblockchain.db.lmdb  
src/blockchain_db/lmdb/db_lmdb.cpp:1155   LMDB memory map needs to be resized, 
doing that now.  
2018-03-21 14:17:52.164 719f8bf9e740INFOglobal  
src/blockchain_db/lmdb/db_lmdb.cpp:494LMDB Mapsize increased.  Old: 
1024MiB, New: 2048MiB
Bus error

If any of the users of this community have this software or using this wallet 
for XMR can help me, that'd be highly appreciated.

If not, no worries.

Have a good day.
King Regards.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/11eef4fa-e2e6-4b95-85b8-cb716c62924b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread Yuraeitha
On Wednesday, March 21, 2018 at 3:14:33 AM UTC, cooloutac wrote:
> On Tuesday, March 20, 2018 at 11:10:52 AM UTC-4, Unman wrote:
> > On Mon, Mar 19, 2018 at 05:00:05PM -0700, cooloutac wrote:
> > > Can't download qubes 4.0 not enough space.  tried to raise system storage 
> > > size on template through qubes manager.  messag said I might have use 
> > > resize2f.   tried that didn't do antyhing.   Tried to use qvm-grow-root  
> > > it staid to start template to complete process but it also didn't change.
> > > 
> > >in vm settings it shows the size I specified,  but when running 
> > > nautlius and looking at the space or doing df -h it is still only 4.3gb 
> > > out of 10.5 available.
> > >   I've never downloaded a file this large in qubes so never ran into this 
> > > problem. Only thing I ever had to increase was private storage.  I have 
> > > this issue with all templates.
> > >  
> > > Qubes 3.2 iso must be under the limit so I was able to download that iso 
> > > but can't donload 4.0 it is too large and fails to download.
> > > 
> > > 
> > > Is there any detailed step by step instructions because I'm obviously 
> > > doing something wrong?
> > > 
> > > Ty for the help.
> > > 
> > > Rich.
> > > 
> > 
> > Rich,  can you confirm you're using 3.2?
> > 
> > How are you downloading the iso?
> > Are you doing this as root or user?
> > Where are you trying to download it to?
> > 
> > As you have enough space in /home my guess is that you are using /tmp
> > or /dev/shm 
> > If you run df in the qube you're using WHILE the download is running,
> > you should see the free space moving down as the download progresses.
> > Can you check this and report back?
> 
> Yes i'm definitely using 3.2.  
> 
>   it starts off as 4.3 or 4.7 available I believe available out of 10.5gb.  
> no matter what I set private storage to. its the system storage.I 
> remember marek showing how to increase the temp file storage size when having 
> a diff issue a few qubes versions ago,  when I use to have the issue of 
> playing long video streams cutting off using fedora.  I forget how maybe 
> similar issue here? But it doesn't matter which appvm or template I use. 
> 
> and yes i can see the available space slowly doing down as downloading. using 
> df-h or just watching in file manager.
> 
> I'm trying to download the iso from any vm,  using any template.  loading 
> firefox or google chrome and clicking on the iso.  they all have the same 
> problem.   I'd really have ot hate to use some other operating system just to 
> download 4.0,  almost seems like a joke on qubes users, that the extra  
> 100mb's puts me over the top and it fails to download lol.
> 
> I mean I do have media qubes with 100s of gbs of data in there.  But they 
> were copied to vms from usb devices and I did have to increase private 
> storage size.  this seems to be a diff issue.

You must be concise in describing what you're trying to do. Are you refuting 
the normal method to increase the AppVM's size, in favor for some old method 
from several Qubes versions back? 

I apologize for the rude question, but at this point it needs to be asked. Is 
this an attempt to try preserve old habits instead of trying to build new 
habits? Are you getting stuck in old ways of doing things, which may no longer 
be supported/working?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/f442dd09-efcb-4ff3-b744-78e7da5ac158%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] bash autocomplete

2018-03-21 Thread evastar via qubes-users
Can this be included at Qubes Q4 or at some Qubes repo with tools for quick 
installation?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0b4htZdqNsJ40UFY3UKniGzozsxG7PcKbStfij0qJiafLkKoaW3mHOKYEKEVOaGCbNgEy1eGDu-M92ifRGhqJmkGIozUVr95xu-YvJJXQ2E%3D%40protonmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes 4.0-rc5 Some issues

2018-03-21 Thread evastar via qubes-users
After restore from Q3.2 buckup I have all network VM doubled with "disp-" 
prefix? Why? Is it safe to remove them all? All of them have 0.0 MiB size 
reported at Qube manager.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/fcdy7KaulRq3Ao5CyzYijEBRHFFJfxeUPLD6gZVMNrHt9GAm79Z5lFIdwBQYPUwpGwGjwFUnhNVYUJJpeh84aWODydik0_HYch5EgZ-ppiE%3D%40protonmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes 4.0-rc5 Some issues

2018-03-21 Thread evastar via qubes-users
Sorry, I tried other usd drive with NTFS and ExFAT and no results! It does not 
mound automatically and I do not know how to mount all this drives. The problem 
not only with usb drive, but also with HDD. Maybe my template lack some driver 
that support NTFS? Hot to check his? I guess it's possible, because current 
fedora-26 image from rc5 come without 'nano'...
How to check this and fix this issue : 
Thanks!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/qyTKLrPLkyLPE4Qa05GMol6ebu5VSLsEZF-O8ABotQcaRU_pfRMAthNiGb6luEazV9r8BHtZpZgCz13U8GVWB3h2fgb2JCweNc2QvOIL8YU%3D%40protonmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] can't download qubes 4.0 how to raise 4.3gb download limit.

2018-03-21 Thread Unman
On Tue, Mar 20, 2018 at 08:14:33PM -0700, cooloutac wrote:
> On Tuesday, March 20, 2018 at 11:10:52 AM UTC-4, Unman wrote:
> > On Mon, Mar 19, 2018 at 05:00:05PM -0700, cooloutac wrote:
> > > Can't download qubes 4.0 not enough space.  tried to raise system storage 
> > > size on template through qubes manager.  messag said I might have use 
> > > resize2f.   tried that didn't do antyhing.   Tried to use qvm-grow-root  
> > > it staid to start template to complete process but it also didn't change.
> > > 
> > >in vm settings it shows the size I specified,  but when running 
> > > nautlius and looking at the space or doing df -h it is still only 4.3gb 
> > > out of 10.5 available.
> > >   I've never downloaded a file this large in qubes so never ran into this 
> > > problem. Only thing I ever had to increase was private storage.  I have 
> > > this issue with all templates.
> > >  
> > > Qubes 3.2 iso must be under the limit so I was able to download that iso 
> > > but can't donload 4.0 it is too large and fails to download.
> > > 
> > > 
> > > Is there any detailed step by step instructions because I'm obviously 
> > > doing something wrong?
> > > 
> > > Ty for the help.
> > > 
> > > Rich.
> > > 
> > 
> > Rich,  can you confirm you're using 3.2?
> > 
> > How are you downloading the iso?
> > Are you doing this as root or user?
> > Where are you trying to download it to?
> > 
> > As you have enough space in /home my guess is that you are using /tmp
> > or /dev/shm 
> > If you run df in the qube you're using WHILE the download is running,
> > you should see the free space moving down as the download progresses.
> > Can you check this and report back?
> 
> Yes i'm definitely using 3.2.  
> 
>   it starts off as 4.3 or 4.7 available I believe available out of 10.5gb.  
> no matter what I set private storage to. its the system storage.I 
> remember marek showing how to increase the temp file storage size when having 
> a diff issue a few qubes versions ago,  when I use to have the issue of 
> playing long video streams cutting off using fedora.  I forget how maybe 
> similar issue here? But it doesn't matter which appvm or template I use. 
> 
> and yes i can see the available space slowly doing down as downloading. using 
> df-h or just watching in file manager.
> 
> I'm trying to download the iso from any vm,  using any template.  loading 
> firefox or google chrome and clicking on the iso.  they all have the same 
> problem.   I'd really have ot hate to use some other operating system just to 
> download 4.0,  almost seems like a joke on qubes users, that the extra  
> 100mb's puts me over the top and it fails to download lol.
> 
> I mean I do have media qubes with 100s of gbs of data in there.  But they 
> were copied to vms from usb devices and I did have to increase private 
> storage size.  this seems to be a diff issue.
> 

I'm a little confused by what you are saying - what does "its the system
storage" mean?
Can you post the output from 'df -h ', and also what value you have set the
private storage to .

I recommend that you use a single qube for this, rather thsan trying
many templates and many qubes. It will really help with troubleshooting
your problem.
So please say also what template you are using and whether you are using
testing repos.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20180321132334.nmcpyc4bwgcvftbx%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Bitmask installation problem

2018-03-21 Thread Chris Laprise

On 03/19/2018 02:21 PM, niepowie...@gmail.com wrote:

I also tried using standalone version of bitmask and program starts but there is info " The 
VPN requires that certain helpers are installed on your system." and once I click on 
"Install Helper Files" nothing is happen and can't set up working vpn connection.



I recall seeing a bug report on the leap-discuss list about a "blank 
window" problem that prevents making connections; I have experienced it 
myself but its intermittent.


Unless you are using the newer (release candidate) version from January, 
you should use bitmask in an appVM to avoid connection problems.


--

Chris Laprise, tas...@posteo.net
https://github.com/tasket
https://twitter.com/ttaskett
PGP: BEE2 20C5 356E 764A 73EB  4AB3 1DC4 D106 F07F 1886

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/39f4d81b-d647-2241-8222-369e10576272%40posteo.net.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Bitmask installation problem

2018-03-21 Thread Thierry Laurion
Their gpg signing key is expired. Report to leap!

Le lun. 19 mars 2018 18:03, Unman  a écrit :

> On Mon, Mar 19, 2018 at 08:50:50AM -0400, Chris Laprise wrote:
> > On 03/19/2018 04:32 AM, niepowie...@gmail.com wrote:
> > > Hello,
> > >
> > > I'm trying make set up vpn with bitmask application.
> > >
> > > I tried install bitmask to debian template.
> > >
> > >   have done steps listed on bitmask site as below in termainal:
> > >
> > > sudo apt install leap-archive-keyring
> > > sudo sh -c 'echo "deb http://deb.leap.se/client release stretch" >
> /etc/apt/sources.list.d/bitmask.list'
> > > sudo apt update && sudo apt install bitmask
> > >
> > > But there is info as below
> > >
> > > Some packages could not be installed. This may mean that you have
> > > requested an impossible situation or if you are using the unstable
> > > distribution that some required packages have not yet been created
> > > or been moved out of Incoming.
> > > The following information may help to resolve the situation:
> > >
> > > The following packages have unmet dependencies:
> > >   bitmask : Depends: bitmask-core but it is not going to be installed
> > > Depends: bitmask-qt but it is not going to be installed
> > > Depends: bitmask-vpn but it is not going to be installed
> > > Depends: bitmask-mail but it is not going to be installed
> > > E: Unable to correct problems, you have held broken packages.
> > >
> > > How can I resolve this problem? Any advices?
> > >
> >
> > Hi,
> >
> > I'm getting an authentication error when I try to install 'bitmask' with
> > apt:
> >
> > > WARNING: The following packages cannot be authenticated!
> > >   python-leap-common python-sqlcipher soledad-common soledad-client
> bitmask-core bitmask-js
> > >   bitmask-qt bitmask-vpn bitmask-mail bitmask
> >
> >
> > You should probably report the problem to the leap-discuss list. Their
> > bitmask repository may currently be in a transitional state; I know they
> > were planning a new release with Qubes support I contributed.
> >
> > The current release of the standalone bundle can be downloaded here:
> > https://dl.bitmask.net/client/linux/
> >
> > Note the current release v0.10.2 doesn't have Qubes proxyVM support. This
> > means if you run it in a proxyVM some firewall protections won't be in
> > effect, but it should still work. The latest release candidate v0.10.3rc1
> > does have the Qubes proxyVM support.
> >
> > Another difference between the current release and the release candidate
> is
> > that the former has been signed and can be manually verified with gpg.
> >
>
> There does seem to be something amiss with the repo - I imported the
> signing key but still get a GPG error with invalid signature.
>
> --
> You received this message because you are subscribed to the Google Groups
> "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to qubes-users+unsubscr...@googlegroups.com.
> To post to this group, send email to qubes-users@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/qubes-users/20180319220302.s7d2et6wedj337nz%40thirdeyesecurity.org
> .
> For more options, visit https://groups.google.com/d/optout.
>

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAAzJznyFf5p8Wo-V3PgWa8uieq%3D-ma1Fy4-4u4Gwq%2BeARok%3DmA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] qvm-run blocks Dom0 terminal in R4

2018-03-21 Thread 'awokd' via qubes-users
On Wed, March 21, 2018 2:33 am, Bill Wether wrote:
> On Tuesday, March 20, 2018 at 3:08:13 PM UTC-4, awokd wrote:

>> Design choice. Try appending a " &" after the command string.
>>
>
>
> Could you give me a few more words about that?  Running it in the
> background is like setsid, except that the cruft stays in the same
> process.

Marek said somewhere (mailing list? issue?) that this was a design choice
for 4. Can't recall exactly where though!

> ISTM that 'qvm-run' should just run the program in the VM, if necessary
> starting the VM first.  What's it doing, waiting for a return code?

I believe it's waiting on a return code, yes. It makes sense for running
one-shot programs in a VM. Of course, longer running programs involving
user input will take longer to return on exit. Sorry, don't have much more
details than that.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/2deba4b475223875ef432b0c8f6d74a1.squirrel%40tt3j2x4k5ycaa5zt.onion.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Macbook Pro - Broadcom WLAN adapter BCM43602 causing freezing under Qubes OS 4.0 rc5

2018-03-21 Thread q120248681
在 2018年3月21日星期三 UTC+8下午4:01:12,Greg写道:
> > Hi, can you share the script and where to run it?(i.e. which tty should I 
> > run it in?) I'm struggling with the system freeze during setting up the 
> > network
> 
> I did the following to get past the system freeze during setup on my Macbook:
> 1) Run Qubes installation, it will reboot and show the "Initial Setup" screen.
> 2) Press fn+ctrl+alt+f3 to switch to a tty (you might have to press it 
> multiple times for some reason).
> 3) Logon to the tty using the user your created during part 1 of the setup.
> 4) If you don't know the pci address of your problematic device, type 
> "qvm-pci l" to find it (mine is dom0:03_00.0).
> 5) Start a bash loop that will try to remove the problematic pci device from 
> sys-net the moment it is created. Basically just type something like the 
> following at the bash prompt (though replace dom0:03_00.0 with the pci 
> address you want to remove) and hit enter:
> 
> "while ! qvm-pci d sys-net dom0:03_00.0; do sleep 0.1; done"
> 
> It will spit out lots of errors saying "no such domain 'sys-net'". That is 
> expected, you want to leave it running while you complete the setup. 
> Basically when sys-net is created by setup the bash loop should remove the 
> pci device from sys-net before it is started. (You need the sleep period to 
> be small enough so that the device will be removed between the time setup 
> creates sys-net and the time it starts sys-net.)
> 
> 6) With the bash loop running, switch back to Qubes setup using 
> fn+ctrl+alt+f2 and complete setup as usual. If you specify the correct pci 
> address to remove then hopefully the bash loop with remove it in the 
> background and setup will complete without freezing.
> 
> There are probably other ways to do this, but the above worked for me.

Will have a try, thanks very much :P

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b643ffad-f5d2-45cf-a3b9-49017c92e71f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Macbook Pro - Broadcom WLAN adapter BCM43602 causing freezing under Qubes OS 4.0 rc5

2018-03-21 Thread Greg
> Hi, can you share the script and where to run it?(i.e. which tty should I run 
> it in?) I'm struggling with the system freeze during setting up the network

I did the following to get past the system freeze during setup on my Macbook:
1) Run Qubes installation, it will reboot and show the "Initial Setup" screen.
2) Press fn+ctrl+alt+f3 to switch to a tty (you might have to press it multiple 
times for some reason).
3) Logon to the tty using the user your created during part 1 of the setup.
4) If you don't know the pci address of your problematic device, type "qvm-pci 
l" to find it (mine is dom0:03_00.0).
5) Start a bash loop that will try to remove the problematic pci device from 
sys-net the moment it is created. Basically just type something like the 
following at the bash prompt (though replace dom0:03_00.0 with the pci address 
you want to remove) and hit enter:

"while ! qvm-pci d sys-net dom0:03_00.0; do sleep 0.1; done"

It will spit out lots of errors saying "no such domain 'sys-net'". That is 
expected, you want to leave it running while you complete the setup. Basically 
when sys-net is created by setup the bash loop should remove the pci device 
from sys-net before it is started. (You need the sleep period to be small 
enough so that the device will be removed between the time setup creates 
sys-net and the time it starts sys-net.)

6) With the bash loop running, switch back to Qubes setup using fn+ctrl+alt+f2 
and complete setup as usual. If you specify the correct pci address to remove 
then hopefully the bash loop with remove it in the background and setup will 
complete without freezing.

There are probably other ways to do this, but the above worked for me.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/27f1e987-1f69-43de-86b3-f6a74aeeb3e1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] DNS propagation in Qubes

2018-03-21 Thread Alex Dubois


Sent from my mobile phone.

> On 13 Mar 2018, at 18:49, David Hobach  wrote:
> 
> On 03/13/2018 07:14 AM, Alex Dubois wrote:
>>> On 12 Mar 2018, at 18:40, David Hobach  wrote:
>>> 
 On 03/11/2018 03:15 PM, David Hobach wrote:
 An alternative might be to setup the local DNS service in a VM closer to 
 the Internet, i.e. not in the proxy VM which also implements the qubes 
 firewall.
 Something like
 Internet <-- sys-net <-- sys-firewall <-- DNS server VM <-- proxy VM with 
 qubes-fw <-- client VM
 I didn't test that though.
>>> 
>>> I just tested that as well now and it works as expected without any of the 
>>> aforementioned caveats.
>>> 
>>> So I'd recommend the one above over the previously discussed
>>> Internet <-- sys-net <-- sys-firewall <-- DNS server VM <-- client VM
>>> (at least I was talking about that architecture - maybe the others were 
>>> talking about something different...).
>>> The same holds true for VPN users.
>> This type of architecture is bad practice as the attack surface of DNS is 
>> bigger than Qubes firewall, and an attack on this daemon compromise all 
>> traffic, not just DNS.
>> A better arch is
>> Internet
>> - netVM
>> - - firewallVM
>> - - - Service (ie DNS or VPN)
>> - - - clientVM1
>> - - - clientVM2
> 
> I believe your essential point was not to use proxy VMs for services at all.
> 
> My main point was not to mix a Qubes Firewall VM with local services. I think 
> you basically agree with that.

Yes agree

> 
> I however also disagree with your point wrt proxy VM usage as there's no 
> attack vector for E2E encrypted traffic on proxy VMs except for DoS which 
> you'll notice.

Let’s agree to disagree;). This is possibly true client to VPN, but the attack 
surface VPN to internetVPN is not small, there are a substantial number of line 
of code for the support of various protocols, with negotiation phases, parsing 
of data stream into such control flow. (I.e. some of the long list of OpenSSL 
vuln lead to remote code exec I suspect). 
So my point is you can use proxy if all the clients are going to use the VPN. 
And this apply also only if all the traffic would flow through the service (VPN 
use case OK, dns or http proxy not OK).

> If you're using non-E2E encrypted traffic (except for maybe DNS) you have a 
> different problem altogether and even then I'd trust my proxy VM a lot more 
> than any other hop (your Wifi provider? the 4+ backbone providers you pass?) 
> on the route to the destination.
I may have misunderstood you, but this is outside the subject of the discussion 
or please clarify. 

> 
> Moreover it is rather inconvenient to configure each and every client VM to 
> use that service VM which can also lead to unexpected misconfigurations & 
> leakages.
I agree that it is less trivial to setup but you lower your attack surface 
significantly.

So I agree that it depends on the circumstances, but I think my statement is 
preferable as a general rule, and I think Qubes should move toward supporting 
such setup, making it easier to configure. 

Best Regards
Alex
> 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/14B0F388-B653-4981-A8B6-D0901E3B5B18%40gmail.com.
For more options, visit https://groups.google.com/d/optout.