Re: [qubes-users] Disk Manager does not start

2018-11-04 Thread William Fisher
Dom0 does recognize the HDD storage disk but Disk Manager in Qubes does not 
start to give me access to the files on the HDD or to backup my VMs

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/31baa25f-7750-4b17-ac76-b770da2b3c2f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] HCL - DELL M6800

2018-11-04 Thread Kayla Thompson
Check the BIOS setup, most Dell laptops have a toggle to allow for BIOS
downgrade. I would keep it on while you mess around with it.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAKSXK8m5ugBqvZO094c5%3DM9g_dKLi6dCTeJVOXyEtq3_BfSuGg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Cannot boot new HVM from cdrom. What is the new command?

2018-11-04 Thread Otto Kratik
Previously when creating a new Windows HVM on Qubes 3.2, to boot from a 
physical CD in the physical CD drive I would do:

qvm-start --cdrom=/dev/cdrom win7

When I try that in Qubes 4.0, I get an error that starts with "Traceback" and 
ends with "Not enough values to unpack (expected 2, got 1)."

What am I doing wrong? What is the new command to make this work in Qubes 4?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/f991bcb7-633d-4251-837c-bfd795dc4402%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Manjaro Spitfire laptop with Qubes 4.x?

2018-11-04 Thread Teqleez Motley
Hi all, anyone who have tried the Manjaro Spitfire laptop with Qubes 4.x? (or 
even 3.x?)

Ref-1. https://manjaro.org/hardware-spitfire/
Ref-2: https://www.qubes-os.org/hcl/

-- 
Regards,
Teqleez

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/1541354787.2531903.1565227080.5A0FB881%40webmail.messagingengine.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] how do I check Tor & Whonix version?

2018-11-04 Thread qubes123456
Thanks for the helpful information. I will upgrade to Whonix 14. (Completely 
new download and instalation).

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/156f1009-dba9-49d4-b651-e13748442255%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] Qubes 4: Unable to get any DVM app to ever launch

2018-11-04 Thread unman
On Sat, Nov 03, 2018 at 03:14:00PM -0700, Otto Kratik wrote:
> On Thursday, November 1, 2018 at 10:13:36 AM UTC-4, unman wrote:
> > On Wed, Oct 31, 2018 at 12:27:06PM -0700, Otto Kratik wrote:
> > > On Wednesday, October 31, 2018 at 7:49:43 AM UTC-4, awokd wrote:
> > > > Otto Kratik wrote on 10/31/18 2:28 AM:
> > > > > Qubes 4.0
> > > > > 
> > > > > 
> > > > > Whenever attempting to launch an app in a DVM, the result is always 
> > > > > the same. The popup message comes up saying "Disp1234 has started", 
> > > > > and then nothing happens. Then about two minutes later, another popup 
> > > > > says "Disp1234 has halted". No app ever launches.
> > > > > 
> > > > > It doesn't matter what app I try.. xterm, konsole, firefox, dolphin, 
> > > > > thunar, tor browser, gedit, kwrite etc. Always the same behavior. 
> > > > > Also doesn't matter if I try from Q Menu shortcuts, command line in 
> > > > > dom0, command line in another AppVM.. no difference. Just the same 
> > > > > type of message in the terminal, says it's launching, then shuts down 
> > > > > two minutes later with no output.
> > > > > 
> > > > > Doesn't make a difference either if I try to open a file in a DVM or 
> > > > > just straight launching an app. Nothing ever opens. Launching apps 
> > > > > regularly from normal AppVM's works perfectly all the time, just not 
> > > > > DVM's.
> > > > > 
> > > > > Slight correction: About 1 in 10 times, launching Firefox from a 
> > > > > Fedora-template-based DVM succeeds. The other 9 times it fails. All 
> > > > > other apps fail 10 out of 10 times. And launching any app (including 
> > > > > Firefox) from a Whonix-ws-14-template-based DVM also fails 100% of 
> > > > > the time as described above.
> > > > > 
> > > > > How is this issue best investigated and resolved?
> > > > > 
> > > > 
> > > > Have you upgraded to Whonix 14 or customized the DVM? Try removing it 
> > > > completely (you might have to temporarily change DVM defaults to a 
> > > > different template), then recreating it with `sudo qubesctl state.sls 
> > > > qvm.whonix-ws-14-dvm`. If that doesn't work, see 
> > > > https://www.whonix.org/wiki/Qubes/Uninstall and 
> > > > https://www.whonix.org/wiki/Qubes/Install to completely uninstall and 
> > > > reinstall the workstation template and DVM. You can skip the gateway 
> > > > steps if you've already upgraded it to 14 since it sounds like that's 
> > > > still working.
> > > 
> > > It's a fresh install of Qubes 4 with freshly downloaded/installed Whonix 
> > > 14/DVM templates using the salt/qubesctl command mentioned above and in 
> > > the documentation. No customisations. So I doubt reinstalling would have 
> > > any effect. 
> > > 
> > > Whonix-ws-14 template works perfectly fine for running apps the normal 
> > > way, from AppVMs based upon it. No issue whatsoever. Only running them 
> > > from whonix-ws-14-dvm causes trouble.
> > > 
> > > However as I said, even trying to run apps from Fedora-26-dvm also fails 
> > > the majority of the time, so I'm not even convinced it's a whonix 
> > > specific issue. Rather a DVM one in general.
> > > 
> > > Any other things to try?
> > > 
> > 
> > I would try this:
> > Install all updates in dom0 and qubes.
> > Create a new Fedora based qube.
> > Confirm you can run programs as expected.
> > Make it a template for dispvms, using qvm-prefs.
> > Close all unnecessary qubes.
> > Then , at command line, start to test running programs in dispvms based
> > on the qube.
> > 
> > Generally , the command should be:
> > qvm-run --dispvm  
> > 
> > That's the most basic form.
> > Anything you can run using qvm-run   should work in
> > disposableVM based on qube (except gnome-terminal)
> > 
> > That will test the basic infrastructure.
> > 
> > If all is good, start testing a more complex form:
> > qvm-run -a  --service  --dispvm= --qubes.StartApp+
> > 
> >  here should have an associated desktop file.
> > Again, anything you can run using qvm-run --service   should 
> > work in
> > disposableVM based on the qube (except gnome-terminal)
> > 
> > That will test the more complex infrastructure.
> > 
> > If all's good, you can start testing different template based qubes,
> > including Whonix. If it's not good there's something fundamentally
> > broken.
> > 
> > qvm-run *does* have -v option, but it doesn't generate verbose output.
> > 
> > Check back when you have some results from testing.
> > 
> > unman
> 
> 
> Hi, thanks for your detailed reply and suggestions. Here is what I have found:
> 
> I created a new qube/AppVM based on the fedora26 template, and called it 
> 'fedoratest'. I also enabled it as a DVM template using qvm=prefs. Running 
> all of the following commands from dom0 worked perfectly:
> 
> qvm-run fedoratest firefox
> qvm-run fedoratest nautilus
> qvm-run fedoratest gedit
> qvm-run --dispvm fedoratest firefox
> qvm-run --dispvm fedoratest nautilus
> qvm-run --dispvm fedoratest gedit
> 
> However, as soon as I introduced the '--service' 

Re: [qubes-users] UnicodeDecodeError during Qubes 4.0 installation

2018-11-04 Thread lorodion
I have a similar problem installing Qubes R4.0 - it fails when loading the 
graphical installer with an "unknown error". The error is similarily: 
"UnicodeDecodeError: 'utf-8' codec can not decode byte 0xc0 in position 3: 
invalid start byte".
Looking through the stack trace reveals that the problem is related to the file 
system (not hardware naming): "... line 67, in ensure_unicode_string
value = value.decode(sys.getfilesystemencoding())".
This is used in the blivet osinstall populator, I haven't read through this 
package yet though to figure out its purpose in detail.

I have been forced to use the nouveau.modeset = 0 flag to get the installer 
running to this stage, otherwise it stops before starting the graphical 
installer. I have also tried the text installer but it stops with the same 
error: https://imagebin.ca/v/4LROpDUqDhVz

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/5d05e071-3a18-48c3-a150-639056ddb771%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] HCL - DELL M6800

2018-11-04 Thread ludwig jaffe
Unfortunately this computer has ME in the firmware.
Most modern BIOS is A23

I am running the old BIOS A16, but plan to update when I found out
how to disable or disturb ME firmware w/o bricking the laptop.
I know there is me_cleaner.
I have fear to update the bios as it could prevent me from down dating
if I need it.

ME is vulnerable in A16 BIOS, I use at the moment.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAP7JdrJhoT%3DSvBBn-SeiUQsfLqvqOaXDAeeRsxCcDjraKXNBqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


Qubes-HCL-Dell_Inc_-Precision_M6800-20181104-103921.yml
Description: application/yaml


Re: [qubes-users] Disk Manager does not start

2018-11-04 Thread 'awokd' via qubes-users

William Fisher:

I just installed qubes 4.0 and the disk manager doesn’t start and show any disk 
drives. It just shows the settings for the mAnager. I can’t get the manager to 
start. I try to install or back-up vms and when I try to select a destination I 
get the error: whoops a Critical error has occurred. This is most likely a bug 
in Qubes Restore VMs application. Qubes VM Error. Cannot start Dom0 fake domain 
at line 102 of file base.py

Did you update dom0 & templates after installing, and reboot? I am not 
following where you are running into trouble. Are you trying to backup 
VMs, or restore them?


--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/7ed5a09b-7d25-2d52-c094-c264dd2fbadb%40danwin1210.me.
For more options, visit https://groups.google.com/d/optout.