Re: [qubes-users] Another newbie question related to TemplateVMs

2020-05-29 Thread WillyPillow
On Saturday, May 30, 2020 6:48 AM, 'Jackie' via qubes-users 
 wrote:

> Frédéric Pierret:
> 

> > On 2020-05-29 18:26, viktor.ransm...@gmail.com wrote:
> > 

> > > Hello Frederic,
> > > Am Freitag, 29. Mai 2020 14:01:46 UTC+2 schrieb Frédéric Pierret:
> > > 

> > >  On 2020-05-29 13:53, viktor@gmail.com  wrote:
> > >  >
> > >  > I'm trying to continue my journey into the various Qubes OS 
> > > options from the smaller - and not - from the larger template POV.
> > >  >
> > >  > I'm not asking for any additions to the provided packages 
> > > available for example in 'fedora-31-minimal'.
> > >  >
> > >  > All I'm asking for is help to resolve the following question:
> > >  >
> > >  > *What do I need to do in order to activate / enable the copy / 
> > > paste pattern via copy-c/v for xterm?
> > >  > *
> > > 

> > >  Control+Middle mouse clic -> Select to Clipboard. Then, you can you 
> > > QubesOS clipboard shortcut (Control+Shift+C).
> > > 

> > > 

> > > It may be obvious to you, but for me - coming from the Windows world - it 
> > > is not really clear ...
> > 

> > The middle click simply the wheel click but indeed, with only left and 
> > right buttons it's both at the same time. Here when hold Control in 
> > addition to left and right mouse button (keep holding) on xterm, it makes 
> > appearing a little menu where the selection is made by unholding mouse 
> > buttons. On this little menu you would see the 'Select to Clipboard' option.
> 

> For what it's worth i can't get this to work on xterm either. I use
> gnome-terminal which lets you right click -> copy (or edit -> copy),
> 

> then qubes copy/paste shortcuts work like normal.

To enable simulating middle clicks that way, I had to follow
.


Alternatively, you should be able to add `XTerm.vt100.selectToClipboard: 1`
to `~/.Xresources` and run `xrdb -merge ~/.Xresources` to enable the
Select to Clipboard feature by default.

> https://blog.nerde.pw/
>
> PGP fingerprint = 6CCF 3FC7 32AC 9D83 D154 217F 1C16 C70E E7C3 1C84
>
> Protonmail PGP = D02D CEFF ACE5 5A7B FF5D 871E 4004 1CB1 F52B 127E

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/D8mh0TS1VXTcEHlOF3LbQsxxocJpWMkyJLN7gwmkBGnMi84NjA8SdAodug2uu-tn6nc450WjklDTp7Y4KZ4gRi_-31x8fYSC5Rba9f8L_1M%3D%40nerde.pw.


publickey - wp@nerde.pw - 0xD02DCEFF.asc
Description: application/pgp-keys


signature.asc
Description: OpenPGP digital signature


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread dennisjmenzel
Update! Solved the issue. For future searchers:

All that had to be done for me was:

•Launch in Legacy boot
•On the blue install screen, highlight Install and press Tab
•move the text cursor with your left arrow key and after “alpha_support=1” add 
“modprobe.blacklist=nouveau” (without the quotes)
•press enter and you should be brought to the install screen!

Good luck to anyone having a similar problem!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b73b4607-b171-4965-b3b8-bd5912de5a5a%40googlegroups.com.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread dennisjmenzel
I verified with the PGP key. Redownloded. Wrote the dd in Fedora. Still not 
working. I’m stumped. I don’t get it. I’m super bummed. 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/af2307c8-61fb-44c3-b10a-6ba470080df6%40googlegroups.com.


Re: [qubes-users] Another newbie question related to TemplateVMs

2020-05-29 Thread 'Jackie' via qubes-users

Frédéric Pierret:


On 2020-05-29 18:26, viktor.ransm...@gmail.com wrote:

Hello Frederic,

Am Freitag, 29. Mai 2020 14:01:46 UTC+2 schrieb Frédéric Pierret:

 On 2020-05-29 13:53, viktor@gmail.com  wrote:
 >
 > I'm trying to continue my journey into the various Qubes OS options from 
the smaller - and not - from the larger template POV.
 >
 > I'm not asking for any additions to the provided packages available for 
example in 'fedora-31-minimal'.
 >
 > All I'm asking for is help to resolve the following question:
 >
 > *What do I need to do in order to activate / enable the copy / paste 
pattern via copy-c/v for xterm?
 > *

 Control+Middle mouse clic -> Select to Clipboard. Then, you can you 
QubesOS clipboard shortcut (Control+Shift+C).


It may be obvious to you, but for me - coming from the Windows world - it is 
not really clear ...


The middle click simply the wheel click but indeed, with only left and right 
buttons it's both at the same time. Here when hold Control in addition to left 
and right mouse button (keep holding) on xterm, it makes appearing a little 
menu where the selection is made by unholding mouse buttons. On this little 
menu you would see the 'Select to Clipboard' option.


For what it's worth i can't get this to work on xterm either. I use 
gnome-terminal which lets you right click -> copy (or edit -> copy), 
then qubes copy/paste shortcuts work like normal.


--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/10759012-d729-11a7-688f-fb6d0cc3c8ca%40danwin1210.me.


Re: [qubes-users] Re: Libreoffice Calc windowsize is 1x1 cm ..

2020-05-29 Thread Steve Coleman
I loved the idea of the macros to manage the desktop in general as I would
really like to pin Qubes Manager to desktop 1 and not have it start on
whatever desktop the person last logged out from.  But that is obviously
fixable now.

I did do a little digging into this LO window size issue just because I
wanted to understand what was actually happening. I have had several VMs
act up, but not all of them in the same way, so I dug deeper to see what
the differences might be.

The answer is  that window size information is stored in the file:
.config/libreoffice/4/user/registrymodifications.xcu

> grep
ooSetupFactoryWindowAttributes
.config/libreoffice/4/user/registrymodifications.xcu


This will give you several lines like:

*61,61,1807,982;5;38,56,1807,982;*


By opening any Libreoffice app you can navigate to see/edit the same values
from the Tools menu:
Tools
   Advanced
  click [Open Expert Configuration]
 Search for: "ooSetupFactoryWindowAttributes"
Then scroll right to see the values set for each component as a string
value, eg:  "*61,61,1807,982;5;38,56,1807,982;*"

The window position values are specified as:
x-pos,y-pos,*width,height ;* window-state *;*
maximized-x-pos,maximized-y-pos,maximized-width,maximized-height *;*

In my VMs that were broken (two pixel window size) this file was missing
all but one ooSetupFactoryWindowAttributes line in this file, where as
there were many lines, one for each libraOffice app in the working VMs. As
a test, I cut-n-pasted the group of lines from a working VM into the broken
xcu file using gedit and saved, and tried again. Everything worked! The
window size problem was gone. So then I started looking more closely with
gedit and meld to watch what was changeing.

As each LO app is run it adds its line to the xcu file with x-pos,y-pos,
*2,2*,... as the default width,height values of only two pixels. Changing
those values to any valid set of Width,Height numbers will make the window
open with that predefined size. Upon exiting the app with any manually
adjusted size does not save that new value back to the xcu file. Its
width,height values are apparently read at the start and completely ignored
on exit, even though the xcu file will be rewritten with many other
modified values.  For instance if you open and manually resize the window
and then click maximize just before before exiting then the *0,0* for the
*maximized-width,maximized-height* will be updated to that new set of
values but the origional *width,height* values will remain unchanged. It
appears that manually editing these width,height values from 2,2 to
'something more reasonable' is the only way to perminantly change them.

Steve.






On Thu, May 28, 2020 at 3:27 PM  wrote:

>
>
> Am Donnerstag, 28. Mai 2020 20:34:45 UTC+2 schrieb Dave:
>>
>> Ok thanks for the tip, i just tested you suggestion and it resizes the
>> window perfectly.
>> Do you autostart devilspie2 at boot .. or how do you use it ..?
>>
>>
>  I start it via .desktop file in .config/autostart.
>
> It really is a handy tool. I use it for other things like mapping domains
> to certain workspaces.
>
> --
> You received this message because you are subscribed to the Google Groups
> "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to qubes-users+unsubscr...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/qubes-users/3e39d011-8d2b-474e-818a-ed0b6058ef40%40googlegroups.com
> 
> .
>

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAJ5FDnj7Z%3DcL%2BCA3RO2DfRWjpd%3DvKDr3N618uNmVmUVKpXHfYA%40mail.gmail.com.


Re: [qubes-users] Updating sys-usb template

2020-05-29 Thread dhorf-hfref . 4a288f10
> > disable sys-usb autostart.

> maybe "lock out" refers to a USB keyboard ?

yes, that is how i read it, and that is what my suggestions for
dealing with the update are about.



-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20200529220220.GY1079%40priv-mua.


Re: [qubes-users] Updating sys-usb template

2020-05-29 Thread haaber

On 5/29/20 10:04 PM, dhorf-hfref.4a288...@hashmail.org wrote:

On Thu, May 28, 2020 at 09:26:34AM +0200, Zbigniew Łukasiak wrote:

My sys-usb uses a very old template. I tried some googling - but
failed to find any advice about update it without locking me out of
the system.


disable sys-usb autostart. and reboot.
now you can replace the sys-usb template.
and try to start sys-usb with the new template.
if that fails, you will have to reboot again, and retry.

but basicly this reduces the problem from "locked out and need a
recovery disk" to "additional unplanned reboots" (which are not
that critical if you shut down all other VMs first)


maybe "lock out" refers to a USB keyboard ? That is how I read the
question. We let Zbigniew explain.

--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/9b9bfbb5-5858-c36c-ae0d-5a7fa2b8a926%40web.de.


Re: [qubes-users] USB3 Controller

2020-05-29 Thread Magali Bardet
thanks, it's working! using the command line tool like in
https://www.qubes-os.org/doc/block-devices/

best,

Magali

On 2020-05-29 23:23, dhorf-hfref.4a288...@hashmail.org wrote:
> On Fri, May 29, 2020 at 11:09:00PM +0200, Magali Bardet wrote:
>> Does anyone know what is the problem ? How can I solve it ?
> 
> use "qvm-block" instead of "qvm-usb" to attach it to another qube.
> (or the block instead of the usb section of the device widget)
> 
> 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b5cc50dd-b6b0-fc96-f9c7-50e29cf164eb%40univ-rouen.fr.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread dennisjmenzel
I didn’t verify, no. But I’m gonna redownload now and try again from scratch. 

And hey, I’m pretty much a moron with this so, any help is amazing!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b7113b16-12b7-4da9-9210-2df8c60aac6b%40googlegroups.com.


Re: [qubes-users] USB3 Controller

2020-05-29 Thread dhorf-hfref . 4a288f10
On Fri, May 29, 2020 at 11:09:00PM +0200, Magali Bardet wrote:
> Does anyone know what is the problem ? How can I solve it ?

use "qvm-block" instead of "qvm-usb" to attach it to another qube.
(or the block instead of the usb section of the device widget)



-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20200529212349.GX1079%40priv-mua.


[qubes-users] USB3 Controller

2020-05-29 Thread Magali Bardet
Hello community,

I'm using Qubes (R4.0) for almost a year now, and I really enjoy it. It
works well, except for the USB part:

when I connect an external hard-drive on USB3, I can access it through
the sys-usb qube (and thus copy between qubes). But when  I attach it to
another qube, nothing happens, and with the command "sudo dmesg" I get
the message

[25600.556228] usb 2-1: USB controller vhci_hcd.0 does not support
streams, which are required by the UAS driver.
[25600.556266] usb 2-1: Please try an other USB controller if you wish
to use UAS.
[25600.556291] usb-storage 2-1:1.0: USB Mass Storage device detected
[25600.557418] scsi host0: usb-storage 2-1:1.0
 vhci_hcd: unlink->seqnum 47
[25622.455904] vhci_hcd: urb->status -104
[25626.012450] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?
[25626.012519] usb 2-1: USB disconnect, device number 12

Does anyone know what is the problem ? How can I solve it ?

Note that everything works fine with a small USB key (I think using USB2).

many thanks in advance,

Magali

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/4c0d6cad-acab-7b13-ecf2-5c02322fa87e%40univ-rouen.fr.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread Andrew Sullivan
Did you check the ISO you downloaded was good? As described here:

https://www.qubes-os.org/security/verifying-signatures/

Apologies if I'm teaching you to suck eggs!

Andrew

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/070d0900-1703-4000-ab82-be58a754720f%40googlegroups.com.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread dennisjmenzel
Hey Andrew!

Did exactly that and even went a step further. 

Installed Fedora onto my 256gb USB drive. Works flawlessly. 

Then copied the Qubes iso onto the 256gb Fedora drive. 

Wrote the Qubes install using the command line onto 32gb USB drive. (Same exact 
kind used to install Fedora)

Shutdown restart and boot the Qubes installer with legacy boot from usb. 

Blue splash screen with “Install Qubes” and “Test Media then Install Qubes” 
appears. 

Chose install Qubes, about and same errors occur. 

Could there be something corrupted with the .iso? I’m seriously at a loss

Here’s a link to a video I shot with the last attempt. Maybe there’s something 
I’m missing: 
https://drive.google.com/file/d/1Yndf1lGhQexMtfe0SdZtCninkAE8m4lU/view?usp=drivesdk

Thanks so much for the help!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/228d14f1-0ead-4802-9328-123e882daca1%40googlegroups.com.


Re: [qubes-users] Updating sys-usb template

2020-05-29 Thread dhorf-hfref . 4a288f10
On Thu, May 28, 2020 at 09:26:34AM +0200, Zbigniew Łukasiak wrote:
> My sys-usb uses a very old template. I tried some googling - but
> failed to find any advice about update it without locking me out of
> the system.

disable sys-usb autostart. and reboot.
now you can replace the sys-usb template.
and try to start sys-usb with the new template.
if that fails, you will have to reboot again, and retry.

but basicly this reduces the problem from "locked out and need a
recovery disk" to "additional unplanned reboots" (which are not
that critical if you shut down all other VMs first)



-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20200529200439.GW1079%40priv-mua.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread Andrew Sullivan


On Friday, 29 May 2020 16:58:14 UTC+1, dennis...@gmail.com wrote:
>
> Hey Peter! 
>
> I did install Fedora successfully using the same USB device. No problems 
> at all. 
>
> I’m running an Alienware M15 R3 which is on the Qubes compatible list. 
>
> Could it be Rufus not writing the DD properly? 
>
> Thanks so much for your help!


Hello Dennis

Might be a bit of a long way round, but if you have aLinux Live system on a 
USB stick, could you boot from that then try to write the Qubes installer 
using dd from the command line?

Good luck 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/59400fad-1194-46e0-878d-968ea7abb67c%40googlegroups.com.


Re: [qubes-users] Another newbie question related to TemplateVMs

2020-05-29 Thread Frédéric Pierret

On 2020-05-29 18:26, viktor.ransm...@gmail.com wrote:
> Hello Frederic,
> 
> Am Freitag, 29. Mai 2020 14:01:46 UTC+2 schrieb Frédéric Pierret:
> 
> On 2020-05-29 13:53, viktor@gmail.com  wrote:
> >
> > I'm trying to continue my journey into the various Qubes OS options 
> from the smaller - and not - from the larger template POV.
> >
> > I'm not asking for any additions to the provided packages available for 
> example in 'fedora-31-minimal'.
> >
> > All I'm asking for is help to resolve the following question:
> >
> > *What do I need to do in order to activate / enable the copy / paste 
> pattern via copy-c/v for xterm?
> > *
> 
> Control+Middle mouse clic -> Select to Clipboard. Then, you can you 
> QubesOS clipboard shortcut (Control+Shift+C).
> 
> 
> It may be obvious to you, but for me - coming from the Windows world - it is 
> not really clear ...

The middle click simply the wheel click but indeed, with only left and right 
buttons it's both at the same time. Here when hold Control in addition to left 
and right mouse button (keep holding) on xterm, it makes appearing a little 
menu where the selection is made by unholding mouse buttons. On this little 
menu you would see the 'Select to Clipboard' option.
 
> I searched for 'middle mouse clic' & I was told that on a regular two button 
> mouse, this maps / translates to pressing both left & right mouse at the same 
> time.
> 
> However in the xterm started from the qube 'f31-min-test-vm' this does not 
> create any result :-(
> 
> Whenever I try to perform a Control+Shift+C operation afterwards, it reports 
> ZERO bytes ...
> 
> What am I missing?
>  
> 
> 
> > I do know, that this is not a Qubes OS specific question - but - it 
> seems to be a Qubes OS/ Minimal TemplateVM related question.
> >
> > I tried several options recommended to me, when I searched the Internet 
> for "copy text from xterm [fedora]". - Unfortunately w/o success :-(
> >
> > Additional information, just for the record:
> >
> > I created a qube, which I called 'f31-min-test-vm' based on the 
> template 'fedora-31-minimal'
> >
> > I start the xterm - and - would like to retrieve the content of all all 
> installed packages, i.e. 'rpm -qa | sort', to start adding necessary packages 
> for my use-case(s) ...
> >
> > Again for information only:
> >
> > When I execute 'rpm -qa | wc - l' in an xterm, it reports only
> >
> > * 431 for 'f31-min-test-vm' - but -
> > * 1142 for 'f31-test-vm' ...
> >
> > *Any suggestions to my initial question?
> 
> What is 'f31-test-vm'? You only spoke about f31-min-test-vm.
> 
> 
> You are right, I should have mentioned 'f31-test-vm' explicitly as well.
> 
> I created this qube fresh from the 'fedora-31' template, simply to get the 
> number of packages which are installed, if I would base any cloned template 
> on it.
> 
> I just mentioned it as an argument, why *I* want to start from the smaller - 
> and not - from the larger template.
> 
> With kind regards,
> 
> VR
> 
> -- 
> You received this message because you are subscribed to the Google Groups 
> "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to qubes-users+unsubscr...@googlegroups.com 
> .
> To view this discussion on the web visit 
> https://groups.google.com/d/msgid/qubes-users/07a939fe-0884-45af-81bf-7a87b3c9b26c%40googlegroups.com
>  
> .

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/3a70539d-3194-ea05-37c8-ef0a1fcfa9c3%40qubes-os.org.


signature.asc
Description: OpenPGP digital signature


Re: [qubes-users] Another newbie question related to TemplateVMs

2020-05-29 Thread viktor . ransmayr
Hello Frederic,

Am Freitag, 29. Mai 2020 14:01:46 UTC+2 schrieb Frédéric Pierret:

> On 2020-05-29 13:53, viktor@gmail.com  wrote: 
> > 
> > I'm trying to continue my journey into the various Qubes OS options from 
> the smaller - and not - from the larger template POV. 
> > 
> > I'm not asking for any additions to the provided packages available for 
> example in 'fedora-31-minimal'. 
> > 
> > All I'm asking for is help to resolve the following question: 
> > 
> > *What do I need to do in order to activate / enable the copy / paste 
> pattern via copy-c/v for xterm? 
> > * 
>
> Control+Middle mouse clic -> Select to Clipboard. Then, you can you 
> QubesOS clipboard shortcut (Control+Shift+C). 
>

It may be obvious to you, but for me - coming from the Windows world - it 
is not really clear ...

I searched for 'middle mouse clic' & I was told that on a regular two 
button mouse, this maps / translates to pressing both left & right mouse at 
the same time.

However in the xterm started from the qube 'f31-min-test-vm' this does not 
create any result :-(

Whenever I try to perform a Control+Shift+C operation afterwards, it 
reports ZERO bytes ...

What am I missing?
 

>
> > I do know, that this is not a Qubes OS specific question - but - it 
> seems to be a Qubes OS/ Minimal TemplateVM related question. 
> > 
> > I tried several options recommended to me, when I searched the Internet 
> for "copy text from xterm [fedora]". - Unfortunately w/o success :-( 
> > 
> > Additional information, just for the record: 
> > 
> > I created a qube, which I called 'f31-min-test-vm' based on the template 
> 'fedora-31-minimal' 
> > 
> > I start the xterm - and - would like to retrieve the content of all all 
> installed packages, i.e. 'rpm -qa | sort', to start adding necessary 
> packages for my use-case(s) ... 
> > 
> > Again for information only: 
> > 
> > When I execute 'rpm -qa | wc - l' in an xterm, it reports only 
> > 
> > * 431 for 'f31-min-test-vm' - but - 
> > * 1142 for 'f31-test-vm' ... 
> > 
> > *Any suggestions to my initial question? 
>
> What is 'f31-test-vm'? You only spoke about f31-min-test-vm. 
>

You are right, I should have mentioned 'f31-test-vm' explicitly as well.

I created this qube fresh from the 'fedora-31' template, simply to get the 
number of packages which are installed, if I would base any cloned template 
on it.

I just mentioned it as an argument, why *I* want to start from the smaller 
- and not - from the larger template.

With kind regards,

VR

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/07a939fe-0884-45af-81bf-7a87b3c9b26c%40googlegroups.com.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread dennisjmenzel
Hey Peter!

I did install Fedora successfully using the same USB device. No problems at 
all. 

I’m running an Alienware M15 R3 which is on the Qubes compatible list. 

Could it be Rufus not writing the DD properly? 

Thanks so much for your help!

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0553894d-79cd-4568-9e05-b22d5a12d220%40googlegroups.com.


Re: [qubes-users] Another newbie question related to TemplateVMs

2020-05-29 Thread Frédéric Pierret


On 2020-05-29 13:53, viktor.ransm...@gmail.com wrote:
> Hello community,
> 
> I'm trying to continue my journey into the various Qubes OS options from the 
> smaller - and not - from the larger template POV.
> 
> I'm not asking for any additions to the provided packages available for 
> example in 'fedora-31-minimal'.
> 
> All I'm asking for is help to resolve the following question:
> 
> *What do I need to do in order to activate / enable the copy / paste pattern 
> via copy-c/v for xterm?
> *

Control+Middle mouse clic -> Select to Clipboard. Then, you can you QubesOS 
clipboard shortcut (Control+Shift+C).


> I do know, that this is not a Qubes OS specific question - but - it seems to 
> be a Qubes OS/ Minimal TemplateVM related question.
> 
> I tried several options recommended to me, when I searched the Internet for 
> "copy text from xterm [fedora]". - Unfortunately w/o success :-(
> 
> Additional information, just for the record:
> 
> I created a qube, which I called 'f31-min-test-vm' based on the template 
> 'fedora-31-minimal'
> 
> I start the xterm - and - would like to retrieve the content of all all 
> installed packages, i.e. 'rpm -qa | sort', to start adding necessary packages 
> for my use-case(s) ...
> 
> Again for information only:
> 
> When I execute 'rpm -qa | wc - l' in an xterm, it reports only
> 
> * 431 for 'f31-min-test-vm' - but -
> * 1142 for 'f31-test-vm' ...
> 
> *Any suggestions to my initial question?

What is 'f31-test-vm'? You only spoke about f31-min-test-vm.

> 
> With kind regards,
> 
> VR
> 
> -- 
> You received this message because you are subscribed to the Google Groups 
> "qubes-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to qubes-users+unsubscr...@googlegroups.com 
> .
> To view this discussion on the web visit 
> https://groups.google.com/d/msgid/qubes-users/c9dfac76-2e5b-4d89-8675-aad2647d97e2%40googlegroups.com
>  
> .


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a2493abd-d8aa-2d5f-0f7f-c490776b650c%40qubes-os.org.


signature.asc
Description: OpenPGP digital signature


[qubes-users] Another newbie question related to TemplateVMs

2020-05-29 Thread viktor . ransmayr
Hello community,

I'm trying to continue my journey into the various Qubes OS options from 
the smaller - and not - from the larger template POV.

I'm not asking for any additions to the provided packages available for 
example in 'fedora-31-minimal'.

All I'm asking for is help to resolve the following question: 


*What do I need to do in order to activate / enable the copy / paste 
pattern via copy-c/v for xterm?*
I do know, that this is not a Qubes OS specific question - but - it seems 
to be a Qubes OS/ Minimal TemplateVM related question.

I tried several options recommended to me, when I searched the Internet for 
"copy text from xterm [fedora]". - Unfortunately w/o success :-(

Additional information, just for the record:

I created a qube, which I called 'f31-min-test-vm' based on the template 
'fedora-31-minimal'

I start the xterm - and - would like to retrieve the content of all all 
installed packages, i.e. 'rpm -qa | sort', to start adding necessary 
packages for my use-case(s) ...

Again for information only:

When I execute 'rpm -qa | wc - l' in an xterm, it reports only

* 431 for 'f31-min-test-vm' - but -
* 1142 for 'f31-test-vm' ...


*Any suggestions to my initial question?*

With kind regards,

VR

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c9dfac76-2e5b-4d89-8675-aad2647d97e2%40googlegroups.com.


Re: [qubes-users] X Startup Failed, Aborting Installation. Pane is Dead.

2020-05-29 Thread Peter Funk
Hello Dennis,

dennisjmen...@gmail.com schrieb am Donnerstag, den 28.05.2020 um 21:58:
> Full transparency, I’m completely new to Qubes. So treat me like I’m an 
> idiot. 
> 
> I’ve dd’d the iso onto my usb 3.0 drive using Rufus.
> 
> When I run the installer legacy it opens the installer GUI. 
> 
> I’ve tried:
> • regular install of R4.0.3. 
> • test this media and install Qubes R4.0.3
> • ran UEFI text only installer. 
> • different usb drives. (But same brand.)
> • different USB ports 
> 
> Always, I get the message:
> X startup failed, aborting installation. 
> 
> Any help would be greatly appreciated! Thanks so much!

You could try another Live-Linux Distro (for example fedora) to
find out, whether your graphics hardware is supported by Linux at all.

See 
https://docs.fedoraproject.org/en-US/quick-docs/creating-and-using-a-live-installation-image/index.html
for more information.

Best regards, Peter Funk
-- 
Peter Funk ✉:Oldenburger Str.86, 2 Ganderkesee, Germany; :+49-179-640-8878 
✉office: ArtCom GmbH, Haferwende 2, D-28357 Bremen, Germany
☎office:+49-421-20419-0 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20200529103811.GA22715%40pfmaster-P170EM.


Re: [qubes-users] Multiple X sessions in Dom0?

2020-05-29 Thread Frédéric Pierret


On 2020-05-29 02:34, brendan.h...@gmail.com wrote:
> Can Qubes support multiple X sessions in dom0?

I guess you want to see VMs in separate X sessions. Without speaking of user 
management, yes it can but currently gui-daemon is running on DISPLAY=:0 
waiting for all VM start/shutdown and starting a proper server for them. In 
your case of having multiple DISPLAY, that would mean to adapt the automatic 
start of each deamon per VM.

I would say, wait or try the (undocumented) GuiVM implementation in R4.1, that 
would ease such use-case/management..
 
> e.g. default session on primary terminal (via ctrl-alt-f1), then start 
> another session on the third pty (ctrl-alt-f3) after logging in as the 
> primary qubes user in dom0?
> 
> B
> 

Best,
Frédéric

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/d486161a-8ba4-cc22-3fad-aeb864a71176%40qubes-os.org.


signature.asc
Description: OpenPGP digital signature


Re: [qubes-users] Multiple X sessions in Dom0?

2020-05-29 Thread donoban
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On 2020-05-29 02:34, brendan.h...@gmail.com wrote:
> Can Qubes support multiple X sessions in dom0?
>
> e.g. default session on primary terminal (via ctrl-alt-f1), then
> start another session on the third pty (ctrl-alt-f3) after logging
> in as the primary qubes user in dom0?
>

Generally Qubes is not multi-user system since the user who controls
dom0 has full access to everything. As a linux based system you could
do something for getting it but it will break things.

Or do you mean multiple X sessions with the same user?
-BEGIN PGP SIGNATURE-

iQIzBAEBCAAdFiEEznLCgPSfWTT+LPrmFBMQ2OPtCKUFAl7Q4LIACgkQFBMQ2OPt
CKWEOhAAt3e7ZTgIv0/Io/sUsGqYW7mfgLZ2NFICS+cNP6v4b4zqdR/wlsP4lnbH
x914QzIBxMUMtn8HLIdY29YLj4i2azLMZWok3xNTk4wyp6qTS2ekEOJC3o8fWc9b
0/jCf0IoZyBXp666iiv6cIeGFiMOqzazE3W5rKY2BvdvFdubqUx4tzxpn8dzoM1k
ziTyLmrOimFeixrrqxek/4Go8fL6eG9AiPoYfwUVp+PenZKpWPehzurvWVMGUk+Z
z116RF3yidH1u1mjbI5qRZ4KGcSsiw/Pbc6g9Dmun2S/7m1I40dX7MqUY8Darf+u
8adCdlVDFhGirYqls6ysOZWDipbiiaFab81dCgoc/TYUjG7wPRDd35yimuSzEOSP
EDunzYPKxm0WrXv4xl8j8f3hgz0NILJb/Al97OtYH4feIsUIbVL1k7fdNQWDkFLd
wdGa/dOY6PKq3vnwkvEwvnothuP5OcPp3ILbiPbOcDsGs7T+fNtVTvljxmUQ+wJ4
Qq2+9nrTuWL9S6nzG8t0nnUnK4G62SRuWU8QMgMaYvaK6S4dk4hFCF9CDH0svxWp
3qoA7ts+uR4eT1OHKmN4/LyUO2F5vw+IfuCzRwJOpFhMQ1YPV068qYUAqTOriX0H
o+/UKPYV9lPoaPBe2XDUYcchXGq3eH2KJ1TJzspPfPPjT610Dw4=
=Uhd8
-END PGP SIGNATURE-

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/49ce2293-5a2c-75cf-900e-d2212840cc3a%40riseup.net.