[qubes-users] Trying to build a rchlinux-template, missing dependencies python-sh?

2017-08-11 Thread Richard Brown
Hi,
Im trying to install an archlinux template.
I'm stuck on a dependencies issue with: python-sh

make qubes-vm
\Currently installed dependencies:
git-2.9.4-1.fc25.x86_64
rpmdevtools-8.9-1.fc25.noarch
rpm-build-4.13.0.1-1.fc25.x86_64
createrepo-0.10.3-10.fc25.noarch
debootstrap-1.0.87-1.fc25.noarch
dpkg-dev-1.17.27-1.fc25.noarch
package python-sh is not installed
dialog-1.3-5.20160828.fc25.x86_64
ERROR: call 'make install-deps' to install missing dependencies
Makefile:199: recipe for target 'check-depend.rpm' failed
make: *** [check-depend.rpm] Error 1



[user@Development qubes-builder]$ make install-deps
Redirecting to '/usr/bin/dnf install -y git rpmdevtools rpm-build createrepo 
debootstrap dpkg-dev python-sh dialog' (see 'man yum2dnf')

Last metadata expiration check: 4:03:27 ago on Wed Aug  9 21:08:11 2017.
Package git-2.9.4-1.fc25.x86_64 is already installed, skipping.
Package rpmdevtools-8.9-1.fc25.noarch is already installed, skipping.
Package rpm-build-4.13.0.1-1.fc25.x86_64 is already installed, skipping.
Package createrepo-0.10.3-10.fc25.noarch is already installed, skipping.
Package debootstrap-1.0.87-1.fc25.noarch is already installed, skipping.
Package dpkg-dev-1.17.27-1.fc25.noarch is already installed, skipping.
Package python2-sh-1.12.14-1.fc25.noarch is already installed, skipping.
Package dialog-1.3-5.20160828.fc25.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Sending application list and icons to dom0
Complete!
[user@Development qubes-builder]$ 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/7c9f13d5-7eea-4d7c-96c9-203dca1bc28f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Trying to Build Archlinux Template Qubes 4.0

2017-08-09 Thread Richard Brown
Ive been trying to build archlinux template with make qubes-vm.


This is where I get to.

xen-shared-loop-losetup.patch  is missing?


How do I get this file???


---


==> Starting build()...
+ patch -s -F0 -E -p1 --no-backup-if-mismatch -i 
./patches.qubes/xen-shared-loop-losetup.patch
patch:  Can't open patch file ./patches.qubes/xen-shared-loop-losetup.patch 
: No such file or directory
++ echo '*** patch ./patches.qubes/xen-shared-loop-losetup.patch failed ***'
*** patch ./patches.qubes/xen-shared-loop-losetup.patch failed ***
==> ERROR: A failure occurred in build().
Aborting...
/home/user/qubes-builder/qubes-src/builder-archlinux/Makefile.archlinux:120: 
recipe for target 'dist-package' failed
make[2]: *** [dist-package] Error 2
Makefile.generic:156: recipe for target 'packages' failed
make[1]: *** [packages] Error 1
Makefile:209: recipe for target 'vmm-xen-vm' failed
make: *** [vmm-xen-vm] Error 1




[user@Development patches.qubes]$ ls
libxl-disable-forced-vkb-for-HVM.patch
stubdom-lwip-fix-for-dhcp.patch
stubdom-linux-0004.patch  
stubdom-vbd-non-dom0-backend.patch
stubdom-linux-0005.patch  
vm-0001-hotplug-do-not-attempt-to-remove-containing-xenstore.patch
stubdom-linux-0006.patch  xen-disable-dom0-qemu.patch
stubdom-linux-config-qubes-gui.patch  
xen-hotplug-external-store.patch
stubdom-linux-config-stubdom-mem.patch
xen-hotplug-qubesdb-update.patch
stubdom-linux-fix-need-memory.patch   
xen-libxl-qubes-minimal-stubdom.patch
stubdom-linux-libxl-silence-dm_check_start.patch  xen-no-downloads.patch
stubdom-linux-libxl-soname.patch  xen-stubdom-qubes-gui.patch
stubdom-linux-libxl-suspend.patch xen-tools-qubes-vm.patch
stubdom-linux-pci-add-del.patch   
xenconsoled-enable-logging.patch

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/6264c992-abb3-41ec-974d-84eb036888c0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Qubes 4.0 qubes-templates-community

2017-08-03 Thread Richard Brown
On Thursday, August 3, 2017 at 1:14:32 PM UTC+12, Richard Brown wrote:
> Hello Qubes community.
> 
> I have just installed Qubes 4.0-rc1 on my laptop.
> 
> Im trying to install whonix.
> 
> But when trying to enable the repo is get this error;
> 
> Failed to synchronize cache for repo 'qubes-templates-community', disabling
> Last metadata expiration check: 0:17:28 ago on Thu Aug 3 00:48:06 2017.
> 
> 
> What am I doing wrong??

http://yum.qubes-os.org/r4.0/

>From the looks of it, there is no community-templates atm.
So I'm guessing my solution is to wait.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/061c3aaa-9b88-43ae-a68c-5dd8d2e73385%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Qubes 4.0 qubes-templates-community

2017-08-02 Thread Richard Brown
Hello Qubes community.

I have just installed Qubes 4.0-rc1 on my laptop.

Im trying to install whonix.

But when trying to enable the repo is get this error;

Failed to synchronize cache for repo 'qubes-templates-community', disabling
Last metadata expiration check: 0:17:28 ago on Thu Aug 3 00:48:06 2017.


What am I doing wrong??

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/70bf467f-6fd6-423d-97f7-84929046555a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Qubes 3.2 install problem: Encryption requested for LUKS device sda2 but no encryption key specified

2017-07-07 Thread Richard Brown
Confirmed.
I'm having the same issue.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/ba41803d-7957-47cd-a485-70274d6fbc6e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: [Issue ] Qube Fallback Installer Anaconda

2017-06-15 Thread Richard Brown
Has anyone has any success with the fallback installer?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/00b3c37e-2d34-414d-83a8-d119b8b72146%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Installation from USB fails

2017-06-11 Thread Richard Brown
Have you read?

https://www.qubes-os.org/doc/uefi-troubleshooting/

Id also recommend testing usb drive on another computer to see if it works 
there.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/f3f0425c-0852-4476-9a11-1619dfbc4530%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] [Issue ] Qube Fallback Installer Anaconda

2017-06-08 Thread Richard Brown
Hello everyone,

I've been trying to install Qube R3.2 on my laptop.
I have an Nvidia chip.

I can boot to the fallback installer when I select the troubleshooting option.

How ever I can't seam to get this installer to work.

Option (5) install medium.
>> Select HDD
>> Use all Free Space
>> LUKs

I get this;

Generating update storage configuration
storage configuration failed: autopart failed:
Encryption requested for LUKS device sda2 but no encryption key specified for 
this device.


I have tryed every type Partition Scheme available.
But always seam to get this issue.

Is this a BUG?  

I expect it to prompt for for the keys but this doesn't happen?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/9ac60963-b8eb-4159-aefc-2d3e8f1ef0a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.