Re: [qubes-users] Suggestions as a user

2020-08-14 Thread acharya . sagar . sagar5
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 But one can't trust Intel right? How can one be sure that tests and warnings generating code is not malware. Open code is the 1st requirement for security right?! I don't think hidden security enhancing code is really enhancing security. Qubes

[qubes-users] Suggestions as a user

2020-08-12 Thread acharya . sagar . sagar5
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Hello guys, I would like to suggest a few changes and while you may not have them in qubes by default, I ask you to give an option to the users such that they be able to make it easily. With GUI VM coming in 4.1, I request you to have linux-libre

[qubes-users] Nitropad Intel ME neutering

2020-03-08 Thread acharya . sagar . sagar5
Disabling Intel ME completely will shut off the processor completely and so, the malicious part of the code has been suppressed according to the information given in the below link https://github.com/osresearch/heads-wiki/blob/master/Clean-the-ME-firmware.md Does ME cleaning achieve removing

Re: [qubes-users] Neither WiFi card nor USBs work

2019-10-02 Thread acharya . sagar . sagar5
Qubes was meant to be for end users who wanted to be more secure, it wasn't meant for security experts or expert coders who would want to edit files and configure things for themselves. Without a doubt, the 4.0 version of Qubes hasn't been managed well. Updating dom0 with meant to be stable OS

[qubes-users] sudo root or sudo bash without password for building Qubes

2019-09-28 Thread acharya . sagar . sagar5
I tried to make things work using Qubes built iso but the updates (dom0) instead of stabilizing the system, broke it. I couldn't boot up! I'm trying to build Qubes in which I face problem in making "sudo bash" run without password. While there are some solutions which ask to make edit in

Re: [qubes-users] Neither WiFi card nor USBs work

2019-09-26 Thread acharya . sagar . sagar5
It is kernel doesn't support reset from sysfs for PCI devices and many more probably irrelevant things. I'm updating to Fedora 30 now. Mostly it should update the driver. On Thursday, September 26, 2019 at 5:03:49 PM UTC+5:30, awokd wrote: > > acharya.s...@gmail.com : > > I did it using GUI

Re: [qubes-users] Neither WiFi card nor USBs work

2019-09-26 Thread acharya . sagar . sagar5
I did it using GUI earlier. I again tried using permissive=true in dom0 terminal and started sys-usb. I still get the error. libxenlight failed to create new domain 'sys-usb' Updated dom0 using ethernet cable. Still broadcom WiFi and USBs do not work. On Wednesday, September 25, 2019 at

[qubes-users] Neither WiFi card nor USBs work

2019-09-25 Thread acharya . sagar . sagar5
I've made a fresh install of Qubes OS on my Laptop where I face the problem of configuring USB and network devices to VMs It's quite similar to https://groups.google.com/forum/#!searchin/qubes-users/balance_when_enough_memory|sort:date/qubes-users/8Q4bc_51fyc/r6Lkd299BwAJ When I add 00:14.0

Re: [qubes-users] Structure of qubes

2019-03-12 Thread acharya . sagar . sagar5
I mean Fedora 29 qube above, not template. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscr...@googlegroups.com. To post to this group, send

Re: [qubes-users] Structure of qubes

2019-03-12 Thread acharya . sagar . sagar5
Can someone from the qubes managers please try yumdownloader --resolve xorg-x11-drv-nvidia yumdownloader --source nvidia-kmod sudo dnf install kernel-latest-devel-4.20.3-1.pvops.qubes.x86_64.rpm rpm-build kmodtool sudo rpmbuild --nodeps -D "kernels 4.20.3-1.pvops.qubes.x86_64" --rebuild

Re: [qubes-users] Structure of qubes

2019-03-11 Thread acharya . sagar . sagar5
I tried booting up with just the APU plugged in and found out that the recent kernel is also not compatible with the APU providing the graphics. My sys-firewall and sys-whonix wouldn't start. I went back to square 1, installing NVIDIA drivers in dom0 with rpm and found that earlier I was using

Re: [qubes-users] Structure of qubes

2019-03-04 Thread acharya . sagar . sagar5
> lsmod confirms that is LKM : you can also check by looking in > /proc/modules Thank you. I'm on it! :D I'm not switching back to Ubuntu, I'm getting things done here. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this

Re: [qubes-users] Structure of qubes

2019-03-03 Thread acharya . sagar . sagar5
> Not sure of the answer, but all you should have to do to use that option > is add it to your kernel= line. I think this is an important decision. I need to be sure. There are 2 different ways to proceed as shown here... https://wiki.xen.org/wiki/Xen_PCI_Passthrough It maybe a point of no

Re: [qubes-users] Structure of qubes

2019-03-03 Thread acharya . sagar . sagar5
Thanks awokd, Is xen-pciback compiled in the kernel or is it compiled as a module in qubes? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

Re: [qubes-users] Structure of qubes

2019-03-03 Thread acharya . sagar . sagar5
I updated the kernel of dom0 to 4.20 and qubes booted with Integrated Graphics from Ryzen APU as in one of the earlier posts. When I change the NVIDIA pci device (VGA compatible controller) from dom0 to fedoraDev template, my system crashes which means it's using GTX 1060 as graphics after

Re: [qubes-users] Structure of qubes

2019-03-02 Thread acharya . sagar . sagar5
I dug many things. The docs on qubes official site are old. I tried both the ways to install my NVIDIA GTX 1060 and the problem is even after installing, it's unclear whether I would be able to use it outside dom0. I found a better method. I have a Ryzen 3 2200G APU which I intend to use for

Re: [qubes-users] Structure of qubes

2019-02-28 Thread acharya . sagar . sagar5
Yes, unman, it was installed in /home/user I made /tmp/site_packages and added a line export PIP_TARGET='/tmp/site_packages' in ~./bashrc Now, pandas is installed in /tmp/site_packages and pip3 freeze doesn't even detect it in template. Anyways, it looks solvable. I can't get around

[qubes-users] Structure of qubes

2019-02-28 Thread acharya . sagar . sagar5
I wanted to understand the tree structure of qubes. So my guess is this. dom0 is the owner of every other thing. There are 4 template VMs, fedora, debian, 2 whonix ones. When a domain restarts, it takes it settings from the template on which it is based and it's own home directory and other

Re: [qubes-users] How to connect to usb tethering of my mobile to sys-net qube

2019-02-25 Thread acharya . sagar . sagar5
Solved the tethering problem. Stuart pointed the solution out but I used it after understanding a few things. Tethering is automatically configured by the qube in which the USB bus exists. So, we just have to make sure that the USB exists in that VM. I made sys-usb because I didn't think

Re: [qubes-users] How to connect to usb tethering of my mobile to sys-net qube

2019-02-25 Thread acharya . sagar . sagar5
On Monday, February 25, 2019 at 10:32:34 PM UTC+5:30, acharya.sa...@gmail.com wrote: > This is harder than it looks guys. I got my WiFi adapter today. > > I found out that sys-net already has USB 2.0 assigned in it(Bus 001). lsusb > under sys-net gives them. I plugged my wifi adapter in 2.0 USB

Re: [qubes-users] How to connect to usb tethering of my mobile to sys-net qube

2019-02-25 Thread acharya . sagar . sagar5
This is harder than it looks guys. I got my WiFi adapter today. I found out that sys-net already has USB 2.0 assigned in it(Bus 001). lsusb under sys-net gives them. I plugged my wifi adapter in 2.0 USB (Bus 001) still I don't get any connection. I tried making sys-wifi assuming sys-net will

Re: [qubes-users] How to connect to usb tethering of my mobile to sys-net qube

2019-02-22 Thread acharya . sagar . sagar5
Stuart, I read things on tethering earlier and there's no clear indication that the people were able to solve the problem and get the connection. So I have ordered a WiFi adapter and I'll install it in a couple of days reading relevant sources. Regarding USB, there's a nice GUI + sign tool on

Re: [qubes-users] How to connect to usb tethering of my mobile to sys-net qube

2019-02-21 Thread acharya . sagar . sagar5
I don't have a sys-usb. If I assign my usbs to sys-usb, then how will the net VM have access to it? Also according to Joanna here, networking stacks lie in NetVM https://blog.invisiblethings.org/2017/10/03/core3.html So I want to move my USB bus of the mobile connection to sys-net. When I tried

[qubes-users] How to connect to usb tethering of my mobile to sys-net qube

2019-02-20 Thread acharya . sagar . sagar5
I understand that the other VM which have firewall as their NetVM get the network which gets filtered through firewall VM to secure the system. The firewall system in turn receives network from sys-net. I connected my mobile and flipped the switch of USB tethering but am not sure how to

[qubes-users] Pane is dead error

2018-09-28 Thread acharya . sagar . sagar5
To add, I haven't installed any drivers yet Because i haven't been able to install any OS yet -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] Pane is dead error

2018-09-28 Thread acharya . sagar . sagar5
I am using integrated Vega graphics in AMD Ryzen 3 and my installer fails to load xen. CPU 2 and CPU 3 error is shown as I can see in statements. When I tried both options "install Qubes4.0" and "test media and install qubes 4.0", I ultimately get to pane is dead. Please help me. It's a new pc