[qubes-users] Re: I can't install Qubes 4.0

2018-05-07 Thread velcro
Do you have VT-x enabled? I managed to get mine installed when I changed the LCD/Display settings in the BIOS. This is not my strong point but it sounds like you are close... -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe

[qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-05-07 Thread velcro
> > 1) > can you update your templates otherwise? Yes I can update my templates > 2) > sudo apt-get install openvpn should have nothing to do with the later > step of install the tasket scrip-let . (not the tunnel) just > the VPN script on GitHub I was just hoping to make sure

Re: [qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-05-05 Thread velcro
Strangest thing, I did a fresh installation of Qubes and now I can't get this to work again? Sorry for the basic question but is there something I need to do to the fresh debian template after installation? I am trying to eliminate all possible issues but to install OpenVPN to the debian

[qubes-users] Re: I can't install Qubes 4.0

2018-05-05 Thread velcro
Having struggled with installation I have found trying different BIOS settings helps. Even what I thought was the most unrelated change in the BIOS sometimes worked including: Legacy only Turning off secure boot LCD settings Boot order I wish I had a specific answer but have you tried changing

Re: [qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-04-30 Thread velcro
Sorry correction to my notes: Using qTunnel: For Debian proxy, add OpenVPN package to your VPN template: su apt-get update && apt-get install openvpn unzip Download and transfer file to template https://github.com/tasket/qubes-tunnel.git cd “Then drag downloaded file into terminal from

Re: [qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-04-30 Thread velcro
Here are my notes/instructions I made based on yours, I drag and drop some files into terminal(vs purely command lines): Using qTunnel: For Debian proxy, add OpenVPN package to your VPN template: su apt-get update && apt-get install openvpn unzip Download and transfer file to template

Re: [qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-04-30 Thread velcro
Adding this to my config: setenv tunnel_dns '208.67.222.222 208.67.220.220' instead of: setenv vpn_dns '208.67.222.222 208.67.220.220' worked. Both http://welcome.opendns.com/ and https://www.dnsleaktest.com/ show that OpenDNS are being used. I am more then happy to help test, I was

Re: [qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-04-29 Thread velcro
Using debian 9, link indicates "Link is up", I get internet connection, https://www.dnsleaktest.com/ indicates my VPNs IP(despite "setenv vpn_dns '208.67.222.222 208.67.220.220'" in my vpn configuration) when I use this configuration... V -- You received this message because you are

Re: [qubes-users] Re: ANN: Testing new VPN code for Qubes

2018-04-29 Thread velcro
Chris/Tasket, I am currently using this version: https://github.com/tasket/Qubes-vpn-support "Master version" I have this running in a proxy AppVM (Not in a template) Using PIA VPN service OpenDNS checks out OK I just tried this version in 4.0 in the template. Some notes feedback: 1) When

[qubes-users] The best compromise for a Laptop (Balance security with reality of implementation)?

2018-04-15 Thread velcro
I am exploring the best Qubes laptop based on the following criteria: 1) Secure/Privacy 2) Usability and maintenance for the layman in need of security 3) Price 4) New laptop Based on my research the most secure would be: Older laptops: G505 x220 T420 W520/W530 Pro: -price/value -Coreboot

[qubes-users] Errors on booting 4.0 and time is off? Otherwise working great!

2018-04-15 Thread velcro
I am getting ACPI errors when I boot, everything works, or at least I haven't seen a functionaility issue. I am however concerned and trying to understand implications from a functonal and security perspective. The errors are: [ 1.] ACPI Error: [\_PR_.CPU0._CST] Namespace lookup

[qubes-users] Stock firewall vs a new created firewall in 4.0?

2018-04-14 Thread velcro
I created a new sys-firewall from the one that came with the installation of 4.0...is there anything special I need to do to make this the same as sys-firewall in terms of configuration? Its working: New appvm, provides networked=checked, connected to sys-net is what I did to create it.

[qubes-users] Re: Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-14 Thread velcro
Manage to get this working on 4.0 using the Master! Below are my abreviated steps: Using Master File from Tasket Create proxy using VPN template: sys-VPN Green Provides Network Checked connect to sys-net Launch settings - Checked Settings: Add files and Terminal to Applications Add

[qubes-users] Re: HCL - Lenovo Thinkpad T480

2018-04-14 Thread velcro
Thanks for sharing...my understanding is you can get this Laptop new? Not sure if you know but this can come with either these processors: 8th Generation Intel® Core™ i7-8550U Processor (1.80GHz, up to 4.0GHz with Turbo Boost, 8MB Cache) or 8th Generation Intel® Core™ i7-8650U Processor

Re: [qubes-users] Re: Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-09 Thread velcro
Chris, I tried the Master and it didn't work, following your guidleines(and trying mine above). The Qubes4.0 version does work... Using a Debian template, setup entirely in a AppVM, using 4.0, I follow the instructions on Github: https://github.com/tasket/Qubes-vpn-support. After step 2 in

Re: [qubes-users] Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-08 Thread velcro
Correction to instructions I followed: Create proxy using VPN template: sys-VPN Green Provides Network Checked connect to sys-net Launch settings - Checked Settings: Add files and Terminal to Applications Initial memmory = 500mb Max memory = 4500 Add “vpn-handler-openvpn” to services Open a

Re: [qubes-users] Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-08 Thread velcro
Once again Tasket/Chris thanks for the help...got it working with both Debian and Fedora in 4.0 running as a Appvm. The issue was in the .conf file/password linking and the order I was doing this. I think my debian issue was not having openvpn in the debian template. Is Qubes4 still the file

Re: [qubes-users] Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-06 Thread velcro
> > I pulled the logs, looked thru them, I didn't see any personal information. > > Seemed OK to past on the forum but sent them to you directly just in > > case...feel free to post any info for the greater good of the community. > > Thank you again for the help... > > > > I pulled the 3

Re: [qubes-users] Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-06 Thread velcro
I pulled the logs, looked thru them, I didn't see any personal information. Seemed OK to past on the forum but sent them to you directly just in case...feel free to post any info for the greater good of the community. Thank you again for the help... I pulled the 3 files .crt, .pem and the

Re: [qubes-users] Error: Failed to synchronize cache for repo 'qubes-vm-r4.0-current' with Fedora and 4.0?

2018-04-06 Thread velcro
Worked like a charm! Thanks... -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscr...@googlegroups.com. To post to this group, send email to

Re: [qubes-users] Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-06 Thread velcro
Thanks Chris...again thank you for the effort! This tool is great... Does it matter that Private internet access provides 3 seperate files (key, cert and client config)? I have the proxy AppVM set up with "provides network"(proxy) checked, I have tried a setup in proxy only and a setup in

[qubes-users] Error: Failed to synchronize cache for repo 'qubes-vm-r4.0-current' with Fedora and 4.0?

2018-04-05 Thread velcro
I think there is an issue with Fedora updates thru TOR... Any body willing to share the specific commands or instructions to change an update file from http to https? Here is the thread: https://github.com/QubesOS/qubes-issues/issues/3737 A potential solution was: "Try to modify

Re: [qubes-users] Re: Help with 4.0 transition from 3.2?

2018-04-05 Thread velcro
Sorry lots of questions in 1 thread but thank you all for the responses: Question 1- The ACPI errors were: ERROR parsing PCC subspaces from PCCT [Failed] Failed to start Load Kernel Modules - Followed by [OK] started Apply Kernel Variable/[OK] Started Setup Virtual Console ACPI error: parse

[qubes-users] Qubes 4.0 and Private Internet Access? Tasket VPN solution...

2018-04-05 Thread velcro
I thought I would start a new thread, I had Taskets VPN solution working like a charm with 3.2 but when I transitioned to Qubes 4.0 it no longer worked. I did manage to get it working but I didn't capture my steps:( 3.2 thread: https://groups.google.com/forum/#!topic/qubes-users/FUQaRPWXPj8 I

[qubes-users] Help with 4.0 transition from 3.2?

2018-04-03 Thread velcro
I recently transitioned to the new 4.0thank you Qubes Developers and Community for the effort and help. I really appreciate the better security. I managed to get 4.0 installed however I am having some challenges and concerns: 1) I am getting numerous ACPI erros when I boot? 4.0 seems to

Re: [qubes-users] how to add "Files" manually to AppVM

2018-03-27 Thread velcro
In Debian you need to install it: su apt-get install nautilus By no means an expert...but I struggled with this in the Debian template AppVMs. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving

Re: [qubes-users] Re: Setting up privateinternetaccess on qubes 3.2

2018-03-27 Thread velcro
My Fedora setup is still working great. Passes OpenDNS check when they are added to config, reconnects generally after I turn off my wireless. I am trying to get this to work with a stock Debian9 template(upgraded from Debian8 with stock install). I can't seem to get it to work with Debian,

Re: [qubes-users] Spilt-GPG help - 3.2

2018-03-27 Thread velcro
I am not sure if the "Split-GPG" is for email signing and encryption only but I am being prompted to enter a password for a VM that I use for email. Is this expected? I like the idea of a password to access this VM but is there a better way to secure this? -- You received this message

[qubes-users] Enhancing Template security?

2018-03-25 Thread velcro
I am trying to harden my Fedora and Debian templates and was hoping for some basic help and commands to do the following: How would I enable sudo authentication in a Template? How would I add a service like Qubes-VM-hardening ? Should I enable AppArmor in a template and VM? Any other

[qubes-users] Spilt-GPG help - 3.2

2018-03-25 Thread velcro
I love Qubes! Kudus to those developing and helping on this forum...I am sure others would agree that the effort is greatly appreciated. I am hoping I can get some help with "split-GPG" setup and signing emails. Some notes and questions about my configuration: * I plan to use Thunderbird. * I

Re: [qubes-users] Re: Setting up privateinternetaccess on qubes 3.2

2018-03-06 Thread velcro
Pretty slick Chris... I just reconfigured with your Qubes4 (https://github.com/tasket/Qubes-vpn-support/tree/qubes4)...I assume it defaults to 1.4beta2. I added the following to the PIA OpenVPN config file: setenv vpn_dns '208.67.222.222' ...at the bottom of the config file and hit "save".

Re: [qubes-users] Re: Setting up privateinternetaccess on qubes 3.2

2018-03-05 Thread velcro
Again I have been using the Tasket VPN setup with Fedora 26 for a few weeks and it works well...love the kill switch element! I was hoping to beef up the security(maybe compromise the privacy) of the VPN service by adding OpenDNS or Quad9 DNS addresses to this configuration. My questions I was

Re: [qubes-users] Anonymizing your MAC Address with macchanger and scripts

2018-02-28 Thread velcro
Chris if you could replicate the simplicity in your instruction for a "kill-switc-VPN" for the this feature that would be awesome... This seems like a great feature...I am getting up to speed on the Linux commands but I suspect a lot of the laypeople(who likely need the security) would

Re: [qubes-users] High spec laptop for Qubes OS

2018-02-24 Thread velcro
I know they were volunteered recalled but could be an opportunity for good refurb pricing... -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

Re: [qubes-users] High spec laptop for Qubes OS

2018-02-24 Thread velcro
I think a Lenovo is the way to go...the Qubes developers use them, the X1/Gen5 was mentioned as being popular with them. I googled and Max Ram is 16, however I went from 8-12 and more then satisfied with improvement. I wanted the X1 but thought it was out of my budget and thought I would look

[qubes-users] What does an AEM alert look like?

2018-02-24 Thread velcro
Curious as to what to look for with an AEM alert? Is there log? Does it alert you when you boot? Appreciate any thoughts... Thanks, V -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails

[qubes-users] Re: Proxy/firewall VM with template fedora-26-minimal non-functional

2018-02-23 Thread velcro
Try downloading a fresh fedora 26 template: https://www.qubes-os.org/news/2018/01/06/fedora-26-upgrade/ -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

Re: [qubes-users] Problem installing Qubes on Lenovo Thinkpad T450s

2018-02-22 Thread velcro
I am trying to load 3.2 onto a T450s, I'd like to keep Legacy mode as it allows me to have AEM. I was able to install using the same thumb(created using dd) on another computer, no problems, however I keep going back to "Test and install 3.2" when trying to load Qubes onto a T450s. I saw some

Re: [qubes-users] Problem installing Qubes on Lenovo Thinkpad T450s

2018-02-22 Thread velcro
I am trying to load 3.2 onto a T450s, I'd like to keep Legacy mode as it allows me to have AEM. I was able to install using the same thumb(created using dd), no problems, however I keep going back to "Test and install 3.2" when trying to load Qubes onto a T450s. I saw some users having

Re: [qubes-users] Re: Setting up privateinternetaccess on qubes 3.2

2018-02-14 Thread velcro
Thank you Tasket\Chris... Thanks for the education on trust/veracity/trustworthiness with Github. You and the Qubes team are doing a good thing! I really appreciate all the help... Thank you! V -- You received this message because you are subscribed to the Google Groups "qubes-users"

Re: [qubes-users] Re: Setting up privateinternetaccess on qubes 3.2

2018-02-13 Thread velcro
Thanks Chris(and "tasket"!)took me a few tries but I managed to get it going, I tweaked the implementation a bit(scarey). I was not however able to get this command going from step #3 of the Github guide: sudo /usr/lib/qubes/qubes-vpn-setup --config I doubt I did this right/well but when

[qubes-users] Re: Setting up privateinternetaccess on qubes 3.2

2018-02-12 Thread velcro
I have tried, tried, tried ...and tried and I am over my head! (Fedora 26, Qubes 3.2) I am stuck I tried this: https://www.qubes-os.org/doc/vpn/ and this, this was a pretty good video but unfortunately its not the same as PIAs config.: https://www.youtube.com/watch?v=K1_zqT7_N7k (Nice

Re: [qubes-users] Re: Is a legacy BIOS preferable to UEFI for a secure system?

2018-02-01 Thread velcro
Is legacy BIOs still preferred and likely compatible with 4.0 when final? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] Re: Qubes update to fedora 26 but dnf still using fedora 23 repo

2018-02-01 Thread velcro
When you say upgraded did you install a fresh fedora 26 template? https://www.qubes-os.org/news/2018/01/06/fedora-26-upgrade/ I think the advice is not to "upgrade" from fedora 23 but to install a fresh template. Not sure thats your issue...if not I am not sure how to correct. Qubes rocks!

Re: [qubes-users] noscript xss warning on qubes os site

2018-02-01 Thread velcro
I got it in Fedora 26 appVM as well but the website was fedora.org. I am using 3.2... -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] DebianTemplate for DVM with additional software is flagging an update(despite already updated)? 3.2

2018-01-17 Thread velcro
Running Qubes 3.2the Debian Template I created for printing is showing an update is needed in my GUI interface (Green arrow pointing down). I updated this template and other Debian templates but my printer template keeps showing an update is needed? *Tried an update again from GUI-Terminal

[qubes-users] Re: Just installed AEM(Anti-Evil-Made)...see an error:(

2018-01-14 Thread velcro
Managed to find what was causing the error and how to remove the error: https://askubuntu.com/questions/778875/tpm-error-6-when-booting-thinkpad https://bugzilla.redhat.com/show_bug.cgi?id=1413409 In my BIOS I went to Security -> Security Chip -> Security Chip set to "Active" However this

[qubes-users] Re: how to reinstall template? (i think it's not enabled by repo)

2018-01-13 Thread velcro
No expert, but try: sudo yum remove qubes-template-whonix-ws then sudo qubes-dom0-update --enablerepo=qubes-templates-community \ qubes-template-whonix-ws You might have tried this but I had to do the whonix reinstall myself Source: https://www.qubes-os.org/doc/templates/

[qubes-users] Just installed AEM(Anti-Evil-Made)...see an error:(

2018-01-13 Thread velcro
I have been running Qubes for a few months now, numerous 3.2 installs, most recent install was a month or so ago on the the same PC. I just installed AEM for the first time. Everything still works, however in my BIOS I had "enabled" the ability to see notes/alerts during boot. Before I

Re: [qubes-users] Re: Basic setup verification tests for correct setup? VT-d? Other?

2018-01-13 Thread velcro
Thank you awokd and Yethal...learned a lot! -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscr...@googlegroups.com. To post to this group, send

[qubes-users] Re: Basic setup verification tests for correct setup? VT-d? Other?

2018-01-13 Thread velcro
Thank you, a lot quicker results...the results were: XEN Intel VT-d iommu 0 supported page sizes: 4kB XEN Intel VT-d iommu 1 supported page sizes: 4kB XEN Intel VT-d Snoop Control not enabled XEN Intel VT-d Dom0 DMA Passthrough not enabled XEN Intel VT-d Queued Invalidation enabled XEN Intel VT-d

[qubes-users] Basic setup verification tests for correct setup? VT-d? Other?

2018-01-13 Thread velcro
I am hoping some folks can help me with some basic tests and commands to verify my Qubes 3.2 is set up correctly: I ran a qubes command in Dom0 to verify if VT-d is working(https://www.qubes-os.org/doc/security-guidelines/): qubes-hcl-report AppVM (Name of "AppVM" I was running) The results

[qubes-users] AEM? USB devices? Love the name but need guidance...running 3.2

2017-12-19 Thread velcro
I have read the instructions here: https://www.qubes-os.org/doc/anti-evil-maid/ In dom0: sudo qubes-dom0-update anti-evil-maid ...but still a little unsure how and where to set up AEM? My setup is as follows: a) I have setup a sys-usb with 2 devices selected in VM settings(working well!) b) I

Re: [qubes-users] Trying to get my head around a configuration for a VPN-Proxy VM and its firewall?

2017-12-15 Thread velcro
I have scenario #1 working...I checked DNS leak and was able to get different results depending on the VM I was on. Is this just likely to break due to the bug you reference? Scenario 2 was supposed to depict 3 separate sys-net, not running at the same time. clarified as follows: Clarrified

[qubes-users] Re: Trying to get my head around a configuration for a VPN-Proxy VM and its firewall?

2017-12-15 Thread velcro
I just wanted to clarify my questions...I made some edits: > Scenario #1 > VM---sys-vpn--\ >\ > \ > VM-sys-firewall---sys-net > / > / > VM-/ > > > > Scenario #2 >

[qubes-users] Trying to get my head around a configuration for a VPN-Proxy VM and its firewall?

2017-12-15 Thread velcro
Scenario #1 VM---sys-vpn\ \ \ VM-\sys-firewall---sys-net / / VM---/ Scenario #2 VM--sys-vpn--sys-firewall---sys-net(Wireless and ethernet)

Re: [qubes-users] R3.2: Debian 9 template fails to update 50% of the time

2017-12-09 Thread velcro
Thank you both! Not sure if thanking on this forum is appropriate as the post goes to the top but thanks anyway! Learnt a lot! -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it,

[qubes-users] Trying to download new Whonix templates and fedora 23 gets updated?

2017-12-09 Thread velcro
I am trying to download new whonix templates and I get the following(abbreviated): Time sync failed! - Exiting Using sys-firewall to download updates for Dom0... I then get (in red text) Qubes Templates repository Fedora 23... Qubes Dom0 Repository Fedora 23... No Packages downloaded

Re: [qubes-users] R3.2: Debian 9 template fails to update 50% of the time

2017-12-08 Thread velcro
I am struggling with this same issue...I find that after a restart I can do the update but wanted to do this right. I checked the link posted above: "User-initiated updates/upgrades may not run when a templateVM first starts. This is due to a new Debian config setting that attempts to update

[qubes-users] Optimize my Lenovo T420 BIOS (or settings when I hit “ThinkVantage” during start-up)

2017-12-01 Thread velcro
I wanted to start by thanking all those who have made Qubes possible….the idea of a “reasonably” secure operating system is such a great thing! Not only do I think I am more secure but I feel more secure...again thank you! I am hoping some folks can help me harden and optimize my hardware/OS

Re: [qubes-users] Printer working with Debian DVMs but not when opening up a doc in a DVM from e.g. Work VM?

2017-11-29 Thread velcro
I am not sure of the pros and cons but I actually think its OK and makes sense. I like the restricted DVM having restrictions. Thanks again...and thanks Qubes team! -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this

Re: [qubes-users] Printer working with Debian DVMs but not when opening up a doc in a DVM from e.g. Work VM?

2017-11-29 Thread velcro
I managed to work it out! It is a wireless printer...thank you Unman...you rock! However my trouble shooting brought up another question: It appears as if the DVM launched from "work" inherits the firewall settings from "work"? Is that to be expected? All I needed to do was add my printers IP

[qubes-users] Printer working with Debian DVMs but not when opening up a doc in a DVM from e.g. Work VM?

2017-11-28 Thread velcro
I am using Qubes 3.2, I have a dedicated Debian Template for my more trusted VMs and a separate dedicated Debian Template for my DVMs with printer drivers installed. This is tricky but I will try to explain: I managed to get my printer set up using a Debian Template(printed Test Page fine

Re: [qubes-users] Copying file from Debian8(or Whonix) to a Fedora VM?

2017-11-22 Thread velcro
Ahhh...space bar! I think I tried every key except the biggest oneit worked! All working...thank you both and thank you to all who have made this OSS package possible! Probably going to try a fresh install again and start from scratch just to make sure. My only concern is I have Firefox

Re: [qubes-users] Copying file from Debian8(or Whonix) to a Fedora VM?

2017-11-21 Thread velcro
Thank you both for taking the time to help... Managed to upgrade the template, also managed to get my wifi working on debian-8 template(seems faster now to boot!). I found this post with instructions: 1) sudo apt install firmware-iwlwifi 2) sudo apt update && sudo apt upgrade However I am

Re: [qubes-users] Copying file from Debian8(or Whonix) to a Fedora VM?

2017-11-19 Thread velcro
On Sunday, November 19, 2017 at 4:03:44 PM UTC-6, Chris Laprise wrote: > On 11/19/2017 01:48 PM, v wrote: > > I have been using Qubes 3.2 for about 5 months and love it...thank you all > > who have contributed! > > > > I am a noobie so be gentle...I am also by no means an expert at Linux > >

[qubes-users] Copying file from Debian8(or Whonix) to a Fedora VM?

2017-11-19 Thread velcro
I have been using Qubes 3.2 for about 5 months and love it...thank you all who have contributed! I am a noobie so be gentle...I am also by no means an expert at Linux however I have been forced to learn quick. I managed to upgrade my Fedora template to 25 and have most of my VMs running on