Re: [qubes-users] error device attach failed. no device info received, connection failed.

2018-12-16 Thread 'awokd' via qubes-users

haaber wrote on 12/12/18 1:02 PM:
This happens when I connect my mobile via usb. I have qubes-input-proxy 
installed on sys-usb and untreusted (say), and I can mount other usb 
devices (my backup HD  for example). Did you encouter this problem 
already? Thank you for hints. Bernhard


Yes, some USB devices don't work well with Qubes. If you have a 
free/unused USB controller, you can assign it to your VM but there are 
security tradeoffs.


--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c7ff209f-636b-97bc-5e9c-1c5a7ff8a4fe%40danwin1210.me.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] error device attach failed. no device info received, connection failed.

2018-12-12 Thread haaber
This happens when I connect my mobile via usb. I have qubes-input-proxy 
installed on sys-usb and untreusted (say), and I can mount other usb 
devices (my backup HD  for example). Did you encouter this problem 
already? Thank you for hints. Bernhard


--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/90213f12-d613-0ecd-027d-1ddf8df416ef%40web.de.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] ERROR: Device attach failed

2018-01-27 Thread Ilpo Järvinen
On Sat, 27 Jan 2018, beso wrote:

> On Saturday, January 27, 2018 at 4:33:47 PM UTC+2, awokd wrote:
> > On Sat, January 27, 2018 2:20 pm, beso wrote:
> > 
> > >> On Sat, January 27, 2018 6:31 am, beso wrote:
> > >>
> > >>> ERROR: Device attach failed: /usr/lib/qubes/usb-import: 37: [:
> > >>> Illegal
> > >>> number: stash: printf: I/O error.
> > >>> How to solve this problem?
> > >>>
> > 
> > > Sorry,
> > 
> > No trouble!
> > 
> > > Qubes - 3.2;
> > > Attached device - Samsung M3 Portable 1TB;
> > > Command I used to attach to one of my appVm - qvm-usb -a appvm
> > > sys-net:3-1;
> > 
> > I'm assuming the ";" at the end of sys-net:3-1 is a separator and not
> > actually part of the command you are entering, right? Has this device
> > worked before on your system or is this the first time you are trying it?
> > If it was working before, when did it start giving you the error?
> 
> Yes, that is separator here. No, it never worked.

I'd recommend you use qvm-block instead of qvm-usb (for block capable 
devices such as external HDDs). qvm-block should work even with usb3 
connected devices.

This particular error message you see is caused by a formating change in 
usbip status file for 4.9 kernels that is incompatible what 
qubes-usb-proxy expects.

There's an updated version for qubes-usb-proxy in R3.2 testing repo 
that is capable of getting past this error (but ironically, even there 
there is inconsistency between assumed status file format and what 4.9 
prints but it luckily affects only unused variables). However, qvm-usb 
will fail in R3.2 with even if this error is fixed based on the 
testing I did yesterday: usbip doesn't seem to, e.g., fall-back to 
highspeed but attempts to use superspeed that is only supported starting 
4.13 kernel and you just get a different error message.


-- 
 i.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/alpine.DEB.2.20.1801272200590.9381%40whs-18.cs.helsinki.fi.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] ERROR: Device attach failed

2018-01-27 Thread 'awokd' via qubes-users
On Sat, January 27, 2018 3:00 pm, beso wrote:
> On Saturday, January 27, 2018 at 4:33:47 PM UTC+2, awokd wrote:
>
>> On Sat, January 27, 2018 2:20 pm, beso wrote:
>>
>>
 On Sat, January 27, 2018 6:31 am, beso wrote:


> ERROR: Device attach failed: /usr/lib/qubes/usb-import: 37: [:
> Illegal
> number: stash: printf: I/O error.
> How to solve this problem?
>
>
>>
>>> Sorry,
>>>
>>
>> No trouble!
>>
>>
>>> Qubes - 3.2;
>>> Attached device - Samsung M3 Portable 1TB;
>>> Command I used to attach to one of my appVm - qvm-usb -a appvm
>>> sys-net:3-1;
>>>
>>
>> I'm assuming the ";" at the end of sys-net:3-1 is a separator and not
>> actually part of the command you are entering, right? Has this device
>> worked before on your system or is this the first time you are trying
>> it? If it was working before, when did it start giving you the error?
>>
>
> Yes, that is separator here. No, it never worked.

If you're running through an external USB hub, try a direct port. I've
also seen some people have had trouble with USB 3.0, so use a 2.0 direct
port if possible. If neither of those help, hopefully someone else will
have a better idea!



-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/2abf36b03f29635c6ee1f7566c0c624c.squirrel%40tt3j2x4k5ycaa5zt.onion.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] ERROR: Device attach failed

2018-01-27 Thread beso
On Saturday, January 27, 2018 at 4:33:47 PM UTC+2, awokd wrote:
> On Sat, January 27, 2018 2:20 pm, beso wrote:
> 
> >> On Sat, January 27, 2018 6:31 am, beso wrote:
> >>
> >>> ERROR: Device attach failed: /usr/lib/qubes/usb-import: 37: [:
> >>> Illegal
> >>> number: stash: printf: I/O error.
> >>> How to solve this problem?
> >>>
> 
> > Sorry,
> 
> No trouble!
> 
> > Qubes - 3.2;
> > Attached device - Samsung M3 Portable 1TB;
> > Command I used to attach to one of my appVm - qvm-usb -a appvm
> > sys-net:3-1;
> 
> I'm assuming the ";" at the end of sys-net:3-1 is a separator and not
> actually part of the command you are entering, right? Has this device
> worked before on your system or is this the first time you are trying it?
> If it was working before, when did it start giving you the error?

Yes, that is separator here. No, it never worked.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/2b2e84f6-77f9-4d82-a72e-91e43d6c872a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] ERROR: Device attach failed

2018-01-27 Thread 'awokd' via qubes-users
On Sat, January 27, 2018 2:20 pm, beso wrote:

>> On Sat, January 27, 2018 6:31 am, beso wrote:
>>
>>> ERROR: Device attach failed: /usr/lib/qubes/usb-import: 37: [:
>>> Illegal
>>> number: stash: printf: I/O error.
>>> How to solve this problem?
>>>

> Sorry,

No trouble!

> Qubes - 3.2;
> Attached device - Samsung M3 Portable 1TB;
> Command I used to attach to one of my appVm - qvm-usb -a appvm
> sys-net:3-1;

I'm assuming the ";" at the end of sys-net:3-1 is a separator and not
actually part of the command you are entering, right? Has this device
worked before on your system or is this the first time you are trying it?
If it was working before, when did it start giving you the error?


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/7c63a2dafe233ac59c97f8438aa94f25.squirrel%40tt3j2x4k5ycaa5zt.onion.
For more options, visit https://groups.google.com/d/optout.


Re: [qubes-users] ERROR: Device attach failed

2018-01-27 Thread beso
On Saturday, January 27, 2018 at 3:58:35 PM UTC+2, awokd wrote:
> On Sat, January 27, 2018 6:31 am, beso wrote:
> > ERROR: Device attach failed: /usr/lib/qubes/usb-import: 37: [: Illegal
> > number: stash: printf: I/O error.
> > How to solve this problem?
> 
> Not to sound cranky, but can you review
> https://www.qubes-os.org/mailing-lists/ Discussion list guidelines?
> There's not enough information in your question to be able to answer it.
> For example: Qubes version, type of USB device, speed of USB device,
> command or method you are using to attach it, etc.

Sorry,

Qubes - 3.2;
Attached device - Samsung M3 Portable 1TB;
Command I used to attach to one of my appVm - qvm-usb -a appvm sys-net:3-1;

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/a7284e2d-3eff-4290-b28e-4746f3978853%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] ERROR: Device attach failed

2018-01-26 Thread beso
ERROR: Device attach failed: /usr/lib/qubes/usb-import: 37: [: Illegal number: 
stash: printf: I/O error.
How to solve this problem?


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/b0c6b3d2-f849-40d0-8bb9-1273a92ac55c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.