[qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-23 Thread leonardo . porpora2000
I have got problems on installing qubes r4.0 on the Lenovo pc. I get a kernel panic. Where can I publish the photo of the screen? Please help me :) -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-08 Thread rysiek
Dnia Saturday, January 6, 2018 9:32:20 PM CET Sven Semmler pisze: > On 12/15/2017 03:20 AM, kotot...@gmail.com wrote: > > It does boot but the X server cannot start. Text installation did > > not work. > > Based on swami's post from 9/15/17 I suspect you need kernel 4.9 in > dom0 ... > >

[qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-07 Thread leonardo . porpora2000
Sorry man, My question might be a duplicate but I’m not really good in IT would you be so nice to tell me with which of these components is that laptop compatible HVM IOMMU SLATTPM Xen Kernel Let me know. Thanks very much  Leonardo -- You received this message because you

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-07 Thread kototamo
Thanks everyone for the replies. I finally opted for RC3 and after fixing the iso with a live fedora and livecd-tools it went almost almost without problems. The only problem was that the keyboard layout chosen during the installation was not taken in account for promting the encryption

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-06 Thread Josef Johansson
Just to note this here, we tried to install Qubes 3.2 on a T470p with intel and nvidia graphics, with secureboot off and starting the installer through refind. It all went fine, except that neither ethernet nor wifi was detected ( solvable through fw updates I assume ). X started ok though.

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-06 Thread Sven Semmler
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 12/15/2017 03:20 AM, kotot...@gmail.com wrote: > It does boot but the X server cannot start. Text installation did > not work. Based on swami's post from 9/15/17 I suspect you need kernel 4.9 in dom0 ...

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread Josef Johansson
Sorry, I missed that part of your reply. I was answering both of you :) I'll see if I can get Qubes 3.2 running on my T470p in the weekend if there's time. My collegue ended up with 4.0 with legacy boot to get everything working, so I just started from there. Using it for critical work and so far

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread kototamo
Thank you for your reply. Could you explain to me why using EFI would solve the problem of the X server not starting? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread Josef Johansson
Hi, I would try my path, download rEFInd to another usb-stick and boot the installer from there. The only file you need is the EFI-file: https://sourceforge.net/projects/refind/ Also, that is an interesting data point as well, the bootx64.efi loader on the usb install works if it is started

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread kototamo
Hello everyone, I tried to install Qubes 3.2 on a T470s without success. I have the version with the Intel graphics. I did everything in Legacy Mode (no EFI). It does boot but the X server cannot start. Text installation did not work. Stephan Marwedel says in this thread he managed to install

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-14 Thread pub08goog
OK, here is (I hope) a *public* version of said screen shot: https://photos.google.com/share/AF1QipMRlHUC5EOV-PQD5kfWWfCp9BDroAHDXGAFdWcq_SrmJhfhnHHOF6ZvYU7-JenLOA?key=MlJxWFRyZm1OTHBnWXpHd1pfUXNVYzJjMmJsTlRR (Just learning Google Photo, Google+, gmail, etc., for purposes of this post. Until

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-14 Thread Eric Siegerman
Here's a screenshot of the above-described boot error: https://photos.google.com/photo/AF1QipMO-vL-kcyiORVEZ5P4ydjpdBJwwzzTZ00JuNm1 On Thu, Dec 14, 2017 at 10:04 PM, wrote: > > Does anyone have an idea what the difference livecd-iso-to-disk make, > > compared to isohybrid?

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-14 Thread pub08goog
> Does anyone have an idea what the difference livecd-iso-to-disk make, > compared to isohybrid? If possible, we'd like to installation iso work > out of the box on UEFI systems, including new ones... No, but I have what seems like another data point. On my Lenovo T520 under UEFI, trying to boot

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-04 Thread Andrew Sorensen
On Saturday, December 2, 2017 at 1:02:52 AM UTC-8, Joe Hemmerlein wrote: > On Friday, December 1, 2017 at 2:01:47 PM UTC-8, Stephan Marwedel wrote: > > I have installed Qubes 3.2 successfully on my Thinkpad T470p > > (20J6CTO1WW). This machine is pretty similar to the T470, except > >

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-03 Thread Mike Keehan
On Sun, 3 Dec 2017 03:03:59 +0100 Marek Marczykowski-Górecki wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA256 > > On Sat, Dec 02, 2017 at 01:02:52AM -0800, Joe Hemmerlein wrote: > > Danke, Stephan, your pointers were very valuable! > > > > At first, I

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-03 Thread Joe Hemmerlein
On Saturday, December 2, 2017 at 6:04:08 PM UTC-8, Marek Marczykowski-Górecki wrote: > Does anyone have an idea what the difference livecd-iso-to-disk make, > compared to isohybrid? If possible, we'd like to installation iso work > out of the box on UEFI systems, including new ones... > > I

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-02 Thread Marek Marczykowski-Górecki
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On Sat, Dec 02, 2017 at 01:02:52AM -0800, Joe Hemmerlein wrote: > Danke, Stephan, your pointers were very valuable! > > At first, I decided to just borrow an external DVD drive and boot off a DVD > burned from the ISO, in UEFI mode. The result

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-02 Thread Joe Hemmerlein
On Saturday, December 2, 2017 at 3:41:26 AM UTC-8, Stephan Marwedel wrote: > Now we have a nice recipe to install Qubes on modern Thinkpads. This > should become part of the official documentation. Pull request: https://github.com/QubesOS/qubes-doc/pull/490 -- You received this message because

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-02 Thread Stephan Marwedel
Hi Joe, thanks for the concise summary :-) I actually forgot to mention the necessary changes to the xen.cfg that you correctly described. Now we have a nice recipe to install Qubes on modern Thinkpads. This should become part of the official documentation. Using this recipe will try to

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-02 Thread Joe Hemmerlein
On Friday, December 1, 2017 at 2:01:47 PM UTC-8, Stephan Marwedel wrote: > I have installed Qubes 3.2 successfully on my Thinkpad T470p > (20J6CTO1WW). This machine is pretty similar to the T470, except > that is has a quad-core i7 CPU.  It runs perfectly and all Qubes >

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-01 Thread Stephan Marwedel
I have installed Qubes 3.2 successfully on my Thinkpad T470p (20J6CTO1WW). This machine is pretty similar to the T470, except that is has a quad-core i7 CPU.  It runs perfectly and all Qubes functionality is available on that machine. The installation, however, was not an easy task. 1.

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-01 Thread Mike Keehan
On Thu, 30 Nov 2017 17:10:46 -0800 (PST) Joe Hemmerlein wrote: > On Thursday, November 30, 2017 at 1:37:59 PM UTC-8, Mike Keehan wrote: > > Hi Joe, > > > > This is the content of my EFI/qubes directory after installing > > Qubes 4.0-rc3 in EFI mode :- > > > > -rwxr-xr-x

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-11-30 Thread Joe Hemmerlein
On Thursday, November 30, 2017 at 1:37:59 PM UTC-8, Mike Keehan wrote: > Hi Joe, > > This is the content of my EFI/qubes directory after installing > Qubes 4.0-rc3 in EFI mode :- > > -rwxr-xr-x 1 root root 22231327 Nov 28 17:29 > initramfs-4.9.56-21.pvops.qubes.x86_64.img > -rwxr-xr-x 1 root

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-11-30 Thread Joe Hemmerlein
On Thursday, November 30, 2017 at 11:12:34 AM UTC-8, Tom Zander wrote: > I think its a known issue that Qubes doesn't support EFI. Do you have a reference for that? I don't think that's true. I can run Qubes OS without problems with UEFI on other hardware, and there is even UEFI troubleshooting

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-11-30 Thread Mike Keehan
On Thu, 30 Nov 2017 02:07:56 -0800 Joe Hemmerlein wrote: > Hi, > > so far it was easy to install and run Qubes OS 4.0 RC3 (and RC2) on > this hardware - as long as I keep boot mode on "Legacy Only". > > However, the TPM chip on this hardware works in UEFI boot mode

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-11-30 Thread Rashiq
Hey, Dnia Thursday, November 30, 2017 2:07:56 AM CET Joe Hemmerlein pisze: > I also tried installing Qubes OS 3.2 on this system which didn't work and > initial troubleshooting failed; but I'd like to concentrate my efforts on > making this work for Qubes 4.0 so i didn't spend too much time on

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-11-30 Thread 'Tom Zander' via qubes-users
On Thursday, 30 November 2017 11:07:56 CET Joe Hemmerlein wrote: > However, the TPM chip on this hardware works in UEFI boot mode only I think its a known issue that Qubes doesn't support EFI. It ironically creates an efi partition, but the installer doesn't create the right stuff to actually

[qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-11-30 Thread Joe Hemmerlein
Hi, so far it was easy to install and run Qubes OS 4.0 RC3 (and RC2) on this hardware - as long as I keep boot mode on "Legacy Only". However, the TPM chip on this hardware works in UEFI boot mode only; and even with secureboot disabled and CSM support enabled, I can't get Qubes OS to boot in