Re: [qubes-users] Re: Drive Passthrough not functioning correctly.

2017-01-19 Thread Unman
On Wed, Jan 18, 2017 at 05:22:01PM -0800, Drew White wrote:
> On Thursday, 19 January 2017 12:05:07 UTC+11, 01v3g4n10  wrote:
> > On Thursday, January 19, 2017 at 12:48:17 AM UTC, Drew White wrote:
> > > Hi folks,
> > > 
> > > Here is what I was trying to do..
> > > Pass the drive to the guest.
> > > 
> > > 
> > > [{user}@dom0 {folder}]$ qvm-block -a {vmname} dom0:/dev/sdc
> > > Usage: qvm-block -l [options]
> > > usage: qvm-block -a [options]  :
> > > usage: qvm-block -A [options]  :
> > > usage: qvm-block -d [options] :
> > > usage: qvm-block -d [options] 
> > > List/set VM block devices.
> > > 
> > > qvm-block: error: Invalid device name: dom0:/dev/sdc
> > > 
> > > 
> > > 
> > > Why does it say that it's invalid device?
> > > 
> > > Disk /dev/sdc: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
> > > 
> > > The device is there, so what's happenned?
> > > 
> > > Hope someone can help please.
> > > 
> > > Sincerely,
> > > Drew.
> > Try removing /dev/ from /dev/sdc and instead use dom0:sdc
> > qvm-block -a {vmname} dom0:sdc
> > https://www.qubes-os.org/doc/usb/
> 
> Same thing, just doesn't have the "/dev/" in the text...
> 
> Thanks for the link... Aparently.
> root@dom0 {folder}]$ xl block-attach {VMNAME} phy:/dev/sdc xvdr
> 
> I had to use that.
> 
> So that worked, but qvm-block doesn't.
> 
> Is this a bug in qvm-block?
> 

Hi Drew

Are you sure that sdc isn't already in use in dom0?
Those are the cases where I have been able to attach using xl but not
with qvm-block, and where qvm-block reports an invalid device name.

What's the output of qvm-block -l ?

unman

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20170119225844.GB20518%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.


[qubes-users] Re: Drive Passthrough not functioning correctly.

2017-01-18 Thread '01v3g4n10' via qubes-users
On Thursday, January 19, 2017 at 12:48:17 AM UTC, Drew White wrote:
> Hi folks,
> 
> Here is what I was trying to do..
> Pass the drive to the guest.
> 
> 
> [{user}@dom0 {folder}]$ qvm-block -a {vmname} dom0:/dev/sdc
> Usage: qvm-block -l [options]
> usage: qvm-block -a [options]  :
> usage: qvm-block -A [options]  :
> usage: qvm-block -d [options] :
> usage: qvm-block -d [options] 
> List/set VM block devices.
> 
> qvm-block: error: Invalid device name: dom0:/dev/sdc
> 
> 
> 
> Why does it say that it's invalid device?
> 
> Disk /dev/sdc: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
> 
> The device is there, so what's happenned?
> 
> Hope someone can help please.
> 
> Sincerely,
> Drew.
Try removing /dev/ from /dev/sdc and instead use dom0:sdc
qvm-block -a {vmname} dom0:sdc
https://www.qubes-os.org/doc/usb/

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/23da9da5-96ba-4cd7-a815-156d8445cb14%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.