Re: [qubes-users] Windows Tools

2018-02-03 Thread Matteo
> Problem is: > 1) > I can't really tell if QWT is or is not installed. From the HVM I > wasn't able to copy out to another AppVM but Frankly: > > I don't really follow the protocol To install the QWT, I have it from > the --repos in dom0 but then I am supposed to once flag it to install >

Re: [qubes-users] How to deal with Yubikey ?

2018-02-03 Thread 'awokd' via qubes-users
On Sat, February 3, 2018 7:16 am, ThierryIT wrote: >> sys-usb:4-1 Logitech_USB_Receiver >> sys-usb:4-2 Yubico_Ybikey_4_U2F+CCID >> >> >> qvm-usb attach vm_name sys-usb:4.2 qvm-usb: error: backend vm 'sys-usb' >> doesn't expose device '4.2' You need to use "4-2", not "4.2". >> And it is not

[qubes-users] Re: Qubes Manager / Qubes 4.0 R3 ?

2018-02-03 Thread ThierryIT
Le lundi 29 janvier 2018 09:00:23 UTC+2, ThierryIT a écrit : > Hi, > > Not possible anymore to hide "un-running VMs" ? > By the way, is it possible to create in Qubes Manager folders to be able to > sort out VMs ? > > Thx nobody ? -- You received this message because you are subscribed to

Re: [qubes-users] Re: sys-usb / template install yubikey tools ?

2018-02-03 Thread ThierryIT
Le vendredi 19 janvier 2018 13:19:29 UTC+2, Alex Dubois a écrit : > On Friday, 19 January 2018 05:57:16 UTC, ThierryIT wrote: > > Not familiar with this ... Will need procediure to follow. > > > > > > Le mercredi 17 janvier 2018 23:03:31 UTC+2, Alex Dubois a écrit : > > > On Wednesday, 17

Re: [qubes-users] Qubes 3.2: Temporarily allowing full access does not revoke it after the time runs out

2018-02-03 Thread David Hobach
- open in dom0: /usr/lib/systemd/system/qubes-reload-firewall@.timer and add "OnUnitActiveSec=1m" on the end of file. - Reload systemd config -> "systemctl daemon-reload" and try to test again. Doesn't changing the config and reloading all services with changed config just reload the

Re: [qubes-users] Qubes 3.2: Temporarily allowing full access does not revoke it after the time runs out

2018-02-03 Thread donoban
On 02/03/2018 01:10 PM, David Hobach wrote: >> - open in dom0: /usr/lib/systemd/system/qubes-reload-firewall@.timer >> and add "OnUnitActiveSec=1m" on the end of file. >> >> >> - Reload systemd config -> "systemctl daemon-reload" and try to test >> again. > > Doesn't changing the config and

[qubes-users] Re: Qubes OS 4.0-rc4 has been released!

2018-02-03 Thread John
Likewise, I have got used to doing without it but removing it was a step backwards in terms of usability, particularly for newcomers - although I understand why the Qubes team made that decision. In future if the plans for Qubes Air come off some sort of dashboard will be extremely useful for

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Mike Keehan
On Sat, 3 Feb 2018 08:00:33 -0800 (PST) Shashank wrote: > I am using dell XP’s 15 9560, I set the SATA option to ahci > Instead of RAID and boot into qubes. Qubes 3.2 worked with above > options perfectly. Is there a way I set legacy mode explicitly? I > couldn’t find

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
I found it!! I have a couple of questions before I change to legacy. Do you use legacy and uefi? So the last time I was trying to install(ona diff machine) I had switched to legacy and installed qubes rc3. When I wanted to boot back into windows I changed to uefi and all he’ll broke loose I

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Mike Keehan
On Sat, 3 Feb 2018 08:29:08 -0800 (PST) Shashank wrote: > I found it!! > I have a couple of questions before I change to legacy. Do you use > legacy and uefi? So the last time I was trying to install(ona diff > machine) I had switched to legacy and installed qubes rc3.

[qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Hi I’ve been trying to install qubes 4.0 rc4 in my dell xps15 But I am not able to get the installation done. After I boot through the USB: *starting graphic installer *if installer doesn’t start type inst.txt to start text install * not starting VNC because we don’t have network * cannot start

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Mike Keehan
On Sat, 3 Feb 2018 05:37:05 -0800 (PST) Shashank wrote: > Hi I’ve been trying to install qubes 4.0 rc4 in my dell xps15 > But I am not able to get the installation done. > > After I boot through the USB: > > *starting graphic installer > *if installer doesn’t start

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Hi The installation does not take me to the options for selecting Initially there is a long list of loading that happens And immediately after that it’s the screen that I’ve posted above There is no check and install, install, or rescue qubes screen Thanks -- You received this message

Re: [qubes-users] How to deal with Yubikey ?

2018-02-03 Thread ThierryIT
Le samedi 3 février 2018 16:44:13 UTC+2, ThierryIT a écrit : > Le samedi 3 février 2018 14:33:17 UTC+2, awokd a écrit : > > On Sat, February 3, 2018 7:16 am, ThierryIT wrote: > > > > >> sys-usb:4-1 Logitech_USB_Receiver > > >> sys-usb:4-2 Yubico_Ybikey_4_U2F+CCID > > > > >> > > >> > > >> qvm-usb

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Can you please guide me on how to get to the boot options? The only thing working on that screen is alt-tab to switch screen Where it goes to terminal like screen with root@qubes$ I think it was. -- You received this message because you are subscribed to the Google Groups "qubes-users"

[qubes-users] Qubes 3.2: Temporarily allowing full access does not revoke it after the time runs out

2018-02-03 Thread donoban
Hi, Some days ago I decided to investigate this issue: https://github.com/QubesOS/qubes-issues/issues/1173 I think that I found the solution, at least it seems working fine for me. If some dev could take a look, it's very simple to check and fix and if you are considering a new 3.2 release would

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
I guess I’ll not jump into booting into legacy mode and having to mess up all the boot options again. If you do find a way to install it in uefi mode like 3.2 please do post the solution. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To

[qubes-users] upgrade 3.x -> 4.x, "firewall has been modified manually - please use qvm-firewall"

2018-02-03 Thread Dave C
65-4d69-4b58-b113-3ef5d347747e%40googlegroups.com. For more options, visit https://groups.google.com/d/optout. Qubes-HCL-LENOVO-20HHCTO1WW-20180203-093935.yml Description: Binary data

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Mike Keehan
On Sat, 3 Feb 2018 06:45:00 -0800 (PST) Shashank wrote: > Hi > > The installation does not take me to the options for selecting > > Initially there is a long list of loading that happens > > And immediately after that it’s the screen that I’ve posted above > >

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Yes I am doing the same thing, in fact I had qubes 3.2 earlier Now switching to 4.0. But I am getting this error. I enter the bios boot menu by hitting F12 (one time boot menu) And then select the usb to boot into. But for some reason it’s all messed up and I really want 4.0. How else would

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Mike Keehan
On Sat, 3 Feb 2018 07:25:41 -0800 (PST) Shashank wrote: > Yes I am doing the same thing, in fact I had qubes 3.2 earlier > Now switching to 4.0. But I am getting this error. > > I enter the bios boot menu by hitting F12 (one time boot menu) > And then select the usb

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
I am using dell XP’s 15 9560, I set the SATA option to ahci Instead of RAID and boot into qubes. Qubes 3.2 worked with above options perfectly. Is there a way I set legacy mode explicitly? I couldn’t find the option -- You received this message because you are subscribed to the Google Groups

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread 'awokd' via qubes-users
On Sat, February 3, 2018 1:37 pm, Shashank wrote: > Hi I’ve been trying to install qubes 4.0 rc4 in my dell xps15 > But I am not able to get the installation done. > and the message below goes on repeating Watchdog: BUG: soft lockup - cpu > stuck for 22s[xorg:1325] Is it trying to initialize a

[qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-03 Thread xxx . leny
On Wednesday, January 17, 2018 at 9:08:40 AM UTC+8, mossy-nw wrote: > miaoski: > > Just checking in to see if you (or anyone) is still using that laptop > and has made the switch to Qubes R4 and has an easy fix. I'll post more > details (lspci, dmesg) soon as time permits if not. > I am in the

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Here is the full error: Starting Installer, one moment Anaconda 25.28.9-10 for Qubes R4.0-rc4 started. *Installation log files are stored in /temp during the installation *shell is available on TTY2 *If the graphical Installation interface fails to start, try again With the Inst.text

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread 'awokd' via qubes-users
On Sat, February 3, 2018 2:29 pm, Shashank wrote: > Here is the full error: > Starting Installer, one moment > Anaconda 25.28.9-10 for Qubes R4.0-rc4 started. > *Installation log files are stored in /temp during the installation > *shell is available on TTY2 > *If the graphical Installation

Re: [qubes-users] How to deal with Yubikey ?

2018-02-03 Thread ThierryIT
Le samedi 3 février 2018 14:33:17 UTC+2, awokd a écrit : > On Sat, February 3, 2018 7:16 am, ThierryIT wrote: > > >> sys-usb:4-1 Logitech_USB_Receiver > >> sys-usb:4-2 Yubico_Ybikey_4_U2F+CCID > > >> > >> > >> qvm-usb attach vm_name sys-usb:4.2 qvm-usb: error: backend vm 'sys-usb' > >> doesn't

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Is there a way that I can set boot options through command line when I hit alt-tab it takes me to the command line with root@localhost If I Ls then I can see boot folder along with others and boot folder contains initrmd.img I think it is called. -- You received this message because you are

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread 'awokd' via qubes-users
On Sun, February 4, 2018 2:29 am, Tim W wrote: > > Thanks will try that as the most basic. > > > Did you use ./setup or just run off the master build.conf in examples > directory? ./setup. Mostly followed the same steps as here https://github.com/QubesOS/qubes-issues/issues/3426, just skip the

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
On Saturday, February 3, 2018 at 11:39:09 PM UTC-5, awokd wrote: > On Sun, February 4, 2018 4:21 am, Tim W wrote: > > > packages'. Error: Error downloading packages: > > Status code: 503 for > > https://mirrors.fedoraproject.org/metalink?repo=fedora-25=x86_64 > > > > > An issue with the link in

[qubes-users] TPM: Device not found (Lenovo P51, Qubes 4.x)

2018-02-03 Thread Dave C
ogle.com/d/msgid/qubes-users/afc13b69-4650-4084-99da-92514ba440d6%40googlegroups.com. For more options, visit https://groups.google.com/d/optout. Qubes-HCL-LENOVO-20HHCTO1WW-20180203-093935.yml Description: Binary data

[qubes-users] Re: templates update fail over sys-usb (but work using sys-net, on Qubes 4.x rc4)

2018-02-03 Thread Yuraeitha
On Saturday, February 3, 2018 at 9:18:45 PM UTC+1, Dave C wrote: > I've noticed that in templates, `dnf` fails, i.e. > > ``` > user@f26-devel ~]$ sudo dnf install tmux > Error: Failed to synchronize cache for repo 'updates' > ``` > > While in an appvm, the same command works fine. > > The

Re: [qubes-users] Re: sys-usb / template install yubikey tools ?

2018-02-03 Thread Alex Dubois
On Saturday, 3 February 2018 10:12:25 UTC, ThierryIT wrote: > Le vendredi 19 janvier 2018 13:19:29 UTC+2, Alex Dubois a écrit : > > On Friday, 19 January 2018 05:57:16 UTC, ThierryIT wrote: > > > Not familiar with this ... Will need procediure to follow. > > > > > > > > > Le mercredi 17

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-03 Thread mossy-nw
xxx.l...@gmail.com: > On Wednesday, January 17, 2018 at 9:08:40 AM UTC+8, mossy-nw wrote: >> miaoski: >> >> Just checking in to see if you (or anyone) is still using that laptop >> and has made the switch to Qubes R4 and has an easy fix. I'll post more >> details (lspci, dmesg) soon as time

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread 'awokd' via qubes-users
On Sun, February 4, 2018 4:21 am, Tim W wrote: > packages'. Error: Error downloading packages: > Status code: 503 for > https://mirrors.fedoraproject.org/metalink?repo=fedora-25=x86_64 > > An issue with the link in the makefile? Probably a Fedora repo issue, maybe it's being updated. You might

Re: [qubes-users] How to deal with Yubikey ?

2018-02-03 Thread ThierryIT
Le samedi 3 février 2018 21:56:04 UTC+2, awokd a écrit : > On Sat, February 3, 2018 2:49 pm, ThierryIT wrote: > > > Attached device seems to work as it should be when this is a mass usb > > storage ... Is there any thing special to install on sys-usb or targeting > > VM for Yubikey ? > > Check

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
On Saturday, February 3, 2018 at 8:40:27 PM UTC-5, awokd wrote: > On Sun, February 4, 2018 1:16 am, Tim W wrote: > > Has anyone accomplished a clean build? > > I've successfuly built 4.0rc3 in a Fedora 26 VM with the following installed: > sudo dnf install git createrepo rpm-build make wget

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread 'awokd' via qubes-users
On Sun, February 4, 2018 4:48 am, Tim W wrote: > On Saturday, February 3, 2018 at 11:39:09 PM UTC-5, awokd wrote: > >> On Sun, February 4, 2018 4:21 am, Tim W wrote: >> >> >>> packages'. Error: Error downloading packages: Status code: 503 for >>>

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
On Saturday, February 3, 2018 at 9:44:22 PM UTC-5, awokd wrote: > On Sun, February 4, 2018 2:29 am, Tim W wrote: > > > > Thanks will try that as the most basic. > > > > > > Did you use ./setup or just run off the master build.conf in examples > > directory? > > ./setup. Mostly followed the same

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-03 Thread xxx . leny
Yes I stil have the permissive mode on 3a:00.0 No luck in HVM mode with the current-testing repo. qubes-core-dom0 4.0.21 vm kernel 4.14.13-3 > > Thanks for writing -- are you using permissive mode in combination with > PV mode for sys-net? > > I've been relying on a usb wifi adapter, but will

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
On Saturday, February 3, 2018 at 9:56:06 PM UTC-5, Tim W wrote: > On Saturday, February 3, 2018 at 9:44:22 PM UTC-5, awokd wrote: > > On Sun, February 4, 2018 2:29 am, Tim W wrote: > > > > > > Thanks will try that as the most basic. > > > > > > > > > Did you use ./setup or just run off the master

[qubes-users] Re: Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
Also when I ran setup script it required PyYaml and that was also shown in https://www.qubes-os.org/doc/qubes-builder/ Building Qubes From Scratch Then you have the build directions that there is notes to follow the Archlinux directions for using the builder tools and they do not have them but

[qubes-users] HCL - Lenovo Thinkpad T420s

2018-02-03 Thread Christopher Morrow
The attached data from Feb 2018 (20180203) are for running Qubes 4, rc4. The attached data from Aug 2017 (20170810) are for runing Qubes 3.1. It runs well on both, if not terribly performant. I can't run more than a few qubes before capping out on memory. Tested hardware and working well: Wifi

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
On Sunday, February 4, 2018 at 12:25:46 AM UTC-5, awokd wrote: > On Sun, February 4, 2018 4:48 am, Tim W wrote: > > On Saturday, February 3, 2018 at 11:39:09 PM UTC-5, awokd wrote: > > > >> On Sun, February 4, 2018 4:21 am, Tim W wrote: > >> > >> > >>> packages'. Error: Error downloading packages:

[qubes-users] HCL - Dell XPS 15 9560

2018-02-03 Thread Shashank
Hi I have the same machine as you. Trying to install Q4 rc4 but having a lot of trouble. Although I am trying to install it in uefi settings as I had installed Q3.2 did you try installing it in uefi? Were You able to install it? Also in legacy are you dual booting with windows or is qubes the

Re: [qubes-users] Qubes 3.2: Temporarily allowing full access does not revoke it after the time runs out

2018-02-03 Thread donoban
For clarify: On 02/03/2018 01:10 PM, David Hobach wrote: >> - open in dom0: /usr/lib/systemd/system/qubes-reload-firewall@.timer >> and add "OnUnitActiveSec=1m" on the end of file. >> >> >> - Reload systemd config -> "systemctl daemon-reload" and try to test >> again. > > Doesn't changing the

Re: [qubes-users] How to deal with Yubikey ?

2018-02-03 Thread 'awokd' via qubes-users
On Sat, February 3, 2018 2:49 pm, ThierryIT wrote: > Attached device seems to work as it should be when this is a mass usb > storage ... Is there any thing special to install on sys-usb or targeting > VM for Yubikey ? Check out https://github.com/QubesOS/qubes-issues/issues/3525. Think you

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Shashank
Hi Yuraeitha, Thanks for the explanation. I actually didn’t try installing in legacy on dell xps 15 but on an acer. Do you switch between legacy and uefi (dual booting) on xps 15? And qubes4 installed good in legacy? -- You received this message because you are subscribed to the Google

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread 'awokd' via qubes-users
On Sat, February 3, 2018 8:19 pm, Yuraeitha wrote: > So as a basis you can use LegacyBOOS with Grub, and then point the Grub > menu for Windows to UEFI/EFI boot, even though you're on LegacyBIOS > initially. I don't remember the exact command-line in Grub, but it should > be somewhat easy to do

Re: [qubes-users] Re: sys-usb / template install yubikey tools ?

2018-02-03 Thread Alex Dubois
On Saturday, 3 February 2018 22:42:46 UTC, Alex Dubois wrote: > On Saturday, 3 February 2018 10:12:25 UTC, ThierryIT wrote: > > Le vendredi 19 janvier 2018 13:19:29 UTC+2, Alex Dubois a écrit : > > > On Friday, 19 January 2018 05:57:16 UTC, ThierryIT wrote: > > > > Not familiar with this ...

[qubes-users] Re: HCL - Dell XPS 15 9560

2018-02-03 Thread hotratz04
On Friday, February 2, 2018 at 5:49:50 PM UTC-6, hotr...@gmail.com wrote: > Legacy boot > needed Kernel parm modprobe.blacklist=nouveau Hi, Qubes 4.0 rc4 is the only OS on the machine right now. I don't use Windows! Set SATA to ACHI Set Legacy Boot node Got "soft lockup - CPU#0 stuck for 23s!"

[qubes-users] chromium gnome keyring how to disable in ?TempVM // Lastpass login doesn't persist FF 58

2018-02-03 Thread yrebstv
Hello in search Qubes Users I did find -- Re: [qubes-users] Re: Chromium asking about choosing password for new keyring? Other recipients: raah...@gmail.com, gaikokuji...@gmail.com - show quoted text - Exyctly, the window is coming from gnome-keyring. And it comes back, at least it did for

[qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread Tim W
Has anyone accomplished a clean build? I have tried with a standard builder.conf as well as using the ./setup script to create the builder.conf. Doing the builder.conf from example when I uncomment whonix I am asked for git username and password during #make get-sources for that. Even with

[qubes-users] Re: chromium gnome keyring how to disable in ?TempVM // Lastpass login doesn't persist FF 58

2018-02-03 Thread yrebstv
On 2018-02-03 12:31, yreb...@riseup.net wrote: > Hello in search Qubes Users I did find > > -- > > Re: [qubes-users] Re: Chromium asking about choosing password for new > keyring? > Other recipients: raah...@gmail.com, gaikokuji...@gmail.com > - show quoted text - > Exyctly, the window is

[qubes-users] Re: templates update fail over sys-usb (but work using sys-net, on Qubes 4.x rc4)

2018-02-03 Thread Yuraeitha
On Saturday, February 3, 2018 at 10:38:15 PM UTC+1, Dave C wrote: > On Saturday, February 3, 2018 at 12:52:21 PM UTC-8, Dave C wrote: > > On Saturday, February 3, 2018 at 12:34:18 PM UTC-8, Yuraeitha wrote: > > > On Saturday, February 3, 2018 at 9:18:45 PM UTC+1, Dave C wrote: > > > > I've noticed

[qubes-users] Re: templates update fail over sys-usb (but work using sys-net, on Qubes 4.x rc4)

2018-02-03 Thread Dave C
On Saturday, February 3, 2018 at 1:56:14 PM UTC-8, Yuraeitha wrote: [ ... snip ... ] > It might be a good idea to put this on github, chances are that they might > fix it soon if the problem is general issue for all USB tethering's, which > could affect many people, thus possibly given higher

[qubes-users] Re: Ubuntu templates

2018-02-03 Thread Yuraeitha
On Saturday, February 3, 2018 at 9:11:31 AM UTC+1, Foppe de Haan wrote: > On Saturday, February 3, 2018 at 3:56:05 AM UTC+1, Yuraeitha wrote: > > On Thursday, February 1, 2018 at 12:56:29 AM UTC+1, Unman wrote: > > > I'm just pushing up some PRs to remove zesty and institute build support > > >

[qubes-users] Re: Do Qubes v4.0-RC3 have stronger hardware limitations?

2018-02-03 Thread Yuraeitha
On Tuesday, January 30, 2018 at 2:23:56 PM UTC+1, pascal.mi...@gmail.com wrote: > I've tried to install Qubes v4.0-RC3 on an HP ProBook 650 laptop. > > The installation interface prevent me to proceed, saying that my hardware is > not compatible with Qubes v4.0. > > But the processor is a

Re: [qubes-users] 4.0-rc4 Install Help

2018-02-03 Thread Yuraeitha
On Saturday, February 3, 2018 at 5:29:08 PM UTC+1, Shashank wrote: > I found it!! > I have a couple of questions before I change to legacy. Do you use legacy and > uefi? So the last time I was trying to install(ona diff machine) I had > switched to legacy and installed qubes rc3. When I wanted

[qubes-users] templates update fail over sys-usb (but work using sys-net, on Qubes 4.x rc4)

2018-02-03 Thread Dave C
I've noticed that in templates, `dnf` fails, i.e. ``` user@f26-devel ~]$ sudo dnf install tmux Error: Failed to synchronize cache for repo 'updates' ``` While in an appvm, the same command works fine. The failure above occurs when I have sys-firewall using *sys-usb* (that is, tethering over

Re: [qubes-users] Building Qubes 4rc4 iso from source

2018-02-03 Thread 'awokd' via qubes-users
On Sun, February 4, 2018 1:16 am, Tim W wrote: > Has anyone accomplished a clean build? I've successfuly built 4.0rc3 in a Fedora 26 VM with the following installed: sudo dnf install git createrepo rpm-build make wget rpmdevtools dialog rpm-sign gnupg dpkg-dev debootstrap python2-sh I used the