Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread Josef Johansson
Hi, I would try my path, download rEFInd to another usb-stick and boot the installer from there. The only file you need is the EFI-file: https://sourceforge.net/projects/refind/ Also, that is an interesting data point as well, the bootx64.efi loader on the usb install works if it is started

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread Josef Johansson
Sorry, I missed that part of your reply. I was answering both of you :) I'll see if I can get Qubes 3.2 running on my T470p in the weekend if there's time. My collegue ended up with 4.0 with legacy boot to get everything working, so I just started from there. Using it for critical work and so far

[qubes-users] HCL - Lenovo T470p

2017-12-05 Thread Josef Johansson
Installation: * Disable Secure Boot * Use rEFInd to boot installation Workflow: * To restart and avoid broken LVMs (using thinpool), restart with `qvm-shutdown --all --wait && sudo reboot` * DPI is totally off due to awesome screen resolution/XFCE/14" screen. Fedora just doesn't work with the

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-06 Thread Josef Johansson
. /Josef On Fri, 15 Dec 2017, 20:23 Josef Johansson, <jose...@gmail.com> wrote: > Sorry, I missed that part of your reply. I was answering both of you :) > > I'll see if I can get Qubes 3.2 running on my T470p in the weekend if > there's time. My collegue ended up with 4.0 with

Re: [qubes-users] Networking issue with sys-whonix, missing vif*

2021-04-01 Thread Josef Johansson
Hi, As another data point: This is happening in debian-10 as well. However not in debian-11. On Friday, 19 March 2021 at 20:24:57 UTC+1 awokd wrote: > Vladimir Lushnikov: > > Hello, > > > > Since updating to latest Whonix 15/Qubes R4.1, I am having issues with > > sys-whonix not bringing up

[qubes-users] Re: How to build Qubes with patches from Xen ?

2021-04-01 Thread Josef Johansson
Hi, You should take my words with a grain of salt since I'm doing this the first time around. But anyhow. Go to https://www.qubes-os.org/doc/qubes-iso-building/ and make sure you have a Fedora VM to download everything to, and plenty of space. Download a builder.conf file from

[qubes-users] Re: Poor battery life running Qubes

2021-04-01 Thread Josef Johansson
Hi, Just curious, is xen-acpi-processor module loaded in dom0 (lsmod / modprobe xen-acpi-processor) and what does xenpm get-cpufreq-para tell you? On Monday, 29 March 2021 at 16:07:53 UTC+2 jonath...@gmail.com wrote: > Hi there > > I've been using Qubes for about 18 months now, and it's great.

[qubes-users] Re: Compiling XEN 4.15 in vmm-xen

2021-04-01 Thread Josef Johansson
So basically, since I'm moving from 4.14 to 4.15, there is a lot of dependencies e.g. core-libvirt, qubes-vchan-xen and kernel-qubes-vm that needs to be recompiled against the new xen-devel. I just missed the warnings about xen-libs not being possible to upgrade. core-libvirt fails on 3 tests

[qubes-users] HCL - Lenovo P14s (AMD Ryzen 7 Pro 4750U)

2021-03-18 Thread Josef Johansson
Fix reboots on suspend: * activate Linux as type of OS in BIOS (enables S3 instead of S2idle) * add acpi_sleep=nonvs in GRUB_CMDLINE_LINUX in /etc/default/grub * smt=on seems to help Boot is a bit slow, but doing this after boot solves that, it's possible to set under GRUB_CMDLINE_XEN_DEFAULT

Re: [qubes-users] HCL - Lenovo P14s (AMD Ryzen 7 Pro 4750U)

2021-03-19 Thread Josef Johansson
Hi, I applied clocksource=tsc tsc=unstable hpetbroadcast=0 https://github.com/QubesOS/qubes-issues/issues/6055 to my grub xen cmdline and the laptop is smooth as butter and really fast. No need for dom0_max_vcpus=2 or dom0_vcpus_pin. Managed to get the webcam working as well. I'm quite

Re: [qubes-users] HCL - Lenovo P14s (AMD Ryzen 7 Pro 4750U)

2021-04-16 Thread Josef Johansson
No problem. I've been trying to get suspend/resume working properly for a while now. It seems that the machine resumes, but there is something stalling CPUs such that VMs can't be started properly. If you try it out please let me know. -- You received this message because you are subscribed