[qubes-users] HCL - Lenovo s230u "Twist"

2017-04-18 Thread wordswithnemo
qubes-hcl-report document is attached. Here are my notes: * Required steps to address hardware issues before installation ** Option 1: Immediately replace Broadcom PCIe WIFI chip with Intel Centrino 2230 (as explained below) ** Option 2: Remove Broadcom PCIe WIFI chip during installation ***

[qubes-users] Re: Network problems with Windows 7 HVM and AppVM

2017-07-10 Thread wordswithnemo
> I was able to gain network access by changing the network adapter IPv4 > address to the same IP address set for the DNS, class A subnet mask, and no > gateway. I did receive a warning that this IP was in use. I have not however > seen any issues arise. I have internet access on my windows vm

[qubes-users] Re: Windows 7 HVM - suddenly no networking / Starting of Qubes Network Setup fails

2017-07-10 Thread wordswithnemo
On Tuesday, March 22, 2016 at 1:22:21 PM UTC-4, piitb...@gmail.com wrote: > Hello, > > after updating my windows 7 machine to the latest version, suddenly the > network conmectivity seems to be broken. > If i try an ipconfig /release and ipconfig /renews I get the following Error > Message: >

Re: [qubes-users] Copying between VMs from dom0

2017-06-28 Thread wordswithnemo
> > Thanks, and point taken on not focusing on security implications. > > I found a thread from last year where some third-party devs are concerned > about the implications of letting qvm-run -p run wild: > > https://github.com/SietsevanderMolen/i3-qubes/issues/15 > > It's a good idea, but I

Re: [qubes-users] Copying between VMs from dom0

2017-06-29 Thread wordswithnemo
On Thursday, June 29, 2017 at 2:11:15 PM UTC-4, Vít Šesták wrote: > I feel this to be controversial. It is right as long as you implement it > carefully (How would you handle the separator being present in the content of > the file? How would you sanitize the filenames? And so on…) AND you don't

[qubes-users] Re: cognitive issues when default is to use tor

2017-07-05 Thread wordswithnemo
My understanding is that you shouldn't be accessing Tor through anything but anon-whonix or a copy of that VM (this might be wrong). I'm not sure what metadata your work applications may leak that will compromise the anonymity of your Tor connection. You should do some reading up on whonix.

[qubes-users] Temporarily disabling xfce keyboard shortcuts while fulscreen

2017-07-06 Thread wordswithnemo
I'm looking to create a close-to-original-as-possible Windows 7 environment that I can run in fullscreen mode. I'd like to keep Alt+Space and CTRL+Shift+C/V enabled, but disable the rest of the xfce shortcuts and pass that input directly to the VM (eg Alt+Tab). Is there a simple way to do

[qubes-users] Re: Introducing the Qubes Admin API

2017-06-28 Thread wordswithnemo
On Tuesday, June 27, 2017 at 9:58:04 PM UTC-4, Andrew David Wong wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > Dear Qubes Community, > > Joanna has just published a new post: "Introducing the Qubes Admin API". > You can view the post on the Qubes website here: > >

[qubes-users] Re: Introducing the Qubes Admin API

2017-06-28 Thread wordswithnemo
On Tuesday, June 27, 2017 at 9:58:04 PM UTC-4, Andrew David Wong wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > Dear Qubes Community, > > Joanna has just published a new post: "Introducing the Qubes Admin API". > You can view the post on the Qubes website here: > >

[qubes-users] Copying between VMs from dom0

2017-06-28 Thread wordswithnemo
I want to copy network connection profiles from sys-net to sys-net-profiles as my computer shuts down. I'm creating a bash script in dom0 to help with this. I could use qvm-run -ap sys-net "sudo qvm-copy-to-vm sys-net-profiles /etc/NetworkManager/system-connections/*" ...but that will spawn

Re: [qubes-users] Copying between VMs from dom0

2017-06-29 Thread wordswithnemo
On Thursday, June 29, 2017 at 1:26:57 AM UTC-4, Vít Šesták wrote: > It might be pointless to consider risks of passing result of qvm-run -p to > dom0 Bash expansion when you have path traversal in the first place. When > command «ls > /etc/NetworkManager/system-connections/» in sys-net returns

Re: [qubes-users] Copying between VMs from dom0

2017-06-29 Thread wordswithnemo
On Wednesday, June 28, 2017 at 4:21:36 PM UTC-4, Chris Laprise wrote: > On 06/28/2017 12:19 PM, wordswithn...@gmail.com wrote: > > Thanks, and point taken on not focusing on security implications. > > > > I found a thread from last year where some third-party devs are concerned > > about the

Re: [qubes-users] Copying between VMs from dom0

2017-06-28 Thread wordswithnemo
On Wednesday, June 28, 2017 at 10:07:04 AM UTC-4, qubenix wrote: > qubenix: > > wordswithn...@gmail.com: > >> I want to copy network connection profiles from sys-net to > >> sys-net-profiles as my computer shuts down. > >> > >> I'm creating a bash script in dom0 to help with this. > >> > >> I

Re: [qubes-users] Copying between VMs from dom0

2017-06-28 Thread wordswithnemo
On Wednesday, June 28, 2017 at 11:53:51 AM UTC-4, qubenix wrote: > wordswithn...@gmail.com: > > On Wednesday, June 28, 2017 at 10:07:04 AM UTC-4, qubenix wrote: > >> qubenix: > >>> wordswithn...@gmail.com: > I want to copy network connection profiles from sys-net to > sys-net-profiles

[qubes-users] Re: Mounting folder from one VM on another?

2017-04-26 Thread wordswithnemo
On Wednesday, April 26, 2017 at 5:13:52 PM UTC-4, wordsw...@gmail.com wrote: > I'm looking for a solution similar to qvm-copy-to-vm, but without all the > copying. > > I'd like to mount /home/user/foo from Secure appvm at /home/user/foo on > Personal appvm. The folder would be mounted as read

[qubes-users] Mounting folder from one VM on another?

2017-04-26 Thread wordswithnemo
I'm looking for a solution similar to qvm-copy-to-vm, but without all the copying. I'd like to mount /home/user/foo from Secure appvm at /home/user/foo on Personal appvm. The folder would be mounted as read only. Rather than copy the files and waste space, I'd like to just have them

[qubes-users] Issues with building debian-8-minimal in Qubes Automated Build System

2017-05-02 Thread wordswithnemo
I'm stuck partway through the process. I'm following the directions here: https://www.qubes-os.org/doc/building-archlinux-template/ with substitutions for debian-8-minimal. I've gotten through with minimal problems (had to manually create ~/qubes-builder/keyring folders), but came across a

[qubes-users] Re-adding dom0 shortcuts to Start Menu

2017-05-03 Thread wordswithnemo
Not sure how, but I've randomly lost all my dom0 shortcuts, eg Logout, System Settings, Terminal. Possibly through running the Qubes Automated Build System or by attempting a dom0 update when there was none available. How can I rebuild the menu, or manually re-add these shortcuts? -- You

Re: [qubes-users] Issues with building debian-8-minimal in Qubes Automated Build System

2017-05-03 Thread wordswithnemo
On Tuesday, May 2, 2017 at 4:52:01 PM UTC-4, u+q...@bestemt.no wrote: > wordswithn...@gmail.com [2017-05-02 20:48 +0200]: > > 'make install-deps' and manually attempting to install the dependencies > > confirms that they're all installed. > > I got this error when I

[qubes-users] Re: How to download and install Broadcom BCM43224 to Qubes

2017-05-17 Thread wordswithnemo
On Wednesday, May 10, 2017 at 12:27:45 PM UTC-4, Urfey wrote: > When I try initial setup,Qubes always freeze at networking setup. > > So I didn't coufigure anything. Then I created sys-net and sys-firewall > manually. > > But when I started the VMs,it freezed again. > > > > I guess because

[qubes-users] So you accidentally attached your SATA controller to sys-usb

2017-06-19 Thread wordswithnemo
Just sharing a bit of knowledge recently-gained knowledge. If you accidentally attach a device to sys-usb that you shouldn't have, Qubes may refuse to boot. Here's how to fix the problem: 1) Boot into Recovery/Rescue mode from the Qubes Install USB 2) Qubes will mount your drive after you

[qubes-users] Lenovo T470 - x startup failed

2017-05-28 Thread wordswithnemo
I'm attempting to install on my new T470: i7-7600U Intel HD Graphics 620 500GB HDD Starting the installer, I get this error: X startup failed, falling back to text mode I'm assuming there is some graphics card issue, but I can't find any reports of people working to solve installer problems

[qubes-users] Re: Lenovo T470 - x startup failed

2017-05-28 Thread wordswithnemo
On Sunday, May 28, 2017 at 10:41:33 PM UTC-4, cooloutac wrote: > On Sunday, May 28, 2017 at 10:41:00 PM UTC-4, cooloutac wrote: > > On Sunday, May 28, 2017 at 9:12:44 PM UTC-4, wordsw...@gmail.com wrote: > > > I'm attempting to install on my new T470: > > > > > > i7-7600U > > > Intel HD Graphics

Re: [qubes-users] Lenovo T470 - x startup failed

2017-05-31 Thread wordswithnemo
On Monday, May 29, 2017 at 12:21:35 AM UTC-4, Mike Freemon wrote: > On 05/28/2017 08:12 PM, wordswithn...@gmail.com wrote: > > I'm attempting to install on my new T470: > > > > i7-7600U > > Intel HD Graphics 620 > > 500GB HDD > > > > Starting the installer, I get this error: > > > > X startup

Re: [qubes-users] Lenovo T470 - x startup failed

2017-06-03 Thread wordswithnemo
On Wednesday, May 31, 2017 at 8:24:59 PM UTC-4, cooloutac wrote: > On Wednesday, May 31, 2017 at 1:39:00 PM UTC-4, wordsw...@gmail.com wrote: > > On Monday, May 29, 2017 at 12:21:35 AM UTC-4, Mike Freemon wrote: > > > On 05/28/2017 08:12 PM, wordswithn...@gmail.com wrote: > > > > I'm attempting to

[qubes-users] Re: HCL - Lenovo s230u "Twist"

2017-06-03 Thread wordswithnemo
On Tuesday, April 18, 2017 at 2:50:02 AM UTC-4, wordsw...@gmail.com wrote: > qubes-hcl-report document is attached. > > Here are my notes: > > * Required steps to address hardware issues before installation > ** Option 1: Immediately replace Broadcom PCIe WIFI chip with Intel Centrino > 2230

[qubes-users] Lenovo T450 UEFI Troubleshooting - what does this mean?

2017-06-02 Thread wordswithnemo
>From https://www.qubes-os.org/doc/thinkpad-troubleshooting/: Instructions for getting your Lenovo 450 laptop working with Qubes/Linux Lenovo 450 uses UEFI, so some settings are needed to get Qubes (or Fedora) to boot, otherwise Qubes install USB stick will reboot right after boot selector

Re: [qubes-users] Lenovo T470 - x startup failed

2017-06-03 Thread wordswithnemo
On Saturday, June 3, 2017 at 3:48:57 AM UTC-4, wordsw...@gmail.com wrote: > On Wednesday, May 31, 2017 at 8:24:59 PM UTC-4, cooloutac wrote: > > On Wednesday, May 31, 2017 at 1:39:00 PM UTC-4, wordsw...@gmail.com wrote: > > > On Monday, May 29, 2017 at 12:21:35 AM UTC-4, Mike Freemon wrote: > > >

[qubes-users] T470 - High temp/short battery life despite low/no CPU load

2017-06-14 Thread wordswithnemo
I'm running the 4.9.29-17 testing kernel on dom0, because my display requires it. At idle, my CPU runs around 40-45C. This is when I'm not using the laptop and Qubes VM Manager, as well as dom0 system tools, show ~0% CPU usage. Under load it can spike as high as 75C. Load in this case might be

[qubes-users] Re: QSB #30: Critical Xen bugs related to PV memory virtualization (XSA-213, XSA-214)

2017-05-05 Thread wordswithnemo
On Tuesday, May 2, 2017 at 8:10:13 AM UTC-4, Andrew David Wong wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > Dear Qubes community, > > We have just published Qubes Security Bulletin (QSB) #30: > Critical Xen bugs related to PV memory virtualization (XSA-213, XSA-214). > > The

Re: [qubes-users] Options for securing /boot

2017-08-30 Thread wordswithnemo
> Plus, you always need to > disconnect all untrusted USB devices while rebooting Qubes, regardless > of whether you have USB qube set up or not. > I just want to make sure that this is not always the case - according to https://www.qubes-os.org/doc/usb/, if you create the USB VM automatically

Re: [qubes-users] Options for securing /boot

2017-08-30 Thread wordswithnemo
On Tuesday, August 29, 2017 at 7:16:16 PM UTC-4, steve.coleman wrote: > If your laptop contains an active TPM and a TCG Opal 2.0 compliant SED > (SSD or spinning platter) drive, then you can create a range, install > the bootstrap/OS, and then mark that range as read-only. > > After doing that

Re: [qubes-users] Re: Error: VM Kernel does not exist:

2017-08-31 Thread wordswithnemo
> Known bug: https://github.com/QubesOS/qubes-issues/issues/2757 > > Workaround (in dom0): > > $ for VM in `qvm-ls --raw-list`; do qvm-prefs -s $VM kernel default; done > The recent dom0 update caused this issue for me again (I've had it before), and it was quickly fixed by the command above.

[qubes-users] Re: Windows HVM has network access, but claims there isn't

2017-10-20 Thread wordswithnemo
On Monday, September 11, 2017 at 1:24:37 PM UTC-4, anguil...@gmail.com wrote: > On Saturday, September 9, 2017 at 7:18:56 AM UTC-7, Francesco wrote: > > Hello, > > > > some strange behavior. on Windows HVM template as well as dependent VMs. In > > all of them internet is working. I am sure of

[qubes-users] Re: Sporadic Inter-VM Routing Issues with Qubes Updates Proxy

2018-01-18 Thread wordswithnemo
On Monday, January 15, 2018 at 12:39:41 PM UTC-5, Kiwi17 wrote: > Hi, I was hoping someone may be able to help make heads or tails of this > frustrating issue I'm having. > > > > Background > > I use a VPN configured as-per the Qubes recommended config for VPNs >

[qubes-users] Re: Moving dom0 screenshots immediately to VMs

2018-01-19 Thread wordswithnemo
On Friday, January 19, 2018 at 6:32:33 AM UTC-5, Alex Dubois wrote: > On Friday, 19 January 2018 08:55:27 UTC, wordsw...@gmail.com wrote: > > I've been working on a solution for this, but unfortunately there are too > > many factors that I'm not familiar with. > > > > My goal is to to able to:

[qubes-users] Re: Moving dom0 screenshots immediately to VMs

2018-01-19 Thread wordswithnemo
On Friday, January 19, 2018 at 6:48:28 AM UTC-5, wordsw...@gmail.com wrote: > On Friday, January 19, 2018 at 6:32:33 AM UTC-5, Alex Dubois wrote: > > On Friday, 19 January 2018 08:55:27 UTC, wordsw...@gmail.com wrote: > > > I've been working on a solution for this, but unfortunately there are too

[qubes-users] Moving dom0 screenshots immediately to VMs

2018-01-19 Thread wordswithnemo
I've been working on a solution for this, but unfortunately there are too many factors that I'm not familiar with. My goal is to to able to: 1) Take a screenshot using the dom0 hotkey 2) In the "Screenshot" dialogue, select a script from the "Open with:" option 3) A text entry box that prompts