Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-18 Thread 'awokd' via qubes-users
On Sat, February 17, 2018 8:33 pm, ynwa44 via qubes-users wrote: > On Tuesday, February 13, 2018 at 4:31:33 PM UTC+4, awokd wrote: > >> On Tue, February 13, 2018 11:32 am, xxx.l...@gmail.com wrote: >> >>> Thank you for your help awokd, I now have sys-net running in HVM mode >>> on the XPS 9350

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-17 Thread ynwa44 via qubes-users
On Tuesday, February 13, 2018 at 4:31:33 PM UTC+4, awokd wrote: > On Tue, February 13, 2018 11:32 am, xxx.l...@gmail.com wrote: > > Thank you for your help awokd, I now have sys-net running in HVM mode on > > the XPS 9350 wifi card in permissive mode, this resolve the issue on 4.0. > > Glad it

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-13 Thread 'awokd' via qubes-users
On Tue, February 13, 2018 11:32 am, xxx.l...@gmail.com wrote: > Thank you for your help awokd, I now have sys-net running in HVM mode on > the XPS 9350 wifi card in permissive mode, this resolve the issue on 4.0. Glad it worked out! But consider getting a different wifi card some day that doesn't

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-13 Thread xxx . leny
Thank you for your help awokd, I now have sys-net running in HVM mode on the XPS 9350 wifi card in permissive mode, this resolve the issue on 4.0. > > PV is ParaVirtual mode. It's OK for testing, but in R4.0 you want to use > PVH mode for everything except for qubes with an attached PCI

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-07 Thread 'awokd' via qubes-users
On Wed, February 7, 2018 9:03 am, Davit Barbakadze wrote: > Sorry, but what's PV mode? > > > On Sunday, February 4, 2018 at 7:49:19 AM UTC+4, xxx@gmail.com wrote: > >> Yes I stil have the permissive mode on 3a:00.0 PV is ParaVirtual mode. It's OK for testing, but in R4.0 you want to use PVH

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-07 Thread Davit Barbakadze
Sorry, but what's PV mode? On Sunday, February 4, 2018 at 7:49:19 AM UTC+4, xxx@gmail.com wrote: > Yes I stil have the permissive mode on 3a:00.0 > > No luck in HVM mode with the current-testing repo. > qubes-core-dom0 4.0.21 > vm kernel 4.14.13-3 > > > > > > Thanks for writing -- are you

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-03 Thread xxx . leny
Yes I stil have the permissive mode on 3a:00.0 No luck in HVM mode with the current-testing repo. qubes-core-dom0 4.0.21 vm kernel 4.14.13-3 > > Thanks for writing -- are you using permissive mode in combination with > PV mode for sys-net? > > I've been relying on a usb wifi adapter, but will

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2018-02-03 Thread mossy-nw
xxx.l...@gmail.com: > On Wednesday, January 17, 2018 at 9:08:40 AM UTC+8, mossy-nw wrote: >> miaoski: >> >> Just checking in to see if you (or anyone) is still using that laptop >> and has made the switch to Qubes R4 and has an easy fix. I'll post more >> details (lspci, dmesg) soon as time

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-05 Thread miaoski
Hi. A simple solution is to use PCIe permissive mode, which weakens device isolation. Please refer to "PCI passthrough issues" of https://www.qubes-os.org/doc/assigning-devices/ Although there is a dmesg saying [2.411487] brcmfmac :00:00.0: Direct firmware load for

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-05 Thread miaoski
It's very weird that "SB chip is not supported" showed in dmesg. According to http://lxr.free-electrons.com/source/drivers/net/wireless/broadcom/brcm80211/brcmfmac/chip.c#L932 , it shows only when socitype == SOCI_SB and chip is not BCM4329. Given the chip is BCM4350, socitype should not be

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-04 Thread miaoski
Hi Marek, Thanks for the suggestion. Just tried kernel 4.8.12_12 but same dmesg popped up. Will try to copy a working firmware and parameters tonight. Thanks Miaoski -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-04 Thread Marek Marczykowski-Górecki
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On Sun, Dec 04, 2016 at 08:03:48AM -0800, miaoski wrote: > I can use my USB WiFi dongle by running NetworkManager on sys-usb VM. > After WiFi is connected, set the NetVM of sys-firewall to sys-usb. Yes, this is one way to use USB network adapter

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-04 Thread miaoski
I can use my USB WiFi dongle by running NetworkManager on sys-usb VM. After WiFi is connected, set the NetVM of sys-firewall to sys-usb. I think BCM4350 has some issue with kernel 4.4.14. dmesg shows, [3.558678] brcmfmac :00:00.0: Xen PCI mapped GSI16 to IRQ22 [3.560707] brcmfmac:

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-04 Thread miaoski
Hi Marc, 2016年12月4日日曜日 17時04分38秒 UTC+8 Marc de Bruin: > How different is a 9350 from a 9550? I had no problems using the internal > Wifi, e.g. > > lspci? Just to compare? 9350 (2016) is a Skylake with Broadcom 4352. I'm not sure about XPS 15 9550, but XPS 13 9350 is very similar to XPS 13 9343

Re: [qubes-users] Re: Install on Dell XPS 13 (9350)

2016-12-04 Thread Marc de Bruin
Op 4 dec. 2016, om 07:20 heeft miaoski het volgende geschreven: > > I failed to assign my TP-LINK TL-WN722N wireless USB dongle to sys-net. > Google'd a bit and found some docs, still no idea on how to do it. Help is > much appreciated. > How different is a 9350 from