Re: [qutebrowser] editor

2019-01-21 Thread Luis Mochan
Thank you again!
I misunderstood you. I thought you said I should configure the
'editor'  command, which I did. Finally, I understood you meant I should
configure the 'editor.command' configuration variable. I set
editor.command to ["emacsclient", "+{line}:{column}", "{file}"] and it
is working very nicely. Thanks for the help and the patience.
Best regards,
Luis


On Mon, Jan 21, 2019 at 10:13:16AM -0800, Jay Kamat wrote:
> 
> Luis Mochan writes:
> 
> > Thanks Jay!
> > ...
> 
> Have you tried configuring the editor.command setting yet? It's not clear if
> you tried that or not.
> 
> > :(
> > Is there a way to find out why?
> > Could this be related to my previous problem (failure to print)?
> > Thanks and regards,
> > Luis
> 
> If you run ':messages debug', you should get a detailed log of what's going
> on. Probably, it's trying to launch with the default 'gvim' command, and you
> don't have gvim installed.
> 

-- 

  o
W. Luis Mochán,  | tel:(52)(777)329-1734 /<(*)
Instituto de Ciencias Físicas, UNAM  | fax:(52)(777)317-5388 `>/   /\
Apdo. Postal 48-3, 62251 |   (*)/\/  \
Cuernavaca, Morelos, México  | moc...@fis.unam.mx   /\_/\__/
GPG: 791EB9EB, C949 3F81 6D9B 1191 9A16  C2DF 5F0A C52B 791E B9EB



Re: [qutebrowser] editor

2019-01-21 Thread Luis Mochan
Thanks Jay!
Sorry for the confusion.
I have now tried to configure 'editor' by either writing and editor script
in my ~/bin directory (which is in my $PATH) or by running
update-alternatives to make a system wide change. I tried nano (the
default, terminal oriented) and emacs (x-windows oriented) and got the
same
Error while spawning editor: The process failed to start.
:(
Is there a way to find out why?
Could this be related to my previous problem (failure to print)?
Thanks and regards,
Luis



On Sun, Jan 20, 2019 at 11:50:01PM -0800, Jay Kamat wrote:
> 
> Hi Luis,
> 
> Luis Mochan writes:
> 
> > I tried using different editors (visual or text based) running qutebrowser 
> > as
> >
> > EDITOR=/usr/bin/emacs qutebrowser
> >
> > or
> >
> > VISUAL=/usr/bin/emacs qutebrowser
> 
> qutebrowser launches the editor defined in editor.command , can you try
> configuring that instead?
> 
> -Jay
> 

-- 

  o
W. Luis Mochán,  | tel:(52)(777)329-1734 /<(*)
Instituto de Ciencias Físicas, UNAM  | fax:(52)(777)317-5388 `>/   /\
Apdo. Postal 48-3, 62251 |   (*)/\/  \
Cuernavaca, Morelos, México  | moc...@fis.unam.mx   /\_/\__/
GPG: 791EB9EB, C949 3F81 6D9B 1191 9A16  C2DF 5F0A C52B 791E B9EB



Re: [qutebrowser] editor

2019-01-20 Thread Jay Kamat


Hi Luis,

Luis Mochan writes:

> I tried using different editors (visual or text based) running qutebrowser as
>
> EDITOR=/usr/bin/emacs qutebrowser
>
> or
>
> VISUAL=/usr/bin/emacs qutebrowser

qutebrowser launches the editor defined in editor.command , can you try
configuring that instead?

-Jay