Re: [R] How to turn off warnings about class name conflicts

2018-02-14 Thread Ayhan yuksel
Thanks Daniel for your reply

However I get these warnings even I start with a fresh R session and remove
all objects (including hidden ones) before executing the mentioned codes

I also tried reinstalling these libraries including zoo and xts libraries,
but the problem continues

I guess this is a generic problem when we load two libraries with same
defined class names

Any idea ?

On 14 February 2018 at 12:16, Daniel Nordlund  wrote:

> On 2/13/2018 11:47 PM, Ayhan yuksel wrote:
>
>> Hi,
>>
>> I am using two packages (quantmod and FRAPO)
>>
>> Quantmod and FRAPO both have a class names "zoo"
>>
>> R is displaying the following warning when I manipulate an object of class
>> zoo:
>>
>> Found more than one class "zoo" in cache; using the first, from namespace
>> 'quantmod'
>> Also defined by ‘FRAPO’
>>
>> The warning is displayed every time I manipulate a zoo object and becomes
>> pretty annoying.
>>
>> I searched for a solution but couldn't found.
>>
>> A related but unanswered question is here:
>> http://r.789695.n4.nabble.com/setOldClass-quot-xts-quot-td4714332.html
>>
>> How can I turn off the warning?
>>
>> Reproducible example:
>>
>> library(quantmod)
>> library(FRAPO)
>> z<-zoo(runif(100),1:100)
>>
>>
>> Session Info (I am using Microsoft R):
>>
>> R version 3.4.3 (2017-11-30)
>> Platform: x86_64-w64-mingw32/x64 (64-bit)
>> Running under: Windows >= 8 x64 (build 9200)
>>
>> Matrix products: default
>>
>> locale:
>> [1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United
>> States.1252
>> [3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
>>
>> [5] LC_TIME=English_United States.1252
>>
>> attached base packages:
>> [1] stats graphics  grDevices utils datasets  methods   base
>>
>> other attached packages:
>>   [1] FRAPO_0.4-1   timeSeries_3022.101.2 timeDate_3012.100
>>   Rglpk_0.6-2
>>   [5] slam_0.1-40   cccp_0.2-4quantmod_0.4-12
>>   TTR_0.23-2
>>   [9] xts_0.10-1zoo_1.8-0 RevoUtils_10.0.7
>> RevoUtilsMath_10.0.1
>>
>> loaded via a namespace (and not attached):
>> [1] Rcpp_0.12.10 lattice_0.20-35  codetools_0.2-15 grid_3.4.3
>>   curl_3.1
>> [6] tools_3.4.3  compiler_3.4.3
>>
>> [[alternative HTML version deleted]]
>>
>> __
>> R-help@r-project.org mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide http://www.R-project.org/posti
>> ng-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>>
>>
> I tried your example (in a clean session) under R-3.4.3 from CRAN and
> Microsoft R Open 3.4.3.0 and did not get the message you are getting.  I
> suspect you have something in your workspace that is causing the problem.
>
> Dan
>
> --
> Daniel Nordlund
> Port Townsend, WA  USA
>

[[alternative HTML version deleted]]

__
R-help@r-project.org mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.


Re: [R] How to turn off warnings about class name conflicts

2018-02-14 Thread Daniel Nordlund

On 2/13/2018 11:47 PM, Ayhan yuksel wrote:

Hi,

I am using two packages (quantmod and FRAPO)

Quantmod and FRAPO both have a class names "zoo"

R is displaying the following warning when I manipulate an object of class
zoo:

Found more than one class "zoo" in cache; using the first, from namespace
'quantmod'
Also defined by ‘FRAPO’

The warning is displayed every time I manipulate a zoo object and becomes
pretty annoying.

I searched for a solution but couldn't found.

A related but unanswered question is here:
http://r.789695.n4.nabble.com/setOldClass-quot-xts-quot-td4714332.html

How can I turn off the warning?

Reproducible example:

library(quantmod)
library(FRAPO)
z<-zoo(runif(100),1:100)


Session Info (I am using Microsoft R):

R version 3.4.3 (2017-11-30)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United
States.1252
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C

[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats graphics  grDevices utils datasets  methods   base

other attached packages:
  [1] FRAPO_0.4-1   timeSeries_3022.101.2 timeDate_3012.100
  Rglpk_0.6-2
  [5] slam_0.1-40   cccp_0.2-4quantmod_0.4-12
  TTR_0.23-2
  [9] xts_0.10-1zoo_1.8-0 RevoUtils_10.0.7
RevoUtilsMath_10.0.1

loaded via a namespace (and not attached):
[1] Rcpp_0.12.10 lattice_0.20-35  codetools_0.2-15 grid_3.4.3
  curl_3.1
[6] tools_3.4.3  compiler_3.4.3

[[alternative HTML version deleted]]

__
R-help@r-project.org mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.



I tried your example (in a clean session) under R-3.4.3 from CRAN and 
Microsoft R Open 3.4.3.0 and did not get the message you are getting.  I 
suspect you have something in your workspace that is causing the problem.


Dan

--
Daniel Nordlund
Port Townsend, WA  USA

__
R-help@r-project.org mailing list -- To UNSUBSCRIBE and more, see
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.