Re: [R-pkg-devel] data and load version 3

2020-06-30 Thread Tomas Kalibera
On 6/30/20 11:48 AM, Göran Broström wrote: On 2020-06-30 01:07, Jeff Newmiller wrote: Your choice. Do you want to support people using older versions of R, or not? Is that all? No point at all with version 3 in packages? Why was it introduced? I have seen an argument for version 2: "...

Re: [R-pkg-devel] data and load version 3

2020-06-30 Thread Göran Broström
On 2020-06-30 11:58, Ivan Krylov wrote: On Tue, 30 Jun 2020 11:48:29 +0200 Göran Broström wrote: No point at all with version 3 in packages? Format version 3 [1] introduces support for ALTREP objects [2]. Examples of where ALTREP might be useful include really long integer vectors, like

Re: [R-pkg-devel] data and load version 3

2020-06-30 Thread Ivan Krylov
On Tue, 30 Jun 2020 11:48:29 +0200 Göran Broström wrote: > No point at all with version 3 in packages? Format version 3 [1] introduces support for ALTREP objects [2]. Examples of where ALTREP might be useful include really long integer vectors, like 1:1e10. -- Best regards, Ivan [1]

Re: [R-pkg-devel] data and load version 3

2020-06-30 Thread Göran Broström
On 2020-06-30 01:07, Jeff Newmiller wrote: Your choice. Do you want to support people using older versions of R, or not? Is that all? No point at all with version 3 in packages? Why was it introduced? I have seen an argument for version 2: "... needed ... to support name spaces", but

Re: [R-pkg-devel] data and load version 3

2020-06-30 Thread Ivan Krylov
On Mon, 29 Jun 2020 22:55:02 +0200 Göran Broström wrote: > After googling for a while (found nothing relevant in 'WRE'), I > understand that I have two options: (i) Change 'Depends' in > DESCRIPTION as suggested, and (ii) using save with 'version = 2' for > the new files. One of the steps

Re: [R-pkg-devel] data and load version 3

2020-06-29 Thread Jeff Newmiller
Your choice. Do you want to support people using older versions of R, or not? On June 29, 2020 1:55:02 PM PDT, "Göran Broström" wrote: >I added two data sets (.rda) to my package eha, but when I build the >new >version I get: > > WARNING: Added dependency on R >= 3.5.0 because serialized

Re: [R-pkg-devel] data and load version 3

2020-06-29 Thread Uwe Ligges
On 29.06.2020 22:55, Göran Broström wrote: I added two data sets (.rda) to my package eha, but when I build the new version I get:  WARNING: Added dependency on R >= 3.5.0 because serialized objects in serialize/load version 3 cannot be read in older versions of R.  File(s) containing

[R-pkg-devel] data and load version 3

2020-06-29 Thread Göran Broström
I added two data sets (.rda) to my package eha, but when I build the new version I get: WARNING: Added dependency on R >= 3.5.0 because serialized objects in serialize/load version 3 cannot be read in older versions of R. File(s) containing such objects: ‘eha/data/swedeaths.rda’