[Radiant] problem updating to v0.6.7

2008-06-02 Thread Sandip Gangakhedkar
Hi, Im updating my radiant gem to the newest 0.6.7firstly i cannot locate the RADIANT_GEM_VERSION constant in config/environment.rb. So when I try to rake:update it, i get an error saying don't know how to build task rake:update. Here is the trace. Im sure the problem is pretty basic...SOS

[Radiant] reorder on 0.6.7

2008-06-02 Thread Jan T
Hi list, i'm not able to get the reorder extension running on 0.6.7. Updatting works fine, but after installing the extension the +/- buttons next to the page tree stopped working. I applied a patch http://www.ruby-forum.com/topic/150410 , then everything looks fine, but when i want to save a

Re: [Radiant] problem updating to v0.6.7

2008-06-02 Thread Sean Cribbs
Sandip, What does the 'radiant -v' command say when your run it from command line? Also, can you create a new project and run it? Sean Sandip Gangakhedkar wrote: Hi, Im updating my radiant gem to the newest 0.6.7firstly i cannot locate the RADIANT_GEM_VERSION constant in

[Radiant] Any experiences with rails 2.1?

2008-06-02 Thread danny q.
I just saw on Slashdot that Rails 2.1 is out. Are any brave souls running Radiant on it already? Is there any value in updating the rails gem? It didn't sound too risky from the update summary on the blog; then again, it didn't sound all that exciting either ;-) --danny

Re: [Radiant] Re: problem updating to v0.6.7

2008-06-02 Thread John W. Long
On Jun 2, 2008, at 9:28 AM, Sandip Gangakhedkar wrote: I managed to get it workingthanks for your reply. What was it that you did that made it work? It's always helpful a solution if you figure something out that you posted about to people searching the mailing list archives in the

Re: [Radiant] Any experiences with rails 2.1?

2008-06-02 Thread Sean Cribbs
Danny, I intend to upgrade to Rails 2.1 for the next release. We should have minimal compatibility problems, with the exception of maybe the extension loader. Sean danny q. wrote: I just saw on Slashdot that Rails 2.1 is out. Are any brave souls running Radiant on it already? Is there

[Radiant] Questions about deployment

2008-06-02 Thread [EMAIL PROTECTED]
Hey all, I am new to Radiant and even newer to deploying Radiant sites, and the documentation I can find helps little. I have two apps running well on my laptop but it's time to get them up on my shared hosting account at Railsplayground and I am unsure about the best way to do that.

Re: [Radiant] mailers, which one should I use?

2008-06-02 Thread danny q.
Hey Chris, That is pretty much what I was looking for before I used apache rules to do it. I really can't say how big a problem it is because I don't know how many people need to run production radiant on non-root urls, and I don't know how many of them are as green and part-time as me, and

Re: [Radiant] gallery and attachment extension

2008-06-02 Thread Steven Southard
On Jun 1, 2008, at 5:15 PM, Andrea Franz wrote: The one feature I haven't gotten to work right on the gallery extension is reordering the individual images. If fixed that bug in the latest version. Try to pull it from github and try again. Thanks it works great now. Big thumbs

[Radiant] Extensions trouble in 0.6.7

2008-06-02 Thread Shane Thacker
Is anyone having trouble migrating extensions with the 0.6.7 release? After exporting the reorder extension I ran a migration and get this error: *** * config.breakpoint_server has been deprecated and has no effect. *

Re: [Radiant] Styles 'n Scripts Extension Erros

2008-06-02 Thread Jay Levitt
Chris Parrish wrote: Arik Jones wrote: = The proxy server received an invalid response from an upstream server. The proxy server could not handle the request GET /css/tinypixel.css. = I'm getting a 502 proxy error when accessing any asset from the styles n scripts extension.

[Radiant] Re: reorder on 0.6.7

2008-06-02 Thread Jan T
Hi, to answer my own question: the fix was pretty easy: i just uncommented the line require_dependency 'application' in reorder_extension.rb and now reorder seems to work as before and without shards. cheers, Jan On Mon, Jun 2, 2008 at 2:36 PM, Jan T wrote: Hi list, i'm not able to get

Re: [Radiant] Extensions trouble in 0.6.7

2008-06-02 Thread Sean Cribbs
Shane, Try two things and then get back to us: 1) Run rake radiant:update to copy the new config files from the gem/vendor. 2) Remove :shards from config.extensions in config/environment.rb if it exists. Sean Shane Thacker wrote: Is anyone having trouble migrating extensions with the 0.6.7

Re: [Radiant] Re: reorder on 0.6.7

2008-06-02 Thread Sean Cribbs
Jan, Can you create and send a patch and/or pull request? This should be applied to the extension for public consumption. Sean Jan T wrote: Hi, to answer my own question: the fix was pretty easy: i just uncommented the line require_dependency 'application' in reorder_extension.rb and

Re: [Radiant] Export import problem

2008-06-02 Thread Christopher Dwan
You've probably gotten past this point, but you can always try out my transfer rake task. It transfers from SQLite to MySQL and vice-versa without the YML in the middle. http://blog.radixhound.com/2008/4/28/backing-up-radiant-cms-using-sqlite3 -Chris On 31-May-08, at 11:42 AM, Anton J

[Radiant] Re: reorder on 0.6.7

2008-06-02 Thread Jan T
was a little fast in answering - everything looks good now, but i cannot move any items! On Mon, Jun 2, 2008 at 11:18 PM, Jan T [EMAIL PROTECTED] wrote: Hi, to answer my own question: the fix was pretty easy: i just uncommented the line require_dependency 'application' in

[Radiant] Re: Extensions trouble in 0.6.7

2008-06-02 Thread Shane Thacker
Sean Cribbs wrote: Shane, Try two things and then get back to us: 1) Run rake radiant:update to copy the new config files from the gem/vendor. 2) Remove :shards from config.extensions in config/environment.rb if it exists. Sean I'm assuming it's okay to leave shards in the

Re: [Radiant] Re: Extensions trouble in 0.6.7

2008-06-02 Thread Sean Cribbs
Shane, Try removing all extensions from loading while doing this. Edit the appropriate line of config/environment.rb to read: config.extensions = [] Also, comment out the line in config/environments/development.rb that starts 'config.breakpoint_server' # config.breakpoint_server =

Re: [Radiant] Export import problem

2008-06-02 Thread Anton Aylward
I've tried a lot of things and learnt a lot of things. As they say, you learn more form failure than success :-( Your extension looks nice ... but I'm never sure what the target of the rake db:migrate rake db:migrate:extension is going to be. Christopher Dwan said the following

Re: [Radiant] Re: reorder on 0.6.7

2008-06-02 Thread Sean Cribbs
Jan, I understand, but sending a patch reminds me to fix it ;). Sean Jan T wrote: Hi again, so, in another installation it did work and in a freah one too. so i hope, that my problem is solved so far. I could send you a patch, but you could also just open the file and uncomment the 2nd line

Re: [Radiant] Re: Extensions trouble in 0.6.7

2008-06-02 Thread Jan T
HI, could be a similar problem to the one that i had with the reorder extension, because during my several try-outs i got same error messages. Probably the extension needs to have a reference to the app now, since shards is in there now. Something like: require_dependency 'application' But i

Re: [Radiant] Re: Re: Extensions trouble in 0.6.7

2008-06-02 Thread Sean Cribbs
Shane, No, please remove shards, it will break things. Sean Shane Thacker wrote: Sean Cribbs wrote: Shane, Try removing all extensions from loading while doing this. Edit the appropriate line of config/environment.rb to read: config.extensions = [] Also, comment out the line in

Re: [Radiant] Export import problem

2008-06-02 Thread Anton Aylward
Anton Aylward said the following on 02/06/08 06:02 PM: I've tried a lot of things and learnt a lot of things. As they say, you learn more form failure than success :-( Among them is that the SQL syntax of a sqlite3 .dump is not the SQL syntax that MySQL requires. Yes, there are pages on the

Re: [Radiant] Re: Re: Extensions trouble in 0.6.7

2008-06-02 Thread Jan T
no, you don't need shards, if you're trying to (re-)install reorder, have a look at the other thread. j On Tue, Jun 3, 2008 at 12:55 AM, Shane Thacker [EMAIL PROTECTED] wrote: Sean Cribbs wrote: Shane, Try removing all extensions from loading while doing this. Edit the appropriate line of

[Radiant] Re: Re: Re: Extensions trouble in 0.6.7

2008-06-02 Thread Shane Thacker
Sean, Thanks for your patience. I'm not sure what I'm doing wrong. Here is what I've done: - exported mailer and reorder to the /vendor/extensions/ folder - commented out the config.extensions line in /config/environment.rb - commented out the config.breakpoint_server = true line in

[Radiant] Re: Re: Re: Extensions trouble in 0.6.7

2008-06-02 Thread Shane Thacker
Sean, I Forgot to mention that I removed shards from the extensions folder... shane -- Posted via http://www.ruby-forum.com/. ___ Radiant mailing list Post: Radiant@radiantcms.org Search: http://radiantcms.org/mailing-list/search/ Site:

Re: [Radiant] Re: Re: Re: Extensions trouble in 0.6.7

2008-06-02 Thread Sean Cribbs
Shane, Can you run the rake task with the --trace option and put the results in a pastie? (http://pastie.org) Sean Shane Thacker wrote: Sean, Thanks for your patience. I'm not sure what I'm doing wrong. Here is what I've done: - exported mailer and reorder to the /vendor/extensions/

Re: [Radiant] Export import problem

2008-06-02 Thread Anton Aylward
Anton Aylward said the following on 02/06/08 07:00 PM: Anton Aylward said the following on 02/06/08 06:02 PM: I've tried a lot of things and learnt a lot of things. As they say, you learn more form failure than success :-( Among them is that the SQL syntax of a sqlite3 .dump is not the SQL

[Radiant] Re: Re: Re: Re: Extensions trouble in 0.6.7

2008-06-02 Thread Shane Thacker
Sean, Sure thing. http://pastie.org/207596 shane -- Posted via http://www.ruby-forum.com/. ___ Radiant mailing list Post: Radiant@radiantcms.org Search: http://radiantcms.org/mailing-list/search/ Site: