Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread Albert Astals Cid
El dilluns, 7 d’agost de 2017, a les 9:46:59 CEST, Rex Dieter va escriure: > David Faure wrote: > > On mercredi 2 août 2017 22:55:10 CEST Rex Dieter wrote: > >> David Faure wrote: > >> > According to the policy that KF5 should work with the last 3 releases > >> > of Qt5.x, it is time now for

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread Rex Dieter
David Faure wrote: > On lundi 7 août 2017 18:25:35 CEST Rex Dieter wrote: >> David Faure wrote: >> >> > Isn't it an option to leave it in, at version 5.36, rather than >> >> > removing it completely ? >> >> >> >> In the short-term, yes. >> >> >> >> Long term, I'm not willing to ship (and

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread David Faure
On lundi 7 août 2017 18:25:35 CEST Rex Dieter wrote: > David Faure wrote: > >> > Isn't it an option to leave it in, at version 5.36, rather than > >> > removing it completely ? > >> > >> In the short-term, yes. > >> > >> Long term, I'm not willing to ship (and support) this if it's not > >>

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread Rex Dieter
David Faure wrote: >> > Isn't it an option to leave it in, at version 5.36, rather than >> > removing it completely ? >> >> In the short-term, yes. >> >> Long term, I'm not willing to ship (and support) this if it's not >> supported upstream either (where bugs are usually fixed in newer >>

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread David Faure
On lundi 7 août 2017 17:36:05 CEST Rex Dieter wrote: > David Faure wrote: > > On lundi 7 août 2017 16:46:59 CEST Rex Dieter wrote: > >> David Faure wrote: > >> > On mercredi 2 août 2017 22:55:10 CEST Rex Dieter wrote: > >> >> David Faure wrote: > >> >> > According to the policy that KF5 should

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread Rex Dieter
David Faure wrote: > On lundi 7 août 2017 16:46:59 CEST Rex Dieter wrote: >> David Faure wrote: >> > On mercredi 2 août 2017 22:55:10 CEST Rex Dieter wrote: >> >> David Faure wrote: >> >> > According to the policy that KF5 should work with the last 3 >> >> > releases of Qt5.x, it is time now for

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread David Faure
On lundi 7 août 2017 16:46:59 CEST Rex Dieter wrote: > David Faure wrote: > > On mercredi 2 août 2017 22:55:10 CEST Rex Dieter wrote: > >> David Faure wrote: > >> > According to the policy that KF5 should work with the last 3 releases > >> > of Qt5.x, it is time now for upcoming releases of KF5 to

Re: KF 5.37 requiring Qt 5.7

2017-08-07 Thread Rex Dieter
David Faure wrote: > On mercredi 2 août 2017 22:55:10 CEST Rex Dieter wrote: >> David Faure wrote: >> > According to the policy that KF5 should work with the last 3 releases >> > of Qt5.x, it is time now for upcoming releases of KF5 to drop support >> > for Qt 5.6. >> > >> > Packagers: is that

Re: KF 5.37 requiring Qt 5.7

2017-08-06 Thread David Faure
On mercredi 2 août 2017 22:57:31 CEST Christoph Feck wrote: > On 02.08.2017 22:47, David Faure wrote: > > According to the policy that KF5 should work with the last 3 releases of > > Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt > > 5.6. > > > > Packagers: is that

Re: KF 5.37 requiring Qt 5.7

2017-08-06 Thread Eric Hameleers
On Wed, 2 Aug 2017, David Faure wrote: According to the policy that KF5 should work with the last 3 releases of Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt 5.6. Packagers: is that acceptable? Normally I would have just gone ahead with applying the policy, but

Re: KF 5.37 requiring Qt 5.7

2017-08-05 Thread Heiko Becker
On 08/02/17 22:47, David Faure wrote: > According to the policy that KF5 should work with the last 3 releases of > Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt 5.6. > > Packagers: is that acceptable? We already have 5.9.1 in our repos and thus also have no problem

Re: KF 5.37 requiring Qt 5.7

2017-08-05 Thread Andreas Sturmlechner
On Wednesday, 2 August 2017 at 22:47, David Faure wrote: > According to the policy that KF5 should work with the last 3 releases of > Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt > 5.6. > Packagers: is that acceptable? Certainly no objection from Gentoo. Qt 5.7.1 is

Re: KF 5.37 requiring Qt 5.7

2017-08-05 Thread Nicolas Lécureuil
Le 2017-08-02 22:47, David Faure a écrit : According to the policy that KF5 should work with the last 3 releases of Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt 5.6. Packagers: is that acceptable? Normally I would have just gone ahead with applying the policy,

Re: KF 5.37 requiring Qt 5.7

2017-08-04 Thread Tobias C. Berner
Also fine for FreeBSD, where on 5.7.1. mfg Tobias On 4 August 2017 at 10:09, Bernhard Rosenkraenzer wrote: > On Wednesday, August 02, 2017 22:47 CEST, David Faure > wrote: > > > According to the policy that KF5 should work with the last 3 releases of > > Qt5.x,

Re: KF 5.37 requiring Qt 5.7

2017-08-04 Thread Bernhard Rosenkraenzer
On Wednesday, August 02, 2017 22:47 CEST, David Faure wrote: > According to the policy that KF5 should work with the last 3 releases of > Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt 5.6. > > Packagers: is that acceptable? Works for OpenMandriva.

Re: KF 5.37 requiring Qt 5.7

2017-08-03 Thread David Faure
On mercredi 2 août 2017 22:55:10 CEST Rex Dieter wrote: > David Faure wrote: > > According to the policy that KF5 should work with the last 3 releases of > > Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt > > 5.6. > > > > Packagers: is that acceptable? > > I'd prefer

Re: KF 5.37 requiring Qt 5.7

2017-08-02 Thread Christoph Feck
On 02.08.2017 22:47, David Faure wrote: According to the policy that KF5 should work with the last 3 releases of Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt 5.6. Packagers: is that acceptable? Normally I would have just gone ahead with applying the policy, but

Re: KF 5.37 requiring Qt 5.7

2017-08-02 Thread Rex Dieter
David Faure wrote: > According to the policy that KF5 should work with the last 3 releases of > Qt5.x, it is time now for upcoming releases of KF5 to drop support for Qt > 5.6. > > Packagers: is that acceptable? I'd prefer to continue to allow 5.6 awhile, to continue to allow support for rhel