Re: Issue 3770 in reviewboard: rbt post with 0.7.1 release get the error: UnicodeDecodeError

2015-03-12 Thread reviewboard

Updates:
Status: Fixed

Comment #2 on issue 3770 by trowb...@gmail.com: rbt post with 0.7.1 release  
get the error: UnicodeDecodeError

https://code.google.com/p/reviewboard/issues/detail?id=3770

Fixed in rbtools release-0.7.x (de0e748). This will ship in 0.7.3. Thanks!

--
You received this message because this project is configured to send all  
issue notifications to this address.

You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
reviewboard-issues group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.


Re: Issue 3770 in reviewboard: rbt post with 0.7.1 release get the error: UnicodeDecodeError

2015-03-11 Thread reviewboard

Updates:
Status: PendingReview
Owner: trowb...@gmail.com
Labels: Component-RBTools

Comment #1 on issue 3770 by trowb...@gmail.com: rbt post with 0.7.1 release  
get the error: UnicodeDecodeError

https://code.google.com/p/reviewboard/issues/detail?id=3770

(No comment was entered for this change.)

--
You received this message because this project is configured to send all  
issue notifications to this address.

You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
reviewboard-issues group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.


Issue 3770 in reviewboard: rbt post with 0.7.1 release get the error: UnicodeDecodeError

2015-02-13 Thread reviewboard

Status: New
Owner: 
Labels: Type-Defect Priority-Medium

New issue 3770 by shirph...@126.com: rbt post with 0.7.1 release get the  
error: UnicodeDecodeError

https://code.google.com/p/reviewboard/issues/detail?id=3770

*** READ THIS BEFORE POSTING!
***
*** You must complete this form in its entirety, or your bug report will be
*** rejected.
***
*** If you have a security issue to report, please send it confidentially
to
*** secur...@reviewboard.org. Posting security-related issues to this bug
*** tracker causes us to have to do an emergency release.
***
*** For customer support, please post to reviewbo...@googlegroups.com
***
*** If you have a patch, please submit it to
http://reviews.reviewboard.org/
***
*** This bug tracker is public. Please check that any logs or other
information
*** that you include has been stripped of confidential information.


What version are you running?
0.7.1

What's the URL of the page containing the problem?


What steps will reproduce the problem?
1.modify the local working copy;
2.run the command rbt post -o -d
3.get the following error:
E:\DEMO\trunkrbt post -o -d

RBTools 0.7.1
Python 2.7.9 (default, Dec 10 2014, 12:24:55) [MSC v.1500 32 bit  
(Intel)]

Running on Windows-XP-5.1.2600-SP3
Home = C:\Documents and Settings\yihui.hu\Application Data
Current directory = E:\DEMO\trunk
Checking for a Subversion repository...
Running: svn info --non-interactive

Traceback (most recent call last):
  File C:\Python27\Scripts\rbt-script.py, line 9, in module
load_entry_point('RBTools==0.7.1', 'console_scripts', 'rbt')()
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\commands\main.py,  
line 133, in main

command.run_from_argv([RB_MAIN, command_name] + args)
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\commands\__init__.py,  
line 538, in run_from_argv

exit_code = self.main(*args) or 0
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\commands\post.py,  
line 589, in main

client_name=self.options.repository_type)
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\commands\__init__.py,  
line 566, in initialize_scm_tool

client_name=client_name)
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\clients\__init__.py,  
line 385, in scan_usable_client

repository_info = tool.get_repository_info()
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\clients\svn.py,  
line 58, in get_repository_info

data = self._run_svn(svn_info_params, ignore_errors=True)
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\clients\svn.py,  
line 658, in _run_svn

return execute(cmdline, *args, **kwargs)
   
File C:\Python27\lib\site-packages\rbtools-0.7.1-py2.7.egg\rbtools\utils\process.py,  
line 109, in execute

data = data.decode('utf-8')
  File C:\Python27\lib\encodings\utf_8.py, line 16, in decode
return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd0 in position 372:  
invalid continuation byte


What is the expected output? What do you see instead?
Expected result: Create a new review request in reviewboard server.

What operating system are you using? What browser?
Windows XP, IE/Chrome

Please provide any additional information below.
I have two reviewboard server, one is 1.7.20, another is 2.0.13,
but there are the same error

--
You received this message because this project is configured to send all  
issue notifications to this address.

You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
reviewboard-issues group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard-issues+unsubscr...@googlegroups.com.
To post to this group, send email to reviewboard-issues@googlegroups.com.
Visit this group at http://groups.google.com/group/reviewboard-issues.
For more options, visit https://groups.google.com/d/optout.