Re: Review Request 52719: Renamed a function for clarity.

2016-10-18 Thread Neil Conway

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/52719/
---

(Updated Oct. 18, 2016, 9:07 p.m.)


Review request for mesos and Vinod Kone.


Changes
---

Fix description per review.


Bugs: MESOS-6332
https://issues.apache.org/jira/browse/MESOS-6332


Repository: mesos


Description (updated)
---

`Master::reconcile(Framework*, const scheduler::Call::Reconcile&)` and
`Master::reconcile(Slave*, const vector&, const
vector& tasks)` are only loosely related. Per discussion on the
development list, using overloading to distinguish these two functions
is confusing. Hence, rename the latter to `reconcileKnownSlave`.


Diffs (updated)
-

  src/master/master.hpp 881f0d6127c4d6a7fccb1677fb3129310777f737 
  src/master/master.cpp 3c6b18ead44cd5f2978093f5415e974cfcbfa714 

Diff: https://reviews.apache.org/r/52719/diff/


Testing
---

`make check`


Thanks,

Neil Conway



Re: Review Request 52719: Renamed a function for clarity.

2016-10-18 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/52719/#review153171
---


Ship it!




s/reconcileKnownTasks/reconcileKnownSlave/ in the description

- Vinod Kone


On Oct. 11, 2016, 1:03 a.m., Neil Conway wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/52719/
> ---
> 
> (Updated Oct. 11, 2016, 1:03 a.m.)
> 
> 
> Review request for mesos and Vinod Kone.
> 
> 
> Bugs: MESOS-6332
> https://issues.apache.org/jira/browse/MESOS-6332
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> `Master::reconcile(Framework*, const scheduler::Call::Reconcile&)` and
> `Master::reconcile(Slave*, const vector&, const
> vector& tasks)` are only loosely related. Per discussion on the
> development list, using overloading to distinguish these two functions
> is confusing. Hence, rename the latter to `reconcileKnownTasks`.
> 
> 
> Diffs
> -
> 
>   src/master/master.hpp 43518b9bf1bfaa54e26acc7f2e70c4161c667a84 
>   src/master/master.cpp ad8993ae43e2508a3777f4062acaca1177ac77f2 
> 
> Diff: https://reviews.apache.org/r/52719/diff/
> 
> 
> Testing
> ---
> 
> `make check`
> 
> 
> Thanks,
> 
> Neil Conway
> 
>



Review Request 52719: Renamed a function for clarity.

2016-10-10 Thread Neil Conway

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/52719/
---

Review request for mesos and Vinod Kone.


Bugs: MESOS-6332
https://issues.apache.org/jira/browse/MESOS-6332


Repository: mesos


Description
---

`Master::reconcile(Framework*, const scheduler::Call::Reconcile&)` and
`Master::reconcile(Slave*, const vector&, const
vector& tasks)` are only loosely related. Per discussion on the
development list, using overloading to distinguish these two functions
is confusing. Hence, rename the latter to `reconcileKnownTasks`.


Diffs
-

  src/master/master.hpp 43518b9bf1bfaa54e26acc7f2e70c4161c667a84 
  src/master/master.cpp ad8993ae43e2508a3777f4062acaca1177ac77f2 

Diff: https://reviews.apache.org/r/52719/diff/


Testing
---

`make check`


Thanks,

Neil Conway