Re: Review Request 45012: Recommendation and validation logic for HAWQ hdfs-client.xml output.replace-datanode-on-failure property

2016-03-19 Thread jun aoki

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45012/#review124221
---


Fix it, then Ship it!





ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py (line 
694)


do you want to inline this since propertyvalue is used only once.



ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py (line 
979)


Do you want to set (constant) variable for a magic number 4?
```
REPLACE_DATANODE_ON_FAILURE_THREASHOLD = 4 # my poor naming skill...
if numSegments > REPLACE_DATANODE_ON_FAILURE_THREASHOLD and value ... :
  ...
elif numSegments <= REPLACE_DATANODE_ON_FAILURE_THREASHOLD and value ... : 
  ...

```

and you can use it on line 694


- jun aoki


On March 18, 2016, 2:01 a.m., Alexander Denissov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45012/
> ---
> 
> (Updated March 18, 2016, 2:01 a.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, bhuvnesh chaudhary, Goutam 
> Tadi, jun aoki, Jayush Luniya, Lav Jain, and Sumit Mohanty.
> 
> 
> Bugs: AMBARI-15499
> https://issues.apache.org/jira/browse/AMBARI-15499
> 
> 
> Repository: ambari
> 
> 
> Description
> ---
> 
> Recommendation and validation logic for HAWQ hdfs-client.xml 
> output.replace-datanode-on-failure property
> 
> 
> Diffs
> -
> 
>   
> ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hdfs-client.xml
>  c2a756a 
>   ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py 
> c0bc4e2 
>   ambari-server/src/test/python/stacks/2.3/common/test_stack_advisor.py 
> 4f0b4b7 
> 
> Diff: https://reviews.apache.org/r/45012/diff/
> 
> 
> Testing
> ---
> 
> manual
> 
> --
> Ran 253 tests in 7.111s
> 
> OK
> --
> Total run:927
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Alexander Denissov
> 
>



Re: Review Request 45012: Recommendation and validation logic for HAWQ hdfs-client.xml output.replace-datanode-on-failure property

2016-03-19 Thread Lav Jain

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45012/#review124225
---


Ship it!




Ship It!

- Lav Jain


On March 18, 2016, 2:01 a.m., Alexander Denissov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45012/
> ---
> 
> (Updated March 18, 2016, 2:01 a.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, bhuvnesh chaudhary, Goutam 
> Tadi, jun aoki, Jayush Luniya, Lav Jain, and Sumit Mohanty.
> 
> 
> Bugs: AMBARI-15499
> https://issues.apache.org/jira/browse/AMBARI-15499
> 
> 
> Repository: ambari
> 
> 
> Description
> ---
> 
> Recommendation and validation logic for HAWQ hdfs-client.xml 
> output.replace-datanode-on-failure property
> 
> 
> Diffs
> -
> 
>   
> ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hdfs-client.xml
>  c2a756a 
>   ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py 
> c0bc4e2 
>   ambari-server/src/test/python/stacks/2.3/common/test_stack_advisor.py 
> 4f0b4b7 
> 
> Diff: https://reviews.apache.org/r/45012/diff/
> 
> 
> Testing
> ---
> 
> manual
> 
> --
> Ran 253 tests in 7.111s
> 
> OK
> --
> Total run:927
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Alexander Denissov
> 
>



Re: Review Request 45012: Recommendation and validation logic for HAWQ hdfs-client.xml output.replace-datanode-on-failure property

2016-03-19 Thread Alexander Denissov

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45012/
---

(Updated March 18, 2016, 7:47 p.m.)


Review request for Ambari, Alejandro Fernandez, bhuvnesh chaudhary, Goutam 
Tadi, jun aoki, Jayush Luniya, Lav Jain, and Sumit Mohanty.


Changes
---

updated magic number


Bugs: AMBARI-15499
https://issues.apache.org/jira/browse/AMBARI-15499


Repository: ambari


Description
---

Recommendation and validation logic for HAWQ hdfs-client.xml 
output.replace-datanode-on-failure property


Diffs (updated)
-

  
ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hawq-site.xml
 93ad3fe 
  
ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hdfs-client.xml
 c2a756a 
  ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py 
c0bc4e2 
  ambari-server/src/test/python/stacks/2.3/common/test_stack_advisor.py 4f0b4b7 

Diff: https://reviews.apache.org/r/45012/diff/


Testing
---

manual

--
Ran 253 tests in 7.111s

OK
--
Total run:927
Total errors:0
Total failures:0
OK


Thanks,

Alexander Denissov



Re: Review Request 45012: Recommendation and validation logic for HAWQ hdfs-client.xml output.replace-datanode-on-failure property

2016-03-19 Thread Alexander Denissov


> On March 18, 2016, 5:08 p.m., jun aoki wrote:
> > ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py, 
> > line 699
> > 
> >
> > do you want to inline this since propertyvalue is used only once.

I prefer to leave it separate for clarity


> On March 18, 2016, 5:08 p.m., jun aoki wrote:
> > ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py, 
> > line 984
> > 
> >
> > Do you want to set (constant) variable for a magic number 4?
> > ```
> > REPLACE_DATANODE_ON_FAILURE_THREASHOLD = 4 # my poor naming skill...
> > if numSegments > REPLACE_DATANODE_ON_FAILURE_THREASHOLD and value ... :
> >   ...
> > elif numSegments <= REPLACE_DATANODE_ON_FAILURE_THREASHOLD and value 
> > ... : 
> >   ...
> > 
> > ```
> > 
> > and you can use it on line 694

added a constant, but not for the whole file, but rather within the method. I 
feel that exposing the constant for the whole file is too intrusive.


- Alexander


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45012/#review124221
---


On March 18, 2016, 7:47 p.m., Alexander Denissov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45012/
> ---
> 
> (Updated March 18, 2016, 7:47 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, bhuvnesh chaudhary, Goutam 
> Tadi, jun aoki, Jayush Luniya, Lav Jain, and Sumit Mohanty.
> 
> 
> Bugs: AMBARI-15499
> https://issues.apache.org/jira/browse/AMBARI-15499
> 
> 
> Repository: ambari
> 
> 
> Description
> ---
> 
> Recommendation and validation logic for HAWQ hdfs-client.xml 
> output.replace-datanode-on-failure property
> 
> 
> Diffs
> -
> 
>   
> ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hawq-site.xml
>  93ad3fe 
>   
> ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hdfs-client.xml
>  c2a756a 
>   ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py 
> c0bc4e2 
>   ambari-server/src/test/python/stacks/2.3/common/test_stack_advisor.py 
> 4f0b4b7 
> 
> Diff: https://reviews.apache.org/r/45012/diff/
> 
> 
> Testing
> ---
> 
> manual
> 
> --
> Ran 253 tests in 7.111s
> 
> OK
> --
> Total run:927
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Alexander Denissov
> 
>



Re: Review Request 45012: Recommendation and validation logic for HAWQ hdfs-client.xml output.replace-datanode-on-failure property

2016-03-19 Thread Alexander Denissov

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45012/
---

(Updated March 18, 2016, 7:34 p.m.)


Review request for Ambari, Alejandro Fernandez, bhuvnesh chaudhary, Goutam 
Tadi, jun aoki, Jayush Luniya, Lav Jain, and Sumit Mohanty.


Changes
---

changed to lower-case booleans, updated some descriptions


Bugs: AMBARI-15499
https://issues.apache.org/jira/browse/AMBARI-15499


Repository: ambari


Description
---

Recommendation and validation logic for HAWQ hdfs-client.xml 
output.replace-datanode-on-failure property


Diffs (updated)
-

  
ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hawq-site.xml
 93ad3fe 
  
ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hdfs-client.xml
 c2a756a 
  ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py 
c0bc4e2 
  ambari-server/src/test/python/stacks/2.3/common/test_stack_advisor.py 4f0b4b7 

Diff: https://reviews.apache.org/r/45012/diff/


Testing
---

manual

--
Ran 253 tests in 7.111s

OK
--
Total run:927
Total errors:0
Total failures:0
OK


Thanks,

Alexander Denissov



Re: Review Request 45012: Recommendation and validation logic for HAWQ hdfs-client.xml output.replace-datanode-on-failure property

2016-03-18 Thread bhuvnesh chaudhary

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45012/#review124226
---


Ship it!




Ship It!

- bhuvnesh chaudhary


On March 18, 2016, 2:01 a.m., Alexander Denissov wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45012/
> ---
> 
> (Updated March 18, 2016, 2:01 a.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, bhuvnesh chaudhary, Goutam 
> Tadi, jun aoki, Jayush Luniya, Lav Jain, and Sumit Mohanty.
> 
> 
> Bugs: AMBARI-15499
> https://issues.apache.org/jira/browse/AMBARI-15499
> 
> 
> Repository: ambari
> 
> 
> Description
> ---
> 
> Recommendation and validation logic for HAWQ hdfs-client.xml 
> output.replace-datanode-on-failure property
> 
> 
> Diffs
> -
> 
>   
> ambari-server/src/main/resources/common-services/HAWQ/2.0.0/configuration/hdfs-client.xml
>  c2a756a 
>   ambari-server/src/main/resources/stacks/HDP/2.3/services/stack_advisor.py 
> c0bc4e2 
>   ambari-server/src/test/python/stacks/2.3/common/test_stack_advisor.py 
> 4f0b4b7 
> 
> Diff: https://reviews.apache.org/r/45012/diff/
> 
> 
> Testing
> ---
> 
> manual
> 
> --
> Ran 253 tests in 7.111s
> 
> OK
> --
> Total run:927
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Alexander Denissov
> 
>