Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-24 Thread Benjamin Hindman
On June 20, 2015, 7:35 p.m., Alexander Rukletsov wrote: Why do we use different approaches (emplace() and insert()) in c-tors? Is it possible to unify them for clarity? If not, mind leaving a comment explaining the reasoning? Great idea, I added a comment as to why we use 'insert'

Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-24 Thread Benjamin Hindman
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/35694/ --- (Updated June 24, 2015, 10 p.m.) Review request for mesos and Till Toenshoff.

Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-22 Thread Alexander Rukletsov
On June 20, 2015, 7:35 p.m., Alexander Rukletsov wrote: 3rdparty/libprocess/3rdparty/stout/include/stout/hashmap.hpp, line 52 https://reviews.apache.org/r/35694/diff/3/?file=988938#file988938line52 Let's avoid re-creating iterator: ``` for (auto iterator =

Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-22 Thread Till Toenshoff
On June 20, 2015, 7:35 p.m., Alexander Rukletsov wrote: 3rdparty/libprocess/3rdparty/stout/include/stout/hashmap.hpp, line 52 https://reviews.apache.org/r/35694/diff/3/?file=988938#file988938line52 Let's avoid re-creating iterator: ``` for (auto iterator =

Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-22 Thread Till Toenshoff
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/35694/#review88774 --- Ship it!

Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-20 Thread Benjamin Hindman
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/35694/ --- (Updated June 20, 2015, 7:06 p.m.) Review request for mesos and Till

Re: Review Request 35694: Added helper constructors to hashmap.

2015-06-20 Thread Alexander Rukletsov
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/35694/#review88661 --- Why do we use different approaches (emplace() and insert()) in