Re: Review Request 45120: Extended `os::rmdir` in stout to support preserving the root directory.

2016-03-25 Thread Jie Yu

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45120/#review125493
---


Ship it!




Ship It!

- Jie Yu


On March 26, 2016, 12:25 a.m., Neil Conway wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45120/
> ---
> 
> (Updated March 26, 2016, 12:25 a.m.)
> 
> 
> Review request for mesos, Jie Yu and Joris Van Remoortere.
> 
> 
> Bugs: MESOS-2408
> https://issues.apache.org/jira/browse/MESOS-2408
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This allows `os::rmdir("/x")` to optionally remove all the child
> files and directories of the root directory "/x", but preserve "/x"
> itself.
> 
> 
> Diffs
> -
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp 
> 44a59b830f4a09c9a19d55d3e99154ca8e4d2593 
>   3rdparty/libprocess/3rdparty/stout/include/stout/os/windows/rmdir.hpp 
> 4e3dd0ff8cbfe470b14c7cacbd861e7dc8384ba1 
>   3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp 
> 5466991675778c59d8040946717b492cdb1f9b14 
> 
> Diff: https://reviews.apache.org/r/45120/diff/
> 
> 
> Testing
> ---
> 
> make check
> 
> 
> Thanks,
> 
> Neil Conway
> 
>



Re: Review Request 45120: Extended `os::rmdir` in stout to support preserving the root directory.

2016-03-25 Thread Neil Conway

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45120/
---

(Updated March 26, 2016, 12:25 a.m.)


Review request for mesos, Jie Yu and Joris Van Remoortere.


Changes
---

Address review comments, rebase.


Bugs: MESOS-2408
https://issues.apache.org/jira/browse/MESOS-2408


Repository: mesos


Description
---

This allows `os::rmdir("/x")` to optionally remove all the child
files and directories of the root directory "/x", but preserve "/x"
itself.


Diffs (updated)
-

  3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp 
44a59b830f4a09c9a19d55d3e99154ca8e4d2593 
  3rdparty/libprocess/3rdparty/stout/include/stout/os/windows/rmdir.hpp 
4e3dd0ff8cbfe470b14c7cacbd861e7dc8384ba1 
  3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp 
5466991675778c59d8040946717b492cdb1f9b14 

Diff: https://reviews.apache.org/r/45120/diff/


Testing
---

make check


Thanks,

Neil Conway



Re: Review Request 45120: Extended `os::rmdir` in stout to support preserving the root directory.

2016-03-25 Thread Jie Yu

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45120/#review125489
---




3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp (lines 36 - 
37)


Can you put each parameter in its own line? I find it more readable:)



3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp (line 65)


Instead of using path comparison, can we use fts_level instead?



3rdparty/libprocess/3rdparty/stout/include/stout/os/windows/rmdir.hpp (line 114)


Ditto. Can you put each parameter in its own line?: )


- Jie Yu


On March 21, 2016, 6:43 p.m., Neil Conway wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45120/
> ---
> 
> (Updated March 21, 2016, 6:43 p.m.)
> 
> 
> Review request for mesos, Jie Yu and Joris Van Remoortere.
> 
> 
> Bugs: MESOS-2408
> https://issues.apache.org/jira/browse/MESOS-2408
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This allows `os::rmdir("/x")` to optionally remove all the child
> files and directories of the root directory "/x", but preserve "/x"
> itself.
> 
> 
> Diffs
> -
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp 
> cbc97596cd8ed1e6d4261568fd0086c86e063232 
>   3rdparty/libprocess/3rdparty/stout/include/stout/os/windows/rmdir.hpp 
> 4e3dd0ff8cbfe470b14c7cacbd861e7dc8384ba1 
>   3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp 
> daa46e05d113fd62ea9dad042ec41aaab28ad003 
> 
> Diff: https://reviews.apache.org/r/45120/diff/
> 
> 
> Testing
> ---
> 
> make check
> 
> 
> Thanks,
> 
> Neil Conway
> 
>