Re: [Rosegarden-user] Play on RG kills percussion track - SOLVED

2013-01-03 Thread joe
Hi!

Finally I managed to fix the percussion issue - thanks Michael for
mentioning KMidiMon! Let me share the result of my experience with you,
it might be useful for some you later on:

As you're surely all aware, the percussion Bank is set up in RG as
MSB=1, LSB=0 by default. I have just learned in the Clavinova reference
guide, that Yamaha is using MSB=127, LSB=0 for some reason... :(

After changing it in the bank-definition accordingly, the complete
percussion stuff remained permanenty even during playback.

Thanks for the help again,

Bye, Joe



On Wed, 2013-01-02 at 02:56 -0500, D. Michael McIntyre wrote:
 On 01/02/2013 12:53 AM, joe wrote:
 
  Could you please advice me how to monitor or debug the MIDI channels,
  incl. CC07 values being sent?
 
 KMidiMon comes to mind.
 
 I skimmed through your messages.  I don't have anything to add myself. 
 I can't set up and test something like this, because I don't have access 
 to a keyboard that has a sound module in the same unit as the 
 controller.  There could be something to that, but I just can't test it 
 to experiment.



--
Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. ON SALE this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122712
___
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user


Re: [Rosegarden-user] Play on RG kills percussion track - SOLVED

2013-01-03 Thread David Tisdell
Hi Joe,

Thanks for the update. I had just noticed that issue and hadn't had time to
delve into it. I was watching the thread with great interest.

Dave

On Thu, Jan 3, 2013 at 11:51 AM, joe j...@fasor.hu wrote:

 Hi!

 Finally I managed to fix the percussion issue - thanks Michael for
 mentioning KMidiMon! Let me share the result of my experience with you,
 it might be useful for some you later on:

 As you're surely all aware, the percussion Bank is set up in RG as
 MSB=1, LSB=0 by default. I have just learned in the Clavinova reference
 guide, that Yamaha is using MSB=127, LSB=0 for some reason... :(

 After changing it in the bank-definition accordingly, the complete
 percussion stuff remained permanenty even during playback.

 Thanks for the help again,

 Bye, Joe



 On Wed, 2013-01-02 at 02:56 -0500, D. Michael McIntyre wrote:
  On 01/02/2013 12:53 AM, joe wrote:
 
   Could you please advice me how to monitor or debug the MIDI channels,
   incl. CC07 values being sent?
 
  KMidiMon comes to mind.
 
  I skimmed through your messages.  I don't have anything to add myself.
  I can't set up and test something like this, because I don't have access
  to a keyboard that has a sound module in the same unit as the
  controller.  There could be something to that, but I just can't test it
  to experiment.




 --
 Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
 MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
 with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
 MVPs and experts. ON SALE this month only -- learn more at:
 http://p.sf.net/sfu/learnmore_122712
 ___
 Rosegarden-user mailing list
 Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
 https://lists.sourceforge.net/lists/listinfo/rosegarden-user

--
Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. ON SALE this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122712___
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user