Re: [Rosegarden-user] Rosegarden - Yoshimi issue

2017-04-18 Thread David Tisdell
I can compile  but I am using it in a music classroom and have quite a few
stations I would have to do that for. There is a time issue involved. I
might recompile on my own workstation.

On Tue, Apr 18, 2017 at 1:45 PM, Abrolag 
wrote:

> On Tue, 18 Apr 2017 08:51:54 -0400
> David Tisdell  wrote:
>
> > Hi All,
> >
> > I recently switched over to Ubuntu 16.04.2 LTS and added UbuntuStudio.
> > I am running Rosegarden 15.12 and Yoshimi 1.3.8.2
> > I have used Rosegarden and ZynAddsubfx/Yoshimi for years and have never
> run
> > into this before.
> > I can go into Yoshimi and set the sounds I want to use but when I hit
> play
> > in Rosegarden, it is as if it gets a Midi signal to change sounds and
> > starts using sounds I did not select. For the moment, what I have been
> > doing is setting up Yoshimi the way I want and then saving the state. I
> put
> > some empty space at the beginning of Rosegarden and after hitting play, I
> > load the saved state from Yoshimi.
> > I have experimented with the MIDI setting in Yoshimi, trying to tell it
> to
> > ignore change bank messages but to no avail. I have never run into this
> > before and am not sure if Rosegarden is sending a signal that I don't
> want
> > or if it is entirely a yoshimi problem.
> > Any thoughts on how to prevent this from happening?  Loading the saved
> > state after hitting play works but is cumbersome.
> > Thanks.
> >
> > Dave
>
> Are you able to compile the software yourself?
> If so both rosegarden and Yoshimi have been *much* changed and improved
> over
> the last 18 months or so.
>
> --
> W J G
>
> 
> --
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> ___
> Rosegarden-user mailing list
> Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
> https://lists.sourceforge.net/lists/listinfo/rosegarden-user
>
--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot___
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user


Re: [Rosegarden-user] Rosegarden - Yoshimi issue

2017-04-18 Thread David Tisdell
Thanks! I'll try that.

On Tue, Apr 18, 2017 at 2:10 PM, Ted Felix  wrote:

> On 04/18/2017 08:51 AM, David Tisdell wrote:
> > I am running Rosegarden 15.12 and Yoshimi 1.3.8.2
> > I can go into Yoshimi and set the sounds I want to use but when I hit
> play
> > in Rosegarden, it is as if it gets a Midi signal to change sounds and
> > starts using sounds I did not select.
>
>This sounds familiar.  About a year ago, Lorenzo Sutton brought up
> this issue here on the user list.  The conclusion was that he needed to
> use a yoshimi.rgd file and let rosegarden do the configuring.
>
>You can read the discussion here:
>
> https://sourceforge.net/p/rosegarden/mailman/rosegarden-
> user/thread/576B4143.1070207%40tedfelix.com/#msg35177175
>
>Lorenzo's post starts a few screens down.  Search the page for
> Lorenzo to get there quickly.
>
>You should be able to download the latest yoshimi.rgd file directly
> here:
>
> https://sourceforge.net/p/rosegarden/code/HEAD/tree/
> trunk/rosegarden/data/library/yoshimi.rgd?format=raw
>
> Ted.
>
> 
> --
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> ___
> Rosegarden-user mailing list
> Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
> https://lists.sourceforge.net/lists/listinfo/rosegarden-user
>
--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot___
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user


Re: [Rosegarden-user] Rosegarden - Yoshimi issue

2017-04-18 Thread Abrolag
On Tue, 18 Apr 2017 08:51:54 -0400
David Tisdell  wrote:

> Hi All,
> 
> I recently switched over to Ubuntu 16.04.2 LTS and added UbuntuStudio.
> I am running Rosegarden 15.12 and Yoshimi 1.3.8.2
> I have used Rosegarden and ZynAddsubfx/Yoshimi for years and have never run
> into this before.
> I can go into Yoshimi and set the sounds I want to use but when I hit play
> in Rosegarden, it is as if it gets a Midi signal to change sounds and
> starts using sounds I did not select. For the moment, what I have been
> doing is setting up Yoshimi the way I want and then saving the state. I put
> some empty space at the beginning of Rosegarden and after hitting play, I
> load the saved state from Yoshimi.
> I have experimented with the MIDI setting in Yoshimi, trying to tell it to
> ignore change bank messages but to no avail. I have never run into this
> before and am not sure if Rosegarden is sending a signal that I don't want
> or if it is entirely a yoshimi problem.
> Any thoughts on how to prevent this from happening?  Loading the saved
> state after hitting play works but is cumbersome.
> Thanks.
> 
> Dave

Are you able to compile the software yourself?
If so both rosegarden and Yoshimi have been *much* changed and improved over
the last 18 months or so.

-- 
W J G

--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user


Re: [Rosegarden-user] Rosegarden - Yoshimi issue

2017-04-18 Thread Ted Felix
On 04/18/2017 08:51 AM, David Tisdell wrote:
> I am running Rosegarden 15.12 and Yoshimi 1.3.8.2
> I can go into Yoshimi and set the sounds I want to use but when I hit play
> in Rosegarden, it is as if it gets a Midi signal to change sounds and
> starts using sounds I did not select.

   This sounds familiar.  About a year ago, Lorenzo Sutton brought up 
this issue here on the user list.  The conclusion was that he needed to 
use a yoshimi.rgd file and let rosegarden do the configuring.

   You can read the discussion here:

https://sourceforge.net/p/rosegarden/mailman/rosegarden-user/thread/576B4143.1070207%40tedfelix.com/#msg35177175

   Lorenzo's post starts a few screens down.  Search the page for 
Lorenzo to get there quickly.

   You should be able to download the latest yoshimi.rgd file directly here:

https://sourceforge.net/p/rosegarden/code/HEAD/tree/trunk/rosegarden/data/library/yoshimi.rgd?format=raw

Ted.

--
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
___
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user