Re: [Rosegarden-user] a few newbie questions

2017-08-03 Thread Lorenzo Sutton
Hi, I'm no expert on external MIDI devices (for playback - I use them only for input) but I'll skip to your more use-oriented question... On 29/07/17 04:33, Andrew Kilpatrick wrote: - Audio clips don't start when the transport is rewound and then played... it is necessary to press play and

Re: [Rosegarden-user] a few newbie questions

2017-07-31 Thread Ted Felix
On 07/28/2017 10:33 PM, Andrew Kilpatrick wrote: Well I discovered that the metronome must be set to a MIDI port of some kind before any MIDI clocks will be sent. That seems like a bug... what does MIDI clock have to do with metronome? The metronome code is responsible for generating MIDI

Re: [Rosegarden-user] a few newbie questions

2017-07-29 Thread Yves Guillemot
Le samedi 29 juillet 2017, 04:33:19 CEST Andrew Kilpatrick a écrit : > Well I discovered that the metronome must be set to a MIDI port of some > kind before any MIDI clocks will be sent. That seems like a bug... what > does MIDI clock have to do with metronome? > I can't reproduce this: the

Re: [Rosegarden-user] a few newbie questions

2017-07-29 Thread D. Michael McIntyre
On 07/28/2017 10:33 PM, Andrew Kilpatrick wrote: Well I discovered that the metronome must be set to a MIDI port of some kind before any MIDI clocks will be sent. That seems like a bug... what does MIDI clock have to do with metronome? That definitely needs a look. - Sometimes when starting

Re: [Rosegarden-user] a few newbie questions

2017-07-28 Thread Andrew Kilpatrick
Well I discovered that the metronome must be set to a MIDI port of some kind before any MIDI clocks will be sent. That seems like a bug... what does MIDI clock have to do with metronome? A few other things: - Sometimes when starting rosegarden, it complains about a missing MIDI device (they

Re: [Rosegarden-user] a few newbie questions

2017-07-27 Thread Andrew Kilpatrick
Hi Yves, Yeah, it's very strange. I do a lot of MIDI hardware development, so I'm 99% sure that I'm receiving all the messages. They are definitely not coming through. Maybe there is something else wrong with my setup. Also, an unrelated problem I noticed that when playing back a project

Re: [Rosegarden-user] a few newbie questions

2017-07-26 Thread Yves Guillemot
Le mercredi 26 juillet 2017, 19:22:38 CEST Andrew Kilpatrick a écrit : > > Thanks for the info. I checked aconnect and sync out seems to be > connected to every MIDI device, even ones that are not set up in > rosegarden. (my sound interface has a port which I don't use... it's > assigned) > >

Re: [Rosegarden-user] a few newbie questions

2017-07-26 Thread D. Michael McIntyre
On 07/26/2017 01:22 PM, Andrew Kilpatrick wrote: Are there any other kind of settings I need to make? It would also be nice if it wouldn't connect up non-related MIDI devices since I do other MIDI things on my computer which might be upset by receiving useless clock messages. In your case,

Re: [Rosegarden-user] a few newbie questions

2017-07-26 Thread Andrew Kilpatrick
Hi Yves, Thanks for the info. I checked aconnect and sync out seems to be connected to every MIDI device, even ones that are not set up in rosegarden. (my sound interface has a port which I don't use... it's assigned) But when I start and stop I can see that a port sends START, Song

Re: [Rosegarden-user] a few newbie questions

2017-07-26 Thread Yves Guillemot
Le mercredi 26 juillet 2017, 05:30:03 CEST Andrew Kilpatrick a écrit : > I'm not seeing a "sync" port anywhere in the program or the docs. The > MIDI Sync tab has an option "Automatically connect sync output to all > devices in use" which I have checked. I assume this means that any MIDI > device

Re: [Rosegarden-user] a few newbie questions

2017-07-25 Thread Ted Felix
On 07/25/2017 06:05 PM, Andrew Kilpatrick wrote: 1. MIDI clock sending - I turned it on in the MIDI Sync panel but no clock ticks are sent during playback. I could find no mention of this in the manual. I think the clock sync goes out the Rosegarden "sync" port. You'll need to manually

Re: [Rosegarden-user] a few newbie questions

2017-07-25 Thread Abrolag via Rosegarden-user
On Tue, 25 Jul 2017 18:05:13 -0400 Andrew Kilpatrick wrote: > Hi folks, > > I'm trying to get familiar with Rosegarden but can't figure out a few > things. If someone can help out that would be great! I'm running 17.04 > on Linux Mint - built from source.