Re: [rt-users] Fwd: Using getting stuck when choosing new Custom Lifecycle

2017-02-14 Thread Ben Pintilie
Matt / Kyle, Thanks for your fast replies. This has fixed the issue and all is working well. I have just checked my notes going back about 10 years and this is the first time I must have ever used a hyphen in a status! I knew it was something I did, I would never have found it. Thanks for

Re: [rt-users] writing extensions for an old version

2017-02-14 Thread Vinicius Fagundes
I have found. For anyone else who may have the same problem, to create a extension for any deprecated version (RT <4.0) it's necessary allow deprecated RT: RTx ('RT-Extension-Example', {deprecated_rt=>1}); More About:

Re: [rt-users] Recovering Disabled Articles

2017-02-14 Thread Matt Zagrabelny
On Tue, Feb 14, 2017 at 8:14 AM, Matthew Coons wrote: > Hello RT User group, > > I'm curious if there is a way from RT to enable an article that has been > disabled? I don't see a way to search for disabled articles in RT, and > Googling this question does not return any helpful

Re: [rt-users] Fwd: Using getting stuck when choosing new Custom Lifecycle

2017-02-14 Thread Matt Zagrabelny
On Tue, Feb 14, 2017 at 8:14 AM, Dippery, Kyle wrote: > In my own custom lifecycle, I have one hyphenated status ("in-use"). I don't > remember why (perhaps this is the reason), but I have it in quotation marks > as a key in our transitions array: > > transitions => { >

Re: [rt-users] Fwd: Using getting stuck when choosing new Custom Lifecycle

2017-02-14 Thread Dippery, Kyle
In my own custom lifecycle, I have one hyphenated status ("in-use"). I don't remember why (perhaps this is the reason), but I have it in quotation marks as a key in our transitions array: transitions => { ... "in-use" => [qw(allocated recycled stolen lost deleted

[rt-users] Recovering Disabled Articles

2017-02-14 Thread Matthew Coons
Hello RT User group, I'm curious if there is a way from RT to enable an article that has been disabled? I don't see a way to search for disabled articles in RT, and Googling this question does not return any helpful ideas. Thoughts? Matt Coons Incident Responder and Threat Analyst Information &

Re: [rt-users] writing extensions for an old version

2017-02-14 Thread Vinicius Fagundes
Hello, I tried this but the error remaining the same. requires_rt '3.8.8'; Or requires (RT=>'3.8.8'); Is there any other place that I also need to update? About the upgrade we working to do that soon. Thanks, Vinicius Fagundes Em 13 de fev de 2017 15:18, "Martin Wheldon"

[rt-users] Fwd: Using getting stuck when choosing new Custom Lifecycle

2017-02-14 Thread Ben Pintilie
Hi All, Im having a strange issue, I know I have missed a step, but cant see where. I have added in three new statuses, (aw-int aw-ext aw-qa) each new status meaning "awaiting-xxx" I have carried out the update to RT_SiteConfig.pm as usual. I have restarted RT and I can see the new statuses.